cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 8

Communication process failed for the primary Orion server

Hi THWACK Community

I'm busy setting up a new ORION HA Server. The primary server is up and working 100%. The secondary IP's for the primary and secondary servers are 10.1.4.42 and 10.1.4.45. When I attempt to connect the secondary server I get the following error:

Communication process failed for the primary Orion server

The message with Action 'http://tempuri.org/IInstalledProductsProviderService/GetInstalledFeatures' cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver. Check that sender and receiver have the same contract and the same binding (including security requirements, e.g. Message, Transport, None).

Has anyone seen this error before?

Thanks

desiganp

0 Kudos
8 Replies
Level 8

Thanks for all the comments guys. Unfortunately, I couldn't get this working. I re-installed on the Secondary Server.

0 Kudos
Level 8

Hi desiganp, did you get anywhere with this.  We have the same error when trying to install Additional Polling Engine.

0 Kudos

What Orion Platform version are you running on the main? Also, where did you obtain the installer for the Additional Poller?

0 Kudos

Hi aLTeReGo, thanks for your reply.  It's Orion Version 2019.2.  NPM Version 12.5.  Got the APE 2019.2 installer from the Solarwinds download section.

From what we have seen it seems to be failing to start the SFTP service during the install process.

0 Kudos

Hello!  If you're still having trouble with the TFTP service, try these steps:

Go to Start > Run > and type regedit

Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

With the control folder selected, right click in the pane on the right and - select new DWORD Value

Name the new DWORD: ServicesPipeTimeout

Right-click ServicesPipeTimeout, and then click Modify

Click Decimal, type '180000', and then click OK

Restart the computer

Check if TFTP is listed in services.

If it is not present, Try the upgrade again

If present, Can you start it? If not, try to set it with another user other than local system.

Once started, Try the upgrade again




Thanks kasaff, that worked!  and thanks aLTeReGo for suggestions.

Have you tried the suggestions in the links below?

Success Center

Re: SFTP not able to start

Product Manager
Product Manager

The Orion web interface is only accessible from the active member in the pool.

0 Kudos