Showing results for 
Search instead for 
Did you mean: 
Create Post

SNMP Fails with " Test Failed. Exception of type 'SolarWinds.ApiProxyFactory.TransientApiProxyException' was thrown. "

FYI For anyone who gets the above failure (Test Failed. Exception of type 'SolarWinds.ApiProxyFactory.TransientApiProxyException' was thrown.) on an SNMP test this seems to be (in a couple cases I've had in different organizations, installations) an issue with NIC priority in systems with multiple NICs.  Changing priority doesn't always fix it but disabling the interface that doesn't have your poller's primary IP does. 

You may also see that your poller is not syncing with the database or that it is not 'up'.

This has only happened to me with VMWare boxes but, FWIW, I've only installed SolarWinds on VMWare VMs.

I've had this happen without doing anything explicit with the box, sometimes it seems like performing windows updates can do this.  I've never had sole administrative access to the systems so I can't verify that another administrator didn't come in and change something or enable a NIC that was disabled but it seems like this has also happened.

0 Kudos
4 Replies
Level 11

Hi twomonkeysayoyo​,

Many thanks for this info, I am intrigued by this as I have this issue at the moment.

I tried following your resolution and realised that on my poller, I have two active NICs, one which gives me general network access, the other which connects to a site directly for polling.

Unfortunately, disabling any of these would cause issues meaning we won't be able to monitor one site or the other, which is clearly counter productive!

During your time working towards this workaround, did you manage to identify what the root cause is? I am wondering if there is another work around that would be more suitable for my issue.

Kind regards,


0 Kudos

As far as I know your poller will not support dual homed configurations.  I don't know why, but you may have to get another poller or figure out a network workaround.

0 Kudos

Hi twomonkeysayoyo​,

Thanks for the quick response!

I found another thread which got me thinking about firewall rules and accesses. I ran a test with the firewall up an connecting to the second site and I received the error.

I then did the same with the firewall off and found that this was successful without errors.

Happy Days! It is doing exactly what I want it to do, however it requires additional ports open on my firewall! Now to figure out which ones specifically as I thought I had the standard ones set up.

So, in the event of safety, the firewall is back up and I am now working this out.

What I did find interesting during my investigations on this is that despite the exceptions being thrown up, I was able to run SNMPWalks from the polling engine successfully.

As you could imagine, this threw me off the connectivity trail for a while!

But it is worth pointing out, if you have this or a similar issue, try the SNMPWalk tool from the polling engine!

Kind regards,


0 Kudos

I managed to resolve my issue!

After a weekend of wracking my brains, trying to work out why the device was able to complete an SNMP walk but wasn't able to add the node from the Poller, it hit me this morning... The issue wasn't with the connectivity between the node and additional poller, but the connection between the additional poller and the primary.

I had a look over my APE and realised the local firewall was enabled like we wanted, however the rules were not set for the right ports.

I spent over an hour looking at these rules first to make sure and be certain that they weren't there before creating a new rule for internal devices to allow traffic between ports 17777, 17778, 1433 and 1434.

I clicked ok... Logged back in to my platform, and tried adding my node again...

With bated breath and crossed figures, I hovered my mouse over the test button... I was one click away from relieving my weekend long headache...


"Test successful"

The sigh of relief was more a cheer of jubilation...

Not a big win, but by no means a small one either... And hopefully this may help someone in the future