cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post

NPM 10.5 IS NOW AVAILABLE!

Level 12

We are pleased to announce that SolarWinds Network Performance Monitor (NPM) version 10.5 is now available for download.

As today’s dynamic networks grow in size and complexity, the number of active routing topology states grows exponentially.  With the new network route monitoring feature, SolarWinds NPM takes fault and performance monitoring to the next level by providing real-time network route information alongside device status and performance statistics.  With support for major routing protocols including RIP, OSPF, and BGP, IT pros can now view routing tables, changes in default routes, and flapping routes in an intuitive web-based console.

Additionally, many advanced network services including multimedia distribution, finance, education, and desktop imaging rely on IP multicast to reduce network bandwidth usage. SolarWinds NPM’s new IP multicast monitoring feature enables IT pros to monitor routers, switches and end-points that receive and forward multicast packets by automatically detecting and importing existing multicast groups and applications.

Other new updates to SolarWinds NPM include advanced interface filtering by hardware type, name, VLAN and more for importation of new nodes and interface; and interface auditing.

You can learn more about NPM version 10.5 and download a free fully functional 30-day trial so you can see how it works in your network.

62 Comments
Level 13

10.5 failed when I attempted to install this morning.  Support is currently scraching their head trying to figure out what's going on.  It failed with an error message saying:

Could not find stored procedure dbo.upgrade_Wireless_UpgradeNeeded

Because it failed at this point it didn't just skip that install the rest of the modules, it just quit.  My previouse version was 10.4.1.  So I'm dead in the water right now

Level 10

I tried to upgrade, too.  It also failed.  It got through to a point and there was a box that said that something was running and needed to close (I don't remember what it was specifically) and when I clicked the ok button or whatever seemed like the best option to continue the install, the wizard just quit on me.  If I try to open the wizard again, it says it is already installed and when I check my programs list, NPM shows up as v10.5.

We are currently in a limbo state. I can't upgrade the pollers, either, which say "Can't receive data from SolarWinds Information Service RunQuery failed, check fault information." When I try to run the installer on them. IIS V3 is running.  I opened a ticket up and haven't heard back yet

I did find something regarding RunQuery: http://thwack.solarwinds.com/message/150561#150561, but since this is an older post, I don't know how relevant it is.

Also, I'm running Windows server 2012 and SQL 2012

Level 13

They tried having me run the config wizard in repair mode.  That was not good either.  It seems that the support guy is stuck between the pre release support team and me and instead of the that support team getting involved directly they are using him as a go between.  I've seen far to much of this lately.  It's not acceptable.  My Gunny Sergeant personality is about to come out.

Level 10

I'm on the phone with them right now. I'll see if our issue gets resolved and I'll post.

Level 16

all, please contact support, they should be able to help you. We are not aware of any installation problems.

Level 13

Just so you understand my level of frustration, the last upgrade to 10.4.1 took your developers 4 weeks to get working.  I'm certainly not going to accept that same response this time.  I need this working today or a roll back method.  And I'm not going to play email tag.

Level 10

Ok. So it seems like we finally got ours to work.  There is a permissions issue that we had during the install. If you set your user's ACL settings down to "never notify," reboot the server, and re run the wizard then it should hopefully work.  Go into programs and right click Orion NPM and select repair. That should run the wizard again.  Or you can use a local admin account and not your AD account, if that is what you were using.  This is what worked for my error. I'm currently working on getting my pollers upgraded now.

Level 10

We are all in contact with SolarWinds support, as we wrote. We still are waiting a resolution for our currently-not-monitoring monitoring system.

"We are not aware of any installation problems."

Go talk to support. We have both contacted support directly and opened tickets and just informed this thread of two failed installations. You may believe we have not had our issue defined as an installation problem, but from our side it appears that our previously working monitoring system has failed due to issues encountered during a system upgrade of release software, and is currently not running.

And this is me seeking to phrase my comments politely.

Level 13

That is exactly the same problem we had with 10.4.1. I’m attempting the fix as you indicated. You would think they would build some kind of check into the install process to check that

Level 10

Yes, you would think.  At least give you a little note that says, "oh, hey...btw...your install isn't going to work if you use your AD admin account with permissions as is..."  I hope it works for you.

Level 10

And to give credit where due, support was able to help us(rgeist works for me) resolve our issue. Thank you to support for their assistance in resolving this issue.

Level 13

I’ve got the developers on the line now. Mine’s not quite as easy as permissions. It seems that the wireless stored procedure is no there

Level 10

Good luck! Hope you get your issue resolved!

Level 8

A tad ticked right now I have been on with support for 2+hrs going through my issues. I went from Orion Core 2012.1.1, NPM 10.3.1, NTA 3.10.0, IVIM 1.3.0 system and moved my database over to Orion Core 2012.2.2, SAM 5.5.0, NPM 10.4.2, NTA 3.10.0, IVIM 1.5.0 ©.  Now I get major errors just adding groups. Data base update counter is stuck at 360 minutes. If I even want to simply add a node it is throwing a major Javascript error, I don't know what is up with this platform but something is not right. Ugh I am having a real rough time with this.

Level 10

Where is a link to the documentation for 10.5?

Level 13

Developers are finding all sorts of stored procedures and database tables that never got created on the install. Woops

Level 14

The documentation for v10.5 is included with the ZIP file that contains the software installation.  So, just login onto the customer portal and download the Orion NPM software. By the way, I already upgraded our lab server this morning to v10.5 without any problems. 

Level 13

I’m up. Install had stopped in mid stream due to a database lock. This caused the installer to stop. Apparently the developers had not taken that possibility into account so there was no provision to start over and even repair wouldn’t fix it. So they had to manually created the missing table that the installer had failed on and then the config wizard worked. They’re going back to fix the installer. I guess that makes me a guniea pig

Level 16

Thanks from the rest of us for being our ginea pig  🙂

I upgraded our DEV system yesterday with no issues.  Doing prod now....   slow, but we have a 130Gb database so it takes a while....

Level 16

having issues, wizard failed due to a timeout.  rerunning wizard with antivirus turned off....

Level 16

Failed, opened ticket:  got this:

 

Website configuration failed:

• Unable to restart Orion Application Pool. Please use the IIS Manager to restart it manually.

• Web Request for /Orion/Login.aspx failed - The remote server returned an error: (503) Server Unavailable.

App is running and alerting, but website fails

Level 13

I guess I'll wait a wee bit before upgrading. What I saw in RC was just great, but never tried it in the production zone as an upgrade.

Level 8

hey admin can give me the tutorial how to download upgrade my NPM.
cause I'm newbie, i'm need link to download it.

Thanks

Level 16

ran wizard 4th time and all is good now....  I threatened it by opening a ticket...  Orion got scared so it shaped up  🙂

Pollers ran perfectly.  I stopped my anti-virus and I think that made a difference.  Good luck all!!

Level 8

As general rule you should always be using the local admin account when installing software so that you bypass any permissions issues or problems with ACLs etc that might happen

Level 14

All you need to do is access the Customer Portal (https://customerportal.solarwinds.com/customerportal/) with the credentials that SolarWinds provided you.  Once you login, you will see the download link from the Newest Licenses section of the Home screen.  If you are unsure or lost your credentials, you should contact SolarWinds customer support for assistance.

Best wishes.

Level 14

Is there any logical reason why the Release Notes are only available AFTER I download a 400MB file?  SW is the only company I can recall dealing with in the past 5 years that requires this; everyone else posts Changelogs and Release Notes right on the site.

Level 14

Here is a link to the Release Notes pages on the SolarWinds site:

SolarWinds Network Performance Monitor Release Notes

Also, for other documentation, see the link shown below:

http://www.solarwinds.com/documentation/orion/orionDoc.aspx

I hope this helps.

Level 16

I think my issue was more my server than anything.  Anti-virus was taking 85% cpu on a 32 core system.  Kinda crazy...  once I stopped that things got better. 

Level 13

My install is still some what in the toilet this morning.  Developers managed to get the install completed, but as of this morning I get a web page error for any node I try and access.  All the upper level summary pages show up but can't drill down any further.  Spent 15 on hold trying to get to support on my existing case.  Sent an email to them on the existing case and am now waiting.  In the mean time I'm running repair on the core and npm modules to see if that helps.  Oh and one more thing, installing 10.5 broke SAM web page.  I had to run a repair on the SAM module to get the web pages to work.

Overall NPM 10.5 is NOT ready for prime time.

Level 14

There is no need per se to disable your antivirus and I would not recommend it, especially w/all the nasty viruses going around.  Anyway, according to the SolarWinds Orion Admin Guide, your antivirus software has the following exclusions:

For Windows 2003 Server and Windows XP, the following folder should be excluded from antivirus scanning:


  • c:\Documents and Settings\All Users\Application Data\SolarWinds\

For Windows 2007, Windows 2008 and Vista, the following folder should be excluded from antivirus scanning:

  • c:\ProgramData\SolarWinds\

By the way, in our case, we still found issues w/application performance.  That is, until we excluded the inetpub folder as well. 

I hope this helps.

Level 14

Only thing is, wouldn't the best place for malware to offer itself up for distribution be from inetpub ?  I always get leery when software vendors say that the entire directory and all sub-directories that their application runs from must be exempted... if I were a malware writer I'd just write a simple routine to check the target for a list of software whose vendors do this and drop my payload there. I wonder if vendors consider this when writing such recommendations.

Level 9

Installed without a problem for us, both primary and an additional polling engine.

The route flap and multicast monitors are Great!

Level 13

Sigh.....I'm seeing my life slip away because of this product.  I've literally wasted over 4 weeks of time over the last 2 upgrades for NPM

Level 14

TTL,

Please note that I do not work for SolarWinds, so the idea of excluding the inetpub folder did not come from them.  It was something that I tried when after noticing that the exclusions recommended by SolarWinds documents did not seem to be helping.  Still, I agree with you that excluding the inetpub still leaves some exposure to viruses.  So, just go for the exclusions recommended by SolarWinds.  Hopefully, the CPU performance issues will decrease enough with those exclusions that you will not need to take other steps.

Best wishes.

Level 13

16 hours on the phone with support between yesterday and today and it just gets worse.  I hope someone in Solarwinds managment is watching this because I am at the end with this product line.  THIS thing is FUBAR

Level 8

ok thank you for your help...
i have been downloaded..

Level 16

Agree, routing features are terrific...   Just need EIGRP support....

New version looks great !!

Vote for EIGRP support:  http://thwack.solarwinds.com/ideas/2227

Level 14

All,

I'm looking for a little bit of info.  I see from above, some are and some aren't having install issues.  I also know that the 10.3 to 10.4 upgrade was less than desirable with regards to custom properties vanishing, and the NCM integration causing pain.  Has anyone seen any other issues along those lines?  I prefer to wait until the "kinks" are worked out before upgrading.  So, the more info the better.

I'm really looking forward to the routing info...and future EIGRP support (hint!).

D

Level 16

I'm now on day two with 10.5 with no issues.  We see benefits, such as the routing and multicast resources, but nothing negative.  We run 2 additional pollers, NCM, SAM, VNQM, IPAM, UDT and NTA with LEM on the side....  We run 24/7 and there have been zero complaints.  I have MANY custom properties, reports, UnDP's, custom colors for events and custom integrations.  Only thing I had to change was the event colors...  upgrades send it back to default.  I'm happy happy happy!!

We had a bug in 10.4 that was causeing all sorts of issues, but that seems to be gone now as well....

But, as we all know, every upgrade\installation is unique....

Level 9

Just upgraded with the last couple of hours, the only issue so far is that the network tab in the node summary is having problems coming up.  So far all nodes I've looked at are having this problem.

Unexpected Website Error

Object reference not set to an instance of an object.

Time: 05/26/2013 15:33:26.1907

Server: Microsoft-IIS/7.5

Pipeline: Integrated

User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET4.0C; .NET4.0E; .NET CLR 3.5.30729; .NET CLR 3.0.30729)

Error Instance: b29a6f3989ea4dbbbb14aa36a9b22e1c

User: domain\username

URL: http://<ipaddress_of_server>/Orion/NetPerfMon/NodeDetails.aspx?NetObject=N%3a696&ViewID=29

Referrer: http://<ipaddress_of_server>/Orion/NetPerfMon/NodeDetails.aspx?NetObject=N%3a696&ViewID=29

Message: Object reference not set to an instance of an object.

ErrorSite: App_Web.Orion_UDT_Resources_EndpointDetails_EndpointHistoricalConnections.get_EditURL

ErrorType: System.NullReferenceException

Level 7

Hello Everyone

I have NPM v10.4 installed.

Can I upgrade directly to v10.5 or do I need to pass through v10.4.1 before v10.5?

Thanks & Ciao

Level 13

You can upgrade from where you are at.  However, I would wait at least a month before you upgrade so that all the bugs get worked out of the installer and right now there are plenty.  I've spent almost every day since I upgraded last week on the phone with support and directly with the developers fixing issues caused by the installer.  Had another one just yesterday.

Level 7

Excellent release! Installed perfect and the new network routing additions are fantastic! I had a need for every single one of them. Awesome!

Level 14

Have you contacted SW tech support for assistance w/this issue?  If so, would you mind sharing w/us what they replied about this problem?  As I stated in a different thread, we've upgraded two of or SolarWinds NPM sites w/o problems and are planning for a third one this weekend. So, I'd be interested in learning about this, especially since we also have Orion UDT on our SW sites.

Level 7

When I tried to install the update I get the following error and then quits:

Setup is missing an installation prerequisite:

-Microsoft SQL Server 2008 System CLR Types. To continue, install SQL Server System CLR Types from

http:/go.microsoft.com/fwlink/?LinkID=116207 and then run the Setup operation again.

The MS link is dead. I dont even have SQL 2008 I have the 2012 version.

Level 9

I did contact SW support.  A resource called, All Network Connections, which was in the version I upgraded from, is not in this version.  Once I removed it by going into Managed Views in Settings, Node Details - Network, it worked.

Level 7

Thank you for your reply, but I dont have All Network Connections under

Node Details - Network

On Thu, May 30, 2013 at 3:06 PM, c4ucka54m0r3 <

Level 10

Re: New Interface filtering UI to import discovery results


Is there any way to apply these filters to existing devices, or would I have to delete/rediscover nodes to use them?

Level 14

OK.  Here's is my experience w/upgrading to Orion NPM v10.5.  After the installation completed on my core server, the Configuration Wizard aborted with the following message:

Error while executing script: Transaction (Process ID 62) was deadlocked on lock resources with another process and has been chosen as the deadlocked victim.  Rerun the transaction. 

Keeping a cool head, I decided to re-run the Config Wizard before contacted SW tech support.  Sure enough, the second time, the Config Wizard completed successfully and without errors.  Also, the installation completed w/o any issues on my three additional polling engine servers.  By the way, for some strange reason, I had to re-enter credentials for all of my Scheduled Reports in SolarWinds.  I don't know what that was about, so I am still double-checking but so far I have not run into any other issues.  So far, no other problems found with the upgrade.  Still, given this experience and that of some of the others in this thread, I would say that the SW installation file could have used a bit more tweaking before posting the GA version.  Anyway, back to checking up on my Orion servers.  Later folks!!!