cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 8

Free TFTP server won't start on non-english OS

Jump to solution

Free TFTP Server 10.9.1.33 won't start on non-english OS. It fails with the following stack trace (in French):

Le service ne peut pas être démarré. System.Net.Sockets.SocketException: Une seule utilisation de chaque adresse de socket (protocole/adresse réseau/port) est habituellement autorisée

   à System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)

   à System.Net.Sockets.Socket.Bind(EndPoint localEP)

   à System.Net.Sockets.TcpListener.Start(Int32 backlog)

   à System.Net.Sockets.TcpListener.Start()

   à System.Runtime.Remoting.Channels.ExclusiveTcpListener.Start(Boolean exclusiveAddressUse)

   à System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.StartListening(Object data)

   à System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.SetupChannel()

   à System.Runtime.Remoting.Channels.Tcp.TcpServerChannel..ctor(Int32 port)

   à TFTPServer.Service.TFTPServer..ctor()

   à TFTPServer.Service.TFTPServer.get_Current()

   à TFTPServer.Service.TFTPService.OnStop()

   à System.ServiceProcess.ServiceBase.DeferredStop()

   à System.ServiceProcess.ServiceBase.Stop()

   à TFTPServer.Service.TFTPService.OnStar...

However, if I install the english language pack on the same computer, and set the systme language to english, the service starts correctly.

This is with the default values:

<root>

  <tftp-settings>

    <config>

      <AllowAllIP value="True" />

      <ReceiveOnly value="True" />

      <TransmitOnly value="True" />

      <RootDir value="c:\TFTP-Root" />

      <AutoSystemStartUp value="True" />

      <TaskTray value="True" />

      <ForceAsciiErrorMessages value="False" />

      <Timeout value="3" />

      <Retries value="6" />

      <UsedNIC value="Any" />

      <SelectedLanguage value="en-us" />

      <RenameExistingFiles value="False" />

    </config>

    <IPRanges>

    </IPRanges>

  </tftp-settings>

</root>

0 Kudos
1 Solution
Level 8

I've found another server running a French OS that Free TFTP was running fine. However, that server was running TFTP 10.9.0.25. I installed the older version on the server giving me the error above and it worked. It seems to be a bug introduced between the two versions.

View solution in original post

0 Kudos
4 Replies
Level 8

I've found another server running a French OS that Free TFTP was running fine. However, that server was running TFTP 10.9.0.25. I installed the older version on the server giving me the error above and it worked. It seems to be a bug introduced between the two versions.

View solution in original post

0 Kudos
Level 7

any updates about this?

0 Kudos
Level 7

any update?

0 Kudos
Level 7

I have the same issue with free tftp server version 10.9.1.33 on a home test lab: so I have no english os.

Therefore I ask if it would be possible to sent me a link to download free tftp server version 10.9.0.25 as blanalex told this version worked on non-english os

0 Kudos