cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post

SDK 1.8/1.9 - Powershell Connect-Swis Results in OperationTimeout

A couple weeks ago we had a problem with NPM 10.7 and we upgraded to NPM 11.0.1. Since then i've been unable to initialize the SWIS connection with the connect-swis cmdlet. The result displays OperationTimeout 01:00:00

I've tried a couple things:

Connect-Swis -Trusted

Connect-Swis <Enter username/password at prompt> (doesn't seem to matter what creds i enter here)

Connect-Swis -Hostname localhost

$creds = get-credentials

$swis = connect-swis -Credential $creds -Hostname localhost

but nothing seems to work. They all result in OperationTimeout 01:00:00.

Is there a log file that might help me further troubleshoot?

Thanks

Tags (1)
0 Kudos
4 Replies
Level 19

Are you able to connect with SWQL Studio?

Since you specified "-Hostname localhost", I assume you are running this on the Orion server. Is that correct?

0 Kudos

Yes i'm able to connect with SWQL studio without any problems. I've tried running the command from the Orion server and my desktop with the same results.

0 Kudos
Level 19

With SWQL Studio, are you connect with the "Orion (v2)" or "Orion (v3)" server type?

0 Kudos


Both v2 and v3 work within the SWQL Studio

0 Kudos