cancel
Showing results for 
Search instead for 
Did you mean: 

SAM Monitor IIS Powershell Errors

Jump to solution

I'm trying to monitor IIS via SAM. When Solarwinds attempts to automatically configure the IIS server it returns an error that Powershell 2.0 is required. However, the version of Powershell running on the remote server is version 5.1. I then attempted to configure the server manually. All went well until Step 6 Create a WinRM listener for AppInsight for IIS which produced the error pictured below. No idea what it means. In the meantime, Solarwinds reports IIS as "unknown". What's strange is I'm monitoring another node with an identical set up and I had no problem getting Solarwinds to monitor IIS on that machine. Any help would be greatly appreciated.

versionerror.jpg

version.jpg

wsman.png

0 Kudos
4 Replies
sturdyerde
Level 13

Re: SAM Monitor IIS Powershell Errors

Jump to solution

Have you ruled out the possibility of network firewalls or Windows firewall getting in the way? There are two PowerShell commandlets that may help with this troubleshooting step:

Test-NetConnection -ComputerName <String> -CommonTCPPort WINRM

Test-WSMan -ComputerName <String>

Depending on your security configuration, you may need to specify credentials or the -UseSSL parameter. Good luck!

0 Kudos

Re: SAM Monitor IIS Powershell Errors

Jump to solution

The Test-NetConnection command failed to ping due to a timeout. Test-WSMan was successful

0 Kudos
sturdyerde
Level 13

Re: SAM Monitor IIS Powershell Errors

Jump to solution

starfishprime  wrote:

The Test-NetConnection command failed to ping due to a timeout. Test-WSMan was successful

That's a good result, because Test-WSMan is actually a more relevant test for remote management. Test-NetConnection is essentially a ping that lets you target specific ports (like ping+telnet in a way). This tells us that a firewall is not blocking remote management, so it can be ruled out.

0 Kudos

Re: SAM Monitor IIS Powershell Errors

Jump to solution

Finally determined the winrm listener was set to a different port. Solarwinds defaults to HTTPS and port 5986. Through Powershell it was learned that the node was set up for HTTP on port 5985. Once I modified the address on the IIS monitoring page the credentials passed and set up occurred automatically. Looks like a one-off when compared to other nodes I monitor, but the problem is resolved.