This discussion has been locked. The information referenced herein may be inaccurate due to age, software updates, or external references.
You can no longer post new replies to this discussion. If you have a similar question you can start a new discussion in this forum.

Having trouble getting WHD on Linux machines

Hi all, I've been struggling to get WHD up and running on Linux. I've tried Fedora 36, RHEL 9 & RHEL 8.6 all using the newest 12.7.10. The biggest issue I've been running into seems to be that WHD tries to install with outdated dependencies, ie: wants OpenSSL.1.0, while Linux is on OpenSSL3, and wants Readline6, while Linux is on Readline8. After a lot of trouble shooting the farthest I've gotten on an installation is when I preinstall compatibility versions of OpenSSL/Readline on Fedora36, then install WHD. With that I get up to installation step "12. (PostgreSQL database only) Change the default PostgreSQL database password.",  where I get a new error message: "./createuser: error while loading shared libraries: cannot open shared object file: No such file in directory."

My errors have mainly been '<command>: error while loading shared libraries: <outdated dependency>: cannot open shared object file: No such file in directory."

Is there a big important step that I missed that would fix all of these missing dependency issues? Or do I need to keep installing compatibility libraries as I go?

Right now my installation process is as follows:

1| Installed Fedora 36
2| Update with 'sudo dnf upgrade'
3| Install openssl.1.0 with 'sudo dnf install compat-openssl10-devel --allowerasing --releasever=33'
4| Install libreadline6 with 'sudo dnf install compat-readline6.x86_64'
5| Unzipped WHD installation 'gunzip webhelpdesk-'
6| Ran "sudo rpm -ivh webhelpdesk-" to install

  • According to the WHD12.7.10 Installation and upgrade Guide on the following flavours of Linux are supported:

    Red Hat Enterprise Linux (RHEL)

    RHEL 6.5 (64-bit)

    RHEL 7.0 (64-bit)

    RHEL 8.6 (64-bit)


    CentOS 6.5 (64-bit)

    CentOS 7.0 (64-bit)


    Fedora 24 (64-bit)

    Fedora 25 (64-bit)

    so I would not bother with anything else.

    Sounds like something which should be logged with Support anyhow once you are using a supported OS eg RHEL8.6.

    They will want to see the logs which can be gathered by running script found in the <webhelpdesk>/healthcheckutility folder.

  • Yeah, RHEL8.6 is the last one I tried. It was still having problems with OpenSSL.1.0 & Readline6. OpenSSL was easy to find with a dnf search, installed with "sudo dnf install compat-openssl10.x86_64" Now I'm having trouble hunting down a compatible Readline6, when RHEL wants Readline7.

    It could just be those two missing dependencies, but I figured I should post here before spending another day searching for fixes and bugs.

  • I have used CentOS 7 in past as it is supported until 2024 but must admit I haven't tried with WHD12.7.10 but cannot think much has changed on the SW side.

  • We're trying to move away from CentOS since they are moving onto CentOS Stream

  • Not knowing how you deploy things but with WHD12.7.10 it supports external PostgreSQL 14 Databases so you might consider putting your database (if you are PostgreSQL Database based) on another Linux Server which just leaves the foreground & background daemons on your WHD Server, may help. On this new Linux Database Server remove any PostgreSQL from the Distro and then just apply using the relevant dnf/yum from PostgreSQL themselves, this frees you up from using what SW have delivered.

    SW have also freed you up from using the OpenJDK 11 which is shipped with WHD12.7.10 so you can use later hotspots available from MS (must still with a v11 though).