This discussion has been locked. The information referenced herein may be inaccurate due to age, software updates, or external references.
You can no longer post new replies to this discussion. If you have a similar question you can start a new discussion in this forum.

Unable to manage a VM in NPM

Got a bit of strange one here.

I have a couple of VM's that used to be physical machines prior to being converted.

When in VMAN these show up ok, but are not showing as an orion managed node, when i take the option to manage the node and complete the wizard it creates a physical node.

When i click on the physical node, it takes me to the node page which then implies that its a physical machine and not a vm hosted on an esxi node.

Other VM's that we have changed to be a managed orion node work okay and display as a virtual machine hosted on xxx server.

Checking the back end database in the VIM.Virtualmachines the details for these vm's have the Nodeid filed as NULL instead of the NodeId number under Orion.

If i change these values to what they should be, then for a brief period of time they do report as being a virtual machine hosted on xxx server, but shortly after they revert back to the original status in vman of 'this node is not managed by Orion'

Has anyone seen this issue before and does anyone have a fix for it?

I have tried to delete the physical nodes and tried to add them again from the VMAN page but it just does the same as before.


  • What version are you currently running? Once upon a time we did some matching based on MAC address and so converted machines might get confused based on that but as far as I know we do not match like that any longer. It might be a good idea to open a ticket and ask support to help pinpoint where the problem is. If they cannot resolve it they can escalate to engineering for a deeper look.