Oracle User Experience Monitor: Failed to find or load the registered .Net Framework Data Provider

Hello - 

I recently upgraded to 2022.3 and now all of my Oracle User Experience monitors are in an "unknown" state because of the following error message:

"Failed to find or load the registered .Net Framework Data Provider"

Nothing has changed on the linux servers I'm monitoring that host these Oracle DBs, and I already had Oracle .NET installed on our polling server before the upgrade. 

What's the fix please? 

  • We're having a similar problem. We use the "Microsoft .NET Data Provider" Oracle driver type, which required installing an extra tool from Solarwinds. Post-upgrade it's acting as though it isn't installed, though it is.

    I tried creating a brand new application monitor template using the default "Managed Oracle Data Provider for .NET", but I'm getting the same error as you. For this Oracle Driver type is there any addition installation or configuration it needs, or should it just work out of the box? Thanks so much, and congrats on solving your issue!

  • The saga continues:

    It looks like the 2022.3 upgrade wiped (or moved) the "C:\Program Files (x86)\SolarWinds\Orion\APM" path in my SolarWinds install. - is this also the case for you? 

    SolarWinds documentation doesn't cover what the new Oracle path is and how to install the drivers properly. All of the documentation forked to me by support are referencing this old path and I therefore can't even determine where to point the Oracle Driver installer. 

    This is starting to turn into a mess and with 250+ views on this thread, I suspect others are experiencing the same issue. Please chime in Solarians, it looks like it's up to us to resolve this! 

  • Confirmed, it cleared out that folder. We were using the Microsoft .NET Data Provider option, so re-running the installer we originally used re-populated with an OracleClient folder with .dlls, but it's still not finding it. Not sure how to go about figuring out where Solarwinds now wants it to be. Yeah we opened a ticket and my rep is still researching, but he didn't seem immediately familiar with this issue, but I imagine it's at least somewhat widespread. 

  • - I was able to resolve this for a few monitors by exporting / re-importing the monitor. This creates a new monitor in SolarWinds, which I assume points to the new Oracle .NET path (wherever that is). 

    This seemed to resolve all monitors that were on top of nodes being monitored by an agent, but hasn't fixed monitors for nodes that're being monitored via SNMP (which were indeed working before). 

    Hopefully this helps you and others trying to resolve this issue that's seeming to impact many.

    I'll still have to work to figure out how to fix the remaining monitors :( 

    Let me know if the fix worked for you. 

  • Hello ,

    Just wanted to check on this, any progress with the nodes that are being monitored via SNMP?

    Thank you!!!

  • They're still acting up, returning "unknown". I'm working with FW teams to open up ports so I can push agents to them and will let you know if this resolves. 

    SW support hasn't been any help in resolving and keep sending me outdated support articles lol. 

Reply Children