Issues with ServU running on SQL Server 2022

We are migrating our ServU instance to a new set of web and DB servers.

Right now we have version 15.1.1.108 running on a Windows Server 2012 machine.
That connects to a Windows Server 2006r2 machine running SQL Server 2012.
The Users and Groups for ServU are all DB hosted. This setup has been working fine for years.

We are moving to a Windows Server 2022 machine. Current ServU (Serv-U 15.3.2.155)
That will connect to a Windows Server 2022 machine running SQL Server 2022.

I have set up the new servers as per the instructions, using an ODBC connection.
But I get the following error in the servU logs:

[05] Mon 24Apr23 09:17:45 - ODBC ERROR:SQLConnect(0x5f7c8a80, "ServU_DB", -3, "ServU_User", -3, XXXXX, -3) --> SQL_ERROR (-1)
[05] Mon 24Apr23 09:17:45 - [28000] [Microsoft][ODBC Driver 18 for SQL Server][SQL Server]Login failed for user 'ServU_User'.
[05] Mon 24Apr23 09:17:45 - ODBC ERROR:SQLDisconnect(0x5f7c8a80) --> SQL_ERROR (-1)
[05] Mon 24Apr23 09:17:45 - [08003] [Microsoft][ODBC Driver Manager] Connection not open

Here is the error in the DB logs:

Message
Login failed for user 'ServU_User'. Reason: Password did not match that for the login provided. [CLIENT: xxxxxx]

I swear I have checked the password several times, and it is the correct one.

I have tried different ODBC drivers (Sql Server, Sql Server Native Client 11.0, ODBC Driver 17 for SQL Server and ODBC Driver 18 for SQL Server)
and I get the same error.

Is there some kind of forced encryption setting in SQL 2022 happening or something that could be breaking the password?

I figure I'd try here as the paid support is no help at all. I think it might be some sort of chatbot....

  • Updating all Components in one step seems risky in my opinion. Any usefull logs in the database-server?
    Can the new application-server connect to the old database-server?

    best regards,
    Markus

  • So this is odd. At some point when I was messing with the ODBC settings it started to work. Probably when I changed to the new sql odbc drivers.
    I just didn't notice because log still shows the "Login failed" error on servu service startup.


    But I guess after it throws that error it connects ok? It just doesn't log it. The users and groups tables load fine in the UI and I can create and manage db users.


    Turning on ODBC call logging shows it making successful calls.

    I guess this is just a startup bug of some sort?