This discussion has been locked. The information referenced herein may be inaccurate due to age, software updates, or external references.
You can no longer post new replies to this discussion. If you have a similar question you can start a new discussion in this forum.

15.3.2 upgrade failure

Attempted upgrade from 15.3.1 to 15.3.2 on four of our twelve hosts. Identical problem on all of them so far - Serv-U.dll. "An error occurred while trying to replace the existing file: DeleteFile failed; code 5. Access is denied.

Have tried waiting & click "retry". Not happening.  Went in & made sure service is stopped.  Tried shutting down Serv-U first & exiting tray before attempting upgrade.  These are very standard host servers, doing nothing other than hosting Serv-U.  Are there any other customers running Serv-U host on Windows that have successfully upgraded to this version?

  • I havent seen that before but couple of things to check..

    1. When you shutdown Serv-U, check that serv-u.exe is gone from Task Manager before you run the upgrade. On busy servers sometimes it takes some time to 'quit' fully.
    2. When you run the upgrade, it could be that the user you are running the installer as does not have full admin rights or sufficient rights to the Serv-U folder in Program Files. There were changes a few versions ago that may have updated the permissions on the folder, have a check on the folder and or file you're getting the error with.

    Also, if you are upgrading to 15.3.2 and have a lot of users, be aware of the issue listed on the thread below as you will want to get the Buddy Drop fix from support before you do the upgrade if you are affected by the issue..

  • The "fix" is to shut down Serv-U, exit the tray utility, rename the .dll file, and then perform the install.

    I'd LOVE to see one update come out where you just click the executable, watch the progress bar go all the way from left to right without any intervention, and finish successfully.