This discussion has been locked. The information referenced herein may be inaccurate due to age, software updates, or external references.
You can no longer post new replies to this discussion. If you have a similar question you can start a new discussion in this forum.

Serv-u 15.3 will not allow us to login after update

Good day,

I attempted to install Serv-U 15.3 on Thursday night from version 15.2.4 (Released in December) and after the installed, we could not log back into the interface.  We kept getting the "ERROR: Operation was not successful, an unknown error occurred. Your session may have timed out. Please try logging in again:.

After this, I created a brand new Windows 2019 VM server and installed the same version as a test and we got the same error message.  Has anyone else had any issues when it comes to installing the new update?

We were dead in the water so I had to rebuild a server (Windows 2019 server) and re-installed the older version that worked prior in order for us to gain access to Serv-U.  This worked for us but I wanted to see if anyone else had experienced the same thing.  I am skeptical to install the latest version again due to this issue.

I know we need the newest version but I am also a firm believer in doing the same thing will give you the same results.

Has anyone else experienced the same results that we have on this version?

Thank you for your time and consideration.

-Dave

Parents
  • This is an issue introduced in 15.2.5 and 15.3.0. It has been suggested on another thread that it is a change to the XSS handling that doesn't like proxies. Is your instance behind a load balancer or do you use a proxy?

    If you contact support they should be able to help. They sent me a customer special fix that I have yet to try. They may be able to do the same for you.

  • Thank you for your response.  We are behind a load balancer.  I can't lie, since 15.3 broke what we had originally, I am a bit skeptical to install Serv-U 15.3 and apply the hot fix. 

    I have however opened a case with Serv-U support and they did send me a zip file with files that would need to be replaced in order for this to work.

    Alastair,

    Is your version running on a Win server or Linux?  I am only asking to verify that the fix they gave you was able to resolve the login issue.  Our Serv-U environment is running on Win Server 2019.

    Thank you so much for your response by the way.

    I really appreciate it.

    -Dave

  • This is a windows server (2012 R2 for the test box). Testing this morning shows everything working OK. Ensure you take a backup (as in the instructions and best practice) before applying the patch.

    I've not had an issue with hotfixes in the past - usually just 6 files to replace.

    I've also not had a machine that broken I had to rebuild it. Either a restore from backup (program files / programdata and other key files) or by restoring the snapshot for a VM has fixed any broken updates - my fault anyway.

  • Thank you for your feedback AlastairFrench.  I really appreciate your input on this.

    -SuperDave71

Reply Children
No Data