This discussion has been locked. The information referenced herein may be inaccurate due to age, software updates, or external references.
You can no longer post new replies to this discussion. If you have a similar question you can start a new discussion in this forum.

history not working on any NCM jobs

When a job runs, the history file should be the results of the job.  I know this used to work, but does not anymore.  Anyone else see this?  I am running NCM 2020.2.6.  On history that is too large to view, I click save and the screen blanks and I get the error Exception has been thrown by the target of an invocation.  On history of jobs that are not too large, nothing happens and I get There was an error processing the request and it is just Loading.

  • Yep, I'm seeing the same issue. The maximum size for the history seems to have gotten really, really small after the last update. I'm seeing this happen with anything that's more than about 30 or 40 lines. On the bright side, the emailed results are still working regardless of the size. 

  • Are you seeing it from the Jobs list (/Orion/NCM/Resources/Jobs/JobsList.aspx) page?

    When I click on the history icon   I'm getting a modal box with the logs.

    Then if I click save, the file seems to download fine.

    I'm running Orion Platform 2020.2.6 HF1 with NCM 2020.2.6.

    If you are still having problems, I'd definitely open a support case.

  • Running into this issue myself. At the bottom of the Jobs web page it just says "There was an error processing the request" and the loading box will spin indefinitely. This is keeping me from clearing the log also to see if it's just a size issue post upgrade to 2020.2.6 HF1

  • First off - this sounds like a bug and should be reported to support if you haven't already done so.

    Secondly, I wrote something that uses the API to pull these history logs and (optionally) clears the logs.

    If you'd like to try it, you are welcome to see if dumping and then clearing the logs fixes the problem.  As with all scripts, make sure you understand what it's doing and then make a backup of your system and database before running (to just be safe).

    It was tested on Orion Platform 2020.2.6 HF1 and NCM 2020.2.6.

  • We have received your support request for support case #00903155.

    Case open, lets see if anyone can figure it out.

  • Just tried out that script and it's getting an error around JobLogIndicator when it's trying to populate the $NcmJobs variable.

    Get-SwisData : Cannot resolve property JobLogIndicator
    At line:17 char:12
    + $NcmJobs = Get-SwisData -SwisConnection $SwisConnection -Query $Swql
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : InvalidOperation: (:) [Get-SwisData], FaultException`1
    + FullyQualifiedErrorId : SwisError,SwisPowerShell.GetSwisData

  • Huh - I've got that field with Orion Platform 2020.2.6 HF1 and NCM 2020.2.6.  I don't know what to tell you if that field is missing.  I guess you could try and comment it out or remove it, but I used that field to determine if there was a log or not.

  • I have opened a case on this and got a solution.  I have done this on our development server and it did fix the issue.

    Here is what I was told to do...

    RDP to the Primary Orion server
    2. Access the Orion web console from here and see if the issue persists. If not see next step
    3. Navigate to C:\Program Files (x86)\SolarWinds\Orion\NCM\ and look for the file SolarWinds.InformationService.Linq.Plugins.NCM.dll
    4. Copy this file to your Additional web server and paste it on the same location (given that your installation directory is the same as the primary)
    5. Once the file is copied over to the Additional Web Server's NCM install directory, right-click to Properties to 'Unblock',
    6. Open Orion Service Manager and Stop/Start everything (will cause a temporary downtime on this web server only)
    7. Check the NCM job log
    I could not figure out what was meant on step 5 and skipped it.  Still worked.  I can now open History files.
  • Typically when you copy or download files that are untrusted by the server it will have an execution block on it imposed by the OS. If you right click a file and select 'Properties' you will see a button on the lower right of the dialog that says 'Unblock'. This will remove the execution block imposed by the OS.

  • Thank you @usuee! It worked wonderfully!

    Thank you for sharing.