This discussion has been locked. The information referenced herein may be inaccurate due to age, software updates, or external references.
You can no longer post new replies to this discussion. If you have a similar question you can start a new discussion in this forum.

HP GbE2c running iscli hangs with Enable password set

Hi,

Has anyone configured HPGbE2c switches for blade enclosures on Cattools? We have a lot of blade switches here and I have upgraded FW on switches to virtually the latest version (5.1.2). I was able to get configs off a couple of switches by switching to ISCLI mode (virtually IOS). As soon as I put an enable password on, the back up fails as the switch seems to need an extra Carriage Return between telnet login and enable login. I used Cisco switch IOS  and Cisco Other for my device and model type respectively; although I have since tried others and they too have failed. Any help, suggestions, greatly appreciated.

Thanks,

John

  • Hi John,

    Did you not have any luck with the HP.Switch.2500 device type in CatTools then?  I believe this one should work with the HP GbE2c Interconnect switches as we have made a few script tweaks in the past for them (including automatically handling the "Select Command Line Interface mode (aos/iscli)" prompt too.

    Give this a try and let me know how you get on.

    Steve

  • Hi Steve,

    Thanks for getting back to me. Using HP.Switch.2500 still did not work. The script hangs on 'waiting for data'. I did however, did get it to work once, without an enable PW and on an old version of FW. As soon as I upgraded (vers 5.1.2) it does not seem to work. I have tried filling in the prompt fields with the standard prompts but that seems to make no difference. I will keep trying and let you know if I have any success.

    Thanks again,

     

    John

  • Hi John,

    If you have software maintenance for CatTools, I'd recommend opening a support ticket so we can look into this further as it may be something specific to the FW upgrade.

    Please send in the following files when you open the ticket:

    1) a CatTools device capture (debug log). http://www.kiwisyslog.com/help/cattools/mnu_fileenablecapturemode.htm

    2) the infolog.txt file from the \CatTools install folder (after the debuglog file in 1. has been created so they can be cross-referenced)

    3) a sanitised database report. http://www.kiwisyslog.com/help/cattools/mnu_filedebugcreatesanitised.htm

    Regards,

    Steve

  • HPGbE2c are Nortel base devices, use the Nortel.Application.Switch , I set the type to Alteon althought it will work anyway.

    May be you have to set the Username prompt and Password prompt at Prompts tab,

    I used the activity device.backup.running.config, adds your devices and at "Options" tab mark "Use alternante command" and add "lines 0" (without ""), this last is necesary if your device had a big config, if not will start to ask for return and Cattool will not be able to handle it.Hope this help.

  • Choosing Nortel Switch Device Template helped. Thanks!

    Still unable to download config.