This discussion has been locked. The information referenced herein may be inaccurate due to age, software updates, or external references.
You can no longer post new replies to this discussion. If you have a similar question you can start a new discussion in this forum.

Error during Recertification - ARM

Hi Everyone,

I'm trying to perform a manual recertification just to show the users what they will be presented with, but I'm running into the following html error

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "">www.w3.org/.../xhtml1-strict.dtd"> <html xmlns="">www.w3.org/.../xhtml"> <head> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/> <title>502 - Web server received an invalid response while acting as a gateway or proxy server.</title> <style type="text/css"> <!-- body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;} fieldset{padding:0 15px 10px 15px;} h1{font-size:2.4em;margin:0;color:#FFF;} h2{font-size:1.7em;margin:0;color:#CC0000;} h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;} #header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF; background-color:#555555;} #content{margin:0 0 0 2%;position:relative;} .content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;} --> </style> </head> <body> <div id="header"><h1>Server Error</h1></div> <div id="content"> <div class="content-container"><fieldset> <h2>502 - Web server received an invalid response while acting as a gateway or proxy server.</h2> <h3>There is a problem with the page you are looking for, and it cannot be displayed. When the Web server (while acting as a gateway or proxy) contacted the upstream content server, it received an invalid response from the content server.</h3> </fieldset></div> </div> </body> </html>

The configuration box that gets displayed is empty

Hoping for any assistance

Thank you in advance

James

Parents
  • Cause:
    • This problem seems to happen when there is a great number of permissions to be considered, that differ from the inherited ones.
    • This problem has been seen to happen when an SQL Express version or an unsupported SQL Server version is used to host the ARM Database.
     

    To solve this problem, the following solutions can be applied.

    • While keeping the actual SQL Server version, try to recertify smaller portions of the share that contains less folders and therefore fewer permissions.
    • Upgrade the SQL Server to a higher version.
    • Blacklisting big groups may also be needed for both solutions mentioned above.
  • Thank you

    The version of SQL is full Microsoft SQL 2017 as specified by our Vendor that installed ARM, upgrading is not an option at the moment

    The issue is that we have a few shares in which there are multiple folders all with different security groups assigned due to the nature of our business, the folders under each inherit the root folders permission, with the exception of one folder that has the inheritance broken and a different group assigned

    I have tried on a share that has the smallest number of folders but it still fails 

    You actually set up our configuration, have you got any further idea's?

    Thank you again in advance

    James

Reply
  • Thank you

    The version of SQL is full Microsoft SQL 2017 as specified by our Vendor that installed ARM, upgrading is not an option at the moment

    The issue is that we have a few shares in which there are multiple folders all with different security groups assigned due to the nature of our business, the folders under each inherit the root folders permission, with the exception of one folder that has the inheritance broken and a different group assigned

    I have tried on a share that has the smallest number of folders but it still fails 

    You actually set up our configuration, have you got any further idea's?

    Thank you again in advance

    James

Children