WPM Playback Intermittently Down

Hey All,

so this is the issues that we have for couple of transactions that we have:

  • The transaction intermittently failing on the playback - upon seeing the details it appears that the steps stuck on loading the next page, and the next page never show up, hence the playback shown as down - the site itself is not down or having any issues, tested and verified this many times already so I believe that the issue is with the WPM not the sites. This is happening for some of our transactions, with various occurrences, some site like o365 seemingly failed more often than others. The issue happening in totally random occurrences, which makes it very difficult to diagnose. We tried to run the player on different server, even setup one server for testing, but the issue is still there, so I'm convinced that the server is not the issue. The player running on Windows Server 2012 R2.
  • Recording working fine, tested the transactions using the recorder many times, but never failed even once.
  • I found this old discussion: https://thwack.solarwinds.com/thread/100415 which seems to have the similar issues. I have tried to set maxPlaybacksPerWorker to 1 per that thread but doesn't solve the issue, although it appears that it slightly improves the situation but not solving the issue. I have also tried to do the XY recordings, but that doesn't solve the issues as well.
  • I have also taken out Antivirus out of the equation, tested to run on test server with no antivirus and it makes no difference.

I have an open case with support, but wondering if anybody have similar issues? And if so, do you find any solutions?

Thank you

  • Been running this gauntlet for almost 2 years now, and the reason we require 2 failures (20 minutes of downtime) before alerting out. It cuts down on false alerts, but takes 20m+ to detect an issue. It is product related bc our simpler sites are solid in WPM and never/rarely fail. It wouldn't be that bad if we could immediately retest after a failure, but WPM is limited in what it can do at runtime and we have to wait an entire run interval to verify. My team has spent 100s of hours banging our heads against our desks trying to crack this egg and the only hope is a better product. Angular JS.

  • Ugh - hopefully it get fix soon. It affected some of our important monitors, the way it is now, it's impossible to enable the monitor to those affected.

  • Welcome to the 7th circle of Hell, was getting lonely here ;>

  • This is something that I started doing with my WPM transactions that have shown more stability. I'm pretty sure you'd have to re-create your recording though...

    This is how i start.

    1. Maximize the WPM Recording window
    2. Start recording
    3. Navigate to about:blank page
    4. Enable XY mode
    5. Click anywhere on the page
    6. Disable XY mode
    7. Navigate to website

    So steps 1-6 above equal the first step below in the transaction which i just call 'beginning.' I modify the time on the XY step to be 0.05 seconds.

    pastedImage_0.png

    Doing this forces an exact page size when browsing to my websites which isn't automatic in WPM.

    Hope that helps.

  • hey rarko another one here still waiting for a solution.....

    @chad.every - I will try anything once, have already wasted so much time on this, so i'll give this a go also, thanks for the info.

    Just out of curiosity, what is your reasoning behind forcing an exact page size?

  • I have a similar, but not identical, issue as well. I've had very strange WPM behavior in several instances, one I worked with support on for months with no resolution, beyond "you need to upgrade your target page's software", which didn't make me very happy. But I digress.

    The issue I have now is that I have transactions that always take a normal amount of time when running in the recorder taking a significantly longer time in the player, causing alerts. Further, SOMETIMES, those transactions seem to run quickly, but in those cases I noticed there is no screenshot returned, so that makes me believe it's really erroring/timing out but there's no error logged. Then the next polling cycle it takes it's long time, but is successful. To me it is very similar behavior to what the OP's indicated as "random" in that environment. I've tried manipulating the browser emulation settings in the registry, re-recording transactions, etc, and nothing works.

    I've got a case open with support but am still waiting on feedback or anything else to try.

  • Hi,

    The main difference in the run of a transaction in WPM Recorder and WPM Player is user account under which "playback is running". Have you performed following steps during support troubleshooting?

    Troubleshooting (Player is using SEUM-User local accounts for playback):
    You do not know the password to SEUM-User local accounts, but you can recreate them with some password (Just changing password via MMC will cause that WPM Playback service will not know the password for this user, so it cannot use that user account!!)


    Steps to recreate SEUM-User accounts with some known password:

    1. Stop SolarWinds WPM Playback Service and WPM Playback Proxy service.
    2. Open the config file SolarWinds.SEUM.Agent.Service.exe.config in Notepad by default located at "C:\Program Files (x86)\SolarWinds\Orion\SEUM\Player\"
    3. Edit the tag <agentConfiguration> by adding attribute for workerUserPasswordOverride or edit value of this attribute, if it is already presented.
    For example: <workerUserPasswordOverride="Password1"/>.
    4. Remove the file, AgentSettings.dat – removing this file will also remove all configuration done by the Player settings tool. This file is located in "C:\ProgramData\Solarwinds\SEUM\Data"
    5. Start SolarWinds WPM Playback Service and WPM Playback Proxy service.

    Once you have SEUM-User with the known password you can do following:

    1. Stop Solarwinds WPM Playback Service and WPM Playback Proxy service.
    2. Run WPM Recorder under some SEUM-user account (Right click -> Run as the different user) and play the problematic recording and observe behavior and mainly duration.
    3. If duration is also longer the issue is clearly related to this difference between account used for playback and SEUM-User account. You should check run IE  (Right click -> Run as the different user) under the account you are using normally and SEUM-User and mainly check proxy settings.

    Petr





  • I did set a specific password. However when I run the recorder as one of the SEUM user accounts, I get a dialog stating "An unexpected error occured (sic) while trying to connect to the server." I don't see any error logs that provide any additional detail. If I run the recorder as myself using the same login credentials I can get in. If I sign in to IE using that account I can get to the site in a "normal" response time; roughly 2 seconds vs roughly 25 seconds coming back from the player. There are no proxy settings (and no proxy between the player server and the site). I've even tried adding that site to the compatibility mode settings with no luck.

  • And what if you copy recording to the machine and do no try to connect to the server, but instead select the option "work offline" ? Then you import the recording and play it ?

  • Hi,

    One more thing:
    If you run IE as SEUM-User can you do following ?

    1. Stop SolarWinds WPM Playback Service and WPM Playback Proxy service.
    2. Run IE as SEUM-User-x
    3. Navigate to proxy settings.
    4. (Optional grab a screenshot and send it here)
    5. Do some changes there, for example, specify some proxy address (even nonvalid just for testing purposes)
    6. Apply changes, save it, close IE
    7. Run IE as SAME SEUM-User-x as in step 2
    8. Navigate to proxy settings.
    9. Provide following information: Are changes you did in step 5 present?

    Petr