Setup WHD on Azure CentOS VM

Hi,

I have deployed a CentOS 7 VM in Azure.

I downloaded and installed the RPM, but I am stuck at the step to complete the installation.

I am supposed to connect to port 8443.
When I run lsof, I see not process listening on port 8443.

systemctl show the process as exited:

systemctl status webhelpdesk
● webhelpdesk.service - LSB: Web Help Desk
Loaded: loaded (/etc/rc.d/init.d/webhelpdesk; bad; vendor preset: disabled)
Active: active (exited) since Thu 2022-05-05 12:00:16 UTC; 20s ago
Docs: man:systemd-sysv-generator(8)
Process: 3660 ExecStop=/etc/rc.d/init.d/webhelpdesk stop (code=exited, status=0/SUCCESS)
Process: 3963 ExecStart=/etc/rc.d/init.d/webhelpdesk start (code=exited, status=0/SUCCESS)

May 05 12:00:15 whd webhelpdesk[3963]: 2022-05-05 12:00:15.366 UTC [4004] LOG: listening on Unix socket "/tmp/.s.PGSQL.20293"
May 05 12:00:15 whd webhelpdesk[3963]: 2022-05-05 12:00:15.369 UTC [4005] LOG: database system was shut down at 2022-05-05 11:48:27 UTC
May 05 12:00:15 whd webhelpdesk[3963]: 2022-05-05 12:00:15.372 UTC [4004] LOG: database system is ready to accept connections
May 05 12:00:15 whd webhelpdesk[3963]: done
May 05 12:00:15 whd webhelpdesk[3963]: server started
May 05 12:00:15 whd webhelpdesk[3963]: Starting the Web Help Desk on port 8081...
May 05 12:00:15 whd webhelpdesk[3963]: Starting an SSL connection to the Web Help Desk on port 8443...
May 05 12:00:15 whd webhelpdesk[3963]: (See README.txt for information regarding SSL connections.)
May 05 12:00:16 whd webhelpdesk[3963]: Tomcat started.
May 05 12:00:16 whd systemd[1]: Started LSB: Web Help Desk.

It has to do with a folder or symlink missing:

su: warning: cannot change directory to /usr/local/webhelpdesk/bin/pgsql/var/lib/pgsql: No such file or directory

The folder is not there.

WHD creates a folder for pgsql13.

There is no folder var under that folder.

Has anyone alse run into this?

(BTW: when webhelpdesk runs, I'll finish the installation using ssh tunnels as mentioned here https://thwack.solarwinds.com/product-forums/web-help-desk-whd/f/forum/43494/whd-installation-initialization-from-localhost-only.)