Release of Web Help Desk version 12.7.3 - Build #12.7.3.81

version 12.7.3 - Build #12.7.3.81

The downloads was available in my download portal...

Documentation: https://documentation.solarwinds.com/en/success_center/whd/Content/Release_Notes/WHD_12-7-3_release_notes.htm

Just upgraded our development server... how is anyone else getting on?
 
 
  • I'm about to deploy it in a dev environment as well, have you seen any issues with your test so far?

  • Found a few things which I've reported to SW, but nothing major yet

    Let me know how you get on..

  • Thanks for your feedback.  I just got our dev instance built out and have not seeing anything that is an immediate red flag with some basic processes.  It isn't anywhere near a standard install, but if I see a bug in how we run it, I will do a more standard install to see if the bug carries over and send some feedback.

  • I still haven't had the opportunity to really test the dev environment I setup, but I have not seen the occasional hang that I was able to produce in 12.7.2.  There was only 1 instance that I have seen this happen in when pointed at a specific DB backend and I think it may have been either a task(noted as a fixed issue in the release notes) or something else specifically setup on that instance of WHD that I never dug to far into because it was a just a test system to begin with. 

    When I pointed 12.7.3 to that database it isn't having the same issue, so that is a positive.

  • None of the reports work in 12.7.3.  I can't create new ones and all of my old ones fail when I try to run them, forcing me to have to log back into the system.  It generates a java.lang.reflect.InvocationTargetException from the FontManagerFactory.java class on line 86, as it bubbled up from the org.jfree.chart.block stuff.

    Other things seem to work, but reports are completely broken.

  • What's the structure / setup of reports?

    Are the alert level and alert status, as these are also broken in the dashboard...

  • For us, this update broke SSO (tried both ADFS and Azure AD, not working) with a MissingCsrfTokenException error relation to "your session was not found". I cntacted SW and they have confirmed that this is a known issue and the devs are working on it. A little annoyed that this wasn't listed as a known issue/gotcha in the various docs. Current advices from them, if you use SSO auth is:

    • Don't upgrade yet (too late for me)
    • Revert to the previous version (I'd rather not)
    • Turn off SSO and set passwords for Web Help Desk auth while waiting for a fix.

    Aside from not being able to sign in, it seems to otherwise be working fine, LOL.

  • Anyone tried the API? Since TLS 1.0 and 1.1 are disabled by default, which the API used, I hope this doesn't break the API?