Excel Templates download corrupted.

FormerMember
FormerMember

Each time I download an "Asset Import" template.  When I try to open it in Excel 2016, I get a message that "The file is corrupt and cannot be opened."  I've even tried opening the file in Excel manually, by doing an "Open and Repair".  When I do the "Open and Repair", the message says that "the file is corrupt and cannot be opened".  When using Excel 2016, I don't have issues with opening any other Excel document.  It seems that this only happens, when I download an Excel template from Web Help Desk.

I'm using Web Help Desk ver. 12.4.1 - Build # 12.4.1.983 as it's own appliance, running Linux.

  • I would think WHD does not understand the Excel 2016 format, save as old .xls format rather than .xlsx or CSV then import.

  • Not sure about the Linux appliance, but running v.12.5.1 on a Windows box, we have the option to download the template as a TSV, CSV, or Microsoft Excel file.

    I tried both the CSV (which defaults to MS Excel Unicote (UTF-16) file encoding) and the Microsoft Excel file type. I could open both files without issues using Excel 2016 on both Mac and Windows.

    Do you have the option to choose different file types to see if they work? Or possibly a different browser (I'm using latest Chrome, 64-bit).

  • FormerMember
    0 FormerMember over 4 years ago in reply to justin.gray

    I do have have the option to use either a (TSV, CSV, or Excel).  I've tried this on Chrome 64-bit version 60.x, and Microsoft Edge.

    The appliance that I have WHD on is the Virtual Appliance. 

  • If you don't have the option for either TSV, CSV or Excel then something is definitely wrong.

    These options are available on the Import page, see the following screenshot if you're unsure.

    image001.png

    If you download the template after selecting a different file type, the download will correspond to the one selected.

  • Solution 1: Changing Component Services Settings

    Follow these steps to change ‘Component Services’ settings:

    Step 1: Click on ‘Start’ or ‘Win+R’ then type ‘dcomcnfg’ and hit ‘Enter’.

    Step 2: In the navigation panel, expand the “Component Services”, and then expand “Computers”.

    Step 3: Then, right-click on ‘My Computer’, and then click on ‘Properties’.

    Step 4: When the ‘My Computer Properties’ dialog box appears, click on ‘Default Properties’ tab and then set the following values:

    • Default Authentication Level: Connect
    • Default Impersonation Level: Identify

    Step 5: Click on “OK” to change the “Default Properties

     

    Solution 2: By changing the Protected View Setting

    Step 1: Open the MS Excel, navigate to the ‘File’ menu and then click on ‘Options’.
    Step 2: Then, click on “Trust Center” and then on “Trust Center Settings”.
    Step 3: Next, choose Protected View” and uncheck all the options including “Enable Protected View for Outlook attachments” if you use Outlook for email.

    Step 4: Click on ‘OK’. Restart the application and try opening the Excel file again.

    Solution 3: Use an Excel repair software, to know more you can check out this thread