VMAN Cluster alert displays wrong host

Running 2020.2.4, noticed the out of the box Cluster predicted memory depletion alert was on.

Before customising it to inform people, I looked at the details and it is displaying the incorrect host as the cause in both the active alert and the event raised.

When I check the query adding in the inner join in to the swql to show the expected host, and also in the alert to try there also, the swql shows as expected but the alert/event still refer to an incorrect host:

SELECT  Clusters.Uri,  Clusters.DisplayName,  hosts.hostname, clusters.MemoryUtilizationDepletionDate  FROM  Orion.VIM.Clusters  AS  Clusters

inner join  orion.vim.Hosts  as  hosts  on  hosts.ClusterID  =  clusters.clusterid

where DayDiff(getdate(),   clusters.MemoryUtilizationDepletionDate)<7

Helpful advice would be gratefully received.

  • just to add, doing the same query with swql's inbuilt link without the join to remove the additional join being doubted shows the same issues of wrong host returned in the alert compared to the query. Making the alert from scratch again also shows the same. Most odd.

    SELECT   Clusters.Uri,   Clusters.DisplayName,   clusters.hosts.hostname,  clusters.MemoryUtilizationDepletionDate   FROM   Orion.VIM.Clusters   AS   Clusters

    where DayDiff(getdate(),    clusters.MemoryUtilizationDepletionDate)<7

  • Off the top of my head I can't think of a reason this should report this way. Could you open a ticket with support on this so the team can investigate the problem with you?