"Subqueries are not supported" running queries in EOC

Running queries against table NCM.NodeProperties.  

In regular Orion the query works fine.  Attempting the same query in EOC returns an error:

"Subqueries are not supported". 

No subqueries here. Just a simple SELECT statement against a single table

We recently upgraded our Orion and EOC to version 2022.3.  Using SWQL Studio version 3.1.0.343.

Any insight from the community much appreciated.  Thanks.

Parents
  • Can you provide the query in a code block? (Insert, Code, select SQL as the formatter)

  • SELECT TOP 1000 NodeID, CoreNodeID, NodeGroup
    FROM NCM.NodeProperties

    I opened up SWQL studio, connected to my EOC server, data schema browse (left pane) to NCM.NodeProperties, right-mouse click and 'Generate Select Statement'.  Remove some of the fields for clarity.

    Note these queries run fine in regular Orion.  Just not in EOC.

    Thanks for your help. 

  • I don't have EOC installed at the moment, so could you try something for me - as a test?

    See if there are "Cirrus" entities that seem to match and try your query there.

  • Under Cirrus I don't have an NCM.NodeProperties.  However, I do have a Cirrus.NodeProperties table. Right-mouse >> generate select statement also returns the "Subqueries are not supported" error box (screenshot).

  • Yeah - something's not connecting right.  On the EOC website, can you go to myEoc.domain.local/Orion/admin/swis.aspx and see if you have the NCM entities listed in the drop-down?

    Then hit Generate Select Query and Run Query. (Ignore my above query)

    I have a sneaky suspicion that the EOC and native entities aren't connected.  You are running a recent version, so there's something amiss and we may need to get this in front of support or the product manager.

  • Accessing <eoc site>/admin/swis.aspx  >> select entity: NCM.NodeProperties >> generate select query >> . Execute Query.  No data returned. No errors, just nothing returned (screenshot).

    We have other data reports that run out of EOC pulling from NPM tables - node and interface tables.  These run successfully without errors after the 2022.3 upgrade.

  • Yeah - I'm not sure what's happening.  Without an EOC instance to play on, I can't offer much personal help at the moment.

    I'd open a support case and let them know that this worked before the upgrade.  Feel free to reference this thread for more information.  Ask them to contact me if they need more info.

  • Opened a ticket with technical support.

    Solarwinds acknowledges this as a product bug, as detailed below:

    Author: Support Team - Technical Support Address [technicalsupport@solarwinds.com]
    Recipient: robertxxxxxxxxxxxxx

    Hello Robert,  Thank you for your patience, I have heard back from my development team.  My Development team was able to reproduce this issue in our lab.  We have identified it as a BUG in the product; at this time, we do not have a workaround to offer.   Thank you for bringing this to our attention.  Please let me know if this helps or if you require further assistance.  Kind regards, John Wallace, SolarWinds Technical Support  

    For now it appears that queries running against the NCM.NodeProperties table from EOC will fail and return a message "Subqueries are not supported".  These queries will run fine against regular Solarwinds.

    Cheers.

  • Good to know.  Do they have a bug number?  That way you can look at release notes for fix notes.

Reply Children
No Data