Average Availability difference in SWQL Query and Web Report Writer

Hi

I am always getting different result as compare to SWQL Query and Web Report Writer.

Mentioned is Report of Average Availability LAST MONTH.

SWQL Result:

SELECT
concat(round(avg(Availability), 2), ' %' ) as supernet
FROM Orion.ResponseTime rt
where
monthdiff(datetime,getdate())=1 and rt.Node.CustomProperties.SLA_LTE ='supernet'

Web Report Result:

Parents
  • I've tried this on three different systems I manage and none of them are showing a disconnect between a report with this query, the query itself, and a custom widget with the query.  (I did have to skip the Custom Property filter because I don't have this one defined.)

    Couple of quick questions:

    • What version are you running?
    • What time zone are you (your browser) in?
    • What time zone is the Orion web server in?
    • What time zone is the SQL database in?

    These may have nothing to do with anything, but I want to rule them all out.

    Note: There's no need to call me out directly.  I'm subscribed to this space and review forums as I have time.  I was very busy over the last two weeks with THWACKcamp 2022, so my time has been devoted elsewhere.

  • Hi

    • What version are you running?  Orion Platform HF1, NCM, IPAM, NPM, NTA: 2020.2.5
    • What time zone are you (your browser) in? GMT+0500 (Karachi Standard Time)
    • What time zone is the Orion web server in? (UTC+05:00) Islamabad, Karachi
    • What time zone is the SQL database in? (UTC+05:00) Islamabad, Karachi

     

  • Not that it would 100% fix things, but the latest version of the Onion Orion Platform is 2020.2.6 HF4 (at the time of this writing).  I know that some date/time things were remedied in that release and subsequent hotfixes, but I'm not sure if they are the ones you are running up against.

  • Many layers this Onion platform Grinning

Reply Children