CreateSubnetForGroup : Hierarchy group with id/name '191' not found


When invoking CreateSubnetForGroup with a hierarchyGroup other than 0, we get error 'Hierarchy group with id/name not found'. If we use hierarchyGroup 0 it works and gets added to the default "IP Networks" group.

How do we add this new subnet to our created group with GroupId 191 (or any other user created group)? We have verified 191 is the valid GroupId for this group and we also have tried the FriendlyName of the group and it still gives the same error.

Example python call:

swis.invoke('IPAM.SubnetManagement', 'CreateSubnetForGroup', '', '24', '191')


Traceback (most recent call last):
  File "", line 42, in <module>
    swis.invoke('IPAM.SubnetManagement', 'CreateSubnetForGroup', '', '24', '191')
  File "/usr/local/lib/python3.6/site-packages/orionsdk/", line 31, in invoke
    "Invoke/{}/{}".format(entity, verb), args).json()
  File "/usr/local/lib/python3.6/site-packages/orionsdk/", line 63, in _req
  File "/usr/local/lib/python3.6/site-packages/requests/", line 940, in raise_for_status
    raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 400 Client Error: Hierarchy group with id/name '191' not found for url: https://solarwinds:17778/SolarWinds/InformationService/v3/Json/Invoke/IPAM.SubnetManagement/CreateSubnetForGroup
Parents Reply Children
No Data