SWIS / SWQL Studio / API - Windows Group Authentication Issue

Hi All,

One of our SolarWinds NPM 2020.2 instances is experiencing authentication issues with SWIS and SWQL Studio connections.

SWIS and SWQL Studio connections to SolarWinds do not appear to allow authentication of active directory accounts configured for SolarWinds access via "Windows Groups".  SWQL Studio simply reports the following...

Capture.PNG

The Orion log on the primary poller reports the following when such an attempt is made:

WARN  SolarWinds.Data.Providers.Orion.OrionAccountValidator - (null) (null)  Invalid username or password for user 'DOMAIN\username' via password hash comparison.

Logins to the SolarWinds web front end/GUI authenticate via "Windows Groups" without any issues.

Connecting via SWIS/SWQL Studio using an individual account which is configured within SolarWinds (local Orion or active directory account) also works without any issues.

To rule out an issue with a specific windows group, a new group was created and configured for access within SolarWinds however the issue with SWIS/SWQL Studio connections also occurs with this new group.

We have other similar SolarWinds instances which allow "Windows Group" authentication via SWIS/SWQL Studio without any issues, so we know this authentication method should be possible.

Has anyone had similar issues?

Thanks.

Parents
  • Run sql query SELECT AccountID, AccountSID FROM [DATABASE].[dbo].[Accounts] WHERE AccountID='DOMAIN\ACCOUNT'.
    Replace DATABASE and DOMAIN\ACCOUNT with corresponding ones for you.

    If you got NULL AccountSID, just update the value with the proper SID for your account. 

    Fixed for us this exact issue. I'm curios if this helps others and amazed how this does not have an answer yet being opened since more than 1 year

  • Just adding a tag to this as it wasn't one of the results that came up when I was searching, but was the correct solution.

    • SolarWinds.Data.Providers.Orion.OrionAccountValidator
    • Invalid username or password for user via password hash comparison
    • SWQL Studio Unable to connect to Information Service. Invalid username or password
Reply
  • Just adding a tag to this as it wasn't one of the results that came up when I was searching, but was the correct solution.

    • SolarWinds.Data.Providers.Orion.OrionAccountValidator
    • Invalid username or password for user via password hash comparison
    • SWQL Studio Unable to connect to Information Service. Invalid username or password
Children
No Data