Oracle User Experience Monitor: Failed to find or load the registered .Net Framework Data Provider

Hello - 

I recently upgraded to 2022.3 and now all of my Oracle User Experience monitors are in an "unknown" state because of the following error message:

"Failed to find or load the registered .Net Framework Data Provider"

Nothing has changed on the linux servers I'm monitoring that host these Oracle DBs, and I already had Oracle .NET installed on our polling server before the upgrade. 

What's the fix please? 

  • We're having a similar problem. We use the "Microsoft .NET Data Provider" Oracle driver type, which required installing an extra tool from Solarwinds. Post-upgrade it's acting as though it isn't installed, though it is.

    I tried creating a brand new application monitor template using the default "Managed Oracle Data Provider for .NET", but I'm getting the same error as you. For this Oracle Driver type is there any addition installation or configuration it needs, or should it just work out of the box? Thanks so much, and congrats on solving your issue!

  • Take my upvote for contributing to the thread! Sorry to hear that you're dealing with the same thing! 

    We're still having issues too and this problem is not completely resolved for us either. SolarWinds support recommended I re-install the Oracle .NET framework on our polling server

    I'm doing this tonight and will let you know if it works. 

Reply Children
No Data