Odd Characters in "Your incident was received" email

We are seeing odd characters in the "Your incident was received" email. We have not changed the template in anyway.

I created an Incident and the title is "Test Ticket" however when the email is sent it displays as show below

� Test Ticket

It looks like this when received in Outlook and also in the default Mail app on the iPhone.

Navigating to Setup->Service Desk->Notification I have reviewed the "Incident Created for Requester" and the "Incident Created for Assignee" and I see nothing out of the ordinary.

This is currently with the Engineering Team at SolarWinds however no one has been able to figure out where this is coming from. Anyone else ever experience this issue?

Few Screenshots below

Parents
  • Hi,

    Was this ever resolved? We're having a similar issue with our email notifications from Service Desk except the odd character is a question mark inside a diamond. Thanks.

  • It was never resolved. Solarwind states it's our mail server. Here was the closing comments. "Thank you for your patience, our engineering team is certain that the character is due to the encoding on your email server is not set to UFT-8. Kind regards,   Bryan Cuyong ITSM Support | SolarWinds"

  • We got the same response from Solarwinds support hence why I'm researching here to see if others have experienced this. We did test with a Solarwinds email account and the account received the email just fine so they are saying it's our mail server. We're not experiencing this with any other emails though. Only emails from Service Desk and this started happening early August. We have not made any changes with how our emails decode messages, mail flow, notification templates, etc. on our side.

    We have been able to recreate this problem and able to resolve it but still don't know what the root cause is. To resolve this, I had to update all of our notification templates. I had to remove any extra space after a period between two sentences or any extra space at the end of a final sentence. If the space is added back in, it will cause the odd character to show up. I don't know what character Service Desk adds in that space that would cause our mail server to not be able to decode it but their mail server can? Very strange.

  • I'm fairly certain it is our server. It took me a long time to find the setting however located it in Exchange Powershell and found ours is set to iso-8859-1 or Western European ISO and not the suggested UTF-8 encoding. We did start to see the same odd characters from another third-party source after the case was closed, which led me to believe it must be on our end. As a test, I set up a test user in the service desk with an office 365 address, and the messages came through just fine. What mail server/version are you using?

Reply
  • I'm fairly certain it is our server. It took me a long time to find the setting however located it in Exchange Powershell and found ours is set to iso-8859-1 or Western European ISO and not the suggested UTF-8 encoding. We did start to see the same odd characters from another third-party source after the case was closed, which led me to believe it must be on our end. As a test, I set up a test user in the service desk with an office 365 address, and the messages came through just fine. What mail server/version are you using?

Children
  • We are using O365 but have a spam filter that receives the messages first and then forwards to O365. The messages in the spam filter shows the odd characters also. Since I've resolved this by removing the extra spaces from the notification templates I'll wait to see if this happens with another 3rd party, if so, then I'll start to troubleshoot internally. If you happen to still have the location of where you found that setting and can share it, that would be great. Thank you for your time.