Problem with Dynamic Form Rule

I am trying to create a rule that will bring up a mandatory field if a staff member chooses copier as the category. The field is not appearing when I choose copier. Here is how I have it set up. Can anyone spot where my problem may be? I set up the custom field, the custom form, and the dynamic form rule.

  • Hi, 

    My name is Kfir Cohen and I am a product manager on the SWSD Product team. 

    It seems everything was setup correctly. 
    Do you only need the Category = Copier as the condition for form to show? If that's the case, the subcategory clause on the condition is redundant .

    Regardless, it should work properly the way it is setup now. 
    I will consult our engineering team and get back with a response. 


  •  , 
    I managed to reproduce the form, field, categories and dynamic form rule and they all work properly and the Copier Code field is displayed and required. 

    Did you you make any change in your setup since you posted this message 4 days ago? 

  • Hi Kfir,

     Yesterday, I was able to get a sandbox to work in and was able to create the form I needed. I then deleted the field, custom form, and dynamic form rule. I duplicated the information from the sandbox and now it is working. I think the order I created them in played a factor, so I created the field first, then the custom form, and then the dynamic form rule.

     

    Thank you for answering.

  •  

    I started with a form and created the field on top of it.
    Only then I created the dynamic form rule and it worked for me.