Need a WMI advice: Windows PowerShell WMI WIN32_Service not returning all services

Hello, guys. I have the same issue as in this old MS topic and as this reddit thread, but solution from MS forum - sc sdset scmanager (A;;CCLCSWRPWPDTLOCRRC;;;<USERSID>) didn't work for me - issue still exists. And reddit thread was closed without solving.

So the problem is: with local admin rights I got all 200+ services from the remote server, but admin rights is not okay due to our political reasons. So when I try to perform win32_service wmi-request without admin rights, I got only 75 services (from the same remote server).

User has local admin rights:
PS C:\> (Get-WmiObject -Class win32_service -computer "server"  | format-table Name).count

And without them:
PS C:\> (Get-WmiObject -Class win32_service -computer "server"  | format-table Name).count

Maybe now there is other SDDL options I should set? I use Windows 2019 Server.
Thank you in advance, I'm really stuck with that! 

  • Couple of thoughts/questions to consider.

    The thread "Has anybody ever gotten WMI to work without admin credentials" has several solutions that do work. SolarWinds has a document somewhere.

    InfraSight Labs has a relevant guide for how to do this as well (link taken from the above thread). Let us know here if you have any questions about implementing a specific step.

    And finally: try using the newer Get-CIM* cmdlets. You may still get the same results, but in the future, it's what Microsoft is maintaining. Example: 

    Get-CimInstance -ClassName Win32_Service -ComputerName localhost

    UPDATE: Here's the link to SW's knowledge base document [How to create a non-administrator user for SAM polling], but it only describes how to implement the steps manually on one server. The link from InfraSight Labs above is more useful in a managed environment.

  • Hi sturdyerde and thank you for answer.

    Yes, I know about all these guides and I read it carefully. Also I just check InfraSight's manual and I have the same user settings, also I tried to configure UAC and even totally disable it.
    Unfortunately, issue is still exist. That's why I think there must be some special SDDL permission which I missed.