New Devices not returning Network Latency & Packet Loss

I have a SAM installation (Version 6.6.0) and I have added a few devices to be polled by ICMP, they have been added for a few days but although they are showing up I have noticed I am not getting any Network Latency & Packet Loss information back from any of them, I have tried a 'Poll Now' and although it says poll successful I don't get any information on the chart and when I look at the Polling Details the 'Next Poll' details are long gone even though the Last Database Update is up to date.

I have looked at other nodes that are being polled using SNMP and although they seem to be returning the SNMP data the Polling Details again are old, some more than a month.

I have looked at the Polling Engine details and it is showing polling completion as 100 and the last database update as 2 seconds ago but something is obviously not functioning as it should.

All the services are showing as running.

I haven't tried a service restart or server reboot as yet I just wanted to see if anyone else has seen these symptoms before.

Any feedback would be appreciated.