HTTPS broken after upgrade to 15.3.1 (from 15.3.0)

I have Snap and upgrade our FTP server yesterday from 15.3.0 to 15.3.1

now https is no more working.

This site can’t provide a secure connection uses an unsupported protocol.

view certificate is fine and valid.
any idea ?
  • Has ANYONE just installed it and it worked correctly?  I am still not comfortable just "hoping for the best" if I attempt to install this version.  I have yet to hear anything from the support team about this (unless I have missed something somewhere) and I want to make sure that they are aware of all the issues posted above.

    Support has been really good in the past so I just want to make sure they were aware.

    I really appreciate all the input under the forum post.

    Thank you

  • I can confirm it is known 15.3.1 issue - certificates and private keys that are bigger than 4096 bytes are not accepted. There is BD support can provide based on request. Fix will be in code of next release. We also recommend to check current TLS setting in Serv-U management Console if Serv-U 15.3.1 installed.

  • Thank you.

    Is there a certain setting within the TLS settings in Serv-U management we should be checking?  What should this be set at according to support?  

    Thank you for your support.   I just want to be aware BEFORE I make any attempt to install this release.  I may just wait on the next release just to be on the same side.

    Much appreciated.