Can't find/set network drive as path for users

tried the search but since you can't select the Serv-U-forum as source there are too many results and I couldn't find a solution

Installed Serv-U trial on a server 2012 machine, gave the Serv-U service the Administrator user to grant access to the network.

A NAS is mapped as K: and can be accessed by \\nas-name with previously saved user/password on the Windows-Server machine.

When I create a new user in Serv-U and try to select a folder on the NAS as the user's home path, I only see my local drives. If I manually insert the \\xyz path it seems to be tried to get access for 2-3 seconds but then goes back to the screen with my local drives.

So my Serv-U installation is not able to browse/find/be forced to open network share.

  • So I managed to get it working by manually typing in the whole path of the network share in the home path for the domain:

    then I granted a domain-wide folder access:

    the user now just needs that home path where "Test2021" is a subfolder in the network share folder:

    In between I tried to NOT run Serv-U as a service. As a non-service I now saw my network drive letters but browsing in network shares via \\xyz still didn't work.

    So with Administrator as user for the service and deactivated UAC (was already done on our server, don't know if mandatory) you can't browse your network share, but it works when you manually write the complete path in the field. That sh*t cost me too many hours >:-/

  • Generally mapped drives are not available to be used in applications that run as a service - the reason is that the mapped drive is only available in the current 'interactive' user session and to a service it does not exist. I believe this is why your full path works.