NPM 2023.1.0 Upgrade Feedback Thread

I pulled the trigger and updated to 2023.1.0. from 2022.4 last week.

Updated a single polling engine with NPM & NTA that monitors 400 nodes.

Install went smooth using the My Deployment - Updates Wizard.

haven't seen any issues over the last week I believe that is related to update.

how did you install go, did you get an issues you logged with support, if so what are the ticket numbers?

  • Had an issue updating from 2020.2.6 HF5 to 2023.1. After the uninstall of the products, I got this fatal error.
    Found that WPM Transaction Player was still installed and couldn't be uninstalled manually from the Programs list.
    Used the Microsoft uninstall troubleshooter tool to remove it, rebooted and continued the update.

  • Updated my test system yesterday, had a couple strange errors pop up but the upgrade finished and the system is running fine. Doing my production one in a couple of weeks.

  • We just upgraded our QA environment from 2022.3 to 2023.1.  We did not have any issues.  We ran the offline installer from the main poller.  The configuration wizard did take a very long time to run, but completed without any errors.  After that we completed the upgrade from the console using the central deployment tool.  It looks like they worked out a lot of bugs in the GA release of 2023.1.

  • We are upgrading sometime this March. Hopefully the official release for the 2023.1 becomes smooth in our system. lots of hiccups on the current one we have 2022.3 version and was sorted out after weeks of remediation with Solarwinds.

  • Updated 2022.3 to 2023.1 last week. No issues during upgrade and only issue so far post upgrade is seeing constant SAM and NPM database maintenance messages saying it hasn't run in days. I ran it manually yesterday but the message for SAM still persists. I intend on opening up a case today. 

  • In reports, DateTime is now presented in UTC. How can I revert to local time?

  • Hi Nick, i had the same problem i don't have the message from mine, but it appears to fixed itself once I deleted an orphaned agent from solarwinds.

  • Interesting. I don't have any agents deployed though this may help others. Thank you!

  • We are on day 6 of trying to resolve the issues since upgrading from 2020.2.6 to 2023.1. Menu failures, database connection issues due to NCM trying to use the wrong account to access the database, "Manage Accounts" is super slow, "Diagnostics" does not work at all, Many Compliance Reports were broken, the list goes on and on. I was hoping this upgrade would help with some of the instability issues with 2020.2.6 but so far nothing but a nightmare. Repaired the install at the suggestion of SW tech but no help. If anyone has a suggestion on what might be a stable version I would love suggestions.

  • Ran into similar issue with unable to access folder to delete files. I checked and the folders were already empty. Turns out I had to reboot and rerun the installer. Since the uninstall already completed, I was concerned, but the installer picked up right where it needed to be and complete the install.  I did call support and they also suggested that the reboot was the only method around that.