NPM And ServiceNow Integration


I'm trying to integrate my NPM 12.4 to a servicenow (New York) instance.  I followed the installation steps provided on the servicenow store and solarwinds web site, however, I'm still having issues.

I went to the service now installation area of NPM and test the credentials, that works OK.

servicenow Credential Success.PNG

I am able to see my service now data from the main poller using this through the browser https://[INSTANCE NAME]

servicenow connection test.PNG

I still see the status as Down in the instances list.

servicenow status.PNG

servicenow action.PNG

I have tried disabling the instance, deleting it and re adding it, etc.  Nothing seems to work.  Can any of you point me in the right direction?

Thanks in advance!

  • I noticed some weird behavior at first where it just refused to work.  The only thing that solved it was completely removing the app from SN and then reinstalling it.  Not sure if that would help your specific problems, but maybe give it a shot?

  • Thanks for the quick reply.  I tried the uninstall/reinstall as you suggested, but still the same result.  Do you know of any logfiles in the solarwinds directories I can pull from?  Perhaps NPM is not sending the data that servicenow needs?

    It does seem to hit servicenow, here's the log from my most recent attempt:

    solarwinds connection test after reinstall.jpg

  • I have been poking around, making sure I'm running the right version of Solarwinds Core as well.  I'm running 2018.4.

    I don't really understand the layout of this compatibility matrix (perhaps not enough coffee yet) so I might need an upgrade.

  • You can check the integration logs here: C:\ProgramData\SolarWinds\Logs\ESI

    There should be an ESI.BusinessLayer.log file.

    If you want to increase the level of logging in that file, run the Log Adjuster tool on the SolarWinds server. I can't remember if it is called something different in NPM 12.4 but it should be similar to this.



    I'm also not sure you being on an older version on NPM is an issue. You may want to look at upgrading to 2019.4. I agree the matrix in the compatibility KB article is not great.

  • Thanks for pointing to the logfile.

    It looks like I'm hitting a 403 forbidden error.  I'll push this along to my service now integration team to double-check their side and let you know if they see any issues with user permissions.

    2020-05-25 03:44:22,841 [21] ERROR SolarWinds.SNI.Client.SNClient - Exception occurred during GetEntities<IncidentEvent> execution.
    SolarWinds.SNI.Client.SNClientException: ResponseURI = 'https://*******,incident_sys_id,instance_id,event_state,state&sysparm_query=instance_id=d53605f1-117a-4fbc-b778-2c722e3b94e2^event_state=0&sysparm_limit=21', StatusCode = '403', StatusDescription = 'Forbidden'
    SN Message = 'User Not Authorized', SN Detail = 'Failed API level ACL Validation'
    ---> System.Net.WebException: The remote server returned an error: (403) Forbidden.
    at System.Net.WebClient.OpenRead(Uri address)
    at System.Net.WebClient.OpenRead(String address)
    at SolarWinds.SNI.Client.Web.SNWebClient.SolarWinds.SNI.Client.Web.ISNWebClient.OpenRead(String address)
    at SolarWinds.SNI.Client.SNClient.GetEntities[T](String uri)
    --- End of inner exception stack trace ---

  • Thanks everyone for the responses.

    My service now integration team had set some custom security settings and found the issue.  Everything is all cleared up.

  • Hello  ,

    I'm facing the exact same issue in my infra as well. 403 Forbidden error.

    Do you know how your ServiceNow team fixed it..? Can you please elaborate about the custom security settings that the ServiceNow team worked upon to fix the same..?

    Thanks in advance..



  • It looks like the user needed to be added to ITIL users to grant access and stop the 403 error.

    From my service now team:

    "....our system is set so that only ITIL users can access the required view for tickets.  This view is used for the API call as well, therefore the account needs ITIL."

    Hope this helps!


    Thanks for your quick response mate..! I'll try to figure this out on my environment.