Atlas help please, hyperlinks and hover display are wrong. Are there item limits on network maps?

I am running into a strange issue with my network maps.  I have a very complex set of nested maps to provide a heads up view of our entire organization at a glance.  Now, whenever I add anything to the map (shows up fine in Atlas, hover and hyperlink are good), but on the website, it hyperlinks to wrong map. 

I've tried copy and pasting an existing item on the same map and it changes the link on this item as well.

I've tried putting new devices on the map and the same thing happens.  Always, it changes the link of the new item to the last item in my maps list.  Even the hover display is changed on the website.

I've tried clearing my web cache, this didn't help.

The only thing I can think of is that there is a hard limit to the number of nested objects/maps you can have on one map.

  • There is no hard coded limit of nested maps. The only limiting thing here is performance.

    I would try the following:

    1) copy all the nested maps from the problematic map onto another map.

    2)start removing the nested maps from the problematic map, one by one, and always check on the website whether it helped.

    3)if the above does not help, contact our support