Upgraded Orion to 2020.2.6 now have SSH login issue to nodes

Hi everyone,

I've recently been working through upgrading our orion deployment in work, and came across an interesting issue yesterday. We've had NPM, NCM, IPAM and NTA in our deployments since I joined our team in 2019. There have been 2 incremental upgrades and the latest took us from 2020.2.5 to the 2020.2.6 with Orion Platform HF5, NMC HF2, NPM HF3, NTA HF2.

One of our users commented that he could no longer successfully log in to a cisco switch from within orion. I normally dont use this functionality (but have done and never had an issue) but I know that this is his main way of getting on to cisco switches in his area.

I tried to open a session to one of my local switches, having confirmed I could Putty on successfully, and the terminal screen pop up opens as normal. I can input my username and password just fine, and when I click enter after my password, the cursor moves down to a fresh line, and flashes away happily and hangs.......and hangs. Nothing more happens.

I get the same issue if I try connecting to anything in our inventory (Cisco & PA). I even tried connecting using a bogus username and password and no difference, hoping to see some kind of output. It just hangs. This is when I noticed a syslog message that an unauthorised user had tried to log in to this switch. On reviewing the syslog messages I see successful logins and then timeouts for each attempt my user and myself have tried to ssh on to a few switches across our sites, but the ssh window shows absolutely nothing other than my login details in every instance.

This has only been an issue since the upgrade, and I'm a bit baffled by this.

Has anyone seen this before and can offer some advice/resolution please. Google has not been my friend in trying to find a solution as yet, and I've got the rest of the team off on leave at the moment, so trying to resolve this without any other input from our more experienced techs.

Many thanks for taking the time to read this and for any assistance you may be able to offer before I raise a ticket.

Paul

  • Hi Paul , 

    I have the same issue but im not sure if this is happening since the update. I have a support case open . 
    We tried  Change de ssh version in Connection profile under NCM (SSH1 and SSH2) and rebuild the website with Configuration wizard without success. If you edit the node there is a option to test the Conection profile . In my case the test runs ok but the console stuck on the same screen as you.

    I will share with you any update from the support team. 

    Franco

  • Hi Franco,

    Thank you very much for your post. I have searched through all the settings and did the same as you, changed the settings in the conenction profile whch made no diiference, and also have re-run the configuration wizard twice, with no resolution to the issue.

    For us this has only been since the upgrade, as a colleague on a remote site only uses the web console and got in touch the day I did the upgrade to report the quirky issue he was seeing. Initially I thought this was because he was trying to ssh whilst I was upgrading the deployment, then saw the issue when I tried to replicate his issue,

    Hopefully we can get some resolution from the support team.

    Paul

  • I have the same issue after upgrading to: Orion Platform HF5, NCM HF2, NPM HF3, UDT HF3: 2020.2.6.

    //Joacim

  • Hi , 

    Finally the solarwinds supports told me that is a know issue with ssh , there is no actual workaround and we must wait for the next general realese... 

    In my case downgrade is not possible.