Unable to connect to polling engine (APE) on the relevant server. Check logs for details


I'm experiencing an error where my APE doesn't want to download configs in NCM.

I also can't manage my nodes anymore that are connected to this polling engine.

I've opened a ticket at support to solve this issue, tried multiple solutions: reinstalled ncm, rebooted and so forth but nothing does the trick here.

What could be the problem here? All necessary ports are open and it still doesn't want to make a connection.

PS: when I look at the config settings I see this and can't even enter a path here:

  • do a  testnet from powershell on the Polling Engine having an issue. If the test fails check firewall, MS firewall or antivirus. 
    Test-NetConnection -ComputerName MainpollingengineIP -p 17777
    Test-NetConnection -ComputerName MainpollingengineIP -p 17778 

    Make sure in orion Manager all services are started. You can stop and restart all to get a fresh clean log then

    check event logs on polling engine look for  Applications and Services log, then look in Solarwinds.net log for any errors.

    You might see logs like Service was unable to open new database connection when requested.
    Database connection verification failed

  • Do you have other devices connected via NCM? 

  • Directories will need to be the same on the APE as the ones on the Primary Polling engine.