SCP server credentials

Hello,

I am trying to set up NCM to push out mass upgrades. I have used one of the default templates and turned on the SCP server within my solarwinds VM. I can manually run an upgrade on my test switch and pull the IOS from the solarwinds SCP server however, it asks for my credentials. But when I try to run it from NCM it won't pull the image and I feel as though it has something to do with credentials. 

I have tried to use TFTP but it times out on every attempt and even SCP is slow, but it faster than upgrading every switch on its own. 

Any advice is appreciated. 

Thank you!

Top Replies

  • It's been a while since I had to do this but from what I remember there is going to be a difference between the methods that the switch expects back. A good mechanism I use is I run through the commands via a session on and end device and then I annotate what it prompts me for. You need to ensure that whatever it prompts you for is addressed in the firmware upgrade template, from what I remember the big difference between the two protocols was the number of ${CRLF} commands it needed, TFTP only needed like one or two and SCP required like three or four. 

    Another thing you can do is enable session tracing to find out exactly why its failing, here's a link regarding session tracing

    Hopes this helps

  • Thank you so much for replying and thank you for the good info i will definitely use the session tracing. I actually did what you mentioned as far as running the commands the template will run on the end device. This is how i was able to tell that i can pull the image from SCP. I suppose my real big issue is how do I tell the template what credentials to use for SCP when the switch prompts NCM asking for it?