Syslog Server How to enable Active Directory authentication using LDAP?

I have found this article Active Directory Authentication setting for Kiwi Syslog Server Web Access and have to issues

The first and most important is to actually enable LDAP at all - I have applied for the active directory settings:

  • Domain url: I have tried all below
  • Authentication type: empty | none - neither did work
  • Groups: I have tried leaving it blank but also specifying the group name.

All above fails when I try to log on with my AD-userid. I have not found a log file for the Ultidev-web server which could explain what is failing.Did also make sure to restart Ultidev whenever I did update the config, but no help. So I am a bit lost.

Secondly - I need to use ldaps - port 636 - can that be done? I did try to use ldaps and 636 in the url, but then I just got an error while trying to save.

  • I found this post How to Integrate Kiwi Syslog Web Access with Active Directory which stated some important things

    • Log in using domain\username of an account that is a member of your KiwiSyslogAccess group (e.g. npgdom\thedude or npgdom\thedudet).
    • **NOTE** A message will appear telling you to log in again. It’s easy to miss because it looks like an authentication failure message. Log in again to actually log in. The first log in attempt created the local account within Kiwi Syslog. The second actually logs in
    • Gaze in wonderment at your successful log in.
    • the AD integration seems to only support Standard Users

    With that in mind - it now works, only using FQDN, security blank and specifying the group name