Telnet to Juniper via Juniper

I am attempting to add a Juniper QFX device that is connected to with telnet via another Juniper QFX. Connections to the first device are successful. The second, however, fails.

When adding the second device I tried two things. First, set the Host Address field to "telnet", Method to "Session" and Port to "23". When I try to connect, CatTools gives me a PuTTY Error:

"Unable to open connection to


Host does not exist"

The second thing I have tried is to set the Host Address field to "", Method to "Telnet", Port to "23". See the debug log for the first device below:

<NEWSESSION CatTools 3.11.5 10/27/2020 3:49:51 PM>
<DEVICE TYPE=Juniper.Router>
<ACTIVITY TYPE=Device.Backup.Running Config>
<ACTIVITY SCRIPT=C:\Program Files (x86)\CatTools3\Scripts\Client.Device.Backup.Running Config.txt>
<C OK 3:49:52 PM>
<R-3:49:52 PM>Last login: Wed Oct 28 04:47:17 2020 from x.x.x.x[13][13][10]--- JUNOS 18.4R2-S5.4 Kernel 64-bit JNPR-11.0-20200710.a76c78d_buil[13][10]
<R-3:49:52 PM>{master:0}[13][10]user@hostname>
<W-3:49:52 PM>[13]
<R-3:49:52 PM>[13][10][13][10]{master:0}[13][10]user@hostname>

I then changed the "Username prompt" in the Prompts tab to: "login: " and Password prompt to "Password: ". The log for the second device is below:

<R-4:13:29 PM>Login attempt timed out after 120 seconds[13][10]Connection closed by foreign host.[13][10]
<R-4:13:29 PM>[13][10]{master:0}[13][10]user@hostname>
<W-4:14:33 PM>telnet
<R-4:14:33 PM>telnet
<W-4:14:33 PM>[13]
<R-4:14:33 PM> [13][10]
<R-4:14:33 PM>Trying[13][10]Connected to[13][10]Escape character is '^]'.[13][10]
<R-4:14:33 PM>login:

WFMDRetVal=1 Waiting for: "% Connection refused by remote host"
WFMDRetVal=2 Waiting for: "% Connection timed out"
WFMDRetVal=3 Waiting for: "% Unknown command"
WFMDRetVal=4 Waiting for: "... Open"
WFMDBuffer="telnet [13][10]trying[13][10]connected to[13][10]escape character is '^]'.[13][10]login: "

Any ideas how to make this log in successfully?