SFTP/SCP server recursive get results in error "not a regular file"


After download and installation of the product "SFTP/SCP server" on Windows 2016 server, we configured the directory and user sections in SFTP/SCP server settings and successfully connected via SFTP from remote server. We've used standard "sftp" client available in Unix OS (we've tried several servers, AIX and Linux), OpenSSH version 7.4.
We were able to successfully connect, browse in directories, get, send and remove files .. this all worked just fine. But we were not able to use "get -r" command to retrieve directories with files. All our attempts ended by error messages: "not a regular file".
We are able to replicate this same problem whenever we want, I can provide additional logs from SFTP client if needed.
We would like to understand if this is some configuration issue or limitation of the Solarwinds SFTP/SCP server (doesn't allow recursive data transfers?) and if there is any possibility to solve it.

Please let me know, thank you in advance.