What We're Working On for Engineer's Toolset (Updated: February 8, 2021)

Following the Sunburst security incident, SolarWinds remains committed to the safety and security of our products and technology. Throughout 2021, we will prioritize security enhancements ahead of feature development to maximize customer safety and ensure confidence in SolarWinds and our products.  

Items currently being considered include, but are not limited to:

  • Vulnerability fixes identified by third-party scanning tools or recent product penetration tests (pentesting)
  • Documentation of least privileges for Orion Platform operation and monitoring including Orion agents
  • Validation of CIS IIS and SQL Server best practices
  • Secure settings by default with user control
  • Removal of any code unsupported by Microsoft
Anonymous
  • I have told by my Server team that .net framework 3.5 has some security issue and that they are in the process of .net framework 3.5 from the environment and moving to .net 4.8.  I know that .net framework 3.5 must be installed for the Engineers toolkit to fully function.  
    When will this application be updated to support .net 4.XX?   Or will this end up like NTM.