Can't connect Internet sessions ; link invalid or expired

Hey guys,

I'm trying out Dameware as a replacement for Logmein, but it seem to only work locally, with users within the organisation firewall. If a user is outside, he can connect to the DameWare Internet Proxy URL, download the agent, but the Mini Remote Control can't connect with the agent.

In this scenario, the central server is standalone (1 machine) configured using port 11443 (Take note that i tried 443 with same result), the corporate firewall is redirecting this port to the central server and the Mini remote control is on the same subnet as the central server (no firewall). SRV01, a test machine is located outside the corporate firewall. It can connect via the URL to the DameWare Internet proxy URL and installed the agent. It shows as online in the Remote Host.

Steps :

1 - MRC start an internet session

2 - SRV02 manually enter the URL in FireFox

3 - DameWare open, then it show that the session is not avaiable. (The session shown in the administration console status)

My Internet proxy config

Top Replies

Parents
  • Hi,

    I have the same issue.. Any luck solving this??

    thanks

    *edit:

    I tried a lot of things, and got it to work.

    The client I was using has the Dameware miniremote control agent installed. That's normal, it is used Inside the organisation as well as outside.

    So I tried disabling the dwmrcs service, so it forced it to download the Dameware Internet Session agent; that works.

    So it is the mini remote control agent that is broken it seems… (I was v12.0.5.6002 then upgraded to 12.1.0.34)

  • The http/2 is a Microsoft implementation to make the server-client communication faster and more secure.   

    There are 2 parts to this equation, the internet proxy and the Windows machine hosting the MRC console.

    For the moment focus on the host where the internet proxy is installed and add the registry key to allow the server-client connection using the steps below:

    1) Log in to the system hosting the Dameware Proxy.

    2) Open Regedit.

    3) Navigate to the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameter

    4) Change the following parameters:

    Value name: EnableHttp2Tls

    Value type: DWORD (32 bit)

    Value data: 00000000

    5) Save your changes.

    6) Reboot the server.

Reply
  • The http/2 is a Microsoft implementation to make the server-client communication faster and more secure.   

    There are 2 parts to this equation, the internet proxy and the Windows machine hosting the MRC console.

    For the moment focus on the host where the internet proxy is installed and add the registry key to allow the server-client connection using the steps below:

    1) Log in to the system hosting the Dameware Proxy.

    2) Open Regedit.

    3) Navigate to the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameter

    4) Change the following parameters:

    Value name: EnableHttp2Tls

    Value type: DWORD (32 bit)

    Value data: 00000000

    5) Save your changes.

    6) Reboot the server.

Children
No Data