Mission Checklist not loading

Hello there!  Newbie here, so please be gentle.  I am trying to complete the "Thwack 101" mission, but the "Mission Checklist" just displays "Loading..." continuously.  I tried several different browsers and devices with the same result:

All ideas and suggestions welcome!

Cheers,

JJ

Parents
  • Welcome and I trust you find THWACK to be useful...

    As to your issue then there are usually some good reasons behind why this might be ...

    • first is the load on the THWACK forum itself causing issues
    • or it could be an Internet 'thing'
    • but more likely is a browser / cache issue
      • browser - hit that refresh or choose another browser. I have found Opera and Chrome to be good, YMMV and other browsers are not specifically excluded.
      • do you have any adblockers running or other plugins of a similar nature
      • if nothing else try clearing your browser history and temp files

    But as you say it's now working, I'm going to go with a temporary forum load and/or Internet thing Slight smile

Reply
  • Welcome and I trust you find THWACK to be useful...

    As to your issue then there are usually some good reasons behind why this might be ...

    • first is the load on the THWACK forum itself causing issues
    • or it could be an Internet 'thing'
    • but more likely is a browser / cache issue
      • browser - hit that refresh or choose another browser. I have found Opera and Chrome to be good, YMMV and other browsers are not specifically excluded.
      • do you have any adblockers running or other plugins of a similar nature
      • if nothing else try clearing your browser history and temp files

    But as you say it's now working, I'm going to go with a temporary forum load and/or Internet thing Slight smile

Children
No Data