Service "Job Engine v2" dont start after upgrade to version 2.10

Version 1

    hello,

    Last week we decided to upgrade our SolarWinds to last released patchs. So after upgrade "SolarWinds Job Engine v2" to version 2.10 we have problems to start this service then SolarWinds cannot get the spooling of my nodes.

     

    Windows 2008R2 Standard 64 bits

     

    Windows Event Logs:

    Event 1026

    Aplicativo: SWJobEngineSvc2.exe

    Versão do Framework: v4.0.30319

    Descrição: O processo foi terminado devido a uma exceção sem tratamento.

    Informações da Exceção: System.TimeZoneNotFoundException

    Pilha:

      em SolarWinds.JobEngine.ServiceProcess.SolarWindsService.ServiceStart()

      em System.Threading.ThreadHelper.ThreadStart_Context(System.Object)

      em System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

      em System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)

      em System.Threading.ThreadHelper.ThreadStart()

     

    Event 1000

    Nome de aplicativo com falha: SWJobEngineSvc2.exe, versão: 2.10.0.34, carimbo de hora: 0x555a652d

    Nome do módulo de falhas: KERNELBASE.dll, versão: 6.1.7601.18798, carimbo de hora: 0x5507b485

    Código de exceção: 0xe0434352

    Deslocamento com falha: 0x0000c42d

    Identificação do processo com falha: 0x2954

    Hora de início do aplicativo com falha: 0x01d0acdcfb6ca2a1

    Caminho do aplicativo com falha: C:\Program Files (x86)\Common Files\SolarWinds\JobEngine.v2\SWJobEngineSvc2.exe

    FCaminho do módulo de falhas: C:\Windows\syswow64\KERNELBASE.dll

    Identificação do Relatório: 455abf95-18d0-11e5-80bc-000c299f63ec

     

     

    I was thinking that the problem occurs with .NET Framework...After varios tries of reinstalation i start to question one problem with SolarWinds packets.

     

     

    SOLUTION:

    1º     -     Access "Program and features" and try to repair. Test if service get up.

    2º     -     Access "Program and features" and remove "SolarWinds Job Engine v2", reboot the server. Access "C:\ProgramData\Solarwinds\Installers" and reinstall .msi packet. Test if service get up.

     

     

    After do all of this steps my support case comes with answers that i even found    :- l