Bash Vulnerability Test

Version 5

    This is a simple script to check the latest critical Bash shell vulnerability using a perl script

    Edit the exit code to make sure you get the correct level of notification you need.

    0=ok

    1=down

    2=warning

    3=critical

    I initially set exit of 2 so I could use a report and not force all of my servers into alert condition.

    updated to include the new name - ShellShock - very catchy

     

    see here for information on the issue

    https://securityblog.redhat.com/2014/09/24/BASH-specially-crafted-environment-variables-code-injection-attack/