Here's the scenario: you use IE8 with https. You use NPM 10 and upgrade to SP1. Then, IE starts complaining in a message like the one below: 

 

We have heard reports that some customers are seeing this alert on every single page as they navigate through the Orion website. Ugh, we're sorry. So there's good news and bad news. We'll give you the bad news first: we don't have a permanent fix for this yet, but we're working on it. But wait - we have some really good news too. So, the good news is - we know what causes this and we're going to fix it. It has to do with the optional Toolset integration. Additionally, the problem is more annoying than anything else. There's no real danger or underlying issue you need to worry about. But wait - there's still more good news: we also have a workaround. First, you can use Firefox or another browser. That solves the problem in that this is just IE specific. You can also disable Toolset integration by going to Settings->Account Manager -> Select your Account (admin) -> Change the option for “Allow Browser Integration” to No. 

 

We're working to fix this issue in a more permanent way - so stay tuned!

Other IE 8 Issues You Might See

While we're on the topic - we know that IE 8 will also give you all this error even if you don't have HTTPS configured: 

If you add the site to the Local Sites in IE, then you get the option to download SWToolset.exe. 

However, even if you install, you will still be prompted to download and install every time you go to a new page. If you disable Toolset integration, or use a different browser, the ActiveX control is not run and this is not a problem. Also, you can manually register it per the Engineers Toolset V10.2 integration with Orion NPM