As you might have read a couple weeks ago in my AWS review, I started this post almost a month ago. Unfortunetly I ran into a snag after creating my database insatnce and it kept me from completing the article. HP Support however was pretty awesome and jumped on the issue right away, infact within 48 hours the problem was fixed and I was able to continue. With that said let's jump right in... however you need to keep one thing in mind... This service is probably the newest of any of the services I've looked at so far, I think I actually signed up when it was in beta. It is also so new that not all geo's have it as an option yet too.

 

CREATING A HP SQL DATABASE

As I mentioned this feature isn't available everywhere, so I had to navigate to the US West Geo in order to find it. Once there I was able to click the button in Horizon and get started creating.

1.jpg

HP sticks pretty close to the standard Openstack Horizon dashboard layout, so things are pretty clean throughout the UI.

2.jpg

Once you click launch instance you got the pretty much the same questions as we did on every other wizard.

3.jpg

I tossed in some generic stuff for my first database on the instance.

4.jpg

I did find that they make restoring backups pretty simple... Just create a new instance and select the backup image to use... simple as that!

5.jpg

And there you have it, a HP DBaaS! If you look closely you can also see where some of my problems started to show up before HP fixed them... Volume Size showed as "Not Available".

6.jpg

CONNECTING TO YOUR HP SQL DATABASE

So this is where I noticed that I was having problems the first time through... When I went to look for my user's and databases in the Horizon UI everything would time out and just say that the information wasn't available. After HP support did their thing everything was much happier... I should note that they were able to replicate the issue on other instances, so it must have been a bug which they were able to quickly fix. (I do wonder though if I was the first person to try their MySQL DBaaS offering though LOL, because it was unusable before the fix...)

 

Anyhow, the details/Overview page did work just find and it is where I got my connection string from... down at the bottom.

7.jpg

The database tab simply shows what databases are on the instance and gives you the ability to delete them.

8.jpg

So this is where my love hate relationship starts... If I reboot my instance my user account will show up... for a while... then I get this awesome error. So I decided to assume that it's a Horizon issue and not a problem with the instance, plus I know my username is jpaul. One other note about the user area... Even when it is working, I could not find a way to change my password for the instance or add other users to the instance... I would think from the MySQL CLI I could but the GUI is pretty bare.

user data.jpg

Well I wasn't about to let a busted web interface slow me down... I'll open another support ticket today and I'm sure they will have it fixed again in no time... But I know my username, I know the IP address of the instance... and I have a MySQL client.

 

Unfortunely, the CLI didn't go much further. Looks like I will certainly have to open a ticket.

ssh.jpg

The only other thing I can really show you right now is how to restore a backup.

 

BACKUP/RESTORE

So to do a backup there is a create backup button listed beside of each instance that you have running. I won't go into to much detail because it's the same as any other create backup button.

 

Restoring from one of those backups is pretty simple too, you simply navigate back to the Launch Instance button, and fill out the same form that you did before when I created the initial instance, with one exception... this time on the Restore From Backup tab you select which backup you want to restore. Simple as that.

restore.jpg

 

SO WHAT DID YOU THINK?

Let me start by saving I hate doing "bad" reviews, even if they are constructive. I will say that I am a litle disappointed that I have to reopen a ticket with HP support too. I think I opened my first ticket on like a Tueday or a wednesday with them... It took them until Thursday or Friday to figure out the problem and then they expected my to respond within 24 hours (which was a weekend) and I didn't, so they closed the case.

 

Overall I think that the service has promise, but right now I would say it still needs some work. I will post an update once HP support helps me get things going...