The Situation

Over the Christmas holiday I found myself with some extra time and decided to get my backups on my external hard drives in order. About halfway through, Windows decided not to recognize my hard drives anymore. Look familiar?
usb.png

Clicking the message did nothing to assist me.

 

The Wrong Solution

My first instinct was to plug the drives into my other laptop to verify the hardware was still in working order and of course, they worked just fine. At this point I've verified it's not the hardware causing my burgeoning headache. What next? Drivers! Of course, that's it! Perhaps the drivers somehow became corrupt. Piece of cake! Just grab them off the manufacturer's site and I should be back in business.

 

I installed the drivers and pointed Windows to the proper folder and guess what I found? Nothing. Huh? That's odd. I installed the drivers again and this time I watched the folder and files being created from the MSI installation program, only the folder and files were never created, despite the fact that the installer said I was good to go. (I know what you're thinking, did you check the li'l box that says, "Show hidden files and folders" as well as the other li'l box that says, "Show protected operating system files"?  C'mon, that's a rookie mistake for lesser men.)

 

I've had MSI problems in the past so I verified that another MSI installer worked on the same rig. It did, so MSI installers in general are not the problem. I concluded that the devs over at this particular company were complete idiots by providing the end user with a program that installs sailboat fuel.

 

Hour three of my adventure

Trolled Google and learned what I could. Nothing new here.

 

Hour four of my adventure

Get the drivers from a third party program that searches for and installs needed drivers. Sure that will work! The drivers downloaded and updated and sure enough, nothing changed! I still could not get my drives to work.

 

Hour five of my adventure

All the articles and forums online were telling me things I already knew and tried, including tweaking every possible setting in the Control Panel and System Manager. Nothing. One blog even had me tweak some registry settings. Still nothing! Reboot after reboot and I had no external drives. My USB wireless mouse however, never failed during this ordeal. It had to be the drivers!

 

I was getting desperate. The next step, gulp...Microsoft.com. I found myself here:
ms.jpg

This had to work! I mean, they BUILT the damned thing and the Fix It tool they prepared was designed specifically for this problem. Need I tell you what happened? You guessed it, nothing. The tool found errors it could not fix - didn't tell me what they were though. It just told me my hardware was corrupt. (Another wrong assumption.)

 

Hour six of my adventure

I was stupefied. Six hours of reading, reboots, downloads, tools, settings and registry edits, and nothing. What to do? Then my eye caught an obscure article (not unlike this one). The only reason I read it was because the instructions given were different from the hundreds of others that I had read which all gave the same five solutions that didn't work. I had nothing to lose and at some point, even the ridiculous seems viable.

 

Before the big reveal, let's review:

  • With 30+ years of programming and computer experience, I was stumped
  • Microsoft could not fix it
  • Manufacturer could not fix it
  • Updated drivers did not fix it
  • Registry and other settings adjustments did not fix it
  • Reboots did not fix it
  • All but one solution in all of Google, failed

 

The Ridiculous solution

Turn the computer off, physically remove the laptop battery and power cord from the computer. Let sit for five minutes. Resume as normal. YES, THAT REALLY WORKED!!


The Moral of the story?

If you can find one, please add it to the comments below.