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About SolarWinds 

SolarWinds, Inc develops and markets an array of network management, monitoring, and 
discovery tools to meet the diverse requirements of today’s network management and consulting 
professionals. SolarWinds products continue to set benchmarks for quality and performance and 
have positioned the company as the leader in network management and discovery technology. 
The SolarWinds customer base includes over 45 percent of the Fortune 500 and customers from 
over 90 countries. Our global business partner distributor network exceeds 100 distributors and 
resellers. 

Contacting SolarWinds 

You can contact SolarWinds in a number of ways, including the following: 

Team Contact Information 

Sales 

sales@solarwinds.com 
www.solarwinds.com 
1.866.530.8100 
+353.21.5002900 

Technical Support www.solarwinds.com/support  

User Forums thwack.com 

 

Conventions 

The documentation uses consistent conventions to help you identify items throughout the printed 
and online library. 

Convention Specifying 

Bold Window items, including buttons and fields 

Italics Book and CD titles, variable names, new terms 

Fixed font 
File and directory names, commands and code examples, 
text typed by you 

Straight brackets, as 
in [value] 

Optional command parameters 

Curly braces, as in 
{value} 

Required command parameters 

Logical OR, as in 
value1|value2 

Exclusive command parameters where only one of the 
options can be specified 
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Orion Network Configuration Manager Documentation 
Library 

The following documents are included in the SolarWinds Orion Network Configuration Manager 
documentation library: 

Document Purpose 

Administrator Guide 
Provides detailed setup, configuration, and conceptual 
information. 

Page Help 
Provides help for each resource in the Web Console 
accessed through the Help button. 

Quick Start Guide 
Provides installation, setup, and common scenarios for 
which Orion Network Configuration Manager provides a 
simple, yet powerful, solution. 

Release Notes 
Provides late-breaking information, known issues, and 
updates. The latest Release Notes can be found at 
www.solarwinds.com.  
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Chapter 1 

Introduction 

SolarWinds Orion Network Configuration Manager is a comprehensive, intuitive 
solution designed to streamline and automate network configuration 
management. Orion Network Configuration Manager increases availability, saves 
time, improves security, and ensures policy adherence. Orion Network 
Configuration Manager features automation capabilities that reduce the amount 
of time network engineers spend on mundane network tasks, allowing them to 
focus on business-critical network projects. 

Why Install SolarWinds Orion Network Configuration 
Manager 

Out of the box, SolarWinds Orion Network Configuration Manager offers 
numerous management features, including the ability to: 

 Control access based on user roles 

 Schedule device configuration backups 

 Implement configuration changes in bulk (IOS and firmware updates) 

 Manage configuration changes to multiple devices from different vendors 
with change management templates  

 Generate detailed configuration reports for inventory, change, and policy 
management 

 Receive notification of device configuration changes 

 Identify configuration violations through policy management reporting 

 Automatically receive results of appropriate NCM actions with the Orion 
notification of an alerting device (Requires Integration Module) 

 View detailed change history and side-by-side comparison of configurations 

 Perform detailed device inventory for each managed device 

 Track and view configuration changes made by users 

 Access to your device configurations and configuration changes from either 
an NCM or Orion web console (Requires Integration Module) 

 Map the port connections for a specific network switch 
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Orion Network Configuration Manager allows you to easily manage 
configurations on heterogeneous, multi-vendor networks. Orion Network 
Configuration Manager supports routers, switches, firewalls, load balancers, and 
wireless access points from numerous vendors, including Cisco, Cisco ASA, Dell, 
Adtran, Arris, Aruba, Nortel, Nortel Alteon, Nortel BayStack, Extreme, Marconi, 
Radware, Netscreen, Motorola, HP, Netscalar, Juniper and Foundry. You gain a 
single point of management. Whether you are faced with managing network 
configurations for 50 or 5,000 devices, Orion Network Configuration Manager 
provides you with an intuitive solution that immediately impacts the bottom line. 

Key Features of Orion Network Configuration Manager 

Considering the previously mentioned benefits of Orion Network Configuration 
Manager, coupled with the following features, Orion Network Configuration 
Manager is the clear choice to make: 

Scheduled Configuration Backups 

You can schedule configuration downloads, configuration uploads, device 
reboots, command scripts execution, and more. In addition, configuration 
backups are stored both in a relational database for archival history and as 
flat files in an intuitive folder structure for easy viewing. 

Policy Management 

You can ensure device compliance with federal regulations, as well as 
corporate standards. The Policy Reporting Manager comes with several out-
of-the-box policy reports, including SOX, HIPAA, CISP, and Cisco Security. 

Role-Based Access Control 

You can integrate your Windows Active Directory or local system user 
accounts with Orion Network Configuration Manager. You can manage users 
based on their role and establish individual device login credentials per user. 
Orion Network Configuration Manager logs all user activity allowing you to 
keep an archive of changes and activity.  

Multivendor Support 

You can monitor network devices from multiple hardware vendors. As a 
monitor and manager of routers, switches, firewalls, VPN concentrators, 
wireless access points and more, Orion Network Configuration Manager is a 
robust solution that is fully capable of managing your hybrid vendor network. 
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Bulk Changes 

Across many devices you can quickly make changes to community strings, 
passwords, and black lists. With Orion Network Configuration Manager, you 
can execute bulk changes either in realtime or within a scheduled change 
window. Uploads, changes, and global command scripting can be scheduled 
by device type, physical location, by owner, or by any custom property you 
create. 

Configuration Change History 

You can receive reports on what devices have had configuration changes 
over any time period you specify. Configuration change reports can also 
compare current configurations with a baseline configuration alerting you 
whenever a change is discovered. 

Web-Based Configuration Viewing, Tracking, and Comparing 

You can use Orion Network Configuration Manager to remotely view, track 
changes, and compare network device configurations without logging on to 
the physical Orion Network Configuration Manager server. The Orion NCM 
Web Console offers these powerful functions to the users you select. 

Orion Web Console Integration 

With NCM you gain these important resources in the Device Details view of 
the Orion Web Console: 

 Find Connected Port for End Host 

 Recent Configurations 

 Recent Configuration Changes 

 Node Configuration History 

 Last 10 Conf Changes 

 Last X Config Changes 

 Last XX Configurations 

Orion Alerts Integration 

With the Orion NCM integration module you can use a default NCM alert in 
the Orion Alert Manager; and you can specify NCM actions to run when this 
alert triggers, viewing the results of those actions along with the notification. 

Device Configuration Change Templates 

You can use templates to generate an appropriate sequence of CLI 
commands for all relevant devices for which you need to make a specific 
configuration change. 
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Device Configuration Change Management 

You can setup a request and approval system for processing the workflow of 
device configuration changes.  

How Does Orion NCM Work? 

 

Orion Network Configuration Manager utilizes a scripting engine that parses 
individual commands across several different platforms. Combining this scripting 
engine with the Windows Task Scheduler allows Orion NCM to schedule nightly 
backups, configuration changes, inventory scans, and more. There are no agents 
installed on your servers and no remote software to maintain. All configuration 
changes and user activity is stored in the Orion NCM database and accessible 
from the Orion NCM application console and the Orion NCM Web Console. 
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Chapter 2 

Installing Orion Network Configuration 
Manager 

Orion Network Configuration Manager provides a wizard-driven installation 
process.  

Requirements 

The requirements for Orion Network Configuration Manager vary based on a 
number of factors, including the following: 

 The number of nodes 

 The frequency of configuration downloads 

 The length of time that configurations are maintained in the database 

The following table provides the general requirements for an Orion Network 
Configuration Manager installation. 

Software/Hardware Requirements 

Operating System Windows 2003 Server SP2 or later (32-bit and 64-bit) including R2, 
with IIS installed and running in 32-bit mode. Windows 2008 Server 
Enterprise or Standard (32-bit or 64-bit) including R2, with IIS installed 
and running in 32-bit mode. 

Note: SolarWinds does not support installation of Orion NCM on 
Windows XP, Vista, or 7 in production environments. See below. 

Orion NCM Server 
Hardware 

CPU Speed 3GHz dual core dual processor  

Memory 3GB 

Hard Drive Space 20GB 

Installing Windows 
Account 

Requires administrator permission on the target server  

File System Access 
Permissions 

Ensure the Network Service account has modify access to the system 

temp directory (%systemroot%\temp). 

SolarWinds Orion 
Syslog Server 

If you want realtime change detection triggered through devices 
sending Syslog messages, the executable must have read-write 
access to the Orion Core database. For more information, see 
“Enabling Realtime Configuration Change Detection” and “Monitoring 
SNMP”. 
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Software/Hardware Requirements 

SolarWinds Orion Trap 
Service 

If you want realtime change detection triggered through devices 
sending SNMP traps, the executable must have read-write access to 
the Orion CoreOrion NCM database. For more information, see 
“Enabling Realtime Configuration Change Detection” and “Monitoring 
SNMP”. 

Microsoft SNMP Trap 
Service 

Must be installed if you want realtime change detection triggered 
through devices sending SNMP traps. For more information, see 
“Enabling Realtime Configuration Change Detection” and “Monitoring 
SNMP” in the Orion NCM Administrator Guide. 

Microsoft IIS Version 6 or later. DNS specifications require hostnames to be 
composed of alphanumeric characters (A-Z, 0-9), the minus sign (-),  
and periods (.). Underscore characters (_) are not allowed. For more 
information, see RFC 952. 
Note: SolarWinds neither recommends nor supports the installation of 
Orion NCM on the same server or using the same database server as 
a Research in Motion (RIM) Blackberry server. 

Microsoft ASP .NET 2.0 
Ajax Extension 

Version 1 or later (if this is not found on the target computer, the setup 
program downloads and installs the component) 

Microsoft .NET 
Framework 

Version 3.5 SP1 or later (if this is not found on the target computer, 
the setup program downloads and installs the component) 

Database 
The following database servers are supported as the Orion Network 
Configuration Manager datastore: 

 SQL Server 2008 Standard or Enterprise 

 SQL Server 2005 SP1 or later of Express, Standard, or Enterprise 
You can use the following database select statement to check your 
SQL Server version, service pack or release level, and edition: 
select SERVERPROPERTY ('productversion'), 

SERVERPROPERTY ('productlevel'), 

SERVERPROPERTY ('edition') 

 

Your database server must support mixed-mode authentication or 
SQL authentication and have the following protocols enabled: 

 Shared memory 

 TCP/IP 

 Named Pipes 

SQL Server 2005 Express Edition does not enable these protocols. 
 
The following x86 components must be installed (if the components 
are not found on the target computer, the setup program downloads 
and installs the components): 

 SQL Server System Common Language Runtime (CLR) Types 

 Microsoft SQL Server Native Client 

 Microsoft SQL Server Management Objects 

Enabling Full-Text Search on your Orion NCM database significantly 
increases search performance. 



 

 
Installing Orion Network Configuration Manager  9 

Software/Hardware Requirements 

Browser To access the Orion Network Configuration Manager website, use one 
of the following browsers: 

 Microsoft Internet Explorer 7 or later 

 Mozilla Firefox 3 or later 

 Google Chrome 8 

Notes:  

 Typically, you can monitor between 8,000 and 10,000 devices with a single 
NCM instance; however, the total depends on your system hardware, the 
types of devices monitored, and the number and concurrency of the jobs you 
run.  Should you need to manage more devices, and you decide to add NCM 
instances, consider consolidating your views of multiple instances with the 
Orion Enterprise Operations Console. For more information about scaling 
NCM, please contact your account manager.  

  SolarWinds does not support installation of Orion NCM on Windows XP, 
Vista or Windows 7 in production environments. If you are installing Orion 
NCM on Windows Vista for evaluation purposes, ensure you enable the 
appropriate database protocols. See the database section of the 
requirements. 

 The Orion Network Configuration Manager Information Service requires the 

Net. Tcp Port Sharing Service to be enabled and port 17777 open for 

TCP traffic to the Orion NCM computer. By default, this service is disabled. 
The setup program sets the service to manual. Resetting the service setting 
to disabled will adversely affect your installation. 

 To take advantage of the numerous integration points in Orion Network 
Configuration Manager, install the SolarWinds Engineer’s Toolset on the 
same server. You can also take advantage of integration points built into the 
Web Console by installing the Toolset on computers used to access the Web 
Console. 

Server Sizing 

Orion Network Configuration Manager can perform configuration management 
for any sized network, from small corporate LANs to large enterprise and service 
provider networks. Most Orion NCM implementations perform well on 
Pentium-class 3GHz systems with 3GB of RAM using the default simultaneous 
transfer settings and no modification to node monitoring settings. 

Should scalability issues arise, consider adjusting the following variables: 

 Number of simultaneous transfers 

 Frequency of uploads, downloads, and inventory jobs 

 Node polling interval for up-down monitoring 

http://www.solarwinds.com/products/orion/eoc/
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In larger environments, inventory jobs may run longer than expected. To remedy 
this situation, consider breaking large inventory jobs into smaller jobs that do not 
include as many nodes and spacing these jobs over a larger period of time. 
Adjusting server CPU and memory will enhance user interface performance and 
job execution speed.  

Licensing Orion Network Configuration Manager 

Orion Network Configuration Manager can manage almost any network device, 
including routers, switches, and firewalls. Any of your version 3 or earlier SNMP 
enabled devices can provide configuration files to Orion Network Configuration 
Manager. You license Orion Network Configuration Manager by the number of 
nodes. A node is defined as an entire device, that is, a router, a switch, a server, 
an access point, or a modem. 

The following list provides the different types of Orion Network Configuration 
Manager licenses available: 

 Up to 50 devices (DL50) 

 Up to 100 devices (DL100) 

 Up to 200 devices (DL200) 

 Up to 500 devices (DL500) 

 Up to 1000 devices (DL1000) 

 Up to 3000 devices (DL3000) 

 Unlimited devices (DLX) 

Obtaining a Software License Key 

If you are prompted for your name, email address, phone number, customer ID, 
and password, complete the following procedure. 

Note: Versions of the NCM software that are released during the release 
candidate period have a limited license. In upgrading your NCM software, even if 
the software does not change from the release-to-manufacture (RTM) to the 
general availability (GA) distributions, you must re-apply your license upon the 
software’s official release.  

To license your product: 

1. From the appropriate server in your deployment, navigate to 
http://www.solarwinds.com/customerportal and enter the requested 
information to obtain your Activation Key. 

http://www.solarwinds.com/customerportal
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 If you are deploying Orion NCM on one server and integrating with 
Orion products on a different server, then you must install the Orion 
NCM license on the server running the other Orion product. 

For example, if you are integrating Orion NCM on one machine with 
Orion NPM on another, you would install your Orion NCM license on the 
machine that is hosting Orion NPM. 

 If you are deploying Orion NCM standalone or on a single integrated 
server, then you must install the Orion NCM license on that server. 

2. If you have both an activation key and access to the internet, select the 
first option, I have internet access and an activation key…, enter your 
Activation Key, and then click Next. 

Note: If you are using a proxy server to access the internet, check I 
access the internet through a proxy server, and then provide the Proxy 
address and Port. 

3. If you do not have access to the internet from your designated Orion 
NCM server, select This server does not have internet access…, click 
Next, and then complete the steps provided. 

About the Orion Network Configuration Manager 
Database 

A copy of Microsoft SQL Server 2005 Express Edition is distributed with each 
copy of Orion Network Configuration Manager. SQL Server 2005 Express Edition 
supports a maximum database size of 4GB, is limited to 1 GB of RAM use, and 
takes advantage of only 1 CPU in a multi-processor server. For more information 
about SQL Server installation, see the Microsoft website at 
http://www.microsoft.com/sql. 

If you are installing Orion NCM on the same server as Orion NPM, consider 
using a remote database server for your databases. You will gain a number of 
performance enhancements through implementing this installation scenario, as 
the Orion server will no longer need to share resources with SQL Server. 

Warnings:  

 The following characters cannot be included in the database name: 
asterisk (*), closing square bracket (]), colon (:), semicolon (;), single quote 

('), double quote ("), backward slash (\), forward slash (/), less than (<), 

greater than (>), and question mark (?).  

 Do not include the single quote (') or the semicolon (;) in the username or 

password of the database account.  

http://www.microsoft.com/sql
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SNMP Communication 

Orion Network Configuration Manager takes advantage of SNMP communication 
to collect inventory information. Ensure all devices from which you want to collect 
detailed information have SNMP properly configured. 

Planning the Orion NCM Deployment 

How you intend to use Orion NCM determines the process by which you install 
the software. There are three deployment types: Standalone, Integrated Single 
Server, and Integrated Separate Servers. 

Essentially, you need to decide if you intend to run Orion NCM by itself on a 
single server or integrated with other Orion products, either on a single server or 
on separate servers. 

Here is the current list and version of Orion products with which Orion NCM 
version 7.0 can integrate: 

 Orion Network Performance Manager (NPM) version 10.2 and above 

 Orion Application Manager (APM) version 3.5 and above. 

 Orion IP Address Manager (IPAM) version 1.7.1 and above. 

 SolarWinds User Device Tracker (UDT) version 1.0.1 and above 

Orion NCM Standalone 

This option installs NCM—including all necesarry components common to all 
Orion products—on one server. Among the necessary common Orion 
components is an Orion Core database; SolarWinds recommends that , when 
prompted to create this database during the Orin Configuration Wizard session, 
you create it on a separate database server.  

If you select this option, you will be able to install other Orion products--on this 
server only--at a future time; but you will not be able to integrate NCM with 
remotely installed Orion products, either now or in the future. 
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. 

Orion NCM Integrated with another Orion Product 

Integrating Orion NCM with another Orion product add combines all the 
functionality of the products into the Orion NPM Web Console.  

For more information about the resources, click Help on the individual resource. 
Functionality remains the same, including the need to be in the appropriate Orion 
NCM roles. 

 Single Server Integration 

This option installs NCM on a single server on which already resides other 
compatible Orion Core products (Orion NPM, Orion APM, Orion IPAM, or 
SolarWinds UDT).  

 

Separate Server Integration 

This option installs NCM on two separate servers, a primary NCM server and 
another server on which already reside other compatible Orion Core products 
(Orion NPM, Orion APM, Orion IPAM, or SolarWinds UDT).  

To properly install NCM in this deployment, you must first install NCM on the 
server hosting the Orion Core product(s).  
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When that server is properly setup, you should then install NCM version 7.0 on 
server where the primary NCM server will reside. 

Installing Orion Network Configuration Manager 

Orion NCM version 7.0 is architected so that the software is integrated with a 
core platform of components that are common to all Orion products. Besides the 
Orion NCM database, the NCM software also creates an Orion Core database to 
manage account and other information that pertains to Orion common 
components.  

Nodes are considered an Orion common component in Orion NCM version 7.0. 
Every node managed in NCM must also be managed in the Orion Core 
database; and the Orion Core database is the key to maintaining continuity for a 
node through its states of management and unmanagement while you use the 
Orion NCM product. 

It is a feature of Orion NCM that if you delete a node from the Orion Core 
database all existing data for that node, including all backed-up configuraitons, 
are permanently removed. 

Because Orion NCM 7.0 shares common components with all Orion products, 
the process of installing and configuring Orion NCM involves shutting down and 
restarting all Orion services. Choose a time to install Orion NCM 7.0 when your 
IT operation can tolerate a short period of downtime for Orion products. 

Installing Orion Network Configuration Manager version 7.0 involves 5 
processes: 

 

 Installing the NCM software 

 Configuring NCM and the NCM database 

 Configuring Orion Core components and the Orion Core database 
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 Discovering nodes to monitor in Orion and NCM 

 Synchronizing the NCM and Orion Core databases 

Notice that installing the configuring Orion NCM involves running two sessions of 
the Orion Configuration Wizard; the first session to configure Orion NCM and the 
NCM database, the second to configure Orion Core components and the Orion 
Core database. 

You can find Orion NCM 7.0 installation software in your customer portal. 

Follow the steps in the installation section below that corresponds to your 
deployment type.  

Installing Orion NCM Standalone (Single Server) 

Follow these installation steps if you will run Orion NCM on a single server and 
currently have no intention to integrate with other Orion products. 

The following procedures take you through all five related processes—as one set 
of numbered steps—for installing Orion NCM by itself on a single server..  

You must complete all the steps for Orion NCM to be correctly installed. 

To install Orion Network Configuration Manager: 

1. Log on with a local administrator account to the computer on which you want 
to install Orion Network Configuration Manager. 

Note: To ensure that Orion Network Configuration Manager runs properly, do 
not install Orion Network Configuration Manager on a domain controller. 

2. Navigate to your download location and launch the executable. 

3. Click Next on Getting Ready to Install. 

4. Click Next after reviewing the Process Overivew. 

Notice that after installing the NCM software the Installer runs two successive 
configuration wizards. The first wizard configures NCM and the NCM 
database; and the second configures Orion common components and the 
Orion Core database. 

5. Click Next after reviewing the deployment options.  

Since you are following this set of steps you already have chosen to install 
Orion NCM standalone on a single server. 

6. Click No, I want to install/upgrade NCM on one server… and click Next. 

7. Review the Welcome text, click Next. 

8. Accept the license agreement displayed on the License Agreement window, 
and then click Next. 

http://www.solarwinds.com/customerportal/
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9. Accept the default directory for the installation or Browse to another, then 
click Next. 

10. Click Next to have the Setup Wizard start copying files. 

You should see the blue progress bar advancing with annotations of which 
files are being copied. 

11. Click Finish when the Setup Wizard completes its copying. 

12. If you are prompted to license Orion NCM, click Enter Licensing 
Infromation and then complete the following procedure to license your Orion 
NCM installation: 

a. If you have both an activation key and access to the internet, select 
the first option, I have internet access and an activation key…, enter 
your Activation Key, and then click Next. 

Note: If you are using a proxy server to access the internet, check 
access your access toa the internet through a proxy server, and then 
provide the Proxy address and Port. 

b. If you do not have access to the internet from your designated 
Orion NCM server, select This server does not have internet 
access…, click Next, and then complete the steps provided.. 

You need a customer ID and password to successfully install the key. 
For more information, see the section “Obtaining a Software License 
Key”. 

13. Enter registration information, including your name and a valid email 
address, and click Finish. 

If licensing failed for some reason the software should automatically mark the 
installation as an evaluation. You will have 30 days to enter valid license 
information. 

14. Click Next after reviewing your progress in the Process Overview. 

The first of the two configuration wizards launches The first wizard configures 
NCM and the NCM database; and the second configures Orion common 
components and the Orion Core database. 

15. Accept the defaults (Database and Services) and click Next. 

The Orion Network Configuration Manager Wizard starts running through the 
Orion NCM database setup. 

16. Specify the SQL Server instance you want to use for storing configurations 
and node details, the authentication method (Windows or SQL Server 
Authentication) used to communicate with the instance, and then click Next.  

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 
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 If you are using a local instance of SQL Server Express, use the 

following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

17. If this is the first time you are installing Orion NCM, click Create a new 
database, and then click Next.  

Otherwise, select the existing Orion NCM database you want to use, and 
then click Next. 

18. Create a new database account and password, or select an existing account 
with owner rights on the database you created or selected. Then click Next. 

Note: You must supply a strong password. For more information about 
strong passwords, see http://msdn.microsoft.com/en-
us/library/ms143705.aspx. 

19. If all three Service Settings are selected, click Next. 

20. Review the actions to be taken with the Database and Services, click Next. 

The dual blue bars show progress and annotations of the wizard’s current 
actions.   

21. Click Finish when the wizard completes its configuration actions. 

22. Click OK to acknowledge that a second configuration wizard, the Orion Core 
Configuration Wizard, will start in a few moments.  

The Orion Core database stores all discovered nodes. This is a superset of 
nodes from which you will license specific nodes for NCM monitoring and 
configuration. 

23. Click Next after reviewing your progress in the Process Overview. 

The second configuration wizard launches The second wizard configures 
Orion common components and the Orion Core database. 

24. Review the Welcome text, click Next. 

25. To create the Orion Core database, you need to specify the appropriate SQL 
Server instance, the authentication method (Windows or SQL Server 
Authentication) used to communicate with the instance, and then click Next.  

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

http://msdn.microsoft.com/en-us/library/ms143705.aspx
http://msdn.microsoft.com/en-us/library/ms143705.aspx
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 If you are using a local instance of SQL Server Express, use the 

following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

26. Click Create a new database, provide a name, and then click Next. 

27. Create a new database account and password, or select an existing account 
with owner rights on the database you created or selected. Then click Next. 

Note: You must supply a strong password. For more information about 
strong passwords, see http://msdn.microsoft.com/en-
us/library/ms143705.aspx. 

28. Click Next setup the Orion Website with default settings or adjust the 
seetings as needed. 

29. Click Yes if you are informed that a website already exists with the same 
settings. 

30. Click Next after reviewing the settings that will be configured. 

31. Click Next after reviewing the overview configuration plan for the Database, 
Website, and Services. 

The dual blue bars show progress and annotations of the wizard’s current 
actions.   

32. Click Finish when the wizard completes. 

Orion Web Console launches.   

33. Enter an appropriate username and password. 

The default credentials are ‘admin’ with no password. 

34. Click NETWORK SONAR DISCOVERY under NCM Nodes to discover the 
nodes for Orion NCM to manage. 

The software navigates to the Network Sonar Wizard. 

35. Review and accept the defaults (public/private) for the SNMP read-only and 
read-write community strings; or click the pencil icon to edit a credential. 
Click Next when you are finished.  

These default strings are tried first the software interactively requests a 
credential during node discovery. 

36. Click Add New Credential under Windows Credentials as needed. 

WMI is used to collect CPU, memory, volume and other data from Windows 
Servers that do not support SNMP.  

http://msdn.microsoft.com/en-us/library/ms143705.aspx
http://msdn.microsoft.com/en-us/library/ms143705.aspx
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37. Define an IP range, subnet, or a list of specific nodes for the wizard to use in 
discovering nodes. Click Next when you are finished. 

38. Review and adjust discovery settings. Click Ignore nodes… if you want to 
ignore nodes that provide no SNMP or WMI information. 

Click Next when you are finished. 

39. Click DISCOVER to start discovering nodes. 

40. Click Next when you are ready import the devices types discovered.  

41. Click Next when you are ready import the volume types discovered. 

42. Click Import after you have reviewed and adjusted (as needed) the list of 
devices and volumes. 

Details and progress of the import operation is shown in real-time in the 
Import Results window. 

43. Click Finish when the import operation is done. 

The software navigates to Discovery Central.  

44. Review the NCM node count in Manage More Nodes under the NCM Nodes 
option group. 

The nodes managed in NCM are the results of the Network Sonar Wizard 
session just finished. In discovering these nodes, the software has 
automatically added the nodes to the Orion Core database. 

Orion NCM nodes must also be managed in the Orion Core database for the 
NCM software to function correctly. 

45. Click CONFIGS in the Orion NCM Web Console toolbar. 

Installing Orion NCM on Integrated Single Server 

Follow these installation steps if you will run Orion NCM on a single server and 
intend to integrate it with an Orion product that already resides on the server. 

The following procedures take you through all five related processes—as one set 
of numbered steps—for installing Orion NCM and integrating with an Orion 
product on a single server..  

You must complete all the steps for Orion NCM to be correctly installed. 

To install Orion Network Configuration Manager: 

1. Log on with a local administrator account to the computer on which you want 
to install Orion Network Configuration Manager. 

Note: To ensure that Orion Network Configuration Manager runs properly, do 
not install Orion Network Configuration Manager on a domain controller. 
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2. Navigate to your download location and launch the executable. 

3. Take a back-up of your existing Orion product database.  

For detailed information, see “Creating Database Backups” in your Orion 
product’s Administrator Guide. 

4. Click Next on Getting Ready to Install. 

5. Click Next after reviewing the Process Overivew. 

Notice that after installing the NCM software the Installer runs two successive 
configuration wizards. The first wizard configures NCM and the NCM 
database; and the second configures Orion common components and the 
Orion Core database which NCM and the other Orion products on the server 
share. 

6. Click Next after reviewing the deployment options.  

Since you are following this set of steps you already have chosen to install 
Orion NCM integrated with an Orion product on a single server. 

7. Click Yes, this server will be used to perform NCM Server Operations, 
and click Next. 

8. Review the Welcome text, click Next. 

9. Typing Yes acknowledges that you are aware of the need to back up your 
existing Orion product database. Click Next when you are ready. 

10. Accept the license agreement displayed on the License Agreement window, 
and then click Next. 

11. Click Next to have the Setup Wizard start copying files. 

You should see the blue progress bar advancing with annotations of which 
files are being copied. 

12. Click Finish when the Setup Wizard completes its copying. 

13. If you are prompted to license Orion NCM, click Enter Licensing 
Infromation and then complete the following procedure to license your Orion 
NCM installation: 

a. If you have both an activation key and access to the internet, select 
the first option, I have internet access and an activation key…, enter 
your Activation Key, and then click Next. 

Note: If you are using a proxy server to access the internet, check 
access your access toa the internet through a proxy server, and then 
provide the Proxy address and Port. 
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b. If you do not have access to the internet from your designated 
Orion NCM server, select This server does not have internet 
access…, click Next, and then complete the steps provided.. 

You need a customer ID and password to successfully install the key. 
For more information, see the section “Obtaining a Software License 
Key”. 

14. Enter registration information, including your name and a valid email 
address, and click Finish. 

If licensing failed for some reason the software should automatically mark the 
installation as an evaluation. You will have 30 days to enter valid license 
information. 

15. Click Next after reviewing your progress in the Process Overview. 

The first of the two configuration wizards launches The first wizard configures 
NCM and the NCM database. 

16. Accept the defaults (Database and Services) and click Next. 

The Orion Network Configuration Manager Wizard starts running through the 
Orion NCM database setup. 

17. Specify the SQL Server instance you want to use for storing configurations 
and node details, the authentication method (Windows or SQL Server 
Authentication) used to communicate with the instance, and then click Next.  

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 

following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

18. If this is the first time you are installing Orion NCM, click Create a new 
database, and then click Next.  

Otherwise, select the existing Orion NCM database you want to use, and 
then click Next. 

19. Create a new database account and password, or select an existing account 
with owner rights on the database you created or selected. Then click Next. 

Note: You must supply a strong password. For more information about 
strong passwords, see http://msdn.microsoft.com/en-
us/library/ms143705.aspx. 

20. If all three Service Settings are selected, click Next. 

http://msdn.microsoft.com/en-us/library/ms143705.aspx
http://msdn.microsoft.com/en-us/library/ms143705.aspx
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21. Review the actions to be taken with the Database and Services, click Next. 

The dual blue bars show progress and annotations of the wizard’s current 
actions.   

22. Click Finish when the wizard completes its configuration actions. 

23. Click OK to acknowledge that a second configuration wizard, the Orion Core 
Configuration Wizard, will start in a few moments.  

The Orion Core database stores all discovered nodes for your Orion 
products. This is a superset of nodes from which you will license specific 
nodes for NCM monitoring and configuration. 

24. Click Next after reviewing your progress in the Process Overview. 

The second configuration wizard launches The second wizard configures 
Orion common components and the Orion Core database. 

25. Review the Welcome text, click Next. 

26. Specify the appropriate SQL Server instance, the authentication method 
(Windows or SQL Server Authentication) used to communicate with the 
instance, and then click Next.  

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 

following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

27. Provide the database name for your current Orion product—the one with 
which you want NCM to integrate—and then click Next.  

28. Create a new database account and password, or select an existing account 
with owner rights on the database you created or selected. Then click Next. 

Note: You must supply a strong password. For more information about 
strong passwords, see http://msdn.microsoft.com/en-
us/library/ms143705.aspx. 

29. Click Next setup the Orion Website with default settings or adjust the 
seetings as needed. 

30. Click Yes if you are informed that a website already exists with the same 
settings. 

31. Click Next after reviewing the settings that will be configured. 

32. Click Next after reviewing the overview configuration plan for the Database, 
Website, and Services. 

http://msdn.microsoft.com/en-us/library/ms143705.aspx
http://msdn.microsoft.com/en-us/library/ms143705.aspx
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The dual blue bars show progress and annotations of the wizard’s current 
actions.   

33. Click Finish when the wizard completes. 

Orion Web Console launches.   

34. Enter an appropriate username and password. 

The default credentials are ‘admin’ with no password. 

Since this is the your first time logging, the software navigates to Discovery 
Central and highlights Manage More Nodes under NCM Nodes. You may 
need to scroll down to see this part of Discovery Central. 

The current number of Orion Core nodes that NCM is managing is reported; 
most likely the number is 0. 

35. Click Manage More Nodes under NCM Nodes. 

36. Use the Licensed by NCM column to review the NCM license status of Orion 
Core nodes. 

 [No Grouping] lets you see all devices in the list, which is useful for quickly 
reviewing overall NCM license status (Licensed by NCM column).  

Otherwise, select a Group by setting to organize the list as needed.  

37. Click the relevant nodes and then click Add Nodes to NCM. 

For these nodes you will see the status in Licensed by NCM change to Yes. 

38. Click NETWORK SONAR DISCOVERY under NCM Nodes to discover the 
nodes for Orion NCM to manage. 

39. Click Yes when prompted to edit properties for the nodes you have added to 
NCM. 

40. Click on a property group (for example Polling Method) and edit the setting 
as needed. 

Keep in mind that the settings you select are applied to all selected nodes. 

41. Click Submit when you have finished editing. 

NCM nodes must also be managed in the Orion Core database. In case 
there is any disparity between the databases, we run a node synchronization 
next. 

42. Click Node Sync. 

43. Click SYNC NODES under Node Synchronization. 

The software reports the action taken. 

44. Click Finish. 

45. Click CONFIGS in the Orion NCM Web Console toolbar. 
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Installing Orion NCM on Integrated Separate Servers 

Follow these installation steps if you will run Orion NCM on a separate server 
from the Orion product with which you intend to integrate. 

The following procedures take you through all five related processes—as one set 
of numbered steps—for installing Orion NCM and integrating it with an Orion 
product on a different server.  

You must complete all the steps for Orion NCM to be correctly installed. 

To install Orion Network Configuration Manager: 

1. Log on with a local administrator account to the computer where your Orion 
product—the one with which you intend to integrate NCM—is currently 
installed. 

This server is sometimes referred to as the Orion Core server since it 
contains the common components shared by Orion products. 

The following steps are all to be completed on the computer that will 
host your Orion Core server. 

 

2. Navigate to your download location on the Orion Core server and launch the 
Orion NCM executable on the Orion . 

3. Take a back-up of your existing Orion product database.  

For detailed information, see “Creating Database Backups” in your Orion 
product’s Administrator Guide. 

4. Click Next on Getting Ready to Install. 

5. Click Next after reviewing the Process Overivew. 

Notice that after installing the NCM software the Installer runs two successive 
configuration wizards. The first wizard configures NCM and the NCM 
database; and the second configures Orion common components and the 
Orion Core database which NCM and the other Orion products on the server 
share. 

6. Click Next after reviewing the deployment options.  

Since you are following this set of steps you already have chosen to install 
Orion NCM integrated with an Orion product on a separate server. 

7. Click No, my primary NCM is on a different server, and click Next. 

8. Review the Welcome text, click Next. 

9. Accept the license agreement displayed on the License Agreement window, 
and then click Next. 
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10. Click Next to have the Setup Wizard start copying files. 

You should see the blue progress bar advancing with annotations of which 
files are being copied. 

11. Click Finish when the Setup Wizard completes its copying. 

12. Click Next after reviewing your progress in the Process Overview. 

The SolarWinds Core configuration wizard launches to configure Orion 
common components and the Orion Core database. 

13. Review the Welcome text, click Next. 

14. Specify the SQL Server instance—where the Orion Core database is 
located—and enter the authentication method (Windows or SQL Server 
Authentication) used to communicate with the instance. Click Next when you 
are ready. 

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 
following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

15. Click Use an existing database, select the Orion Core database in the 
dropdown list, and then click Next.  

Otherwise, select the existing Orion NCM database you want to use, and 
then click Next. 

16. Click Use and existing account and select the account credentials from the 
dropdown list. Click Next when you are ready. 

17. Accept the default for Website Settings and click Next. 

18. Click Yes to acknowledge that the website already exists and that you want 
to proceed. 

19. Click Next after reviewing the services to install. 

20. Click Next after reviewing the Database, Website, and Services to be 
configured. 

The green progress bars and descriptive text explain what is being done and 
how far along it is. 

21. Click Finish to complete installation and configuration. 

You are done with the first part of the installation. 

Take a breath. 
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The following steps are all to be completed on the computer that will 
host your main Orion NCM Server. 

22. Log on with a local administrator account to the computer that will host your 
main Orion NCM Server. 

23. Navigate to your download location and launch the Orion NCM executable. 

24. Click Next on Getting Ready to Install. 

25. Click Next after reviewing the Process Overivew. 

Notice that after installing the NCM software the Installer runs two successive 
configuration wizards. The first wizard configures NCM and the NCM 
database; and the second configures Orion common components and the 
Orion Core database which NCM and the other Orion products on the server 
share. 

26. Click Next after reviewing the deployment options.  

Since you are following this set of steps you already have chosen to install 
Orion NCM integrated with an Orion product on a separate server. 

27. Click Yes, I want to install/upgrade NCM and integrate with currently 
installed Orion products on a different server, and click Next. 

28. Enter the information for the server where the Orion product—with which you 
want to integrate—is currently installed. 

For the SolarWinds Orion User Password enter the credentials that you use 
to access the Orion Web Console. 

Note: If you receive an error, there are three possible causes: the login 
credentials provided are incorrect, the target server—where the Orion 
product currently resides—does not yet have the NCM integration 
components installed on it, or the network has a problem that is obstructing 
connectivity. 

29. Review the Welcome text, click Next. 

30. Accept the license agreement displayed on the License Agreement window, 
and then click Next. 

31. Accept the default installation path or use Browse to modify it. Click Next 
when you are finished. 

32. Click Next to have the Setup Wizard start copying files. 

You should see the blue progress bar advancing with annotations of which 
files are being copied. 

33. Click Finish when the Setup Wizard completes its copying. 

34. Click Next after reviewing your progress in the Process Overview. 



 

 
Installing Orion Network Configuration Manager  27 

The first of the two configuration wizards launches The first wizard configures 
NCM and the NCM database. 

35. Accept the defaults (Database and Services) and click Next. 

The Orion Network Configuration Manager Wizard starts running through the 
Orion NCM database setup. 

36. Specify the SQL Server instance you want to use for storing configurations 
and node details, the authentication method (Windows or SQL Server 
Authentication) used to communicate with the instance, and then click Next.  

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 

following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

37. If this is the first time you are installing Orion NCM, click Create a new 
database, provide the appropriate database server and a name for the new 
database, and then click Next.  

Otherwise, select the existing Orion NCM database you want to use, and 
then click Next. 

38. Create a new database account and password, or select an existing account 
with owner rights on the database you created or selected. Then click Next. 

Note: You must supply a strong password. For more information about 
strong passwords, see http://msdn.microsoft.com/en-
us/library/ms143705.aspx. 

39. If all three Service Settings are selected, click Next. 

40. Review the actions to be taken with the Database and Services, click Next. 

The dual blue bars show progress and annotations of the wizard’s current 
actions.   

41. Click Finish when the wizard completes its configuration actions. 

42. Click OK to acknowledge that a second configuration wizard, the Orion Core 
Configuration Wizard, will start in a few moments.  

The Orion Core database stores all discovered nodes for your Orion 
products. This is a superset of nodes from which you will license specific 
nodes for NCM monitoring and configuration. 

43. Click Next after reviewing your progress in the Process Overview. 

http://msdn.microsoft.com/en-us/library/ms143705.aspx
http://msdn.microsoft.com/en-us/library/ms143705.aspx
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The second configuration wizard launches The second wizard configures 
Orion common components and the Orion Core database. 

44. Review the Welcome text, click Next. 

45. Specify the appropriate SQL Server instance, the authentication method 
(Windows or SQL Server Authentication) used to communicate with the 
instance, and then click Next.  

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 
following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

46. Provide the database name for your current Orion product—the one with 
which you want NCM to integrate—and then click Next.  

47. Create a new database account and password, or select an existing account 
with owner rights on the database you created or selected. Then click Next. 

48. Click Next after you are finished reviewing the Services to install. 

49. Click Next after reviewing the Database and Services that will be configured. 

The dual blue bars show progress and annotations of the wizard’s current 
actions.   

50. Click Finish when the wizard completes. 

Orion Web Console launches.   

51. Enter an appropriate username and password. 

The default credentials are ‘admin’ with no password. 

Since this is the your first time logging, the software navigates to Discovery 
Central and highlights Manage More Nodes under NCM Nodes. You may 
need to scroll down to see this part of Discovery Central. 

The current number of Orion Core nodes that NCM is managing is reported; 
most likely the number is 0. 

52. Click Manage More Nodes under NCM Nodes. 

53. Use the Licensed by NCM column to review the NCM license status of Orion 
Core nodes. 

 [No Grouping] lets you see all devices in the list, which is useful for quickly 
reviewing overall NCM license status (Licensed by NCM column).  

Otherwise, select a Group by setting to organize the list as needed.  
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54. Click the relevant nodes and then click Add Nodes to NCM. 

For these nodes you will see the status in Licensed by NCM change to Yes. 

55. Click Yes when prompted to edit properties for the nodes you have added to 
NCM. 

56. Click on a property group (for example Polling Method) and edit the setting 
as needed. 

Keep in mind that the settings you select are applied to all selected nodes. 

57. Click Submit when you have finished editing. 

NCM nodes must also be managed in the Orion Core database. In case 
there is any disparity between the databases, we run a node synchronization 
next. 

58. Click Node Sync. 

59. Click SYNC NODES under Node Synchronization. 

The software reports the action taken. 

60. Click Finish. 

61. Click CONFIGS in the Orion NCM Web Console toolbar. 

Upgrading Orion Network Configuration Manager 

 

Orion NCM version 7.0 is architected so that the software is integrated with a 
core platform of components that are common to all Orion products. Besides the 
Orion NCM database, the NCM software also creates an Orion Core database to 
manage account and other information that pertains to Orion common 
components. 

If you are currently running Orion NCM on a server with other Orion products, but 
Orion NCM is not currently integrated with those products (for example, Orion 
Network Performance Monitor), upgrading to Orion NCM version 7.0 on your 
current NCM server will automatically integrate Orion NCM with the other Orion 
products. If you do not want to integrate Orion NCM with other Orion products, 
install Orion NCM version 7.0 on its own server. To do that, consult the section 
“Moving Orion NCM from a Non-Integrated Single to a New NCM Server”. 

Nodes are considered an Orion common component in Orion NCM version 7.0. 
Every node managed in NCM must also be managed in the Orion Core 
database; and the Orion Core database is the key to maintaining continuity for a 
node through its states of management and unmanagement while you use the 
Orion NCM product. 
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It is a feature of Orion NCM that if you delete a node from the Orion Core 
database all existing data for that node, including all backed-up configuraitons, 
are permanently removed. 

If you are an existing customer, and your current version does not qualify for a 
direct upgrade to Orion NCM version 7.0, you first need to install the versions of 
Orion NCM that at least bring your installation to Orion NCM version 6.0. 

For example, if you are running Orion NCM version 5.5, you need to install Orion 
NCM versions 5.5.1, 5.5.2, and 6.0 before you can install Orion NCM 7.0. 
Additionally, in this case, should you want to gain access to the latest NCM/NPM 
integration features, you would need to upgrade your SolarWinds Network 
Performance Manager software to version 10.2 or higher. 

If you need previous versions of Orion NCM, Contact Customer Service and 
Support (customerservice@solarwinds.com).  

Note: Windows XP, Windows Vista, and Windows 7 are supported only for 
evaluation purposes. If you are installing on Windows XP, Windows Vista, or 
Windows 7 and want to use the Orion NCM Web Console, ensure you have 
installed Microsoft Internet Information Server 6 or later. The setup program 
stops the default website and starts the Orion NCM Web Console. Only one 
website can be active on IIS when installed on Windows XP, Windows Vista, or 
Windows 7. 

NCM deployments integrated with multiple NPM instances 

Due to the new Orion NCM architecture, any existing Orion NCM integration with 
multiple instances of Orion NPM are not sustainable in their current form. Since 
there is no NCM Integration Module with Orion NCM version 7.0, you cannot use 
a single instance of NCM to manage nodes on different NPM instances. If you 
are running a current deployment of this kind, to replicate it with Orion NCM 
version 7.0, you must license Orion NCM for each of the NPM instances for 
which you want NCM integration. Depending on your objectives, this may require 
a different licensing strategy; you may need to license Orion NCM in multiple 
smaller bundles than in the a single larger one. 

Moving Orion NCM from a Non-Integrated Single to a New NCM Server 

If you are currently running Orion NCM on the same server with Orion Network 
Performance Monitor, but the two products are not integrated, and you prefer to 
keep them unintegrated, follow the steps in this section. 

1. Back-up existing NCM jobs by copying them to a temporary directory from 
(by default): C:\Program Files (x86)\Solarwinds\Network Configuration 
Manager\Jobs.  

2. Uninstall the Orion NCM from the current Orion NCM server. 

3. Follow the steps under “Installing Orion NCM Standalone (Single Server)”. 

mailto:customerservice@solarwinds.com
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4. When you are finished installing Orion NCM versions 7.0, copy your backed-
up Orion NCM jobs from the previous Orion NCM server to (by default): 
C:\Program Files\Solarwinds\Orion\NCM\Jobs. 

5. Edit each job, retyping the appropriate password when prompted. 

Moving Orion NCM from Integrated Single to Integrated Separate Servers 

If you are currently running Orion NCM in integration with Orion Network 
Performance Monitor on a single server, and you would prefer to use this 
upgrade as an opportunity to split the Orion NCM and other Orion products onto 
different servers, while still maintaining integration, follow the steps in this 
section. 

To move Orion NCM from integrated single to integrated separate servers: 

1. Back-up existing NCM jobs by copying them to a temporary directory from 
(by default): C:\Program Files (x86)\Solarwinds\Network Configuration 
Manager\Jobs.  

2. Uninstall the Orion NCM and the Orion NCM integration module from the 
current Orion NCM server. 

3. Follow the steps under “Installing Orion NCM on Integrated Separate 
Servers”. 

4. When you are finished installing Orion NCM versions 7.0, copy your backed-
up Orion NCM jobs from the previous Orion NCM server to (by default): 
C:\Program Files\Solarwinds\Orion\NCM\Jobs. 

5. Edit each job, retyping the appropriate password when prompted. 

Upgrading Orion NCM Standalone (Single Server) 

Follow these steps if you will run Orion NCM on a single server and intend not to 
integrate it with an Orion product that already resides on the server. 

These procedures take you through all five related processes—as one set of 
numbered steps—for upgrading Orion NCM on a single server. 

You must complete all the steps for Orion NCM to be correctly upgraded. 

To upgrade Orion Network Configuration Manager: 

1. Log on with a local administrator account to the computer on which you want 
to install Orion Network Configuration Manager. 

Note: To ensure that Orion Network Configuration Manager runs properly, do 
not install Orion Network Configuration Manager on a domain controller. 

2. Navigate to your download location and launch the executable. 

3. Click Next on Getting Ready to Install. 
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4. Click Next after reviewing the Process Overivew. 

Notice that after installing the NCM software the Installer runs two successive 
configuration wizards. The first wizard configures NCM and the NCM 
database; and the second configures Orion common components and the 
Orion Core database. 

5. Click Next after reviewing the deployment options.  

6. Stop. Read the information about the dual database architecture inherent in 
Orion NCM 7.0. (Click Next to acknowledge that you understand the dual 
database architecture concept.) 

7. If you do not want to integrate Orion NCM with other Orion products on your 
existing NCM server, click Cancel and consult the section “Moving Orion 
NCM from a Non-Integrated Single to a New NCM Server”.  

Click Next only if you are ready to proceed with the upgrade and expect to 
end up with an Orion NCM deployment on a single server that is integrated 
with Orion Network Performance Monitor or the other compatible Orion 
products that are currently installed on the NCM server. 

8. Review the Welcome text, click Next. 

9. Type Yes after creating your database back-up, and then click Next. 

10. Accept the license agreement displayed on the License Agreement window, 
and then click Next. 

11. If prompted, accept the default directory for the installation or Browse to 
another, then click Next. 

12. Click Next to have the Setup Wizard start copying files. 

You should see the blue progress bar advancing with annotations of which 
files are being copied. 

13. Click Finish when the Setup Wizard completes its copying. 

14. If you are prompted to license Orion NCM, click Enter Licensing 
Infromation and then complete the following procedure to license your Orion 
NCM installation: 

a. If you have both an activation key and access to the internet, select 
the first option, I have internet access and an activation key…, enter 
your Activation Key, and then click Next. 

Note: If you are using a proxy server to access the internet, check 
access your access toa the internet through a proxy server, and then 
provide the Proxy address and Port. 
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b. If you do not have access to the internet from your designated 
Orion NCM server, select This server does not have internet 
access…, click Next, and then complete the steps provided.. 

You need a customer ID and password to successfully install the key. 
For more information, see the section “Obtaining a Software License 
Key”. 

15. Enter registration information, including your name and a valid email 
address, and click Finish. 

If licensing failed for some reason the software should automatically mark the 
installation as an evaluation. You will have 30 days to enter valid license 
information. 

16. Click Next after reviewing your progress in the Process Overview. 

The first of the two configuration wizards launches The first wizard configures 
NCM and the NCM database; and the second configures Orion common 
components and the Orion Core database. 

17. Accept the defaults (Database and Services) and click Next. 

The Orion Network Configuration Manager Wizard starts running through the 
Orion NCM database setup. 

18. Specify the SQL Server instance you want to use for storing configurations 
and node details, the authentication method (Windows or SQL Server 
Authentication) used to communicate with the instance, and then click Next.  

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 

following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

19. If you want to create a new database, click Create a new database, and 
then click Next.  

Otherwise, select the existing Orion NCM database you want to use, and 
then click Next. 

20. Create a new database account and password, or select an existing account 
with owner rights on the database you created or selected. Then click Next. 

Note: You must supply a strong password. For more information about 
strong passwords, see http://msdn.microsoft.com/en-
us/library/ms143705.aspx. 

21. If all three Service Settings are selected, click Next. 

http://msdn.microsoft.com/en-us/library/ms143705.aspx
http://msdn.microsoft.com/en-us/library/ms143705.aspx
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22. Review the actions to be taken with the Database and Services, click Next. 

The dual blue bars show progress and annotations of the wizard’s current 
actions.   

23. Click Finish when the wizard completes its configuration actions. 

24. Click OK to acknowledge that a second configuration wizard, the Orion Core 
Configuration Wizard, will start in a few moments.  

The Orion Core database stores all discovered nodes. This is a superset of 
nodes from which you will license specific nodes for NCM monitoring and 
configuration. 

25. Click Next after reviewing your progress in the Process Overview. 

The second configuration wizard launches The second wizard configures 
Orion common components and the Orion Core database. 

26. Review the Welcome text, click Next. 

27. To create the Orion Core database, you need to specify the appropriate SQL 
Server instance, the authentication method (Windows or SQL Server 
Authentication) used to communicate with the instance, and then click Next.  

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 

following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

 If you are running Orion NCM on the same server as another compatible 
Orion product, the software has automatically detected the database 
relevant to that Orion product and will be using it as the Orion Core 
database; in this case, you will not be prompted to create a database 
and database server user account as indicated in the next few steps (27-
32). Instead, the NCM software will install the Orion Web component that 
is required for Orion NCM integration with the other Orion product.  

28. Click Create a new database, provide a name, and then click Next. 

29. Create a new database account and password, or select an existing account 
with owner rights on the database you created or selected. Then click Next. 

Note: You must supply a strong password. For more information about 
strong passwords, see http://msdn.microsoft.com/en-
us/library/ms143705.aspx. 

http://msdn.microsoft.com/en-us/library/ms143705.aspx
http://msdn.microsoft.com/en-us/library/ms143705.aspx
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30. Click Next setup the Orion Website with default settings or adjust the 
seetings as needed. 

31. Click Yes if you are informed that a website already exists with the same 
settings. 

32. Click Next after reviewing the settings that will be configured. 

33. Click Next after reviewing the overview configuration plan for the Database, 
Website, and Services. 

The dual blue bars show progress and annotations of the wizard’s current 
actions.  

34. Click Finish when the wizard completes. 

Orion Web Console launches.   

35. Enter an appropriate username and password. 

The default credentials are ‘admin’ with no password. 

36. Click Finish when the wizard completes. 

Orion Web Console launches.   

37. Enter an appropriate username and password. 

The default credentials are ‘admin’ with no password. 

Since this is the your first time logging-in after upgrade, the software 
navigates to a page called Node Synchronization and highlights Sync 
Nodes. 

38. Click Sync Nodes. 

All NCM nodes must also be managed in the Orion Core database for you to 
perform NCM work on a node. 

39.  Click Synchronize Databases under Node Synchronization. You may need 
to scroll down to see this part of Discovery Central. 

This operation reports its results in the form of: 

 (n) existing nod(s) synchronized. 

(n) new node(s) added to Orion Core. 

The synchronization moves existing NCM nodes and their existing properties 
into the Orion Core database where they are henceforth managed and 
monitored. From this point forward, any node deleted from the Orion Core 
database also is deleted from the NCM database along with existing data. 
Not conversely, however: any node deleted from NCM remains in the Orion 
Core database. 

40. Click Finish. 
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41. Click CONFIGS in the Orion NCM Web Console toolbar. 

Upgrading Orion NCM on Integrated Single Server 

Follow these steps if you will run Orion NCM on a single server and intend to 
integrate it with an Orion product that already resides on the server. 

If your existing version of your Orion product is not already upgraded to a version 
compatible with NCM 7.0, you must upgrade the Orion product first. Locate the 
relevant executable for the Orion product in your customer portal.  

The following procedures assume that your other Orion product has been 
upgraded to a version compatible with Orion NCM version 7.0; see the NCM 
version requirements of Orion products.  

These procedures take you through all five related processes—as one set of 
numbered steps—for upgrading Orion NCM and integrating with an Orion 
product on a single server. 

You must complete all the steps for Orion NCM to be correctly upgraded. 

To upgrade Orion Network Configuration Manager: 

1. Log on with a local administrator account to the computer on which you want 
to install Orion Network Configuration Manager. 

Note: To ensure that Orion Network Configuration Manager runs properly, do 
not install Orion Network Configuration Manager on a domain controller. 

2. Navigate to your download location and launch the executable. 

3. Take a back-up of your existing Orion product database.  

For detailed information, see “Creating Database Backups” in your Orion 
product’s Administrator Guide. 

4. Click Next on Getting Ready to Install. 

5. Click Next after reviewing the Process Overivew. 

Notice that after upgrading the NCM software the Installer runs two 
successive configuration wizards. The first wizard configures NCM and the 
NCM database; and the second configures Orion common components and 
the Orion Core database which NCM and the other Orion products on the 
server share. 

6. Click Next after reviewing the deployment options.  

Since you are following this set of steps you already have chosen to install 
Orion NCM integrated with an Orion product on a single server. 

7. Click Next to the installer software to upgrade the NCM software that it has 
detected on this server. 

http://www.solarwinds.com/customerportal/
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If you receive and error regarding an unsupported version of installed Orion 
product—for example, Orion NCM version 10.1—you must discontinue this 
installation and upgrade the Orion product before attempting again to 
upgrade Orion NCM. 

8. Review the Welcome text, click Next. 

9. Typing Yes acknowledges that you are aware of the need to back up your 
existing Orion product database. Click Next when you are ready. 

10. Accept the license agreement displayed on the License Agreement window, 
and then click Next. 

11. Click Next to have the Setup Wizard start copying files. 

You should see the blue progress bar advancing with annotations of which 
files are being copied. 

12. Click Finish when the Setup Wizard completes its copying. 

13. If you are prompted to license Orion NCM, click Enter Licensing 
Infromation and then complete the following procedure to license your Orion 
NCM installation: 

a. If you have both an activation key and access to the internet, select 
the first option, I have internet access and an activation key…, enter 
your Activation Key, and then click Next. 

Note: If you are using a proxy server to access the internet, check 
access your access toa the internet through a proxy server, and then 
provide the Proxy address and Port. 

b. If you do not have access to the internet from your designated 
Orion NCM server, select This server does not have internet 
access…, click Next, and then complete the steps provided.. 

You need a customer ID and password to successfully install the key. 
For more information, see the section “Obtaining a Software License 
Key”. 

14. Enter registration information, including your name and a valid email 
address, and click Finish. 

If licensing failed for some reason the software should automatically mark the 
installation as an evaluation. You will have 30 days to enter valid license 
information. 

15. Click Next after reviewing your progress in the Process Overview. 

The first of the two configuration wizards launches The first wizard configures 
NCM and the NCM database. 

16. Accept the defaults (Database and Services) and click Next. 
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The Orion Network Configuration Manager Wizard starts running through the 
Orion NCM database setup. 

17. Specify the SQL Server instance you want to use for storing configurations 
and node details, the authentication method (Windows or SQL Server 
Authentication) used to communicate with the instance, and then click Next.  

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 
following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

18. Click Create a new database or select the existing Orion NCM database you 
want to use. Click Next when you are finished. 

19. Create a new database account and password, or select an existing account 
with owner rights on the database you created or selected. Then click Next. 

Note: You must supply a strong password. For more information about 
strong passwords, see http://msdn.microsoft.com/en-
us/library/ms143705.aspx. 

20. If all three Service Settings are selected, click Next. 

21. Review the actions to be taken with the Database and Services, click Next. 

The dual blue bars show progress and annotations of the wizard’s current 
actions.   

22. Click Finish when the wizard completes its configuration actions. 

23. Click OK to acknowledge that a second configuration wizard, the Orion Core 
Configuration Wizard, will start in a few moments.  

The Orion Core database stores all discovered nodes for your Orion 
products. This is a superset of nodes from which you will license specific 
nodes for NCM monitoring and configuration. 

24. Click Next after reviewing your progress in the Process Overview. 

The second configuration wizard launches The second wizard configures 
Orion common components and the Orion Core database. 

http://msdn.microsoft.com/en-us/library/ms143705.aspx
http://msdn.microsoft.com/en-us/library/ms143705.aspx
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25. Click Yes to restart your system now and allow the NCM configuration 
changes take effect. Click No if you want to postpone rebooting this machine. 

26. Review the Welcome text, click Next. 

27. Specify the appropriate SQL Server instance, the authentication method 
(Windows or SQL Server Authentication) used to communicate with the 
instance, and then click Next.  

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 
following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

28. Provide the database name for your current Orion product—the one with 
which you want NCM to integrate—and then click Next.  

29. Create a new database account and password, or select an existing account 
with owner rights on the database you created or selected. Then click Next. 

Note: You must supply a strong password. For more information about 
strong passwords, see http://msdn.microsoft.com/en-
us/library/ms143705.aspx. 

30. Click Next setup the Orion Website with default settings or adjust the 
seetings as needed. 

31. Click Yes if you are informed that a website already exists with the same 
settings. 

32. Click Next after reviewing the settings that will be configured. 

33. Click Next after reviewing the overview configuration plan for the Database, 
Website, and Services. 

The dual blue bars show progress and annotations of the wizard’s current 
actions.   

34. Click Finish when the wizard completes. 

Orion Web Console launches.   

35. Enter an appropriate username and password. 

The default credentials are ‘admin’ with no password. 

Since this is the your first time logging after upgrade, the software navigates 
to a page called Node Synchronization and highlights Sync Nodes. 

36. Click Sync Nodes. 

http://msdn.microsoft.com/en-us/library/ms143705.aspx
http://msdn.microsoft.com/en-us/library/ms143705.aspx
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All NCM nodes must also be managed in the Orion Core database for you to 
perform NCM work on a node. 

37.  Click Synchronize Databses under Node Synchronization. You may need to 
scroll down to see this part of Discovery Central. 

This operation reports its results in the form of: 

 (n) existing nod(s) synchronized. 

(n) new node(s) added to Orion Core. 

The synchronization moves existing NCM nodes and their existing properties 
into the Orion Core database where they are henceforth managed and 
monitored. From this point forward, any node deleted from the Orion Core 
database also is deleted from the NCM database along with existing data. 
Not conversely, however: any node deleted from NCM remains in the Orion 
Core database. 

38. Click Finish. 

39. Click CONFIGS in the Orion NCM Web Console toolbar. 

Upgrading Orion NCM on Integrated Separate Servers 

Follow these steps if you will run Orion NCM on a separate server from the Orion 
product with which you intend to integrate. 

The following procedures take you through all five related processes—as one set 
of numbered steps—for upgrading Orion NCM and integrating it with an Orion 
product on a different server.  

You must complete all the steps for Orion NCM to be correctly upgraded. 

To upgrade Orion Network Configuration Manager: 

1. Log on with a local administrator account to the computer where your Orion 
product—the one with which you intend to integrate NCM—is currently 
installed. 

This server is sometimes referred to as the Orion Core server since it 
contains the common components shared by Orion products. 

The following steps are all to be completed on the computer that will 
host your Orion Core server. 

2. Navigate to your download location on the Orion Core server and launch the 
Orion NCM version 7 executable on the Orion . 

3. Take a back-up of your existing Orion product database.  

For detailed information, see “Creating Database Backups” in your Orion 
product’s Administrator Guide. 
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4. Click Next on Getting Ready to Install. 

5. Click Next after reviewing the Process Overivew. 

Notice that after installing the NCM software the Installer runs two successive 
configuration wizards. The first wizard configures NCM and the NCM 
database; and the second configures Orion common components and the 
Orion Core database which NCM and the other Orion products on the server 
share. 

6. Click Next after reviewing the deployment options.  

Since you are following this set of steps you already have chosen to install 
Orion NCM integrated with an Orion product on a separate server. 

7. Click No, my primary NCM is on a different server, and click Next. 

8. Review the Welcome text, click Next. 

9. Accept the license agreement displayed on the License Agreement window, 
and then click Next. 

10. Click Next to have the Setup Wizard start copying files. 

You should see the blue progress bar advancing with annotations of which 
files are being copied. 

11. Click Finish when the Setup Wizard completes its copying. 

12. Click Next after reviewing your progress in the Process Overview. 

The SolarWinds Core configuration wizard launches to configure Orion 
common components and the Orion Core database. 

13. Review the Welcome text, click Next. 

14. Specify the SQL Server instance—where the Orion Core database is 
located—and enter the authentication method (Windows or SQL Server 
Authentication) used to communicate with the instance. Click Next when you 
are ready. 

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 

following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

15. Click Use an existing database, select the Orion Core database in the 
dropdown list, and then click Next.  
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16. Click Use and existing account and select the account credentials from the 
dropdown list. Click Next when you are ready. 

17. Accept the default for Website Settings and click Next. 

18. Click Yes to acknowledge that the website already exists and that you want 
to proceed. 

19. Click Next after reviewing the services to install. 

20. Click Next after reviewing the Database, Website, and Services to be 
configured. 

The green progress bars and descriptive text explain what is being done and 
how far along it is. 

21. Click Finish to complete the upgrade and and start configuration. 

You are done with the first part of the ugrade. 

Take a breath. 

The following steps are all to be completed on the computer that will 
host your main Orion NCM Server. 

22. Log on with a local administrator account to the computer that will host your 
main Orion NCM Server. 

23. Navigate to your download location and launch the Orion NCM executable. 

24. Click Next on Getting Ready to Install. 

25. Click Next after reviewing the Process Overview. 

Notice that after installing the NCM software the Installer runs two successive 
configuration wizards. The first wizard configures NCM and the NCM 
database; and the second configures Orion common components and the 
Orion Core database which NCM and the other Orion products on the server 
share. 

26. Click Next after reviewing the deployment options.  

Since you are following this set of steps you already have chosen to install 
Orion NCM integrated with an Orion product on a separate server. 

27. Click Yes, I want to install/upgrade NCM and integrate with currently 
installed Orion products on a different server, and click Next. 

28. Enter the information for the server where the Orion product—with which you 
want to integrate—is currently installed. 

For the SolarWinds Orion User Password enter the credentials that you use 
to access the Orion Web Console. 
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Note: If you receive an error, there are three possible causes: the login 
credentials provided are incorrect, the target server—where the Orion 
product currently resides—does not yet have the NCM integration 
components installed on it, or the network has a problem that is obstructing 
connectivity. 

29. Review the Welcome text, click Next. 

30. Accept the license agreement displayed on the License Agreement window, 
and then click Next. 

31. Accept the default installation path or use Browse to modify it. Click Next 
when you are finished. 

32. Click Next to have the Setup Wizard start copying files. 

You should see the blue progress bar advancing with annotations of which 
files are being copied. 

33. Click Finish when the Setup Wizard completes its copying. 

34. Click Next after reviewing your progress in the Process Overview. 

The first of the two configuration wizards launches The first wizard configures 
NCM and the NCM database. 

35. Accept the defaults (Database and Services) and click Next. 

The Orion Network Configuration Manager Wizard starts running through the 
Orion NCM database setup. 

36. Specify the SQL Server instance you want to use for storing configurations 
and node details, the authentication method (Windows or SQL Server 
Authentication) used to communicate with the instance, and then click Next.  

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 
following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

37. If this is the first time you are installing Orion NCM, click Create a new 
database, and then click Next.  

Otherwise, select the existing Orion NCM database you want to use, and 
then click Next. 
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38. Create a new database account and password, or select an existing account 
with owner rights on the database you created or selected. Then click Next. 

Note: You must supply a strong password. For more information about 
strong passwords, see http://msdn.microsoft.com/en-
us/library/ms143705.aspx. 

39. If all three Service Settings are selected, click Next. 

40. Review the actions to be taken with the Database and Services, click Next. 

The dual blue bars show progress and annotations of the wizard’s current 
actions.   

41. Click Finish when the wizard completes its configuration actions. 

42. Click OK to acknowledge that a second configuration wizard, the Orion Core 
Configuration Wizard, will start in a few moments.  

The Orion Core database stores all discovered nodes for your Orion 
products. This is a superset of nodes from which you will license specific 
nodes for NCM monitoring and configuration. 

43. Click Next after reviewing your progress in the Process Overview. 

The second configuration wizard launches The second wizard configures 
Orion common components and the Orion Core database. 

44. Review the Welcome text, click Next. 

45. Specify the appropriate SQL Server instance, the authentication method 
(Windows or SQL Server Authentication) used to communicate with the 
instance, and then click Next.  

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 
following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

46. Provide the database name for your current Orion product—the one with 
which you want NCM to integrate—and then click Next.  

http://msdn.microsoft.com/en-us/library/ms143705.aspx
http://msdn.microsoft.com/en-us/library/ms143705.aspx
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47. Create a new database account and password, or select an existing account 
with owner rights on the database you created or selected. Then click Next. 

48. Click Next after you are finished reviewing the Services to install. 

49. Click Next after reviewing the Database and Services that will be configured. 

The dual blue bars show progress and annotations of the wizard’s current 
actions.   

50. Click Finish when the wizard completes. 

Orion Web Console launches.   

51. Enter an appropriate username and password. 

The default credentials are ‘admin’ with no password. 

Since this is the your first time logging, the software navigates to Discovery 
Central and highlights Manage More Nodes under NCM Nodes. You may 
need to scroll down to see this part of Discovery Central. 

The current number of Orion Core nodes that NCM is managing is reported; 
most likely the number is 0. 

52. Click Manage More Nodes under NCM Nodes. 

53. Use the Licensed by NCM column to review the NCM license status of Orion 
Core nodes. 

 [No Grouping] lets you see all devices in the list, which is useful for quickly 
reviewing overall NCM license status (Licensed by NCM column).  

Otherwise, select a Group by setting to organize the list as needed.  

54. Click the relevant nodes and then click Add Nodes to NCM. 

For these nodes you will see the status in Licensed by NCM change to Yes. 

55. Click Yes when prompted to edit properties for the nodes you have added to 
NCM. 

56. Click on a property group (for example Polling Method) and edit the setting 
as needed. 

Keep in mind that the settings you select are applied to all selected nodes. 

57. Click Submit when you have finished editing. 

Since this is the your first time logging after upgrade, the software navigates 
to a page called Node Synchronization and highlights Sync Nodes. 

58. Click Sync Nodes. 

All NCM nodes must also be managed in the Orion Core database for you to 
perform NCM work on a node. 
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59.  Click Synchronize Databses under Node Synchronization. You may need 
to scroll down to see this part of Discovery Central. 

This operation reports its results in the form of: 

 (n) existing nod(s) synchronized. 

(n) new node(s) added to Orion Core. 

The synchronization moves existing NCM nodes and their existing properties 
into the Orion Core database where they are henceforth managed and 
monitored. From this point forward, any node deleted from the Orion Core 
database also is deleted from the NCM database along with existing data. 
Not conversely, however: any node deleted from NCM remains in the Orion 
Core database. 

60. Click Finish. 

61. Click CONFIGS in the Orion NCM Web Console toolbar. 

Additional Polling Engine and Web Console  

According to your needs in managing the devices in your network you can add 
an additional poller or website to your Orion NCM deployment. An additional 
website adds versatility in accessing Orion NCM information and an additional 
poller adds scalability to the regular back-up of device configs. 

Installing an Additional Poller 

If you are upgrading to Orion NCM 7.0, before you attempt to install an additional 
poller on another server, you must first upgrade the main Orion NCM server. 

To upgrade the Orion NCM server follow the steps in “Installing Orion Network 
Configuration Manager”. 

Follow the steps in this section to install or upgrade an additional Orion NCM 
poller. 

1. Launch the executable (SolarWinds-Orion_AdditionalPoller.exe) from the 
location where you downloaded it on the server that will host your additional 
poller.  

Visit the Customer Portal to obtain the file if you do not already have it. 

2. Click Next on the Welcome screen. 

3. Click to accept the end user agreement, then click Next. 

4. Click Next to accept the default installation directory or use Browse to adjust 
it. 

5. Click Next to start copying files. 

http://www.solarwinds.com/customerportal/
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The software copies the files, including the Orion Core components needed 
for your server to communicate with the main poller. 

6. Click Finish when the files are finished being copied. 

7. If you are prompted to license the additional poller, click Enter 
Licensing Infromation and then complete the following procedure to license 
your installation: 

a. If you have both an activation key and access to the internet, select 
the first option, I have internet access and an activation key…, enter 
your Activation Key, and then click Next. 

Note: If you are using a proxy server to access the internet, check 
access your access toa the internet through a proxy server, and then 
provide the Proxy address and Port. 

b. If you do not have access to the internet from your designated 
Orion NCM additional poller host server, select This server does not 
have internet access…, click Next, and then complete the steps 
provided.. 

You need a customer ID and password to successfully install the key. 
For more information, see the section “Obtaining a Software License 
Key”. 

8. Review the Welcome text, click Next. 

9. Specify the SQL Server instance—where the Orion Core database is 
located—and enter the authentication method (Windows or SQL Server 
Authentication) used to communicate with the instance. Click Next when you 
are ready. 

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 
following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

10. Click Use an existing database, select the Orion Core database in the 
dropdown list, and then click Next.  
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11. Click Use and existing account and select the account credentials from the 
dropdown list. Click Next when you are ready. 

12. Click Next after reviewing the services to install. 

13. Click Yes to acknowledge that the SNMP Trap Serivce will be disable while 
the SolarWinds Trap Serivce is installed. 

14. Click Next after reviewing the Database and Services to be configured. 

The green progress bars and descriptive text explain what is being done and 
how far along it is. 

15. Click Launch Orion Web and Finish to complete configuration and bring up 
the website on your additional poller. 

Installing an Additional Website 

If you are upgrading to Orion NCM 7.0, before you attempt to install an additional 
website on another server, you must first upgrade the main Orion NCM server. 

To upgrade the Orion NCM server follow the steps in “Installing Orion Network 
Configuration Manager”. 

Follow the steps in this section to install or upgrade your additional website. 

1. Launch the executable (SolarWinds-Orion_WebOnly.exe) from the location 
where you downloaded it on the server that will host your additional poller.  

Visit the Customer Portal to obtain the file if you do not already have it. 

2. Enter the hostname or IP address and the Orion administrator credentials of 
your main Orion NCM server in the Orion Compatibility Checker.  

3. Click Next on the Welcome screen. 

4. Click I accept… and Next to accept the License Agreement.  

5. Click Next to accept the default location for installing the files or first use 
Browse to adjust the location. 

6. Click Next to start copying files. 

The software copies the files, including the Orion Core components needed 
for your server to communicate with the main Orin NCM server. 

7. Click Finish when the files are finished being copied. 

8. When  you are prompted to license the additional poller, click Enter 
Licensing Infromation and then complete the following procedure to license 
your installation: 

http://www.solarwinds.com/customerportal/
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a. If you have both an activation key and access to the internet, select 
the first option, I have internet access and an activation key…, enter 
your Activation Key, and then click Next. 

Note: If you are using a proxy server to access the internet, check 
access your access toa the internet through a proxy server, and then 
provide the Proxy address and Port. 

b. If you do not have access to the internet from your designated 
Orion NCM additional poller host server, select This server does not 
have internet access…, click Next, and then complete the steps 
provided.. 

You need a customer ID and password to successfully install the key. 
For more information, see the section “Obtaining a Software License 
Key”. 

9. Click Next on the Welcome screen of the SolarWinds Configuration Wizard. 

10. Specify the SQL Server instance—where the Orion Core database is 
located—and enter the authentication method (Windows or SQL Server 
Authentication) used to communicate with the instance. Click Next when you 
are ready. 

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 
following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

11. Click Use an existing database, select the Orion Core database in the 
dropdown list, and then click Next.  

12. Click Use and existing account and select the account credentials from the 
dropdown list. Click Next when you are ready. 

13. Accept the default for Website Settings and click Next. 

14. Click Yes to acknowledge that the website already exists and that you want 
to proceed. 

15. Click Next after reviewing the services to install. 

16. Click Next after reviewing the Database, Website, and Services to be 
configured. 

The green progress bars and descriptive text explain what is being done and 
how far along it is. 
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17. Click Launch Orion Web and Finish to complete configuration and bring up 
the Orion Web Console. 

Repairing Orion Network Configuration Manager 

If your installation is behaving abnormally, you can repair it by launching the 
Configuration Wizard. Start it from the SolarWinds Orion Network Configuration 
Manager program group in the Start menu.  

Warning: If you install or make changes to Orion NCM Web, Configuration 
Wizard will reboot your IIS server, shutting down all SolarWinds products on the 
server during the configuration operation. Any websites hosted by the server will 
be stopped and restarted during this process. 

To repair Orion Network Configuration Manager: 

1. Launch Configuration Wizard. 

2. Select the components you want to repair or modify and click Next. 

3. Specify the appropriate SQL Server instance and the authentication method 
used to communicate with the instance, then click Next.  

The SQL Server instance must support SQL authentication or mixed mode. 

Notes: 

 If you are using a local instance of SQL Server Express, use the 
following syntax to use the default instance: (local)\SQLEXPRESS. 

 If you select SQL Authentication, provide an account with sufficient rights 
to create new databases on the server instance. For example, specify 
the SQL administrator (sa) account. 

4. Select the existing Orion NCM database you want to use, and then click 
Next. 

5. Create a new database account and password or select an existing account  
on the database server. 

Note: You must supply a strong password. For more information about 
strong passwords, see http://msdn.microsoft.com/en-
us/library/ms143705.aspx. 

6. If you need to specify a particular IP Address for your Orion NCM Web 
Console installation, provide the IP address you want to use for the Web 
Console. 

SolarWinds recommends that you retain the default IP address setting of All 
Unassigned unless your environment requires the designation of a specific 
IP address for your Orion Web Console. 
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7. Specify both the port through which you want to access the Web Console 
and the volume and folder in which you want to install the Web Console files. 

If you accept the default port or you specify any port other than 80, you must 

include that port in the URL used to access the Web Console. For example, if 
you specify an IP address of 192.168.0.3 and port 8080, the URL used to 

access the Web Console is http://192.168.0.3:8080. 

8. Click Next. I 

9. If you are prompted to use the existing website, click Yes. 

10. Review the services the wizard will install, and then click Next 

 Note: If you want to use the Trap Viewer tool or trigger realtime configuration 
change alerts based on traps, ensure the Windows SNMP Trap Service is 
running. If the SNMP Trap Service is not listed as a running service in the 

service control manager (services.msc), you can enable Simple Network 

Management Protocol in the Management and Monitoring Tools through 
Add/Remove Windows Components in the Add/Remove Programs 
application.  

For more information, see “Enabling Realtime Configuration Change 
Detection” on page 105 and “Monitoring SNMP Traps” on page 321. 

11. Read the summary of what the configuration wizard will configure, and then 
click Next. 

12. Review the Configuration Summary, and then click Finish. 

Using SSL Communication with Orion NCM 

Orion NCM supports the use of Secure Sockets Layer certificates to enable 
secure communications with the Orion NCM Web Console. The following 
procedure enables SSL connections to the Web Console.  

Notes: 

 Secure SSL communications are conducted over port 443.  

 The following procedure does not detail the process of either obtaining a 
required certificate or generating a certificate signing request for a third-party 
certificate authority. It is assumed that the required SSL certificate has 
already been installed on your Orion NCM server. For more information 
about acquiring and installing a required server certificate for SSL 
communications, see http://support.microsoft.com/kb/298805, from which this 
procedure was adapted.  

To enforce SSL connections to the Orion NCM Web Console:  

1. Log on as an administrator to your main Orion NCM server.  
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2. Click Start > Control Panel > Administrative Tools > Computer 
Management.  

3. Expand Services and Applications > Internet Information Services (IIS) 
Manager > Web Sites.  

4. Right click SolarWinds NetPerfMon, then click Properties.  

5. Click the Web Site tab.  

6. Confirm that SSL port is set to 443, and then click Apply.  

7. Click Advanced.  

8. If the Multiple SSL identities for this Web site field does not list the IP 
address for the Orion Web Console with SSL port 443, complete the 
following steps:  

a. Click Add, and then select the IP address of the Orion Web Console.  

Note: As it was set initially in the Configuration Wizard, this option is 
usually set to (All Unassigned). If the IP address of the Orion Web 
Console was not initially set to (All Unassigned), select the actual, 
configured IP address of the Orion Web Console.  

b. Type 443 as the TCP port, and then click OK.  

9. Click the Directory Security tab.  

10. Click Edit in the Secure communications section.  

11. Check Require secure channel (SSL), and then click OK.  

12. Click Apply, and then click OK to exit.  

Setting Node Communication Defaults 

A number of variables can be set globally and applied to all new nodes added to 
Orion NCM. Of course, when adding nodes, you can override the defaults. 

To set default node configuration parameters: 

1. Open the Orion NCM application  in the SolarWinds program group 
(SolarWinds Orion Network Configuration Manager > Orion Network 
Configuration Manager). 

2. Click File > Settings. 

3. Navigate to and expand Global Macro Settings. 

4. Select one of the following tree options and specify the appropriate default 
vaules: 

 Login Information 

 Transfer Protocols 
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 Transfer Ports 

To override default settings for a particular node: 

1. Login to the Orion Web Console. 

2. Click Settings. 

3. Click Manage Nodes under Node & Group Management. 

4. Use the Group by list to organize the node list. 

5. Select the relevant node in the list. 

6. Click Edit Properties. 

7. Scroll down to NCM Properties. 

8. Edit the login and communication information.  

9. Click Submit. 

Configuring Event Logging 

Logging events associated with a specific function of Orion Network 
Configuration Manager allows you to keep a detailed record of events and helps 
you troubleshoot any anomalies you may encounter. 

A number of functional areas within Orion NCM provide verbose logging options, 
including the following: 

Database Updates 

Logs database events, including backup and connectivity events. 

Inventory Monitor 

Logs inventory events, including SNMP timeouts, SNMP community string 
error messages, and status changes. 

Realtime Config Change Detection 

Logs relatime configuration change detection events, including change 
events, notification success and failure messages, and device connectivity 
events. 
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Scheduled Jobs 

Logs scheduled job events, including time completed and individual item 
success or failure, for example, the failure to download an individual 
configuration file included in the job. 

Security 

Logs security events, including login failures, account modifications, and 
global security setting changes. 

To enable logging for Orion Network Configuration Manager events: 

1. Open the Orion NCM application  in the SolarWinds program group 
(SolarWinds Orion Network Configuration Manager > Orion Network 
Configuration Manager). 

2. Click File > Settings. 

3. Click Advanced > Logging. 

4. Check the Orion Network Configuration Manager events you wish to monitor, 
and then click OK. 

Note: Logs are stored in the Logging folder found in your installation 

directory. By default, the Logging folder can be found in \Program 

Files\SolarWinds\Configuration Management\Logging\. 

Moving Orion Network Configuration Manager 

The time necessary to move Orion Network Configuration Manager to a different 
computer depends on how long the database backup procedure takes. 
SolarWinds recommends scheduling an appropriate maintenance window to 
perform the migration procedure. 

Migration Requirements 

To move your Orion Network Configuration Manager installation to a new server, 
you will need the following items. 

 A computer meeting the minimum requirements for the new installation of 
Orion Network Configuration Manager.  

For more information on requirements, see “Requirements”. 

 User accounts with administrative rights on both servers. 
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 You will need to reset your license using the License Manager. For more 
information, see “Resetting Your License” on page 56. 

 A temporary storage area for custom scripts and reports.  This can be any 
storage device able to hold the information and accessible from each Orion 
Network Configuration Manager computer; for example, a network drive 
accessible by each computer, a memory stick, or an external hard drive. 

Migrating Orion Network Configuration Manager 

Complete the following procedure to move Orion Network Configuration 
Manager. 

To move Orion Network Configuration Manager to another computer: 

1. Log on with an administrator account to your current Orion Network 
Configuration Manager. 

2. Close Orion Network Configuration Manager and any other running 
applications. 

3. Open the Orion SQL Database Manager (SolarWinds Orion > Advanced 
Features > SQL Database Manager). 

4. If your SQL Server is not listed, add your server to the list. For more 
information, see “Adding a Server” on page 315. 

5. Click your Orion Network Configuration Manager database in the left pane of 
the Database Manager window, and then click Database > Backup 
Database. 

6. Type a description of the database backup and specify a path and filename 
for the backup file. Save your database backup to a temporary storage area. 
This can be a network drive accessible from each Orion Network 
Configuration Manager computer, a memory stick, or an external hard drive. 

Note: Ensure the target location for the database backup has sufficient 
available disk space. 

7. Click OK. 

8. Run License Manager to reset your current license, making it available for 
your new implementation. For more information, see “Using License 
Manager” on page 56. 

9. Log on to the new computer, and then install Orion Network Configuration 
Manager. For more information, see “Installing Orion Network Configuration 
Manager” on page 7. 

10. Click Start > All Programs > SolarWinds Orion Network Configuration 
Manager > Orion Network Configuration Manager. 

11. Click File > New/Open Database Wizard. 
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12. Review the Welcome window, and then click Next 

13. Click Open an Existing Database, and then click Next. 

14. If you are using a SQL database, complete the following procedure: 

a. Click SQL Server Database. 

b. Select the appropriate authentication method and, if necessary, provide 
your user login credentials. 

c. Select your SQL Server from the list. 

d. Select your database from the list, and then click OK. 

e. Click Finished. 

Resetting Your License 

You can easily install the SolarWinds License Manager, a free utility that gives 
you the ability to easily migrate Orion licenses from one computer to another 
without contacting SolarWinds Customer Service. 

Note: You must install License Manager on a computer with the correct time. If 
the time on the computer is off 5 minutes, in either direction, from Greenwich 
Mean Time, you will be unable to reset licenses. Time zone settings do not affect 
and do not cause this issue. 

Installing License Manager 

Install License Manager on the computer from which you are migrating currently 
licensed products. 

To install License Manager: 

1. Click Start > All Programs > SolarWinds > SolarWinds License Manager 
Setup. 

2. Click I Accept to accept the SolarWinds EULA. 

3. Click Install. After installation completes, the program launches. For more 
information about using License Manager, see “Using License Manager” on 
page 56. 

Using License Manager 

You must run License Manager on the computer where the currently licensed 
SolarWinds product is installed. 

To deactivate currently installed licenses: 

1. Click Start > All Programs > SolarWinds > SolarWinds License Manager. 

2. Check the products you want to deactivate on this computer. 
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3. Click Deactivate. 

4. Specify your SolarWinds Customer ID and password when prompted, and 
then click Deactivate. 

Note: Deactivated licenses are now available for activation on a new 
computer. 

When you have successfully deactivated your products, log on to the computer 
on which you want to install your products and begin the installation procedure. 
When asked to specify your licenses, provide the appropriate information. The 
license you deactivated earlier is assigned to the new installation. 

Migrating Jobs 

If you are running any scheduled jobs, you will need to copy them to the new 
computer. Complete the following procedure to move your scheduled jobs. 

To move jobs to new hardware: 

1. Log on to the old computer. 

2. Copy the files in the Jobs folder. By default, this folder is located at 

C:\Program Files\SolarWinds\Orion\NCM. 

3. Paste the files into the Jobs folder on the new server. By default, this folder is 

located at C:\Program Files\SolarWinds\Orion\NCM. 

4. Click Start > All Programs > Accessories > Windows Explorer. 

5. Browse to My Computer > Control Panel > Scheduled Tasks. 

6. Select all of your Orion Network Configuration Manager jobs, and then click 
Edit > Copy. 

7. Paste the job files into the Scheduled Tasks folder on the new server. By 

default, this folder is located at C:\Program Files\SolarWinds\Orion\NCM.  

Migrating Scripts 

If you have created any custom scripts, it will be necessary to copy them to the 
new computer. Complete the following procedure to move your scripts. 

To move scripts to new hardware: 

1. Log on to the old computer. 

2. Copy the files in the Scripts folder. By default, this folder is located at 

C:\Program Files\SolarWinds\Orion\NCM. 

3. Paste the files into the Scripts folder on the new server. By default, this 

folder is located at C:\Program Files\SolarWinds\Orion\NCM. 
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Migrating Reports 

If you have created any custom reports, it will be necessary to copy them to the 
new computer. Complete the following procedure to move your reports. 

To move reports to new hardware: 

1. Log on to the old computer. 

2. Copy the files in the Reports folder. By default, this folder is located at 

C:\Program Files\SolarWinds\Orion\NCM. 

3. Paste the files into the Reports folder on the new server. By default, this 

folder is located at C:\Program Files\SolarWinds\Orion\NCM. 

Migrating Device Command Templates 

If you have created any custom device command templates, it will be necessary 
to copy them to the new computer. Complete the following procedure to move 
your templates. 

To move device command templates to new hardware: 

1. Log on to the old computer. 

2. Copy the files in the DeviceTypes folder. By default, this folder is located at 

C:\Program Files\SolarWinds\Orion\NCM. 

3. Paste the files into the DeviceTypes folder on the new server. By default, this 

folder is located at C:\Program Files\SolarWinds\Orion\NCM. 
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Chapter 3 

Managing Nodes 

Orion Network Configuration Manager helps you manage, organize, and track 
changes to your network devices, including switches, routers, firewalls, and 
Windows servers. These devices are known collectively as nodes within Orion 
NCM. To begin managing your nodes, review the following sections: 

 Adding Nodes 

 Adding and Managing NCM Nodes  

 Automatically Adding Nodes to NCM During Discovery 

 Using the Network Sonar Discovery Results Wizard 

 Unmanaging and Remanaging Nodes 

 “Adding Custom Node Properties” 

Adding Nodes 

You can add nodes using the SolarWinds Network Sonar, add them individually, 
or import a list of nodes from a file. The following sections guide you through 
these methods: 

 Adding Nodes with the Network Sonar Discovery 

 Adding Individual Nodes 

 Adding and Managing NCM Nodes 

 Automatically Adding Nodes to NCM During Discovery 

Adding Nodes with the Network Sonar Discovery 

SolarWinds Network Sonar Discovery is a high performance network discovery 
engine that allows you to build a database of the structure and devices found in 
your TCP/IP network. 

In discovering nodes, the Network Discovery Sonar software primarily identifies 
network devices to manage within the Orion Core database. All nodes 
discovered must be managed in the Orion Core database.  

Importing discovered nodes into the database involves a related but distinct 
process. For more information on importing the results of your discovery, see 
“Using the Network Sonar Discovery Results Wizard”. 
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Notes:  

 By default, Network Discovery Sonar is setup to add discovered nodes to 
both the Orion Core and the Orion NCM databases. If you discover more 
nodes than your NCM license limit, and you import all of them, the software 
will import only as many nodes into the NCM database as you have licenses 
available; when the license limit is reached the NCM software will generate 
an error informing you that all nodes were not added. The result in this case 
is that some of the nodes managed in NCM may not be the nodes on which 
you want to perform NCM actions. 

 There are two ways to address this issue. You can simply take care to select 
nodes for importing into the databases only those nodes you want to manage 
in NCM. To do this follow the steps in “Using the Network Sonar Discovery 
Results Wizard”. 

As an alternative, you can turn off the option to import discovered nodes into 
both databases. Doing so would not To do that see the section 
“Automatically Adding Nodes to NCM During Discovery”. 

To discover nodes: 

1. Log on to Orion Web Console. 

2. Click Settings. 

3. Click Network Sonar Discovery under Getting Started with Orion. 

4. If you want to create a new discovery, click Add New Discovery, click 
Add New Discovery.  

5. If you have already defined a network discovery, a number of options are 
available on the Network Sonar Discovery tab. Select one of the following: 

 If you want to edit an existing discovery before using it, select the 
discovery you want to edit, and then click Edit. 

 If you want to use an existing discovery to rediscover your network, 
select the discovery you want to use, click Discover Now, and then 
complete the Network Sonar Results Wizard after discovery completes. 
For more information about network discovery results, see “Using the 
Network Sonar Discovery Results Wizard”. 
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 If you want to import some or all devices found in a defined 
discovery that you may not have already imported for monitoring, 
select a currently defined discovery, and then click Import All Results. 
For more information about network discovery results, see see “Using 
the Network Sonar Discovery Results Wizard”. 

 If you want to import any newly enabled devices matching a defined 
discovery profile, select a currently defined discovery, and then click 
Import New Results. For more information about network discovery 
results, see “Using the Network Sonar Discovery Results Wizard”. 

 If you want to delete an existing discovery profile, select a currently 
defined discovery and then click Delete. 

6. If the devices on your network do not require community strings other 

than the default strings public and private provided by Orion NCM, 

click Next on the SNMP Credentials view. 

7. If any of your network devices require community strings other than 

public and private or if you want to use an SNMPv3 credential, 

complete the following steps to add the required SNMP credential. 

Note: Repeat the following procedure for each new community string. To 
speed up discovery, highlight the most commonly used community strings on 
your network, and then use the arrows to move them to the top of the list.  

a. Click Add New Credential, and then select the SNMP Version of your 
new credential. 

b. If you are adding an SNMPv1 or SNMPv2c credential, provide the 
new SNMP Community String. 

c. If you are adding an SNMPv3 credential, provide the following 
information for the new credential: 

 User Name, Context, and Authentication Method 

 Authentication Password/Key, Privacy/Encryption Method and 
Password/Key, if required. 

d. Click Add. 

8. Click Next on the SNMP Credentials view. 
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9. If you want to add Windows credentials for WMI collections, click Add 
New Credential.: 

a. Choose a credential. 

b. Name the credential. 

c. Enter the relevant user name (with privileges to accomplish WMI polling). 

d. Enter and confirm the user account password.  

e. Click Add. 

10. If you want to discover devices located on your network within a 
specific range of IP addresses, complete the following procedure. 

Note: Only one selection method may be used per defined discovery.  

a. Click IP Ranges in the Selection Method menu, and then, for each IP 
range, provide both a Start address and an End address. 

Note: Scheduled discovery profiles should not use IP address ranges 
that include nodes with dynamically assigned IP addresses (DHCP). 

b. If you want to add another range, click Add More, and then repeat the 
previous step. 

Note: If you have multiple ranges, click X to delete an incorrect range. 

c. If you have added all the IP ranges you want to poll, click Next. 

11. If you want to discover devices connected to a specific router or on a 
specific subnet of your network, complete the following procedure: 

Note: Only one selection method may be used per defined discovery.  

a. Click Subnets in the Selection Method menu. 

b. If you want to discover on a specific subnet, click Add a New 
Subnet, provide both a Subnet Address and a Subnet Mask for the 
desired subnet, and then click Add. 

Note: Repeat this step for each additional subnet you want to poll. 

c. If you want to discover devices using a seed router, click Add a 
Seed Router, provide the IP address of the Router, and then click Add. 

Notes: 

 Repeat this step for each additional seed router you want to use. 

 Network Sonar reads the routing table of the designated router and 
offers to discover nodes on the Class A network (255.0.0.0 mask) 
containing the seed router and, if you are discovering devices for an 
Orion NPM installation, the Class C networks (255.255.255.0 mask) 
containing all interfaces on the seed router, using the SNMP version 
chosen previously on the SNMP Credentials page. 
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 Networks connected through the seed router are NOT automatically 
selected for discovery. 

d. Confirm that all networks on which you want to conduct your network 
discovery are checked, and then click Next. 

12. If you already know the IP addresses or hostnames of the devices you 
want to discover and include in the Orion database, complete the 
following procedure: 

a. Click Specific Nodes in the Selection Method menu. 

b. Type the IPv4 addresses or hostnames of the devices you want to 
discover for monitoring into the provided field. 

Note: Type only one IPv4 address or hostname per line. 

c. Click Validate to confirm that the provided IPv4 addresses and 
hostnames are assigned to SNMP-enabled devices. 

d. If you have provided all the IPv4 addresses and hostnames you 
want to discover, click Next. 

13. Configure the options on the Discovery Settings view, as detailed in the 
following steps. 

a. Provide a Name and Description to distinguish the current discovery 
profile from other profiles you may use to discover other network areas. 

Note: This Description displays next to the Name in the list of available 
network discovery configurations on the Network Sonar view. 

b. Position the slider or type a value, in ms, to set the SNMP Timeout. 

Note: If you are encountering numerous SNMP timeouts during Network 
Discovery, increase the value for this setting. The SNMP Timeout should 
be at least a little more than double the time it takes a packet to travel 
the longest route between devices on your network. 

c. Position the slider or type a value, in ms, to set the Search Timeout. 

Note: The Search Timeout is the amount of time Network Sonar 
Discovery waits to determine if a given IP address has a network device 
assigned to it. 

d. Position the slider or type a value to set the number of SNMP Retries. 

Note: This value is the number of times Network Sonar Discovery will 
retry a failed SNMP request, defined as any SNMP request that does not 
receive a response within the SNMP Timeout defined above. 
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e. Position the slider or type a value to set the Hop Count. 

Note: If the Hop Count is greater than zero, Network Sonar Discovery 
searches for devices connected to any discovered device. Each 
connection to a discovered device counts as a hop. 

f. Position the slider or type a value to set the Discovery Timeout. 

Note: The Discovery Timeout is the amount of time, in minutes, Network 
Sonar Discovery is allowed to complete a network discovery. If a 
discovery takes longer than the Discovery Timeout, the discovery is 
terminated. 

14. If you only want to use SNMP to discover devices on your network, 
check Use SNMP only. 

Note: By default, Network Sonar uses ICMP ping requests to locate devices. 

Most information about monitored network objects is obtained using SNMP 
queries. 

15. If multiple Orion polling engines are available in your environment, 
select the Polling Engine you want to use for this discovery. 

16. Click Next. 

17. If you want the discovery you are currently defining to run on a regular 
schedule, select either Custom or Daily as the discovery Frequency, as 
shown in the following steps: 

Notes: 

 Scheduled discovery profiles should not use IP address ranges that 
include nodes with dynamically assigned IP addresses (DHCP). 

 Default Discovery Scheduling settings execute a single discovery of your 
network that starts immediately, once you click Discover. 

 Results of scheduled discoveries are maintained on the Scheduled 
Discovery Results tab of Network Discovery. 

a. If you want to define a custom discovery schedule to perform the 
currently defined discovery repeatedly in the future, select Custom 
and then provide the period of time, in hours, between discoveries. 

b. If you want your scheduled discovery to run once daily, select Daily, 
and then provide the time at which you want your discovery to run every 
day, using the format HH:MM AM/PM. 

18. If you do not want to run your network discovery at this time, select No, 
don’t run now, and then click Save or Schedule, depending on whether you 
have configured the discovery to run once or on a schedule, respectively. 

19. If you want your Network Sonar discovery to run now, click Discover to 
start your network discovery. 
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Note: Because some devices may serve as both routers and switches, the 
total number of Nodes Discovered may be less than the sum of reported 
Routers Discovered plus reported Switches Discovered. 

Adding Individual Nodes 

 The following procedure details the steps required to add a device and its 
interfaces and volumes for monitoring in the Orion Web Console. 

To add a device for monitoring in the Orion Web Console: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Manage Nodes in the Node Management grouping of the Orion 
Website Administration page. 

4. Click Add Node on the Node Management toolbar. 

5. Provide the hostname or IP Address of the node you want to add in the 
Hostname or IP Address field. 

6. If you only want to use ICMP to monitor node status, response time, or 
packet loss for the added node, check Status Only (ICMP). 

7. If you want to add an External node to monitor a hosted application 
with Orion products (for example, Orion APM), check External. 

Note: Orion NCM does not collect or monitor any network performance data 
from nodes designated as External. The External status is reserved for 
nodes hosting application that you want to monitor with Orion Application 
Performance Monitor. 

8. If you want to use SNMP to monitor the added node, confirm that ICMP 
(Ping only) is cleared, and then complete the following steps: 

a. Select the SNMP Version for the added node. 

Notes: 

 Orion NPM uses SNMPv2c by default. If the device you are adding 
supports or requires the enhanced security features of SNMPv3, 
select SNMPv3. 

 If SNMPv2c is enabled on a device you want Orion NCM to monitor, 
by default, Orion NCM will attempt to use SNMPv2c to poll for 
performance information. If you only want Orion NCM to poll using 
SNMPv1, you must disable SNMPv2c on the device to be polled. 

b. If the SNMP port on the added node is not the Orion product default 
of 161, provide the actual port number in the SNMP Port field. 
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c. If the added node supports 64 bit counters and you want to use 
them, check Allow 64 bit counters. 

Note: Orion products support the use of 64-bit counters; however, these 
high capacity counters can exhibit erratic behavior depending on 
manufacturer implementation. If you notice peculiar results when using 
these counters, use the Node Details view to disable the use of 64-bit 
counters for the device and contact the hardware manufacturer. 

9. If you want Orion products to use SNMPv2c to monitor the added node, 
provide valid community strings for the added node. 

Note: The Read/Write Community String is optional, but Orion products 

require the public Community String, at minimum, for node monitoring. 

10. If you want Orion products to use SNMPv3 to monitor the added node, 
provide the following SNMP Credentials, Authentication, and 
Privacy/Encryption settings: 

 SNMPv3 Username and Context 

 SNMPv3 Authentication Method and Password/Key 

 SNMPv3 Privacy/Encryption Method and Password/Key 

11. If you are using SNMP to communicate with your added node, click 
Validate SNMP after entering all credentials to confirm your SNMP settings. 

12. Click Next. 

13. Check the interfaces, volumes, and interface charts for the added node that 
you want Orion to monitor. The following options are available in the 
selection toolbar: 

 Clicking All selects all listed devices and charts for monitoring. 

 Clicking None clears any checked interfaces, volumes, or interface 
charts that have been selected for monitoring. 

 Clicking All Active Interfaces selects only currently active interfaces 
and the associated interface charts for monitoring. 

 Clicking All Volumes selects all listed volumes for monitoring. 

 Clicking All Interfaces selects all listed interfaces for monitoring. 

14. After you have selected interfaces, volumes, or interface charts for 
monitoring, click Next. 
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15. If you want to edit the default polling settings for your added node, 
change the Node Status Polling or Collect Statistics Every values in the 
Polling area of the Change Properties page, as appropriate. 

Note: The Node Status Polling value refers to the number of seconds, 
between the node status checks Orion products perform on the added node. 
The Collect Statistics Every value refers to the period of time between the 
updates Orion products make to displayed statistics for the added node. 

16. If you have defined any custom properties for monitored nodes, provide 
appropriate values for the added node in the Custom Properties area of the 
Change Properties page. 

Note: The Custom Properties area is empty if you have not defined any 
custom properties for monitored nodes.. 

17. Click Add Node to NCM to manage the node as part of NCM. 

18. Click OK, Add Node when you have completed properties configuration. 

19. If you have successfully added the node, click OK on the dialog. 

Adding and Managing NCM Nodes 

All Orion NCM nodes must also be managed in the Orion Core database, which 
all Orion products share. Use these procedures to add, edit, or remove Orion 
nodes to the NCM node list.  

Note: If you remove a node from NCM all data associated  with the node 
(configs, inventory data, etc.) is also removed. 

To find a specific node and its NCM status: 

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and click NCM Settings.  

3. Click Add or Manage Nodes in the NCM Node Management section. 

4. To find a specific node, enter an IP or hostname in the Search window and 
click Search. 

Consult the Licensed by NCM column to review the status of a given node. 

To add a node or nodes to NCM: 

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and click NCM Settings.  

3. Click Add or Manage Nodes in the NCM Node Management section. 

4. As needed, to find a specific node, enter an IP or hostname in the Search 
window and click Search. 
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Consult the Licensed by NCM column to review the status of a given node. 

5. As needed, use the Group by control to organize the list of Orion nodes. 

Consult the Licensed by NCM column to review the status of a given node. 

6. Click the Name(s) of the node(s) you want to license in NCM and then click 
Add  Nodes to NCM. 

To edit a node or nodes from NCM: 

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and click NCM Settings.  

3. Click Add or Manage Nodes in the NCM Node Management section. 

4. As needed, to find a specific node, enter an IP or hostname in the Search 
window and click Search. 

Consult the Licensed by NCM column to review the status of a given node. 

5. As needed, use the Group by control to organize the list of Orion nodes. 

Consult the Licensed by NCM column to review the status of a given node. 

6. As needed, to locate a specific node,  

7. Click the Name(s) of the node(s) you want to delete from NCM and then click 
Remove  Nodes to NCM. 

To remove a node or nodes from NCM: 

Note: If you remove a node from NCM all data associated  with the node 
(configs, inventory data, etc.) is also removed. 

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and click NCM Settings.  

3. Click Add or Manage Nodes in the NCM Node Management section. 

4. As needed, to find a specific node, enter an IP or hostname in the Search 
window and click Search. 

Consult the Licensed by NCM column to review the status of a given node. 

5. As needed, use the Group by control to organize the list of Orion nodes. 

Consult the Licensed by NCM column to review the status of a given node. 

6. Click the Name(s) of the node(s) you want to delete from NCM and then click 
Remove  Nodes to NCM. 
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Automatically Adding Nodes to NCM During Discovery 

By default, Network Discovery Sonar is setup to add discovered nodes to both 
the Orion Core and the Orion NCM databases. However, there is a setting that 
enables and disables this feature. 

To turn on Enable Import from Discovery: 

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and click NCM Settings.  

3. Click Add or Manage Nodes in the NCM Node Management section. 

4. Check Enable Import from Discovery in the right corner of the table. 

To turn off Enable Import from Discovery: 

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and click NCM Settings.  

3. Click Add or Manage Nodes in the NCM Node Management section. 

4. Uncheck Enable Import from Discovery in the right corner of the table. 

Using the Network Sonar Discovery Results Wizard  

The Network Sonar Results Wizard directs you through the selection of network 
devices for monitoring, and it opens whenever discovery results are requested, 
either when the Network Sonar Discovery Wizard completes or when either 
Import All Results or Import New Results is clicked for a selected discovery. 

The following steps detail the selection of discovered objects for monitoring in 
Orion NCM. 

To select the results of a network discovery for monitoring in Orion NCM: 

1. On the Device Types to Import page, check the device types you want Orion 
NCM to monitor, and then click Next. 

Note: If you are not sure you want to monitor a specific device type, check 
the device type in question. If, later, you do not want to monitor a selected 
device, simply delete the device using Web Node Management. 

2. Check the interface types you want Orion NCM to monitor on the Interface 
Types to Import page, and then click Next. 

Note: If you are not sure you want to monitor a specific interface type, check 
the interface type in question. If, later, you do not want to monitor a selected 
interface, delete it using Web Node Management. 
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3. On the Volume Types to Import page, check the volume types you want 
Orion NCM to monitor, and then click Next. 

Note: If you are not sure you want to monitor a specific volume type, check 
the volume type in question. If, later, you do not want to monitor any volume 
of the selected type, delete the volume using Web Node Management. 

4. Check valid states for imported interfaces and then click Next. 

Note: By default, Orion NCM imports interfaces that are discovered in an 
Operationally Up state. However, because interfaces may cycle off and on 
intermittently, the Import Settings page allows you to select interfaces found 
in Operationally Down or Shutdown states for import, as well. 

5. If there are any devices on the Import Preview that you do not ever want 
to import, check the device to ignore, and then click Ignore. Selected nodes 
are added to the Discovery Ignore List. 

6. Confirm that the network objects you want to monitor are checked on the 
Import Preview page, and then click Import. 

7. After the import completes, click Finish. 

Note: Imported devices display in the All Nodes resource. 

Unmanaging and Remanaging Nodes 

When you need to perform maintenance on nodes, such as upgrading firmware, 
installing new hardware, or updating security, you may want Orion Network 
Configuration Manager to discontinue downloading configurations and reporting 
information about the nodes while the devices are down. Unmanaging nodes 
while node maintenance is being performed helps maintain the accuracy of your 
data and prevents unnecessary and inaccurate reports. 

Another reason to unmanage a node is if you want to keep configuration files for 
a decommissioned device. Configuration data for unmanaged nodes will remain 
in the Orion Network Configuration Manager database. 

To unmanage nodes: 

1. Log on to the Orion Web Console with an administrator account. 

2. Click Manage Nodes on the All Nodes resource.  

3. Select the nodes you want to unmanage in the nodes list, and then click 
Unmanage. 
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When nodes are unmanaged, Orion Network Configuration Manager will not 
perform actions on the nodes such as downloading configuration files, running 
scheduled jobs on the nodes, including the unmanaged nodes in reports. 

To remanage nodes: 

1. Log on to the Orion Web Console with an administrator account. 

2. Click Manage Nodes on the All Nodes resource.  

3. Select the nodes you want to unmanage in the nodes list, and then click 
Remanage. 

Viewing Node Interface Details 

You can view the following interface details about a node: 

 Interface / Port Status 

 Interface Traffic 

 Interface / Port Configuration 

 Time data was last transmitted / received 

 Cisco Discovery Protocol (CDP) 

 Orion NCM user activity 

 Realtime ARP cache 

Complete the following procedure to view interface details. 

To view the interface details of a specific node: 

1. Click the Interfaces tab.  

2. Select a category from the Interface Details list, and then click Refresh to 
view the selected statistics. 

3. Check Auto Refresh to update statistics every 30 seconds. 

4. To change the Auto Refresh time interval: 

a. Click File > Settings. 

b. Click Interfaces under Node Details. 

c. Adjust the slider to the appropriate interval. 

d. Click OK to save the changes. 
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Adding Custom Node Properties 

Orion Network Configuration Manager allows you to add custom properties to 
each node. You can define and store custom fields in the Orion Network 
Configuration Manager database. For example, you can define fields for country, 
physical location, asset tag, and serial number. 

Orion Network Configuration Manager provides a collection of the most 
commonly used properties. New custom properties can also be defined. For 
information on creating a custom property see “Creating Custom Properties”. 

After creating a custom property, you can edit the property by editing node 
details. For information on editing a custom property see “Editing Custom 
Properties” 

To add a custom property: 

1. Open the SolarWinds Customer Property Editor (SolarWinds Orion > 
Grouping and Access Control ) 

2. Click File > Settings. 

3. Click Custom Properties in the left pane. 

4. Select a property from the list or type a new property in the right pane. 

5. Click Add New Property. 

Searching for Network Addresses 

Orion Network Configuration Manager provides the ability to search the entire 
database (nodes, configuration files, and inventory) for specific network 
addresses. 

Finding IP Addresses 

It can be important to find an IP address in Orion Network Configuration 
Manager. For example, you may need to search all of your nodes to see if a 
node to which you need to make changes is managed by Orion Network 
Configuration Manager.  

To find an IP address: 

1. Click Edit > Find IP Address. 

2. To ensure that the most complete results are available, click Update 
Inventory at the bottom of the Find Address tab to rescan all nodes in the 
database for any updated information. For more information on performing 
inventory scans, see “Managing Inventory” on page 195. 
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3. Type the address pattern you want to find in the IP Address Pattern field. 

4. Click Find. 

Finding MAC Addresses 

It can be necessary to find an MAC address in Orion Network Configuration 
Manager. For example, you may need to search all of your configuration files to 
see if a MAC address is included in any black lists.  

To find a MAC address: 

1. Click Edit > Find MAC Address. 

2. To ensure that the most complete results are available, click Update 
Inventory at the bottom of the Find Address tab to rescan all nodes in the 
database for any updated information. For more information on performing 
inventory scans, see “Managing Inventory” on page 195. 

3. Type the address pattern you want to find in the MAC Address Pattern field. 

4. Click Find. 

Finding Hostnames 

It can be vital to find a hostname in Orion Network Configuration Manager. For 
example, you may need to search all of your configuration files to see if a 
hostname is included in all of your allow lists. 

To find a hostname: 

1. Click Edit > Find IP 

2. To ensure that the most complete results are available, click Update 
Inventory at the bottom of the Find Address tab to rescan all nodes in the 
database for any updated information. For more information on performing 
inventory scans, see “Managing Inventory” on page 195. 

3. Select Hostname from the Type of Address list. 

4. Type a fully qualified hostname in the Hostname field. 

5. Click Find. 

Understanding How Addresses are Found 

During node inventory, the following tables are populated in the Orion NCM 
database: 

Nodes Table 

Stores a list of all nodes managed by Orion NCM, along with the declared 
node properties. 
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IpAddresses Table 

Stores a list of IP addresses mapped to interface and node IDs. 

Interfaces Table 

Stores a list of interfaces, interface indices, interface types, and interface 
descriptions mapped to node IDs. 

BridgePorts Table 

Stores a list of bridge ports, spanning tree status, spanning tree state, VLAN 
type, and VLAN ID mapped to node IDs. 

MACForwarding Table 

Stores a list of MAC addresses, ports, and how the address was discovered 
mapped to node IDs 

ARPTables 

Stores a list of data returned from ARP tables and mapped back to node IDs. 
This information includes interface index, interface ID, MAC address, IP 
address, and whether the IP address is static or dynamic. 

When you search for an IP address, a hostname, or a MAC address, Orion NCM 
searches these tables for the value and returns all matches. 
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The following screen capture illustrates a typical search result. 

 

Where appropriate, returned values include a ranking which reflects how often a 
MAC address appears in the ARP table for a given port.  

Notes:  

 If you are searching for a MAC address that is part of a VLAN, the returned 
results may incorrectly display a rank of 0 for the address. 

 If you are only managing switches with Orion NCM, IP addresses will not be 
returned by the search. 
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Find Connected Port for a Host (Orion NPM 
Integration) 

 An Orion NCM integration with Orion NPM allows you to search for currently 
connected ports on wired or wireless end hosts.  

The information returned is based on the data available in the Orion database as 
of the last scheduled discovery of network nodes, which is specified at the top of 
the table in which search results are presented, in this form:  

As of last discovery [MM/DD/YYYY] [HH:MM:SS] [AM/PM] . 

You can search for connected ports by these node properties: 

 IP Address 

 DNS Hostname 

 MAC Address 

 Port Description 

To search for connected ports: 

1. Login to the Orion Web Console with administrator privileges. 

Note: If you do not have administrator privileges you may not be able to see 
some results. 

2. Click Configs. 

3. Locate the Find Connected Port for End Host resource. 

4. Select the Search By filter and enter an appropriate value in Find. 

5. Use the Edit button to adjust the columns of data to include in your search 
results.  

6. Click Find. 

Results are presented as rows in a table (one for each connection within the 
reach of hop of the context node) with default columns listed below. 
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Column Description 

  

(For Wired Devices)  

  

Node Vendor and model of context node 

IP Address Of the context node 

MAC Address Of the context node 

Connected Via Interface On the context node 

To This Interface On a connection point 

On This Node Vendor and model of device supporting the 
connection point 

IP Address Of a connection point 

MAC Address Of a connection point 

  

(For Wireless Devices)  

  

Mapped Host Name Vendor and model of context node 

Mapped MAC Address Of context node 

Mapped Device Type Of context node 

Source Interface Of the wireless access point 

Controller Source IP Address Of the wireless access point 

Controller Description Of the wireless access point 

Controller Host Name Source SSID Of the wireless access point 

Source Channel Of the wireless access point 

Source Interface Alias Of the wireless access point 

Source Radio Type Of the wireless access point 

Source Host Name Of the wireless access point 

Source Device Type Of the wireless access point 

Source IP Address Of the wireless access point 

  

 

  



 

 
78  Managing Nodes 

Chapter 4 

Managing Web Accounts 

Orion Web Console user accounts, permissions, and views are established and 
maintained with the the Manage Accounts option. Use the following sections of 
this chapter to work with Orion accounts. 

 Creating a New Account 

 Editing an Orion User Account 

 Creating Account Limitations 

Notes: To prevent issues with web console accounts, your SQL Server should 

not be configured with the no count connection option enabled. The no count 

option is set in the Default connection options area of the Server Properties > 
Connections window of SQL Server Management Studio 

Creating a New Account 

New Orion Web Console user accounts may be created by any web console 
administrator. The following procedure creates a new web console user account. 

To create a new user account: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Manage Accounts in the Accounts grouping of the Orion Website 
Administration page. 

4. Click Add New Account. 

5. Select the type of account you want to add, and then click Next. 

6. If you selected Windows individual account, complete the following steps: 

a. Provide the User Name and Password for a user that has administrative 
access to your Active Directory or local domain. 

b. In the Search for Account area, enter the User name of the Active 
Directory or local domain user for whom you want to create a new web 
console account, and then click Search. 

c. In the Add Users area, select the users for whom you want to create new 
web console accounts, and then click Next. 

7. If you selected Windows group account, complete the following steps: 
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a. Provide the User Name and Password for a user that has administrative 
access to your Active Directory or local domain. 

b. In the Search for Account area, enter the Group name of the Active 
Directory or local domain group for which you want to create a new web 
console account, and then click Search. 

c. In the Add Users area, select the users for whom you want to create new 
web console accounts, and then click Next. 

8. If you selected Orion individual account, complete the following steps: 

a. Provide a User Name and a Password for the Orion individual account. 

b. Confirm the password, and then click Next. 

c. Define user settings and privileges, as appropriate. For more information, 
see “Editing an Orion User Account” on page 79. 

By default a new Orion account is created with the WebUploader role. To 
adjust the NCM role for an account, expand Network Configuration 
Manager Settings and select the appropriate role for the account you are 
creating.  

Select None if you do not want this account to access NCM.  

9. Click Submit to create the account. 

Note: Accounts are enabled by default, and disabling an account does not 
delete it. Account definitions and details are stored in the Orion database in 
the event that the account is enabled at a later time. 

Note: For more information about using Windows Pass-through security, Active 
Directory, and DirectLink accounts for automatic login to the Orion Web Console, 
see “Configuring Automatic Login”. 

Editing an Orion User Account 

The Edit User Account page provides options for configuring web console user 
accounts. On the Edit User Account page, administrators can disable an account, 
set an account expiration date, grant administrator and node management rights, 
set user view limitations, define a default menu bar, and set several other 
defaults defining how a user account views and uses the Orion Web Console.  

The following sections and procedures detail the configuration of user accounts. 

Note: To reset a password, click Change Password at the bottom of the page. 

 Setting User Account Access 

 Setting Account Limitations 

 Creating Account Limitations 
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 Setting Default Account Menu Bars and Views 

 Configuring Audible Web Alerts 

Setting User Account Access 

The following procedure is a guide to setting Orion user account access. 

By default, Orion accounts are given the NCM role ‘WebUploader,’ which 
enables the account user to make changes to device configurations and submit 
them for approval.  

Select None if you do not want this account to access NCM. If you select None 
as the NCM role, and this account might be used for node discovery, you should 
uncheck "Enable Import from Discovery" (in Settings > NCM Settings > Manage 
Nodes) to prevent this and similar account users from adding licensed nodes to 
NCM. 

To edit an Orion user account: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Manage Accounts in the Accounts grouping of the Orion Website 
Administration page. 

4. Select the account that you want to edit, and then click Edit. 

5. Set Account Enabled to Yes or No, as appropriate. 

Note: Accounts are enabled by default, and disabling an account does not 
delete it. Account definitions and details are stored in the Orion database in 
the event that the account is enabled at a later time. 

6. If you want the account to expire on a certain date, click Browse (…) 
next to the Account Expires field, and then select the account expiration 
date using the calendar tool. 

Note: By default, accounts are set to Never expire. Dates may be entered in 
any format, and they will conform to the local settings on your computer. 

7. If you want to allow the user to remain logged-in indefinitely, select Yes 
for the Disable Session Timeout option. 

Note: By default, for added security, new user accounts are configured to 
timeout automatically. 
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8. If you want to grant administrator rights to the selected account, set 
Allow Administrator Rights to Yes. 

Notes: 

 Granting administrator rights does not also assign the Admin menu bar 
to a user. If the user requires access to Admin options, they must be 
assigned the Admin view. For more information, see “Setting Default 
Account Menu Bars and Views”. 

 Administrator rights are not granted by default, but they are required to 
create, delete, and edit accounts. User accounts without administrator 
rights cannot access Admin page information. 

9. If you want to allow the user to manage nodes directly from the Orion 
Web Console, set Allow Node Management Rights to Yes. 

Note: By default, node management rights are not granted. For more 
information about node management in the Orion Web Console, see 
“Managing Devices in the Web Console”. 

10. If you want to allow the user to customize views, set Allow Account to 
Customize Views to Yes. 

Note: By default, customized view creation is not allowed. Changes made to 
a view are seen by all other users that have been assigned the same view. 

11. Designate whether or not to Allow Account to Clear Events and 
Acknowledge Alerts. 

12. Select whether or not to Allow Browser Integration. 

Note: Browser integration can provide additional functionality, including 
access to right-click menu options, depending on client browser capabilities. 

13. If you want to enable audible alerts through the client browser, select a 
sound from the Alert Sound list. 

Note: By default, sounds are stored in the Sounds directory, located at 

C:\Inetpub\SolarWinds\NetPerfMon\Sounds. Sounds in .wav format that 
are added to this directory become available as soon as the Edit User 
Account page refreshes. 

14. Provide the maximum Number of items in the breadcrumb list. 

Note: If this value is set to 0, all available items are shown in breadcrumb 

dropdown lists. 

15. Set account limitatins as needed under Account Limitations. 

For details see “Setting Account Limitations”. 

16. Set menu bars and views (Default Menu Bars and Views) as you want them 
displayed by default in the Orion Web Console. 
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If you are setting up the menu bars and views for a user account with NCM 
role None, and your intention is to hide all NCM-related features and 
functions, select None for all view settings. If you do not set them to None, 
and you select None as the NCM role for the account, the user will still see a 
CONFIGS tab and all the NCM views. 

For details see “Setting Default Account Menu Bars and Views”. 

17. Set an NCM role for the account under Network Configuration Manager 
Settings. 

By default, Orion administrator accounts are given the NCM administrator 
role. All other Orion accounts are given the NCM role ‘WebUploader,’ which 
enables the account user to make changes to device configurations and 
submit them for approval.  

Select None if you do not want this account to access NCM. If you select 
None as the NCM role, and this account might be used for node discovery, 
you should uncheck "Enable Import from Discovery" (in Settings > NCM 
Settings > Manage Nodes) to prevent this and similar account users from 
adding licensed nodes to NCM. 

A user with the NCM role None cannot access the Orion Network 
Configuration Manager application and will not see any NCM resources in 
non-NCM views and tabs on the Orion Web Console. For example, such a 
user sees no Pending Approval List on the Summary view under HOME.  

Though this user would be able to complete the process of adding NCM 
resources through Customize Page, the resources do not display when the 
target view loads.  And though this user may have privileges to add nodes 
into Orion, the user cannot add nodes to NCM (the “Add Node to NCM” 
option does not appear); and NCM properties are hidden when the user edits 
any selected Orion node.  

If an account user with NCM role None sets up an NCM Alert Action the 
software displays an error in alert details.  

If you are setting up the menu bars and views for a user account with NCM 
role None, and your intention is to hide all NCM-related features and 
functions, select None for all NCM view settings (Settings > Manage 
Accounts > Edit [User] Account) . If you do not set them to None, and you 
select None as the NCM role for the account, the user will still see a 
CONFIGS tab and all the NCM views. 

18. Use the settings under General Orion Settings to define how you want 
information to be displayed when a specific node, volume, or group is 
viewed. 

19. Click Submit when you are finished adjusting account settings. 
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Setting Account Limitations 

Account limitations may be used to restrict user access to designated network 
areas or to withhold certain types of information from designated users. The 
following procedure sets user account limitations. 

To set user account limitations: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console, and then click Manage 
Accounts in the Accounts group of the Orion Website Administration page. 

3. If you want to limit an individual user account, complete the following 
steps: 

a. On the Individual Accounts tab, check the account you want to limit. 

b. Click Edit. 

c. Click Add Limitation in the Account Limitations section. 

d. Select the type of limitation to apply, and then click Continue. 

Notes: 

 Because Orion NCM initially caches account limitations, it may take 
up to a minute for account limitations related to NCM to take effect in 
the web console and application. 

 Account limitations defined using the Account Limitation Builder 
display as options on the Select Limitation page. Account limitations 
can be defined and set using almost any custom properties. For 
more information, see “Creating Account Limitations”. 

e. Define the limitation as directed on the Configure Limitation page that 
follows. For more information about defining pattern-type limitations, refer to 
“Defining Pattern Limitations”. 

4. If you want to limit an group account, complete the following steps: 

Note: Limitations applied to a selected group account only apply to the group 
account and not, by extension, to the accounts of members of the group.  

a. On the Groups tab, check the group account you want to limit. 

b. Click Edit. 

c. Click Add Limitation in the Account Limitations section. 

d. Select the type of limitation to apply, and then click Continue. 

Notes: 
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 Because Orion NCM initially caches account limitations, it may take 
up to a minute for account limitations related to NCM to take effect in 
the web console and application. 

 Account limitations defined using the Account Limitation Builder 
display as options on the Select Limitation page. Account limitations 
can be defined and set using almost any custom properties. For 
more information, see “Creating Account Limitations”. 

e. Define the limitation as directed on the Configure Limitation page that 
follows. For more information about defining pattern-type limitations, refer to 
“Defining Pattern Limitations”. 

5. Click Add Limitation in the Account Limitations section. 

6. Select the type of limitation to apply from the list, and then click Continue. 

Notes: 

 Account limitations defined using the Account Limitation Builder display 
as options on the Select Limitation page. Account limitations can be 
defined and set using almost any custom properties. For more 
information, see “Creating Account Limitations”. 

Because Orion NCM initially caches account limitations, it may take up to 
a minute for account limitations related to NCM to take effect in the web 
console and application. 

7. Define the limitation as directed on the Configure Limitation page that 
follows. For more information about defining pattern-type limitations, refer to 
“Defining Pattern Limitations”. 

Creating Account Limitations 

The Account Limitation Builder application allows you to create and customize 
account limitations for the Orion Web Console. These limitations ensure that 
users of the web console can only view the network objects that are pertinent to 
their job duties. The following are but a few examples of the uses of account 
limitation in the Orion Web Console: 
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 Limit customer views to specific network nodes 

 Limit views by department or functional area 

 Limit views by device type or device role 

 Limit views based on the geographic location of devices 

Orion NCM provides predefined account limitations that use built-in Orion NCM 
property to limit user access. For greater flexibility, however, you can use the 
Account Limitation Builder to create your own account limitations based on 
predefined or custom properties. For more information about enabling account 
limitations in the Orion Web Console, see “Setting Account Limitations”. For more 
information about custom properties, see “Creating Custom Properties”. 

Using the Account Limitation Builder 

Before you can use the Account Limitation Builder, you must have first created 
the custom property that you want to use to limit the Orion Web Console view. 
For more information, see “Creating Custom Properties”. After you have defined 
custom properties and populated them with data, you may use the Account 
Limitations Builder as directed in the following procedure. 

Creating an Account Limitation 

The following steps create an account limitation. 

To create an account limitation: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Account Limitation Builder. 

2. Click Start on the splash screen. 

3. Click Edit > Add Limitation. 

4. Select a Custom Property.  

Notes: 

 If Custom Property is empty, you need to define a custom property. For 
more information, see “Creating Custom Properties”. 

 The remaining boxes are populated automatically, based upon your 
selection. 

5. Choose a Selection Method.  

Note: This is the selection format that will appear when you are choosing 
values for the account limitation through the web Account Manager. For more 
information, see “Setting Account Limitations”. 

6. If you want to include your own description of your account limitation, type 
your description over the default text provided in the Description field. 
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7. Click OK.  

Your newly defined account limitation is added to the top of the table view. You 
may now use the new limitation in the Orion Web Console Account Manager. For 
more information, see “Setting Account Limitations”. 

Deleting an Account Limitation 

The following steps delete an account limitation using the Account Limitation 
Builder utility. 

To delete an account limitation: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Account Limitation Builder. 

2. Click Start on the splash screen. 

3. Click the row of the limitation that you want to delete. 

Note: Use Shift+click to highlight multiple consecutive rows or 

Ctrl+Click to highlight multiple non-consecutive rows. 

4. Click Edit > Delete Selected Limitations.  

Note: Although Orion deletes the selected limitations from the table, ensuring 
that they will no longer be available through the web Account Manager, if you 
delete a limitation using the Account Limitation Builder, all accounts that have 
been assigned that limitation will remain limited. Deleting a limitation simply 
makes it unavailable for future use in the Orion Web Console. 

Defining Pattern Limitations 

Pattern limitations may be defined using OR, AND, EXCEPT, and NOT operators with 

_ and * as wildcard characters. The following examples show how to use 

available operators and wildcard characters: 

Note: Patterns are not case sensitive. 
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 foo matches only objects named "foo". 

 foo_ matches all objects with names consisting of the string "foo" followed by 

only one additional character, like foot or food, but not seafood or 

football. 

 foo* matches all objects with names starting with the string "foo", like 

football or food, but not seafood. 

 *foo* matches all objects with names containing the string "foo", like 

seafood or Bigfoot. 

 *foo* OR *soc* matches all objects containing either the string "foo" or the 

string "soc", including football, socks, soccer, and food. 

 *foo* AND *ball* matches all objects containing both the string "foo" and 

the string "ball", including football but excluding food. 

 *foo* NOT *ball* matches all objects containing the string "foo" that do not 

also contain the string "ball", including food but excluding football. 

 *foo* EXCEPT *ball* matches all objects containing the string "foo" that do 

not also contain the string "ball", including food but excluding football. 

You may also group operators using parentheses, as in the following example. 

(*foo* EXCEPT *b*) AND (*all* OR *sea*) matches seafood and 

footfall, but not football or Bigfoot. 

Setting Default Account Menu Bars and Views 

The Default Menu Bar and Views section provides several options for configuring 
the default menu bar and views for your user account. The following procedure is 
a guide to setting these options. 

To set default menu bar and view options: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console, and then click Manage 
Accounts in the Accounts grouping of the Orion Website Administration 
page. 

3. Select the account that you want to configure, and then click Edit. 

4. Scroll down to Default Menu Bar and Views. 

5. Select a Home Tab Menu Bar from the available list. 

Note: This is the default menu bar displayed when you click Home in the 
Orion Web Console. If you are editing a user account that must have 
administrator privileges, set the Home Tab Menu Bar to Admin. 
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6. Select a Network Tab Menu Bar from the available list. 

Note: This is the default menu bar displayed when you click Network in the 
Orion Web Console. If you are editing a user account that must have 
administrator privileges, select Admin. 

7. Select a Virtualization Tab Menu Bar from the available list. 

Note: This is the default menu bar displayed when you click Virtualization in 
the Orion Web Console. If you are editing a user account that must have 
administrator privileges, select Admin. 

8. If you have installed any additional Orion modules, select an Orion Module 
Tab Menu Bar from each available list. 

Note: This step configures the default menu bar displayed when you click the 
tab corresponding to an installed module in the Orion Web Console. If you 
are editing an account that must have administrator privileges, select Admin. 

9. Select a Home Page View. 

Note: If no Home Page View is specified, the default is designated to be the 
same as the page that is specified in the Default Summary View field below. 

10. If the Home Page View you have selected refers to a specific network 
device, select a Default Network Device by clicking Edit and selecting from 
the list of available devices on the next page. 

Note: If the Home Page View you have selected does not require a specific 
network device, Orion will select a device to display, automatically. 

11. Select a Default Summary View for the account. 

Note: This is typically the same as the Home Page View. 

12. If you want all reports to be available for the account, select \Reports 
from the Report folder list in the Default Menu Bars and Views area. 

Note: If you are creating a new user, you must designate the Report Folder 
the new account is to use to access Orion reports. By default, no report 
folder is configured for new users.The Reports directory is located in the 
Orion NCM installation directory: C:\Program Files\SolarWinds\Orion\. 

13. If you want to designate default Node, Volume, and Group Details Views 
for this account, expand Orion General Settings, and then select 
appropriate Node Detail, Volume Detail, and Group Detail Views.  

14. If you want to designate default Virtualization Summary Manager, 
Cluster Details, and Datacenter Details Views for this account, expand 
Integrated Virtual Infrastructure Monitor Settings, and then select 
appropriate default views.  

15. Click Submit. 
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Configuring Audible Web Alerts 

When browsing the Orion Web Console, audible alerts can be sounded 
whenever new alerts are generated. When enabled, you will receive an audible 
alert the first time, after login, that an alert is displayed on the page. This alert 
may come from either an alert resource or the Alerts view. You will not receive 
audible alerts if the Alerts view or the alert resource you are viewing is empty. 

Following the initial alert sound, you will receive an audible alert every time an 
alert is encountered that was triggered later than the latest alert that has already 
been viewed. 

For example, a user logs in and sees a group of alerts with trigger times ranging 
from 9:01AM to 9:25AM, and the user receives an audible alert. If the user 
browses to a new page or allows the current page to auto-refresh, a new alert 
sounds if and only if an alert triggered later than 9:25AM is then displayed. 

To enable audible web alerts: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Manage Accounts in the Accounts grouping of the Orion Website 
Administration page. 

4. Select the account you want to configure. 

5. Click Edit. 

6. Select the sound file you want to play when new alerts arrive from the Alert 
Sound list. 

Note: By default, sounds are stored in the Sounds directory, located at 

C:\Inetpub\SolarWinds\NetPerfMon\Sounds. Sounds in .wav format that 

are added to this directory become available as soon as the Edit User 
Account page refreshes. 

7. Click Submit. 
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Chapter 5 

Managing Configuration Files 

Configuration files can be downloaded, edited, compared, and uploaded using 
Orion Network Configuration Manager. The following procedures guide you 
through various tasks that simplify configuration file management. 

Note: The Config Transfers setting (File > Settings > Configs) limits the number 
of lines required for a config file to be recognized as valid for download. The 
default setting is 11 lines. In the case of a multi-node upload/download operation, 
keep in mind that the Simultaneous Downloads/Uploads setting can be used as a 
throttle; by default it’s set to run 10 Sessions simultaneously. 

Downloading Configuration Files 

You can download configuration files to view the current configuration of your 
device, compare the current to a previous configuration, or just to archive 
configuration files for backup purposes. Orion Network Configuration Manager 
can transfer files using both direct and indirect transfers. Complete the following 
procedure to download configuration files from your devices. 

Notes:  

 On some Nortel devices, you may need to enable CLI mode before the 
command templates supplied with Orion NCM work correctly. Most BayStack 
devices allow you to choose command line from the system menu and type 

cmd-interface cli to enable CLI mode. For more information, see your 

Nortel device documentation. 

  For IPv6, you can rediscover devices that were previously discovered with 
the engine using IPv4; you can do inventories for devices already discovered 
with IPv4 or rediscovered with IPv6, and you can perform all SNMP 
operations except transferring configurations. You can execute scripts, 
upload, and download configuration files on IPv6 addresses; Telnet and SSH 
communication are supported. 

 The Config Transfers setting (File > Settings > Configs) limits the number of 
lines required for a config file to be recognized as valid for download. The 
default is 11 lines. 

Download Configs (Single Node) 

 This resource allows you to download the startup, running, or custom 
configuration from the current node.  

To download a config: 
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1. Open the Network Configuration Manager application or login to the Orion 
Web Console with administrator privileges. 

Note: If you do not have administrator privileges you may not be able to see 
some results. 

2. Click a node in the nodes list. 

3. Select the configuration type from the dropdown list . 

Note: You can download custom types of configuration provided you enable 
NCM to recognize the type and appropriately modify your device 
configuration template. For more information see the section “Enabling a 
New Config Type”. 

4. If you are using the Orion NCM application, select the relevant options for 
handling the config after downloading it. 

 Click View/Edit Downloaded Config if you intend to do either of those 
things. 

 Click Compare to Last Config Downloaded to automatically make that 
comparison. 

 Click Compare to Last Baseline Config to make that comparison. 

5. Click Download.  

Downloaded configuration files are stored on your server in the location specified 
in the local Orion NCM client. 

This resource is available to users with the Orion NCM WebDownloader, 
WebUploader, Engineer, or Administrator role. 

Notes: The Config Transfers setting (File > Settings > Configs) limits the 
number of lines required for a config file to be recognized as valid for download. 
The default setting is 11 lines. In the case of a multi-node download operation, 
keep in mind that the Simultaneous Downloads/Uploads setting can be used as a 
throttle; by default it’s set to run 10 Sessions simultaneously. 

Download Configs (Multiple Nodes) 

 This resource allows you to download the startup, running, or custom 
configuration from the current node.  

To download a config: 

1. Open the Orion Network Configuration Manager application. 

Note: If you do not have administrator privileges you may not be able to see 
some results. 

2. Click Nodes > Download Configs. 
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3. Click Add Devices. 

4. Select relevant devices 

5. Select the type of config to be downloaded.  

Note: You can download custom types of configuration provided you enable 
NCM to recognize the type and appropriately modify your device 
configuration template. For more information see the section “Enabling a 
New Config Type”. 

6. Click OK. 

7. Click view/Edit Downloaded Config if you want to do those things following 
the download.  

8. Click Download.  

Downloaded configuration files are stored on your server in the location specified 
in the local Orion NCM client. 

This resource is available to users with the Orion NCM WebDownloader, 
WebUploader, Engineer, or Administrator role. 

Notes: The Config Transfers setting (File > Settings > Configs) limits the 
number of lines required for a config file to be recognized as valid for download. 
The default setting is 11 lines. In the case of a multi-node download operation, 
keep in mind that the Simultaneous Downloads/Uploads setting can be used as a 
throttle; by default it’s set to run 10 Sessions simultaneously. 

Enabling a New Config Type 

You can create a custom type of configuration to download from relevant 
devices. To do this you must enable NCM to recognize the new type and modify 
the templates for devices from which you intend to download the new type of 
configuration.  

All functions that operate on standard config types in NCM operate as well with 
custom config types, with the following exceptions. 

 The Overall Baseline vs. Running Config Conflicts chart is limited to the 
specified standard config types. 

 The Overall Running vs. Startup Config Conflicts chart is limited to the 
specified standard config types. 

To enable a new config type for your device: 

1. Open the Orion Network Configuration Manager application. 

2. Go to NCM Settings (File > Settings > Configs > Config Types). 

3. Click Add New Config Type. 



 

 
94  Managing Configuration Files 

4. Enter a name for the new config type. 

5. Click OK. 

6. Follow these procedures to modify your relevant device template with an 
appropriate statement. 

 Note: NCM uses the ‘show’ command to download configurations. In 
modifying each relevant device template model your new statement on the 
statements that define the ‘startup’ and ‘running’ configs as valid types of 
config to use with ‘show’. 

Editing Configuration Files 

When you need to update access lists, modify community strings, or make any 
other configuration changes, you will need to edit the configuration files you have 
already downloaded with Orion Network Configuration Manager. Complete the 
following procedure to edit a configuration file. 

To edit an existing configuration file: 

1. Open the Orion Network Configuration Manager application. 

2. Click the configuration file under the relevant node in the node list (left pane), 
and then click Configs > Edit Configs. 

3. After making any changes to the configuration file, click Save Changes. 

4. Type any details regarding the changes made to the configuration file. 

5. Click OK to save the configuration file. 

Note: The revision is saved below the existing configuration file as a 
separate file with the revision comments as the name. 

6. If you have made all necessary changes, upload your configuration. For 
more information, see "Uploading Configuration Changes" on page 102. 

Executing a Script 

 You can execute a script against the selected node or a list of nodes.  

The script you execute needs to be saved as a text file that can be browsed to on 
the client computer. The results of your script can be found on the Configuration 
Management view by clicking Transfer Status in the left navigation pane. 
Transfer Status provides the most resent status of an action taken on a node 
through Orion NCM. Click Script Results to view the results of executing your 
script. 

This resource is available to users with the WebUploader, Engineer, or 
Administrator role. For more information, see "Configuring User Access Control" 
in the Orion NCM Administrator Guide. 
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To execute a script: 

1. Open the Network Configuration Manager application. 

Note: If you do not have administrator privileges you may not be able to see 
some nodes. Your account must be a member of the WebUploader group to 
execute a script against nodes. 

2. Right click a node in the node list and select Execute Command Script...  

3. If there are other devices against which you want to upload the config, 
.click Add Devices. 

 Select the devices. 

 Click OK. 

4. Create a Command Script to Execute or click Load Script. 

5. If you created a new script, click Save Script to store it. 

6. Click Execute Command Script.  

Uploading a Config 

 This resource allows you to upload a configuration file you have previously 
downloaded from this node.  

This resource helps you easily correct unauthorized or incorrect changes made 
to a device configuration. You can also write the uploaded configuration to 
NVRAM, essentially making it the startup configuration for the device.  

Note: In the case of a multi-node upload/download operation, keep in mind that 
the Simultaneous Downloads/Uploads setting can be used as a throttle; by 
default it’s set to run 10 Sessions simultaneously. For IPv6, you can rediscover 
devices that were previously discovered with the engine using IPv4; and you can 
do inventories for devices already discovered with IPv4 or rediscovered with 
IPv6. Otherwise, new IPv6 addresses can be added to Orion NCM, though IPv6 
addresses cannot be communicated with through SNMP. You can execute 
scripts, upload, and download configuration files on IPv6 addresses; Telnet and 
SSH communication are supported. 

To upload a config: 

1. Open the Network Configuration Manager application. 

Note: If you do not have administrator privileges you may not be able to see 
some nodes. Your account must be a member of the WebUploader group to 
upload configs. 

2. Click the + beside a node in the nodes list. 

3. Select the config you want to upload . 
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4. If there are other devices to which you want to upload the config, .click 
Add Devices. 

 Select the devices. 

 Click OK. 

5. Click Upload.  

6. Check post download options. For example, you can select View / Edit 
Downloaded Config or Compare to Last Config Downloaded. 

7. Click Download. 

8. If in the previous steps you downloaded a config file of a custom type, right 
click the same node and download the running config, so that the NCM 
software will use the correct config file in the next Config Change Report. 

Note: If you do not download the running config following a custom config, 
the NCM software may generate the next Config Change Report based on 
the custom config, providing you with misleading results. Consult also the 
explanation provided in this SolarWinds NCM Knowledge base article.  

Once the download completes, the configuration files are written to the database 
and any post download actions are performed. 

Decrypting Cisco Type 7 Passwords 

When viewing a configuration file, all encrypted Cisco Type 7 passwords in the 
file can be decrypted. This is helpful when trying to recover lost passwords. 

To decrypt Cisco Type 7 passwords: 

1. Open the Orion Network Configuration Manager application. 

2. Click on the configuration file in the left pane, and then click Configs > Edit 
Configs. 

3. Click Actions, and then click Decrypt Type 7 Passwords. 

Notes: 

 All passwords that have been decrypted will appear in green text. 

 Decrypting Type 7 Passwords alters the text of the configuration file. If 
the configuration file is saved after decrypting the passwords, the 
passwords will be saved without encryption. 

http://knowledgebase.solarwinds.com/kb/questions/2162/NCM+Requires+Special+Setup+to+Correctly+Report+on+Some+Config+Changes
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Comparing Configurations 

Orion Network Configuration Manager provides the ability to compare 
configuration files. Configuration files can be compared between two nodes; or 
older configurations can be compared with the current configuration. 

To compare two configurations: 

1. Open the Orion Network Configuration Manager application. 

2. Select the two configuration files in the left pane, and then click Configs > 
Compare Selected Configs. 

Notes: 

 Compared files are shown side-by-side. 

 Lines that have been changed are highlighted in yellow. 

 Missing lines are highlighted in red. 

 A green highlight indicates that the line has been added. 

 To change the number of lines to be displayed before and after each config 
change, click File > Settings > Configs> Config Comparisons and enter 
the number to display. 

Using the Comparison Overview 

A comparison overview is displayed to the left of the side-by-side comparison. 
This overview scales to fit the size of the window allowing for an overview of the 
entire comparison. Click anywhere on the comparison overview to jump to the 
associated sections of the configuration files. 

Importing Configuration Files 

You can import configuration files you have already downloaded from your 
devices into Orion Network Configuration Manager. Configuration files can be 
imported using the following file formats: 

 SolarWinds Orion Network Configuration Manager Archive (.Config) 

 SolarWinds Cisco Config Downloader (.CiscoConfig) 

 Text File (.txt) 

 Configuration File (.cfg) 

 Any file in ASCII text 

To import a configuration file to Orion Network Configuration Manager: 
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1. Open the Orion Network Configuration Manager application. 

2. Select the node in the node list to which you want to import a configuration 
file. 

3. Open the Windows Explorer file browser and browse to the folder containing 
your configuration file. 

4. Drag the file from the Windows Explorer to the Orion Network Configuration 
Manager node list. 

5. Type a name for the configuration file, and then click OK. 

Understanding Baselines 

A baseline is a configuration file that is known to be good for a particular 
application. When making node configuration changes, it is a good idea to 
establish a known-good configuration as a baseline. 

Setting a Baseline  

Follow these procedures to mark a downloaded config as the baseline against 
which to compare future downloads.  

To set an existing configuration file as a baseline: 

1. Open the Orion Network Configuration Manager application. 

2. Click the configuration file under the node in the node list (left pane), and 
then click Configs > Set/Clear Baseline Setting. 

Note: When downloading new configuration files, check Compare to Last 
Baseline Config in the Download Config window to automatically compare the 
new configuration file to the baseline. If no baseline is found, the configuration is 
compared against the previous downloaded configuration file. 

Removing a Baseline  

Follow these procedures to clear a downloaded config as the baseline against 
which to compare future downloads.  

 To remove an existing configuration file as a baseline: 

1. Open the Orion Network Configuration Manager application. 

2. Click the configuration file under the node in the node list (left pane), and 
then click Configs > Set/Clear Baseline Setting. 



 

 
Managing Configuration Files  99 

Baselining Your Entire Network 

In some situations, it may be appropriate to establish a baseline configuration for 
every node managed by Orion Network Configuration Manager on your network. 
You can use either of the following options to create your baseline: 

 Set to the last configuration file downloaded 

 Set to the configuration files downloaded on a specific date 

To create a baseline for your entire network: 

1. Open the Orion Network Configuration Manager application. 

2. Click Configs > Baseline Entire Network. 

3. Select the appropriate option. 

4. Click Set Baseline. 

Clearing All Baselines 

Follow these prodedures to clear all baselines from the Orion NCM database. 

To remove all baselines from your database: 

1. Open the Orion Network Configuration Manager application. 

2. Click Configs > Baseline Entire Network. 

3. Click Clear all Baselines and click OK. 

Running Change Reports 

A change report shows all modifications made to each configuration file over a 
specific time period. Change reports can show you changes made during a 
specific date range, or all differences between the latest downloaded 
configuration file and the baseline configuration file. 

To run a config change report: 

1. Open the Orion Network Configuration Manager application. 

2. Click Configs > Config Change Report. 

3. Select the type of change report to generate: 

Compare most recent download to the last running config 

Displays all differences between the most recent running configuration 
and the latest downloaded configuration file. 
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Compare most recent download to the last startup config 

Displays all differences between the most recent startup configuration 
and the latest downloaded configuration file. 

Compare most recent download to the last baseline config 

Displays all differences between the most recent baseline and the latest 
downloaded configuration file. 

Compare the most recent download to the configuration on date 

Displays all differences between the most recent downloaded 
configuration file and a configuration file from the specified date. 

Note: If no configuration file was downloaded on the specified date, the 
configuration file following that date is used. 

Show changes made over the past ## days 

Displays all changes made over the specified number of days. 

Show changes made between dates 

Displays all the changes made through the specified date range. 

4. If you want the config change report to ignore specific changes, 
complete the following procedure: 

a. Click Edit Comparison Criteria. 

b. Check the appropriate exclusions. 

c. If you want to create a new exclusion, see “Creating New Config 
Change Report Exclusions” on page 100. 

d. Click Done. 

5. If you want to see detailed changes between each configuration file, 

click , and then check Show detailed changes. This shows each change 
from one configuration file to the next. For example, if there were 14 
configuration changes made during a specific date range, the report will 
show the differences in the first configuration file as compared to the second 
configuration, and then show the differences in the second configuration file 
as compared to the third, and so on. 

6. Click Generate Report. 

Creating New Config Change Report Exclusions 

When viewing config change reports, some changes can be ignored. For 

example, the !Last Configuration change line in Cisco configuration files can 

safely be ignored. 
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To specify sections of configuration files that can be ignored, Orion Network 
Configuration Manager uses regular expression patterns. The following are some 
of the regular expression pattern combinations Orion Network Configuration 
Manager recognizes: 

^! Last 

Ignores the !Last Configuration change line in Cisco configurations. 

^ntp clock-period 

Ignores the ntp clock-period line in Cisco configurations. 

^wlccp ap username cisco 

Ignores the wlccp line in Cisco access point configurations. 

Exclusions specified with regular expressions are global, and used for all 
comparison operations throughout Orion NCM, including scheduled jobs. For 
more information about regular expression patterns, see “Regular Expression 
Pattern Matching” on page 309. 

To create a new exclusion: 

1. Click Add Pattern. 

2. Type a name for the new comparison criteria in the Title field. 

3. Type the regular expression pattern in the RegEx Pattern field you want 
Orion Network Configuration Manager to ignore when running change 
reports. 

4. Type any comments you have in the Comment field. 

Creating Config Snippets 

A config snippet is a string of text that can be saved to a file, allowing you to 
easily merge sections of configuration files. For example, a config snippet is 
created from a router with the string snmp-server community 123@dm1n RO. 

When editing another router configuration, the config snippet can be reused. 
Config snippets can be used to edit an existing configuration file, or they can be 
uploaded directly to a node or group of nodes. For more information, see 
“Uploading a Config Snippet” on page 104. 

To create a new Config snippet: 

1. Open the Orion Network Configuration Manager application. 

2. Click Configs > Config Snippets. 

3. Click New Snippet. 
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4. Type a name in the Snippet field. 

5. Type configuration lines for the new config snippet in the large text box 
provided, and then click Save Changes. 

Uploading Configuration Changes 

After editing your configuration files, you can easily upload changes to a node or 
group of nodes. There are three different ways to upload configuration changes: 

 Upload an entire configuration 

 Upload selected lines 

 Upload a config snippet. 

Notes: In the case of a multi-node upload/download operation, keep in mind that 
the Simultaneous Downloads/Uploads setting can be used as a throttle; by 
default it’s set to run 10 Sessions simultaneously. For IPv6, you can rediscover 
devices that were previously discovered with the engine using IPv4; and you can 
do inventories for devices already discovered with IPv4 or rediscovered with 
IPv6. Otherwise, new IPv6 addresses can be added to Orion NCM, though IPv6 
addresses cannot be communicated with through SNMP. You can execute 
scripts, upload, and download configuration files on IPv6 addresses; Telnet and 
SSH communication are supported. 

Note: You can upload changes to a custom config type only to a single device 

but through an indirect transfer protocol (Telnet\TFTP). As a result the Write 
config to NVRAM after upload option is disabled. 

Uploading an Entire Configuration 

Complete the following procedure to upload an entire configuration file. 

 Notes:  In the case of a multi-node upload/download operation, keep in mind 
that the Simultaneous Downloads/Uploads setting can be used as a throttle; by 
default it’s set to run 10 Sessions simultaneously. 

To upload an entire configuration file: 

1. Open the Orion Network Configuration Manager application. 

2. Click the configuration file in the left pane, and then click Configs > 
Upload Entire Config. 

Note: For multinode uploads, additional nodes can be added or removed 
from the list by using the associated buttons below the list of nodes. For a 
single node upload, if you are uploading a config file of a custom type, since 
you can only do so with an indirect proptocol (TFTP/Telnet), you cannot elect 
to write the uploaded configuration to NVRAM. 
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3. If you want to write the configuration to memory, check Write Config to 
NVRAM. 

4. If your device needs to be rebooted following the upload, check Reboot 
Device. 

Warning: Rebooting a device may cause momentary connectivity outages. 

5. Click Create Upload Script. 

6. Click Execute Command Script. 

7. If you want to save the results of the script when the upload finishes, 
click Save Results. 

Uploading Selected Lines 

There are times when you only need to upload part of a configuration file. Orion 
Network Configuration Manager includes the ability to upload specific lines of a 
configuration. 

To upload specific lines: 

1. Open the Orion Network Configuration Manager application. 

Note: If you do not have administrator privileges you may not be able to see 
some nodes or settings. 

2. Click a configuration file under the node in the node list (left pane), and then 
click Configs > Edit Configs. 

3. Select the lines you want to upload, and then click Actions > Upload 
Selected Lines. 

Note: Additional nodes can be added or removed from the list by using the 
associated buttons below the list of nodes. 

4. If you want to write the configuration to memory, check Write Config to 
NVRAM. 

5. If you need to reboot your device following the upload, check Reboot 
Device. 

Warning: Rebooting a device may cause momentary connectivity outages. 

6. Click Create Upload Script. 

7. Click Execute Command Script. 

8. If you want to save the results of the script when the upload finishes, 
click Save Results. 
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Uploading a Config Snippet 

Complete the following procedure to upload a config snippet. For information on 
how to create config snippets, see “Creating Config Snippets” on page 101. 

To upload a Config Snippet: 

1. Open the Orion Network Configuration Manager application. 

Note: If you do not have administrator privileges you may not be able to see 
some nodes or settings. 

 

2. Click Configs > Config Snippets. 

3. Right-click the snippet in the Config Snippets window, and then click Upload 
to Devices. 

Note: Additional nodes can be added or removed from the list by using the 
associated buttons below the list of nodes. 

4. If you want to write the configuration to memory, check Write Config to 
NVRAM. 

5. If you need to reboot your device following the upload, check Reboot 
Device. 

Warning: Rebooting a device may cause momentary connectivity outages. 

6. Click Create Upload Script. 

7. Click Execute Command Script. 

8. If you want to save the results of the script when the upload finishes, 
click Save Results. 

Configuring a Config Archive 

Orion Network Configuration Manager can copy every configuration file 
downloaded to an archive location for backup purposes. 

To configure a configuration archive: 

1. Open the Orion Network Configuration Manager application. 

Note: If you do not have administrator privileges you may not be able to see 
some nodes and settings.  

2. Click File > Settings. 

3. Click Configs > Config Archive. 

4. Check Save a copy of each Config to the Config-Archive directory when 
it is downloaded. 
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5. Type or browse to the folder you want to store the configuration files using 
the Config-Archive directory field. 

6. Type the template you want to use when naming the configuration files. For 
more information, see “Configuration Archive Variables” on page 307. 

7. If you want to archive your existing configuration files, click Export all 
Configs to the Config-Archive directory now. 

8. Click OK. 

Enabling Realtime Configuration Change Detection 

The Realtime Configuration Change Detection feature provides notification 
through email whenever a change to any of your device configurations occurs. 
Unlike the Config Change Report, changes are detected only on the same 
configuration type. For example, if you download a startup configuration, make 
changes to it and upload it as a running configuration, the change will be 
detected against the previous running configuration. A comparison is not made 
between running and startup configuration types. 

Requirements 

To utilize realtime configuration change detection you will need the following 
items. 

 A Windows user account with administrative rights. 

 Network devices configured to send Syslog or SNMP Trap messages when 
configurations change. 

 The SolarWinds Syslog Service account must have read-write access to the 
Orion Core database. For example, if your SQL Server resides on the same 
server as Orion NCM, consider using a local administrator account for the 
SolarWinds Syslog Service. 

 The SolarWinds Trap Service account must have read-write access to the 
Orion Core database. For example, if your SQL Server resides on the same 
server as Orion NCM, consider using a local administrator account for the 
SolarWinds Trap Service. 

 Both the SolarWinds Syslog and Trap Services must be configured to run as 
administrator so that their scheduled jobs are processed correctly. For 
detailed steps, see “Running Syslog and Trap Services as Administrator”. 

 Ensure the SNMP Trap Service is running. If the SNMP Trap Service is not 
listed as a running service in the service control manager (services.msc), 

you can enable Simple Network Management Protocol in the Management 
and Monitoring Tools through Add/Remove Windows Components in the 
Add/Remove Programs application. 
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Configuring Realtime Configuration Change Detection 

Complete the following procedure to enable realtime configuration change 
detection using SolarWinds Orion Network Configuration Manager. 

Note: Both the SolarWinds Syslog and Trap Services must be configured to run 
as administrator so that their scheduled jobs are processed correctly. For 
detailed steps, see Running Syslog and Trap Services as Administrator. 

To enable realtime configuration change detection: 

1. Configure your network devices to send syslog or SNMP trap messages to 
your server when configuration changes are detected. For more information, 
see the vendor documentation for each network device. 

2. Open Orion Network Configuration Manager (Start > All Programs > 
SolarWinds Orion Network Configuration Manager > Orion Network 
Configuration Manager). 

3. Click File > Settings. 

4. Click Realtime Change Detection in the left pane. 

5. Check Enable Realtime Config Change Notifications. 

6. Click Config Change Settings in the left pane. 

7. If you want to login to all devices with a single set of account 
credentials, check Use a single set of device login credentials to login 
to all of your devices, and then type the appropriate login credentials. 

8. Type the Windows account credentials you want to use to execute the job. 

Note: To use the Windows account you are currently logged in as, leave the 
User Name and Password fields blank.  

9. If you want to prevent excessive syslog or trap communications from 
impeding performance of your Orion server, click Limit number of 
simultaneous RTN download operations. 

In some cases the syslog and trap information notifications flowing in from 
your network devices can threaten to pin resources on your Orion server.  

10. If you want to save the log file in another location, browse to the new 
location. 

11. Click Download Options in the left pane. 

12. Select the configuration type you want to download. 

13. If you want to be notified that the new configuration is different than the 
previously downloaded configuration, select Last Config. 

14. If you want to be notified that the new configuration is different than the 
baseline configuration, select Baseline Config. 
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15. Click Email Addresses in the left pane, and then provide the appropriate 
email address information. To suppress email notification, leave the email 
address fields blank. 

Note: You can use a custom property as an email address allowing you to 
assign different email addresses for each of your devices. 

16. Click Email Server Details in the left pane, and then provide the appropriate 
email server information. 

17. Click OK. 

18. If your device sends change notifications using Syslog messages, 
complete the following procedure: 

a. Click Start > All Programs > SolarWinds Orion > Syslog and SNMP 
Traps > Syslog Viewer. 

b. Click View > Alerts/Filter Rules. 

Note: If you setup rules in the Orion NCM Syslog Server in a previous 
version of Orion NCM, you can open that application (SolarWinds Orion 
Network Configuration Manager > Orion NCM Syslog Server)  to find 
your previous setup. Use those previously defined rules for recreating 
your logic here in the SolarWinds Orion Syslog Viewer.  

c. Click Add New Rule. 

d. Provide the appropriate information on the General tab and DNS 
Hostname tab. 

e. Click the Message tab, and then type the message pattern to look for in 
the Message Type Pattern field. The message pattern will vary by 
device type. For example, when a change is made to a Cisco router, a 

syslog message containing SYS-5-CONFIG_I: is sent. For more 

information about what messages are sent, see the documentation 
provided by the vendor of your device. 

f. Click the Alert Actions tab, and then click Add New Action. 

g. Select Execute an external program, and then click OK. 
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h. Type the following in the Program to execute field: 

Path\Orion\SolarWinds.NCM.RTNForwarder.exe ${IP},RealtimeNo

tification,${DateTime},${Message} 

Where: 

Path  

Declares the location of the Orion folder. For example, “C:\Program 

Files\SolarWinds”. If the path contains spaces, enclose the path 

section of the statement in quotation marks (“). 

${IP} 

Variable that includes the IP of the triggering device. 

RealtimeNotification 

This text is displayed as the username value. Currently, there is no 
means to parse the message text for the username. The text is required 

to include the Message variable. 

${DateTime} 

Variable that includes the current date and time, this is equavalent to the 

Windows control panel defined Short Date and Short Time format. 

${Message} 

Variable that includes the Syslog message in the realtime detection 
notification. If your Syslog message contains the user making the 
change, the user name is included through the use of this variable. 

Note: You must include the commas and, if including Message, you must 

include placeholder text in the second comma delimited location and the 
DateTime variable. 

i. Click OK. 

j. Ensure the new rule is checked in the Alerts / Filter Rules tab of the 
Syslog Server Settings window, and then click OK. 

19. If your device sends change notifications using SNMP Trap messages, 
complete the following procedure: 

a. Click Start > All Programs > SolarWinds Orion > Syslog and SNMP 
Traps > Syslog Viewer. 

b. Click View > Alerts/Filter Rules. 
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Note: If you setup rules in the Orion NCM Trap Server in a previous 
version of Orion NCM, you can open that application (SolarWinds Orion 
Network Configuration Manager > Orion NCM Trap Server)  to find 
your previous setup. Use those previously defined rules for recreating 
your logic here in the SolarWinds Orion Trap Viewer.  

c. Click Add Rule. 

d. Provide the appropriate information on the General tab and DNS 
Hostname tab. 

e. Click the Conditions tab, and then click Add a condition. 

f. Click SNMPv2-MIB:snmpTrapOID, and then browse to the MIB that 
contains the trap message. For example, browse to CISCO-CONFIG-
MAN-MIB:ccmHistoryEventConfigDestination 

(1.3.6.1.4.1.9.9.43.1.1.6.1.5). 

g. Click the asterisk, and then type the message pattern to match. For 
example, when a change is made to the running config the 
HistoryEventMedium is 3. Changes to the startup config are designated 

by the integer 4. 

h. If you need to match on more than one condition, click the Browse 
(…) next to your last condition, and then click the appropriate conjunction 
(and or or). Repeat Steps f through g for as many conditions as you 
need to match. For example, along with the change history event value, 
consider matching the command source CISCO-
CONFIG_MAN_MIB:ccmHistoryEventCommandSource 

(1.3.6.1.4.1.9.9.43.1.1.6.1.3) and select 1 (command line) or 2 

(snmp) as the value. For more information about what messages are 
sent from your devices, see the documentation provided by the vendor of 
your device. 
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i. Click the Alert Actions tab, and then click Add Action. 

j. Select Execute an external program, and then click OK. 

k. Type the following in the Program to execute field: 

“Path\Orion\SolarWinds.NCM.RTNforwarder.exe” ${IP} 

Where Path is the location of the Orion folder. For example, 

“C:\Program Files\SolarWinds”. If the path contains spaces, enclose 

the path section of the statement in quotation marks (“). 

l. Click OK. 

m. Ensure the new rule is checked in the Alerts / Filter Rules tab of the Trap 
Server Settings window, and then click OK. 

20. If your device sends change notifications to a system other than Orion 
Network Configuration Manager, complete the following procedure: 

a. Start your third-party Syslog or SNMP Trap receiver. 

b. Setup an alert that executes an external program. 

c. Type the following in the Program to execute field: 

“Path\Orion\SolarWinds.NCM.RTNforwarder.exe” ${IP} 

Where Path is the location of the Orion folder. For example, 

“C:\Program Files\SolarWinds”. If the path contains spaces, enclose 

the path section of the statement in quotation marks (“). 

 ${IP} 

Where Path is the location of the Orion folder. For example, 

“C:\Program Files\SolarWinds”. If the path contains spaces, enclose 

the path section of the statement in quotation marks (“). 

d. Save the alert and ensure it is enabled. 

Limiting Realtime Notification Download Operations  

 In some cases the syslog and trap information notifications flowing in from your 
network devices can threaten to pin resources on your Orion server.  

Complete the following procedure to limit the number of simultaneous realtime 
notification download operations that can be performed. 

To limit realtime notification download operations: 

1. Open the Orion Network Configuration Manager application. 

2. Click File > Settings. 
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3. Click Realtime Change Detection in the left pane. 

4. Check Enable Realtime Config Change Notifications. 

5. Click Config Change Settings in the left pane. 

6. Click Limit number of simultaneous RTN download operations. 

7. Click OK.  

Running Syslog and Trap Services as Administrator 

 Although the SolarWinds Syslog Service and Trap Service are installed and 
launched with Administrator access, you must manually grant them such access 
in order for them and their jobs to run correctly. 

To grant Administrator access to the SolarWinds Syslog Service and Trap 
Service: 

1. Navigate to the location where SolarWinds software is installed. The default 
installation path is C:\Program Files\SolarWinds\Orion\.... 

2. Right click SyslogService.exe in the right pane and select Run as….  

3. Click The following user and select Administrator. 

 4. Click OK. 

5. Right click SWTrapService.exe in the right pane and select Run as…. 

6. Click The following user and select Administrator. 

7. Click OK. 
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Searching for Configuration Files (Web Console) 

Complete the following procedure to search for specific strings of text within the 
configuration files stored in the Orion Network Configuration Manager database. 
If you want to complete detailed searches using Regular Expression pattern 
matching or if you want to ensure your configurations follow appropriate 
configuration standards, use the Orion NCM Policy Manager. For more 
information, see “Managing Policy Reports” on page 207. 

To search for text within configuration files: 

1. Login on the Orion Web Console. 

2. Click CONFIGs. 

3. Click Advanced Search under the Search NCM resource. 

4. Enter the stringstring and select a search target from the dropdown list. 

a. If you are searching Configs from All Nodes, select the filters for your 
search. 

 Search the last downloaded config from each node only and 
Search All Configs do as they say. 

 Specify a date range allow you to limit the search to configs 
downloaded within the past week, month, previous month, or within a 
range that is accurate to the second. 

 Include the following Config types allows you to limit the search to 
all the running, startup, or edited config type. (The default setting 
targets all config types as part of the search.) 

b. If you are searching Configs from Selected Nodes, select the relevant 
nodes in the Selected Nodes list and define the filters for your search. 

 Search the last downloaded config from each node only and 
Search All Configs do as they say. 

 Specify a date range allow you to limit the search to configs 
downloaded within the past week, month, previous month, or within a 
range that is accurate to the second. 

 Include the following Config types allows you to limit the search to 
all the running, startup, or edited config type. (The default setting 
targets all config types as part of the search.) 

5. Click Search. 

6. To search within the returned search results, click Search in results, enter a 
relevant string, and click Search again. 



 

 
Managing Configuration Files  113 

Searching for Configuration Files (Application Only) 

Complete the following procedure to search for specific strings of text within the 
configuration files stored in the Orion Network Configuration Manager database. 
If you want to complete detailed searches using Regular Expression pattern 
matching or if you want to ensure your configurations follow appropriate 
configuration standards, use the Orion NCM Policy Manager. For more 
information, see “Managing Policy Reports” on page 207. 

To search for text within configuration files: 

1. Open the Orion Network Configuration Manager application. 

Note: If you do not have administrator privileges you may not be able to see 
some nodes or settings. 

2. Click Edit > Search Configs in the Orion Network Configuration Manager 
application. 

3. If you want to select which nodes to search, complete the following 
procedure: 

a. Click Add Devices. 

b. Select the devices you want to search. 

c. Click OK. 

4. If you want to search all nodes, click Select Nodes Directly, and then 
click All Nodes in the Database. 

5. If you want to search a group of nodes that meet specific criteria, 
complete the following procedure: 

a. Click Select Nodes Directly 

b. Click Specify a Selection Criteria. 

c. Click Browse, and then click Add a Simple Condition. 

d. Click the first asterisk, and then click the appropriate field. 

e. If you want to change the comparison operator, click is equal to, and 
then select the comparison operator you want to use. 

f. Click the second asterisk, and then type the value or select it from the 
list. 

Note: All values currently in the database for the field are displayed 
when you browse the list. 

6. Type the string of text you want to find in the Find field. 
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7. If you want to specify a date range for your search, complete the 
following procedure: 

a. Click  to expand the search criteria pane. 

b. Set the date range for your search. 

8. If you want to specify the type of configuration files to search, complete 
the following procedure: 

a. Click  to expand the search criteria pane. 

b. Check the configuration types you want to search. 

9. Click Start Search. 

10. If you want to save the results of the search, click Save Results. 

Deleting Configuration Files from the Database 

As the Orion NCM database grows in size, you can delete existing configuration 
files from the database. If there is any chance you may need information you 
want to delete, back up your database. For more information, see “Creating 
Database Backups” on page 316. 

To purge configs from the database: 

1. Open the Orion Network Configuration Manager application. 

Note: If you do not have administrator privileges you may not be able to see 
some nodes.  

2. Click Configs > Purge Old Configs. 

3. If you want to delete configuration files from selected nodes, complete 
the following procedure: 

a. Click Add Devices. 

b. Select the devices you want to add to the list. 

c. Click OK. 

4. If you want to delete configuration files from all nodes, click Select 
Nodes Directly, and then click All Nodes in the database. 
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5. If you want to delete configuration files from a group of nodes that meet 
specific criteria, complete the following procedure: 

a. Click Select Nodes Directly 

b. Click Specify a Selection Criteria. 

c. Click Browse, and then click Add a Simple Condition. 

d. Click the first asterisk and then click the appropriate field. 

e. If you want to change the comparison operator, click is equal to, and 
then click the comparison operator you want to use. 

f. Click the second asterisk, and then type the value or select it from the 
list. 

Note: All values currently in the database for the field are displayed 
when you browse the list. 

6. Click the Select Purge Method tab. 

7. If you want to remove configuration files older than a specific date, 
complete the following procedure: 

a. Click Purge all Configs downloaded before. 

b. Type the date or click the arrow to browse. 

c. If you want to specify the time of day, check Include Time, and then 
type or select a time from the list. 

8. If you want to specify the number of configuration files to keep, 
complete the following procedure: 

a. Click Purge all Configs except the last 10. 

b. Adjust the slider to adjust the number of configuration files that should be 
kept in the database. 

9. Click Purge. 

10. When the purge completes, click Purge More Configs to delete more files, 
or click Done to close the window. 

Automating Configuration File Purges 

If you do not need to keep historical configuration files and want to ensure 
excellent database performance, you can automate the removal of unnecessary 
configuration files. If your database is not stored on a performance tuned SQL 
Server or is running on a locally installed instance of SQL Server Express, 
ensure you regularly purge unused config history. For more information, see 
"About the Orion Network Configuration Manager Database" on page 11. 

To schedule database configuration file purges: 
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1. Open the Orion Network Configuration Manager application. 

Note: If you do not have administrator privileges you may not be able to see 
some nodes or settings. 

2. Click Schedule > Create New Job. 

3. Click Purge Old Configs from Database, and then click Next. 

4. Specify a descriptive job name, and then click Next.  

5. Provide a schedule that governs when you want the job to run, and then click 
Next. This schedule does not specify the span of configuration files to delete, 
only the time to run the job. 

6. Provide credentials for the job, and then click Finish. These credentials 
provide the context under which the job is executed and the specified 
account must have write, modify, and delete access to the Orion NCM 
database and must be an Administrator on the NCM server host.  

7. Review the information on the General tab; it should reflect the schedule you 
specified in Step 4. 

8. Click the Nodes tab. If necessary, use the All Nodes in the Database button 
to change what nodes are affected by the purge job. 

9. Click the Purge Configs tab, and then specify the time after which you want 
to delete unnecessary configuration files. If you are comparing to baselines 
or want to preserve your baselines, ensure you check Do not purge 
baseline configs. 

10. Click the Notification tab, and then specify the type of notification you want 
when this job runs. 

11. If you want to change the context under which the scheduled job runs, 
click the security tab and specify a different user name and password. 

12. Click OK. 
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Chapter 6 

Modifying Device Templates 

It may be necessary to create a new device template or modify a supplied 
template to add support for your device. Before attempting to create or modify 
device templates, review the following sections to ensure you have the 
information you need to succeed. 

Gathering the Information You Need 

Before attempting to modify or create a new template, ensure you can answer all 
of the following questions about your device: 

 What are the Machine Type and System OID values displayed in the Device 
Details tab of the node properties? You will use this information to save the 
device template with a unique name Orion NCM recognizes, ensuring its use 
when connecting to the device. 

 What command is used to disable pagination? This command is the value 

used in the template RESET command, for example, terminal pager 0. 

 What command is used to reboot the device? This command is the value 
used in the template Reboot command, for example, reload noconfirm. 

 What command is used to enter configuration mode? This command is the 
value used in the template EnterConfigMode command, for example, 

config terminal. 

 What command is used to exit configuration mode? This command is the 

value used in the template ExitConfigMode command, for example, quit. 

 What command is used to specify the startup configuration? This command 
is the value used in the template Startup command, for example, startup. 

 What command is used to specify the running configuration? This command 
is the value used in the template Running command, for example, running. 

 What command sequence is used to directly download the configuration 
using telnet or SSH? This command sequence is the value used in the 

template DownloadConfig command, for example, show ${ConfigType}. 

For more information about variables that can be used in command scripts 
and device command templates, see “Pre-Command and Command 
Template Variables” on page 131. 
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 What command sequence is used to upload the configuration using telnet or 
SSH? This command sequence is the value used in the template 

UploadConfig command, for example, 

${EnterConfigMode}${CRLF}${ConfigText}${CRLF}${ExitConfigMode}. 

For more information about variables that can be used in command scripts 
and device command templates, see “Pre-Command and Command 
Template Variables” on page 131. 

 What command sequence is used to download the configuration using 
SNMP, that is, indirect transfer? This command sequence is used in the 

template DownloadConfigIndirect command, for example, copy 
${TransferProtocol}://${StorageAddress}/${StorageFilename}$Conf

igType}${CRLF}${CRLF}. For more information about variables that can be 

used in command scripts and device command templates, see “Pre-
Command and Command Template Variables” on page 131. 

 What command sequence is used to erase the configuration? This command 
sequence is used in the template EraseConfig command, for example, 

write erase ${CRLF}Yes. 

 What command sequence is used to commit a configuration to memory? 

This command sequence is used in the template SaveConfig command, for 

example, write memory. 

 What command sequence is used to show the version information? This 

command sequence is used in the template Version command, for example, 

show version. 

Device Command Template Best Practices 

Consult the following best practices before modifying device command 
templates. 

 Review several device templates and familiarize yourself with the appropriate 
command syntax before creating a new template. 

 Write down a list of all the commands you need to include in the new device 

template, including whether or not you have to press Enter after you type the 

command to ensure the device recognizes the command. 

 Telnet to your device to find the pre-commands you need. A pre-command 
can be used for any device which requires input before prompting for 
credentials. A pre-command is used before loging in. For example, when you 
connect to a router and before you are asked for a password, you must press 

Enter to wake up the connection. Add the following line to the template: 

<Command Name="PreCommand" Value="${CRLF}"/>. 

 Create a new device template by modifying an existing device template. 

 Before modifying a device template, make a copy of the original. 
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 If you have a device that indicates enable mode with any character other 

than a number sign (#), add the following line to the template: <Command 

Name="EnableIdentifier" Value="*"/>, where * is the character used to 

indicate the enable privilege level. 

 Ensure that you do not have two command templates with the same System 
OID. 

 If the value for the Command Device Template field within the Node Details 
view is set to Auto Determine, Orion NCM will choose the command template 
with the System OID value that is closest to the system OID of the device. 
For example, if the System OID for the device is 1.3.6.1.9.25.5.4, then Orion 
NCM will start the search for a template that includes 1.3.6.1.9.25.5.4 as the 
System OID. If no template is found, Orion NCM will then look for a template 
with 1.3.6.1.9.25.5, and then 1.3.6.1.9.25, and so on. To be safe, you want to 
use the full System OID when building templates. 

 If you need to declare the ready prompt for your device, use the 

VirtualPrompt command to designation the prompt: <Command 

Name=”VirtualPrompt” Value=”unc-dsf%”/>,  where unc-dsf% is the 

prompt used by the device to designate it is ready for commands to be sent. 
You can use the Virtual Prompt to avoid issue with special characters in 
banners, for example, to avoid Orion NCM recognizing the number sign # as 
an enable prompt. Ensure you use the MenuBased command when using 
the VirtualPrompt command: <Command Name=”MenuBased” 

Value=”false”/> or <Command Name=”MenuBased” Value=”true”/>. 

 Some devices (such as VPN concentrators) may require a null value for the 
Reset command to function properly. If you receive an out of range error, 

change the value of the Reset command from 0 to blank ( ). For example, 

<Command Name="RESET" Value=""/>. 

 Not all commands are supported on all devices. 



 

 
120  Modifying Device Templates 

Communication Process Diagrams 
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Creating or Modifying Device Templates 

To add support for additional devices, you may need to create a new device 
template. You can also modify existing templates to add commands and to 
accommodate any custom commands your devices may have. 

Note: Altering device command templates changes the way that Orion Network 
Configuration Manager communicates with network devices. SolarWinds does 
not recommend altering a device command template file unless you have 
advanced knowledge and experience with device commands and variables. 

To create or modify a device command template: 

1. Close all Orion Network Configuration Manager applications. 

2. Open an existing device command template using a text editor, for example, 

notepad.exe. The default directory for device command templates is 

C:\Program Files\SolarWinds\Orion\NCM\DeviceTypes. 

3. If you want to modify an existing command, apply the changes where 
applicable. For example, a device shows version information when you type 

show sys info. The current device command template shows <Command 

Name="Version" Value="show version"/>. The value needs to be 

changed to show sys info. The updated command is <Command 

Name="Version" Value="show sys info"/>. 

4. If you want to create a new command, start a new line that opens with a 

command tag using the following format: <Command Name="CommandName" 

Value="commands"/>. For example, when you are manually logged into a 

device, you would type config terminal to enter the configuration mode. 
Therefore, the final command would be: <Command 

Name="EnterConfigMode" Value="config terminal"/>. For a list of 

commands and their descriptions, see “Command Template Commands” on 
page 129. 

Notes: 

Any command you add is available to the execute script engine. If you define 

some custom actions in the template and name them DO_MY_STUFF, you can 

use the variable ${DO_MY_STUFF} in a script, and Orion NCM will resolve it to 

your commands. 

Any unresolved commands are left alone and the macro identifier 

(${Command}) will be sent to the device, where Command is the name of the 

command. This will usually cause the device to lock-up or behave erratically. 

5. If you are modifying an existing template, save the file. 
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6. If you are creating a new device command template, save the file with a 

filename using the following format: DeviceType-SystemOID.ConfigMgmt-

Commands. The DeviceType is available under Machine Type within the Node 

Details screen for SNMP enabled devices. The SystemOID can be found by 
clicking on the device in the Orion NCM node tree and then clicking MIBs > 
System Info. 

Note: You can set up cascading templates by creating a series that targets 
slightly different OIDs. For example: 

1.3.6.1.4.1.9 = Cisco (All) 

1.3.6.1.4.1.9.1.23 = Cisco 2507 

You can specify a specific device with a more exact OID, and Orion NCM will 
try to find the closest match. If Orion NCM is talking to a device with a system 
OID of 1.3.6.1.4.1.9.1.25, it will use the Cisco (All) template, but if the system 
OID is 1.3.6.1.4.1.9.1.23, it uses the Cisco 2507 template. 

7. Open Orion Network Configuration Manager and connect to the device to 
test the new commands. 

Note: You may need to override the automatically selected template in the 
Device Details window to one you have customized. 

Example CLI Device Command Templates 

Two example device command templates for CLI devices are provided below. 
For a list of commands and their descriptions, see “Command Template 
Commands” on page 129. 

Cisco IOS Example 

This is an example device command template for a Cisco IOS device. 

File Name 

Cisco IOS-1.3.6.1.4.1.9.ConfigMgmt-Commands 

Contents 

<!--SolarWinds Network Management Tools--> 

<!--Copyright 2008 SolarWinds.Net All rights reserved--> 

<Configuration-Management Device="Cisco Devices" SystemOID=" 

1.3.6.1.4.1.9"> 

 <Commands> 

  <Command Name="RESET" Value="terminal width 

0${CRLF}terminal length 0"/> 
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  <Command Name="Reboot" 

Value="reload${CRLF}y${CRLF}y"/> 

  <Command Name="EnterConfigMode" Value="config 

terminal"/> 

  <Command Name="ExitConfigMode" Value="end"/> 

  <Command Name="Startup" Value="startup"/> 

  <Command Name="Running" Value="running"/> 

  <Command Name="DownloadConfig" Value="Show 

${ConfigType}"/> 

  <Command Name="UploadConfig" 

Value="${EnterConfigMode}${CRLF}${ConfigText}${CRLF}${ExitConfigMo

de}"/> 

  <Command Name="DownloadConfigIndirect" Value="copy 

${ConfigType} 

${TransferProtocol}://${StorageAddress}/${StorageFilename}${CRLF}$

{CRLF}${CRLF}"/> 

  <Command Name="UploadConfigIndirect" Value="copy 

${TransferProtocol}://${StorageAddress}/${StorageFilename} 

${ConfigType}${CRLF}${CRLF}"/> 

  <Command Name="EraseConfig" Value="write 

erase${CRLF}Y"/> 

  <Command Name="SaveConfig" Value="write memory"/> 

  <Command Name="Version" Value="show version"/> 

 </Commands> 

</Configuration-Management> 

Nortel BayStack 380 Example 

This following example device command template is for a Nortel BayStack 380. 

File Name 

Nortel Baystack380-1.3.6.1.4.1.45.3.45.ConfigMgmt-Commands 

Contents 

<!--SolarWinds Network Management Tools--> 

<!--Copyright 2008 SolarWinds.Net All rights reserved--> 

<Configuration-Management Device="Nortel BayStack 380 Devices" 

SystemOID="1.3.6.1.4.1.45.3.45"> 
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 <Commands> 

  <Command Name="RESET" Value="terminal length 0"/> 

  <Command Name="Reboot" Value="reload${CRLF}Yes"/> 

  <Command Name="EnterConfigMode" Value="config 

terminal"/> 

  <Command Name="ExitConfigMode" Value="end"/> 

  <Command Name="Startup" Value="configuration"/> 

  <Command Name="Running" Value="running-config"/> 

  <Command Name="DownloadConfig" Value="show 

${ConfigType}"/> 

  <Command Name="UploadConfig" 

Value="${EnterConfigMode}${CRLF}${ConfigText}${CRLF}${ExitConfigMo

de}"/> 

  <Command Name="DownloadConfigIndirect" Value="copy 

${ConfigType} 

${TransferProtocol}://${StorageAddress}/${StorageFilename}${CRLF}"

/> 

  <Command Name="UploadConfigIndirect" Value="copy 

${TransferProtocol}://${StorageAddress}/${StorageFilename} 

${ConfigType}${CRLF}"/> 

  <Command Name="Version" Value="show sys info"/> 

  <Command Name="PreCommand" Value="${CTRL+Y}"/> 

 </Commands> 

</Configuration-Management>\ 

Creating a Menu-Based Command Template 

Orion Network Configuration Manager also supports menu based devices that do 
not have command-line interfaces. Complete the following procedure to create a 
menu-based device command template. 

All Telnet commands for menu-based devices should be described in the device 
command template XML file (*.ConfigMgmt-Commands). For more information 
about file contents, see “Command Template Commands” on page 129.  

Notes: On some Menu-Based devices such as Cisco SF300 LAN switches: 
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 Menu item numbers can be used instead of arrow moves. For example, 
instead of assigning: 
Value="${ENTER}${DownArrow}${DownArrow}${DownArrow}${DownArrow}

${DownArrow}${DownArrow}}${DownArrow}  

You could instead assign: 

Value= “1$[ENTER]7$[ENTER]” 

 Login username and password have to be sent as PreCommand values 
instead of from the NCM Node Details configuration.   

To do this: 

1. Clear the username and password fields for  the node in Login 
Information, and set Enable to <No Enable Login>.  

2. Then use these PreCommands:  

<Command Nae=”PreCommand” Value="username${DownArrow}”/>  

<Command Nae=”PreCommand” Value="password${ENTER}”/>  

The following example provides the values declared for menu-driven indirect 
transfer: 

 <Commands> 

  <Command Name="RESET" Value=""/> 

  <Command Name="Reboot" Value=""/> 

  <Command Name="EnterConfigMode" Value=""/> 

  <Command Name="ExitConfigMode" Value=""/> 

  <Command Name="Startup" Value=""/> 

  <Command Name="Running" Value=""/> 

  <Command Name="DownloadConfigIndirect" 

Value="${Downarrow}${Downarrow}${Downarrow}${Downarrow}${Downarrow

}${Downarrow}${Downarrow}${Downarrow}${Downarrow}${CRLF}${CRLF}${S

torageFilename}${CRLF}${DownArrow}${StorageAddress}${CRLF}${DownAr

row} ${CRLF}" Delay="300"  

RegEx="written"/> 

  <Command Name="UploadConfig" Value=""/> 

  <Command Name="EraseConfig" Value=""/> 

  <Command Name="SaveConfig" Value=""/> 
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  <Command Name="Version" 

Value="${DownArrow}${DownArrow}${DownArrow}${DownArrow}${DownArrow

}${DownArrow}${DownArrow}${DownArrow}${DownArrow}${DownArrow}${CRL

F}" RegEx="Event Log"/> 

  <Command Name="PreCommand" Value="${CTRL+Y}"/> 

 </Commands> 

To create a menu-based device command template: 

1. Manually Telnet to your device to discover the pre-commands you must send 
before the device presents the login screen. Pre-commands are used for any 
device which requires input before prompting for credentials. For example, 
when you connect to a router and before you are asked for password, you 

must press Enter to wake up the connection. Add the following line to the 

template: <Command Name="PreCommand" Value="${CRLF}"/>. 

2. Orion Network Configuration Manager also sends a Version command during 
the validate login action. To set this command value, complete the following 
procedure: 

a. To determine this command, find the option in the menu which shows 
device version information. For example, if the System Information menu 
shows device version information and to access this menu item you 
press the down arrow key two times and then press Enter, then type the 

following line into the device command template: <Command 

Name="Version" Value="${DownArrow}${DownArrow}${CRLF}">. 

b. Find the string that is received when the command is complete. For 
example, if the command is complete when the device responds with 

System Characteristic, then you must add the following attribute to 

the command: RegEx="System Characteristic". 

c. Add a delay between keystrokes by adding the following attribute: 

Delay="300". 

d. The complete command line for the Version command will now be: 
<Command Name="Version" 

Value="${DownArrow}${DownArrow}${CRLF}" RegEx="System 

Characteristic" Delay="300" />. 
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3. Access the configuration file menu, and then download a configuration 
manually. During this operation, note the keys you press to complete this 
process. For example, on a Nortel Baystack 552048T you would press the 
following keys to download a configuration: 

a. Down arrow (↓) 9 times – Highlights configuration file menu item 

b. Enter – Opens Configuration file menu 

c. Enter – Opens file Download/Upload menu 

d. ConfigName + Enter - Sets the name of configuration file 

e. Down arrow (↓) + TFTP IP Address + Enter – Sets the TFTP server 

address 

f. Down arrow (↓) + Space + Enter – Starts downloading process 

4. Translate all these command into Orion NCM variables. In this example, the 
following commands are used: 

${Downarrow}${Downarrow}${Downarrow}${Downarrow}${Downarrow} 

${Downarrow}${Downarrow}${Downarrow}${Downarrow} 

${CRLF} 

${CRLF} 

${StorageFilename}${CRLF} 

${DownArrow}${StorageAddress}${CRLF} 

${DownArrow} ${CRLF} 

Note: For a list of commands and their descriptions, see “Command 
Template Commands” on page 129. 

5. Find the string that is received when the command is complete. For example, 

the command is complete when the device responds with written. In this 

case, you must add the following attribute to the command: 

RegEx="written". 

6. Add a delay between keystrokes by adding the following attribute: 

Delay="300". 

7. The complete download command is as follows: <Command 
Name="DownloadConfigIndirect" 

Value="${Downarrow}${Downarrow}${Downarrow}${Downarrow}${Downar

row}${Downarrow}${Downarrow}${Downarrow}${Downarrow}${CRLF}${CR

LF}${StorageFilename}${CRLF}${DownArrow}${StorageAddress}${CRLF

}${DownArrow} ${CRLF}" Delay="300" RegEx="written"/>. 
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Command Template Commands 

The following commands are used to modify and declare the behavior of Orion 
NCM device templates. These commands modify the interaction between Orion 
NCM and your network devices. Ensure you fully understand what modifications 
will do before modifying a device in production using these commands. 

Property Description 

DownloadConfig 
Series of commands used to download a configuration from a 
device 

DownloadConfigIndirect 
Series of commands used to download a configuration indirectly 
from a device using TFTP. 

EnableCommand 
Allows you to declare a custom enable command for those 

devices that do not use Enable as the command. 

EnableIdentifier 
Only used when a device does not return the "#" symbol at the end 
of a prompt to indicate enable mode. Declare the value displayed 
while in enable mode for a device. 

EnterCLI 

Specifies the commands to send upon receiving the VirtualPrompt 
value to enter the CLI mode of the menu driven device. Use pre-
command variables to declare the command values. For more 
information, see “Pre-Command and Command Template 
Variables” on page 131. 

EnterConfigMode 
Series of commands used to enter the configuration mode of a 
device 

ExitConfigMode 
Series of commands used to exit the configuration mode of a 
device 

IPAddress 
The IP address of the server where Orion Network Configuration 
Manager is installed 

MenuBased 

Specifies whether the device is menu or cli based. If a device is 
menu based and you can switch it to CLI from the menu, use the 
VirtualPrompt and EnterCLI commands to do so. Valid values are 

true or false. 

MenuDrivenConfigStart 

Allows you to declare a value after which the transmitted data is 
considered the config requested from the menu-driven device. For 
example, in the Cisco VPN Concentrator device template, the 

declared value is ##########. The information sent after the 

ten hash signs is saved as the requested configuration file. 

More 
Specifies the more prompt in the rare instance that this prompt is 
not recognized automatically. Do not specify this command unless 
you are experiencing issues with paging. 

Precommand 
Specifies the device requires a pre-command. For more 
information and valid pre-command variables, see “Pre-Command 
and Command Template Variables” on page 131. 

Reboot Series of commands used to reboot the device 
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Property Description 

RebootAt 
Series of commands used to reboot a device at a specified time. 
Use the variables listed in the “Configuration Archive Variables” 
section on page 307 to assign the date and time. 

RESET 
Series of commands used to set the length and pagination of the 
session 

Running Value used to specify a running configuration type 

SaveConfig 
Series of commands used to write the configuration to the devices 
memory 

Startup Value used to specify a startup configuration type. 

UploadConfig Series of commands used to upload a configuration to a device 

UploadConfigIndirect 
Series of commands used to upload a configuration indirectly to a 
device using TFTP. 

Version 
Series of commands used to display the software version of the 
device. 

VirtualEnablePrompt 

Allows you to specify a regular expression and search for the 
defined value in the entirety of a device response. This command 
is often used with menu-based devices, allowing you to locate a 
specific phrase returned by the device. When specified, ensure 
you also declare the MenuBased command as true or false, also. 

VirtualPrompt 

Specifies the command prompt that will be sent when the device is 
ready for command input. Use this command along with the 
MenuBased command to specify the exact prompt Orion NCM 
should wait to receive before sending commands. 
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Pre-Command and Command Template Variables 

Pre-Command variables are used within command scripts as well as within 
device command templates. The Pre-Command variables mimic keyboard 
strokes that are normally entered in the command interface. For more information 
on creating command scripts, see “Working with Command Scripts” on page 137. 

Property Description 

${ConfigType} Value used to insert the type of configuration 

${CR} Carriage return 

${CRLF} or 
$[ENTER] 

Carriage return - linefeed combination 

${CTRL+@} CTRL + @ 

${CTRL+A} CTRL + A 

${CTRL+B} CTRL + B 

${CTRL+C} CTRL + C 

${CTRL+D} CTRL + D 

${CTRL+E} CTRL + E 

${CTRL+F} CTRL + F 

${CTRL+G} CTRL + G 

${CTRL+H} CTRL + H 

${CTRL+I} CTRL + I 

${CTRL+J} CTRL + J 

${CTRL+K} CTRL + K 

${CTRL+L} CTRL + L 

${CTRL+M} CTRL + M 

${CTRL+N} CTRL + N 

${CTRL+O} CTRL + O 

${CTRL+P} CTRL + P 

${CTRL+Q} CTRL + Q 

${CTRL+R} CTRL + R 

${CTRL+S} CTRL + S 

${CTRL+T} CTRL + T 

${CTRL+U} CTRL + U 

${CTRL+V} CTRL + V 

${CTRL+W} CTRL + W 
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Property Description 

${CTRL+X} CTRL + X 

${CTRL+Y} CTRL + Y 

${CTRL+Z} CTRL + Z 

${CTRL+[} CTRL + [ (equivalent to ESC key press) 

${CTRL+\} CTRL + \ 

${CTRL+]} CTRL + ] 

${CTRL+CTRL} CTRL + CTRL 

${CTRL+_} CTRL + _ 

${UPARROW} Up Arrow 

${DOWNARROW} Down Arrow 

${RIGHTARROW} Right Arrow 

${LEFTARROW} Left Arrow 

${StorageAddress} Value used to insert the TFTP server IP address or hostname. 

${StorageFilename} 
Value used to insert the name generated by Orion NCM for the 
downloaded configuration file.  

${TransferProtocol} 
Value used to insert the transfer protocol used during indirect 
transfer. 

Example Pre-Command Device Template Entry 

The following line from a device command template specifies the pre-command, 
the delay, and the text that triggers the pre-command. Delay and trigger text 
(RegEx) are optional variables. 

<Command Name=”Precommand” Value=”${CTRL+Y}” Delay=”3” 

RegEx=”password:”/> 

Note: Device command templates are located in the DeviceTypes folder of your 

installation folder. By default, you can find this folder in the following location: 

\Program Files\SolarWinds\Configuration Management\DeviceTypes\. 
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Using Command Template Variables to Preclude 
Pseudoterminal Setup 

If your device does not support pseudoterminal device pairs, you can prevent 
Telnet from attempting to negotiate pseudoterminal setup by using the following 
command variable. 

<Command Name=”allocatePty” Value=”false”/>  

Specifies that the command script will be run with pseudoterminal mode 
disabled.  

Using Command Template Variables to Declare a Special 
Command Prompt 

If the command prompt is not > or #, or you need to specify more than one 

character to designate the command prompt, as in the case of banners using the 
# symbol, you can declare the command prompt using the following command 
variables. 

<Command Name=”MenuBased” Value=”false”/>  

Specifies that the template logic should run in CLI mode 

<Command Name=”VirtualPrompt” Value=”CustomPrompt%”/>  

Specifies the exact value of the command prompt designating the device is 
ready to receive commands. 

Using Command Template Variables to Switch User 
Context 

If you Log on to a device and must switch user context to execute a command,, 
resulting in a different command prompt, use the following example to guide you 
in how to handle switching context and recognize the new command prompt. 

<Command Name=”MenuBased” Value=”false”/>  

Specifies that the template logic should run in CLI mode 

<Command Name=”Reset” Value=”appropriateSwitchContextCommands” 

RegEx=”newPrompt”/> 

Specifies the reset command to switch the context of the switch and the new 
prompt to expect. Use pre-command variables to designate the switch 
context commands and specify the entire new prompt in the RegEx value. 
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Using Command Template Variables to Respond to 
Post-Login Interaction Requests  

If you Log on to a device and perform an action and are then prompted for 
interaction (for example, you receive a press any key prompt) consult the 
following example commands in the command template to avoid timing out. 

<Command Name=”PreCommand” Value=”${CTRL+Y}”/> 

Sent when the device does not respond for 3 seconds 

<Command Name=”PreCommand” Value=”${CTRL+Y}” Delay=”5”/> 

Sent when the device does not respond for more than 3 seconds 

<Command Name=”PreCommand” Value=”${CTRL+Y}” Delay=”5” 

RegEx=”press any key”/> 

Sent when the device does not respond for more than 3 seconds and the last 

received data was press any key. 

Troubleshooting Device Connections 

When you experience problems connecting to a device, you may need to perform 
a session trace to troubleshoot the issue. A session trace shows all 
communication sent to and from the network device to which you are trying to 
connect. The session trace log will contain any error messages as well as the 
commands sent that generated the error. 

To troubleshoot a device connection issue with a session trace: 

1. Click File > Settings. 

2. Click Advanced > Session Tracing. 

3. Check Turn on Session Tracing, and then click OK. 

4. Perform the steps to recreate the issue you are troubleshooting. 

5. Open the session trace file to discover what is causing the error. The default 

location for session trace files is C:\Program 

Files\SolarWinds\Orion\NCM\Session-Trace. 

6. Apply the necessary changes to the device command template to resolve the 
issue. For more information, see “Creating or Modifying Device Templates” 
on page 122. 
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Chapter 7 

Working with Command Scripts 

Orion Network Configuration Manager allows you to accomplish several tasks 
through the creation and execution of command scripts. Consider the following 
tasks you can simplify by using command scripts. 

 Downloading configuration files 

 Uploading configuration files 

 Uploading IOS images 

 Updating login banners 

 Updating access control lists (ACLs) 

With the appropriate use of variables, a single script can be executed on several 
different devices, without concern for syntax differences.  

Note: Scripts are delivered one line at a time to the target devices. 

Executing Command Scripts 

Complete the following procedure to create and execute a command script.  

Note: For IPv6, you can rediscover devices that were previously discovered with 
the engine using IPv4; and you can do inventories for devices already discovered 
with IPv4 or rediscovered with IPv6. Otherwise, new IPv6 addresses can be 
added to Orion NCM, though IPv6 addresses cannot be communicated with 
through SNMP. You can execute scripts, upload, and download configuration 
files on IPv6 addresses; Telnet and SSH communication are supported. 

To create and execute a command script: 

1. Click Nodes > Execute Command Script. 

2. If you want to select the nodes on which to run the script, complete the 
following procedure: 

a. Click Add Devices. 

b. Select the devices on which you want to run your command script. 

c. Click OK. 

3. If you want to run the script on all nodes, click Select Nodes Directly, 
and then click All Nodes in the Database. 
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4. If you want to run the script on a group of nodes that meet specific 
criteria, complete the following procedure: 

a. Click Select Nodes Directly. 

b. Click Specify a Selection Criteria. 

c. Click Browse, and then click Add a Simple Condition. 

d. Click the first asterisk, and then click the appropriate field. 

e. If you want to change the comparison operator, click is equal to, and 
then select the comparison operator you want to use. 

f. Click the second asterisk, and then type the value or select it from the 
list. 

Note: All values currently in the database for the field are displayed 
when you browse the list. 

5. If you want to type a new script, type the script in the Command Script to 
Execute field. 

Note: Scripts can consist of a single command or list of commands to be 
executed sequentially. Scripts should mirror commands entered when 
manually typing instructions from the command prompt. For example, when 

sending the show version command to a router via a TELNET session, the 

prompt requires the user to type sh version. The command script must 

mimic this entry. For example, type sh version with a carriage return at the 

end of the line. 

6. If you want to load a previously saved script, complete the following 
procedure: 

a. Click Load Script. 

b. Browse to the script you want to load, and then click Open. 

Note: To view sample scripts, browse to the \Sample Scripts folder. 

7. If you want to see results that meet specific criteria, complete the 
following procedure: 

a. Click . 

b. Check Filter Results that Match a Pattern. 

c. Type the string you want Orion Network Configuration Manager to use 

for filtering. For example, adding the word Serial to the filter displays 

lines that start with the word Serial. For more information on pattern 
matching, see “Regular Expression Pattern Matching” on page 309. 

Note: The example script Get Serial Number from each Device.txt 

demonstrates this feature. 
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8. If you want to write the results of a script to a file, complete the following 
procedure: 

a. Click . 

b. Check Save Results to a File. 

c. Type or browse to the path and filename for the log file. 

9. If you want to hide script commands when the script is executed, 
complete the following procedure: 

a. Click . 

b. Uncheck Show Commands in Output. 

10. Click Execute Command Script. 

11. If you want to save the results of the script, click Save Results. 

Note: Unchecking Outline View displays results without formatting. 

12. If you want to save the script for later use, complete the following 
procedure: 

a. Click the Execute Script tab. 

b. Click Save Script. 

c. Type a filename, and then click Save. 

Using Variables within Scripts 

The power of the Orion Network Configuration Manager scripting engine is 
highlighted by the ability to use variables within scripts. Variables always begin 
with a dollar sign and a curly brace (${) and end with a curly brace (}). 

Script variables substitute the appropriate commands based on the device type. 

For example, the variable ${EnterConfigMode} parses as "config terminal" 

when communicating with Cisco IOS devices, but parses as "configure" when 
communicating with an HP Procurve Switch. 

For more information about variables that can be used in command scripts and 
device command templates, see “Command Template Commands” on page 129. 

Example Variable Script 

The following script contains commands with variables to remove the public read-
only community string. 

${EnterConfigMode} 

no snmp-server community public RO 

${ExitConfigMode} 
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${SaveConfig} 

${Reboot} 

Parsed for Cisco IOS devices: 

config terminal 

no snmp-server community public RO 

end 

write memory 

reload${CRLF}y${CRLF}y 

Parsed for a Dell PowerConnect Switch: 

config 

no snmp-server community public RO 

end 

copy running-config startup-config${CRLF}${CRLF} 

reload${CRLF}Yes 

Note: The ${CRLF} variable equals a carriage return line feed for all devices. 

Script variables are defined in device command templates. Templates are 

located in the Configuration Management\DeviceTypes folder. Each 

.ConfigMgmt-Commands file contains a System OID that is used to uniquely 

identify a device. A list of command names and the corresponding commands to 
be sent to the device when the command name is called are also included in the 
templates. These command names are the variables used when creating a 
script. 

Consider the following line taken from the Cisco IOS device command template: 
<Command Name="EnterConfigMode" Value="config terminal"/> 

When a script is run on a Cisco IOS device, the variable ${EnterConfigMode} 

parses as config terminal. New command names can be added and existing 

command names can be modified within these files.  
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The script engine also allows you to reference variables with variables. For 

example, you can define a complex variable in the device template, ShowInt = 

running | include interface, and then define another variable that includes 

the first, Reveal = show ${ShowInt}. When you call the Reveal variable, 

${Reveal}, it equals show running | include interface. For more 

information about variables that can be used in command scripts and device 
command templates, see “Command Template Commands” on page 129. 
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Chapter 8 

Working with Config Change Templates 

Orion Network Configuration Manager allows you to create, use, and manage 
config change templates that significantly streamline making recurrent and 
complex configuration changes.  

With a single config change template you can generate and execute accurate 
sets of CLI commands to perform a specific task on many different machine 
types in a network of variable size.  

Consider the following tasks you can simplify by using config change templates. 

 Changing VLAN membership by device port 

 Configuring device interfaces based on description 

 Enabling IPSLA for VOIP implementations 

 Managing NetFlow collection at the source devices 

Consult these topics as needed: 

Understanding Config Change Template Semantics 

Executing a Config Change Template 

Creating a Config Change Template 

Editing a Config Change Template 

Executing a Config Change Template 

Use the following steps to generate and execute a list of CLI commands that can 
appropriately change your network device configurations. 

To execute a config change template: 

1. Navigate to the Config Change Templates resource on either the Orion NCM 
Web Console or the Orion Web Console (Configs > Config Change 
Templates). 

2. Find the template in the alphanumerically sorted Config Change Template 
Name list. 

Alternately, if the list is long, click a relevant tag in the left pane and find the 
template in the filtered list.  
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Templates are displayed by the tags applied to them at their time of creation 
or through editing. 

3. Check the relevant template in the Config Change Template Name list. 

If you want to edit the template, click Advanced Modify and make your 
changes. 

As needed, consult Understanding Config Change Template Semantics 

4. Click Define Variables and Run. 

5. Click all target devices in the Nodes list. 

Use the Group By controls to sort the list more efficiently. 

6. Click Next. 

7. Enter the appropriate values in the input fields. 

Input fields for a change configuration template are defined and managed 
through the Edit Config Template resource. For example, in a template that  
turns on NetFlow data exporting for a set of Cisco devices, you might be 
asked to enter in one field the IP address of the a relevant NetFlow collector, 
and in another the port on which your target device exports flow data. 

For more information, see Editing a Config Change Template. 

8. Click Next. 

9. [Optional] Click a relevant node in the tree and click Preview in a New 
Window to see the CLI commands for that device.  

If you choose to open a new window to view CLI commands, you will need to 
minimize or close it to return to the Execute <Template_Name> resource. 

10. Copy the commands to a text file if desired. 

11. Return to the Execute <Template_Name> resource and click Execute when 
you are ready to issue the CLI commands to all selected devices. 

Creating a Config Change Template 

Use the following steps to create a config change template that can guide 
network engineers in producing accurate sequences of CLI commands for 
enacting changes across multiple network devices. 

To create a config change template: 

1. Navigate to the Config Change Templates resource on the Orion web 
console (Configs > Config Change Templates). 

2. Click Create New Config Change Template. 
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3. Enter an appropriate name for this template in Config Change Template 
Name.  

This is the name that appears in the Config Change Template Name list. 

4. Provide a succinct sentence or phrase in Description that will help users 
quickly understand what your template helps them do.  

This description appears when a user checks a config change template in the 
resource list and clicks on its name. 

5. Enter one or more Tags that will help users easily find your template by its 
tags.  

Templates can be displayed by the tags applied to them at their time of 
creation or through editing. 

To be useful, your tagging scheme should be known to the user community 
and applied as consistently as possible. 

6. Create your Config Change Template. 

As needed, consult Understanding Config Change Template Semantics  

7. Click Validate to check syntax in your new template. 

8. Click Submit to save the template or Execute to save and run it.  

If you choose the execute the template, NCM validates the syntax of the 
template. If validation succeeds, NCM saves a copy of the template and 
loads the relevant interface for user input. If validation fails, NCM displays an 
error in red that serves as a guide make changes. 

Importing a Config Change Template 

Use the following steps to import a config change template into NCM from an 
accessible file system. 

To import a config change template: 

1. In the Config Change Template resource on the Orion web console, click 
Import. 

2. Click Browse to find the file on your computer. Config change templates 
have the extension .ncm-template. 

3. Click Submit. 

4. Change the template name as needed.  

This is the name as it appears in the Config Change Template Name list.  

5. Modify the description as needed to help users quickly understand what your 
template helps them do.  
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This description appears when a user checks a config change template in the 
resource list and clicks on it. 

6. Enter one or more Tags that will help users easily find your template by its 
tags.  

Templates can be displayed by the tags applied to them at their time of 
creation or through editing. 

To be useful, your tagging scheme should be known to the user community 
and applied as consistently as possible. 

7. Modify the logic of your Config Change Template. 

As needed, consult Understanding Config Change Template Semantics  

8. Click Validate to check the new logic. 

9. Click Submit. 

Editing a Config Change Template 

Use the following steps to modify how an existing config change template 
generates a list of CLI commands that can appropriately change your network 
device configurations. 

To edit a config change template: 

1. On the Config Change Templates resource in the Orion web console 
(Configs > Config Change Templates), find the template in the 
alphanumerically sorted Config Change Template Name list. 

Alternately, if the list is long, click a relevant tag in the left pane and find the 
template in the filtered list.  

Templates are displayed by the tags applied to them at their time of creation 
or through editing. 

2. Check the relevant template in the Config Change Template Name list. 

3. Click Advanced Modify. 

As needed, consult Understanding Config Change Template Semantics 

4. Change the template name as needed.  

This is the name as it appears in the Config Change Template Name list.  

5. Modify the description as needed to help users quickly understand what your 
template helps them do.  

This description appears when a user checks a config change template in the 
resource list and clicks on it. 
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6. Enter one or more Tags that will help users easily find your template by its 
tags.  

Templates can be displayed by the tags applied to them at their time of 
creation or through editing. 

To be useful, your tagging scheme should be known to the user community 
and applied as consistently as possible. 

7. Modify the logic of your Config Change Template. 

As needed, consult Understanding Config Change Template Semantics  

8. Click Validate to check the new logic. 

9. Click Submit. 

Tagging a Config Change Template 

Use the following steps to manage tags for config change templates. 

To add tags to a config change template: 

1. On the Config Change Templates resource in the Orion web console 
(Configs > Config Change Templates), find and check the relevant 
template(s) in the alphanumerically sorted Config Change Template Name 
list. 

Alternately, if the list is long, click a relevant tag(s) in the left pane and find 
the template in the filtered list.  

Templates are displayed by the tags applied to them at their time of creation 
or through editing. 

2. Click Tags. 

3. In the Edit Tags for <Template_Name> resource, add tags. 

  To add an existing tag, click a tag in the list. 

 To add a new tag, click Add new tag(s) and type your tags in the highlighted 
text field, separating them from each other with commas.  

Templates can be displayed by the tags applied to them at their time of 
creation or through editing, as in this case. Either way, to be useful, your 
tagging scheme should be known to the user community and applied as 
consistently as possible. 

4. Click Submit. 

To delete tags from a config change template: 
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1. On the Config Change Templates resource in the Orion web console 
(Configs > Config Change Templates), find the template in the 
alphanumerically sorted Config Change Template Name list. 

Alternately, if the list is long, click a relevant tag in the left pane and find the 
template in the filtered list.  

Templates are displayed by the tags applied to them at their time of creation 
or through editing. 

2. Click Tags. 

3. In the Edit Tags for <Template_Name> resource, click a valid tag in the 
existing tag list and then click the Remove  tag(s) option. 

4. In the highlighted list select the tag(s) to remove. 

5. Click Submit. 

Exporting a Config Change Template (to thwack) 

 Use the following steps to share a config change template with your user 
community on thwack.com.  

To export a config change template: 

1. On the Config Change Templates resource in the Orion web console 
(Configs > Config Change Templates), find the template in the 
alphanumerically sorted Config Change Template Name list. 

Alternately, if the list is long, click a relevant tag in the left pane and find the 
template in the filtered list.  

Templates are displayed by the tags applied to them at their time of creation 
or through editing. 

2. Check the template and click Export to thwack. 

3. If prompted enter your user information and click Login. 

Exporting a Config Change Template (as a file) 

 Use the following steps to save a config change template on a file system and to 
share it with your user community on thwack.com.  

To export a config change template: 

1. On the Config Change Templates resource in the Orion web console 
(Configs > Config Change Templates), find the template in the 
alphanumerically sorted Config Change Template Name list. 
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Alternately, if the list is long, click a relevant tag in the left pane and find the 
template in the filtered list.  

Templates are displayed by the tags applied to them at their time of creation 
or through editing. 

2. Check the template and click Export as File. Verify that a popup blocker is 
not preventing the file from being downloaded. 

3. Download the file to a local directory. 

4. Click Return to Config Change Templates if you are finished. 

 

5. Click Share Now if you want to upload the template to thwack.com. 

6. Click Upload a File in the content sharing area. 

7. Click Specify File and browse to it on your local system. 

8. Click Save. 

9. Enter a name and description. 

10. Select or enter tags. 

11. Click Save. 

Deleting a Config Change Template 

Use the following steps to delete config change templates that are no longer 
needed. 

To delete a config change template:  

1. On the Config change templates resource in the Orion web console (Configs 
> Config Change Templates), find the template in the alphanumerically 
sorted Config Change Template Name list. 

Alternately, if the list is long, click a relevant tag in the left pane and find the 
template in the filtered list.  

Templates are displayed by the tags applied to them at their time of creation 
or through editing. 

2. Check the template and click Delete. 

3. Click Yes. 
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Understanding Config Change Template Semantics 

Most fundamentally, the framework for creating config change templates 
depends on the SolarWinds Information Service (SWIS), an API installed with 
NCM that interacts with inventory data in the NCM database. Any device that has 
not been inventoried in NCM cannot be targeted with a config change template. 
Each object in a device inventory is a SWIS entity that can be referenced in 
specific ways within scripts.  

Viewed as parsable code, a config change template consists of two parts: 

 Parameters 

This part defines names and descriptions of the interface wizard fields 
associated with the variables that the user delimits when the config change 
template is executed. 

 Commands 

This part defines the variables and their data structures on which the script 

command operates when the config change template is executed, and how 
the relevant data is parsed. Currently variables can be of type int, string, or 
entity. It is also possible to have a list type of int, string, or entity. The 
context node is the node that is targeted for the config change and of whose 
inventory data (in the NCM database) the config change template makes use 
at runtime. 

This part also includes native CLI commands that are parsed inline.  

Parameters 

For every default template there are parameters that define each input field with 
a label and description and the command variable (an integer, string, or SWIS 
entity) associated with the field.  

.PARAMETER_LABEL @<variable_name> 

    Input field label (for example, “Node Name”) 

.PARAMETER_DESCRIPTION @<variable_name> 

    A description of what the user should do with the input field 

There are three other parameters included in each template: 
.CHANGE_TEMPLATE_DESCRIPTION (a description of the template itself), 

.CHANGE_TEMPLATE_TAGS (tags by which templates can be viewed as functional 

groups) and .PLATFORM_DESCRIPTION (the type of device for which the template 

is designed). These parameters are defined in the interface by which you create 
and edit config change templates. 
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Arguments and Commands 

At runtime, the scripting engine generates a list of CLI commands which can be 
sent to the device. The commands section is where you declare the 
arguments/variables that prompt for user interaction and write the logic for 
generating device specific lists of CLI commands. 

Input Arguments 

The script declaration includes all the variables for which the template prompts 

the user to provide input. The declarations are made in this form: 

script <script_name> ( 

    <data_type> @<variable> 

    <data_type> @<variable> 

    <data_type> @<variable> ) 

 

where,  

<data_type> can be ‘swis.entity’ (for example, ‘NCM.Nodes’), ‘int’ (integer), or 

‘string’. 

CLI Statements 

CLI statements are passed through to your CLI output directly. Any variables 
referenced within CLI commands will be parsed inline.  

CLI commands are initiated with the CLI command, and then wrapped by 
brackets { }. Any variables contained within the command {} will be parsed when 
the overall script is run and the CLI commands are presented in sequence in a 
preview window. (For information on executing a config change template, see 
Executing a Config Change Template.) 

This first example shows a very basic use of a CLI statement within a change 
config template command section:  

CLI{ vlan database 

 exit }  

This statement parses to the following output: 

vlan database 

exit 

This second example shows a similar CLI statement but with variables to specify 
VLAN properties. 
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CLI 

{ 

vlan database  

vlan @vlanid 

description @vlandesc 

exit 

} 

For purposes of demonstration, we assume that the variable @vlanid has been 
set to 1 and @vlandesc has been set to Local-Office. So the code parses with 
the following output: 

vlan database 

vlan 1 

description Local-Office 

exit 

Conditional Statements 

Requirements for defining conditional statements within your templates are: 

 Follow the traditional if/else logical pattern 

If (condition is true) 

CLI 

{ 

execute commands 

} 

Else 

CLI 

{ 

execute other commands 

} 

 Enclose the statement within parentheses 

If (condition is true)… 

 Limit use of operators to these: 

== Is Equal To  
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> Is Greater Than  

>= Is Greater Or Equal To  

< Is Less Than  

<= Is Less Or Equal To  

!= Is Not Equal To  

Contains 

containsExact (case sensitive) 

startsWith 

startsWithExact (case sensitive) 

endsWith 

endsWithExact (case sensitive) 

 Use single quotes around string values in comparisons 

if (@ITF.Name=='FastEthernet0/1') 

 The commands to execute when the condition is true must be wrapped in 
curly braces { } as must the commands to execute for the else part of the 
statement. 

Note: The else section of the statement is optional.  

ForEach Statements 

A ForEach statement iterates through a collection of SWIS entity values. 
ForEach statements use the following pattern: 

 

foreach (@item in @EntityCollection) 

CLI 

{ 

execute commands 

} 

This first example would iterate through every interface on a node: 

foreach (@ITF in @Node.Interfaces) 

{ 

  CLI 

  { 
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    interface (@ITF.InterfaceName) 

    switchport access (@vlanid) 

    exit 

  } 

} 

This second example would iterate through every interface within the @ifs list: 

script iterateInterfaces( 

    NCM.Nodes @ContextNode, 

    int @vlanid, 

    NCM.Interfaces[] @ifs 

) 

{ 

  foreach (@ITF in @ifs) 

  { 

    CLI 

    { 

      interface @ITF.InterfaceName 

      switchport access @vlanid 

      exit 

    } 

  } 

}  

Example 1: Enable NetFlow on Cisco ASAs 

The Enable NetFlow on Cisco ASAs config change template automatically 
installs with the NCM software. It configures your Cisco ASA for NetFlow export.  

A sample output of CLI commands from executing this template would look like 
this:  

configure terminal 

flow-export destination inside 10.10.18.157 2055 
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flow-export template timeout-rate 1 

flow-export delay flow-create 60 

logging flow-export syslogs disable 

access-list netflow-export extended permit ip any any 

class-map netflow-export-class 

match access-list netflow-export 

policy-map netflow-policy 

class netflow-export-class 

flow-export event-type all destination 10.10.18.157 

service-policy netflow-policy global 

flow-export enable 

exit 

end  

You could execute this set of CLI commands on your target device and the result 
would be config changes in the status of NetFlow data processing by the device. 

The config change template that produces this output of CLI commands would 
be: 

/* 

.CHANGE_TEMPLATE_DESCRIPTION 

    This change template configures your Cisco ASA for NetFlow 

export. This was verified on an ASA 5505 running ASA software 

version 8.2(1)12. 

.CHANGE_TEMPLATE_TAGS 

    Cisco, ASA, NetFlow 

.PLATFORM_DESCRIPTION 

    Cisco ASA 

.PARAMETER_LABEL @ContextNode 

    NCM Node 

.PARAMETER_DESCRIPTION @ContextNode 
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    The node the template will operate on. All templates require 

this by default. The target node is selected during the first part 

of the wizard so it will not be available for selection when 

defining variable values.  

.PARAMETER_LABEL @NetFlowCollectorIPAddress 

    NetFlow Collector IP Address 

.PARAMETER_DESCRIPTION @NetFlowCollectorIPAddress 

    Enter the IP address of the server running the NetFlow traffic 

analysis solution (e.g. SolarWinds Orion NetFlow Traffic Analyzer) 

.PARAMETER_LABEL @NetFlowExportPort 

    NetFlow Export Port 

.PARAMETER_DESCRIPTION @NetFlowExportPort 

    Enter the NetFlow export port (default for SolarWinds Orion 

NTA is 2055). 

*/ 

 

script EnableNetflowOnCiscoASA (  

    NCM.Nodes @ContextNode,  

    string @NetFlowCollectorIPAddress,  

    int @NetFlowExportPort ) 

{ 

    // Enter config terminal mode and generate NetFlow commands 

    CLI  

    { 

configure terminal 

        flow-export destination inside @NetFlowCollectorIPAddress 

@NetFlowExportPort 

        flow-export template timeout-rate 1 

        flow-export delay flow-create 60 

        logging flow-export syslogs disable 

        access-list netflow-export extended permit ip any any 
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        class-map netflow-export-class 

        match access-list netflow-export 

        policy-map netflow-policy  

        class netflow-export-class 

        flow-export event-type all destination 

@NetFlowCollectorIPAddress 

        service-policy netflow-policy global 

        flow-export enable  

        exit 

        end 

    } 

} 

Parameters 

The parameters defined at the beginning of this script create an interface in 
which the user types the IP address and port of the NetFlow receiver.  

.PARAMETER_LABEL @NetFlowCollectorIPAddress 

    NetFlow Collector IP Address 

.PARAMETER_DESCRIPTION @NetFlowCollectorIPAddress 

    Enter the IP address of the server running the NetFlow traffic 

analysis solution (e.g. SolarWinds Orion NetFlow Traffic Analyzer) 

.PARAMETER_LABEL @NetFlowExportPort 

    NetFlow Export Port 

.PARAMETER_DESCRIPTION @NetFlowExportPort 

    Enter the NetFlow export port (default for SolarWinds Orion 

NTA is 2055). 

The first line defines the parameter or variable name (in this case, 
@NetFlowCollectorIPAddress) for which the user enters a value in a wizard 
interface text box at runtime. The second line defines the label (in this case, 
NetFlow Collector IP Address) that appears in the wizard interface to prompt the 
user to enter the appropriate IP address. The third and fourth lines define the 
description that appears below the wizard interface text box.  
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The parameters for NetFlow Export Port (in lines 5-12) function exactly the same 
way as the first four. Together, by taking in specific user input, the parameter 
variables, labels, and descriptions guide the config change template’s runtime 
execution. 

Arguments and Commands 

The script declaration includes all the variables for which the template prompts 

the user to provide input. In this case, three variables and their data types are 
declared:  

script EnableNetflowOnCiscoASA ( 

    NCM.Nodes @ContextNode,  

    string @NetFlowCollectorIPAddress,  

    int @NetFlowExportPort    ) 

{ 

NCM.Nodes is applied to the @ContextNode variable. NCM.Nodes refers to the 
Nodes entity in the SolarWinds Information Service (SWIS). In the interface 
wizard, the user will enter a string value for the NetFlow Collector IP Address and 
an integer value for the NetFlow Export Port on the device. 

For a complete list of entities and properties, see SolarWinds Information 
Services Data Entities. 

Native Commands 

The majority of config change template code outputs original CLI commands with 
only a few parsed variables. Any time a variable is referenced, a value is used in 
its place. For example, in this case, since the the user has typed 10.10.18.157 as 
the IP address, and 2055 as the collector port number, 
NetFlowCollectorIPAddress will be replaced with 10.10.18.157 and 
@NetFlowExportPort will be replaced with 2055 when the script runs.  

flow-export destination inside @NetFlowCollectorIPAddress 

@NetFlowExportPort 

The previous line of code would generate the following output:  

flow-export destination inside 10.10.18.157 2055 

Example2: Change VLAN Membership on Ports - Cisco IOS 

The Change VLAN Membership on Ports – Cisco IOS config change template 
automatically installs with the NCM integration module. It configures membership 
on your Cisco IOS devices.  

The output generated using this config change template would look like this: 
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configure terminal 

interface FastEthernet0/0 

no switchport access vlan 1004 

switchport access vlan 1002 

exit 

interface FastEthernet0/1 

no switchport access vlan 1004 

switchport access vlan 1002 

exit 

exit 

end 

You could execute this set of CLI commands on your target device and the result 
would be config changes in the VLAN membership of ports on that device. 

The config change template that produces this output of CLI commands would 
be: 

The config change template is written as follows:  

/* 

.CHANGE_TEMPLATE_DESCRIPTION 

        This change template configures VLAN membership on Cisco 

IOS devices.  The template was verified on Cisco 2950 Catalyst 

Switch running IOS software version 12.1(12c). 

.CHANGE_TEMPLATE_TAGS 

 Cisco, IOS, VLAN Membership 

.PLATFORM_DESCRIPTION 

        Cisco IOS 

 

.PARAMETER_LABEL @ContextNode 

        NCM Node 

.PARAMETER_DESCRIPTION @ContextNode 
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        The node the template will operate on.  All templates 

require this by default. The target node is selected during the 

first part of the wizard so it will not be available for selection 

when defining values of variables. 

 

.PARAMETER_LABEL @TargetPorts 

        Select Port(s) 

.PARAMETER_DESCRIPTION @TargetPorts 

        Select the port(s) for which you would like to change VLAN 

membership. 

 

.PARAMETER_LABEL @VlansToRemove 

        VLAN(s) to remove 

.PARAMETER_DESCRIPTION @VlansToRemove 

        Select the VLAN(s) you would like to remove. Selecting 

VLANs irrelevant to interfaces simply will result in no actions 

taken for those interfaces.  

 

.PARAMETER_LABEL @VlanToAssign 

        VLAN to assign      

.PARAMETER_DESCRIPTION @VlanToAssign 

        Select the VLAN you would like to assign. 

*/ 

 

 

 

script ConfigureVLANmembershipCiscoIOS (     

                                          NCM.Nodes @ContextNode,  

                                          NCM.Interfaces[] 

@TargetPorts,  

                                          NCM.VLANs[] 

@VlansToRemove, 
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                                          NCM.VLANs @VlanToAssign           

) 

{ 

  // Enter configuration mode 

  CLI  

  { 

   configure terminal 

  } 

  

  // Loop through selected ports 

  foreach (@portItem in @TargetPorts) 

  { 

    CLI 

    { 

       interface @portItem.InterfaceDescription 

    }  

     

    // Loop through list of vlans to remove 

    foreach (@vlanRemove in @VlansToRemove) 

    { 

       CLI  

       { 

          no switchport access vlan @vlanRemove.VLANID 

       } 

    } 

    CLI  

    { 

       switchport access vlan @VlanToAssign.VLANID 

    } 
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    CLI 

    { 

       exit 

    } 

  } 

 

  // Exit configuration mode 

  CLI 

  { 

    exit 

  } 

} 

The parameters defined at the beginning of the script prompt the user to select 
the ports that are to be changed, the VLAN to remove, and the VLAN to assign. 
The first line defines the parameter or variable name, in this case, @TargetPorts. 
The second line defines the label that appears next to the button that will prompt 
the user for information. The third and fourth lines define the description that 
appears when the user is prompted to select values. The following parameters 
(lines 5-12) are setup exactly the same way. 

.PARAMETER_LABEL @TargetPorts 

        Select port(s) 

.PARAMETER_DESCRIPTION @TargetPorts 

        Select the port(s) for which you would like to change VLAN 

membership 

.PARAMETER_LABEL @VlansToRemove 

        VLAN(s) to remove 

.PARAMETER_DESCRIPTION @VlansToRemove 

        Select the VLAN(s) you would like to remove. Please note, 

if you select VLANs not currently assigned to the interface, it 

will not cause any issues as the command will simply fail when run 

on that interface 

.PARAMETER_LABEL @VlanToAssign 
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        VLAN to assign      

.PARAMETER_DESCRIPTION @VlanToAssign 

        Select the VLAN you would like to assign  

The next lines of code create four variables (@ContextNode, @TargetPort, 
@VLANsToRemove, and @VLANToAssign) and pass values from the device 
inventory tables through SWIS to the associated variables. In this example, 
NCM.Nodes is applied to the @ContextNode variable. NCM.Nodes refers to the 
Nodes entity in SWIS.  

script ConfigureVLANmembershipCiscoIOS (     

    NCM.Nodes @ContextNode,  

    NCM.Interfaces[] @TargetPorts,  

    NCM.VLANs[] @VlansToRemove, 

    NCM.VLANs[] @VlanToAssign 

    )  

The template code opens the configuration terminal on the network device, just 
as if you were typing it in the CLI. 

  CLI  

  { 

   configure terminal 

  } 

The looping code contains the bulk of the script work, running once for every port 
selected by the user. The foreach (value in object) command iterates the code 
based on the number of items found in the object. Any variable parses to its 
value. For example, in this case, the user selected "FastEthernet0/0" as a port to 
change. So, when the script runs, FastEthernet0/0 replaces 
@portItem.InterfaceDescription.  

  foreach (@portItem in @TargetPorts) 

  { 

    CLI 

    { 

       interface @portItem.InterfaceDescription 

    }  
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    foreach (@vlanRemove in @VlansToRemove) 

    { 

       CLI  

       { 

          no switchport access vlan @vlanRemove.VLANID 

       } 

    } 

    CLI  

    { 

       switchport access vlan @VlanToAssign.VLANID 

    } 

    CLI 

    { 

       exit 

    } 

  } 

 

The last lines of code end the configuration session on the network device: 

  CLI 

  { 

    exit 

  } 

For a complete list of entities and properties, see SolarWinds Information 
Services Data Entities.  

SolarWinds Information Services Data Entities 

The following tables document all the SWIS entities and properties that you can 
use in developing config change templates.  
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NCM.ArpTables 

Property Name Datatype Description 

InterfaceIndex System.Int32 

The interface on which this entry's equivalence is 
effective. The interface identified by a particular value of 
this index is the same interface as identified by the 
same value of RFC 1573's ifIndex. 

InterfaceID System.String A unique GUID ID from ncm.Interfaces table. 

MAC System.String The media dependent `physical' address. 

IPAddress System.String 
The IP address corresponding to the media dependent 
physical address. 

IPSort System.Double 
A list of IP addresses sorted with octet markers (dots) 
omitted. 

Source System.String 

The type of IP address associated with an ARP 
operation and media dependent address. 
 
Possible Values: 
Other (1) 
Invalid (2) 
Dynamic (3) 
Static (4) 
 
Setting this object to the value invalid (2) has the effect 
of invalidating the corresponding entry in the 
ipNetToMediaTable. That is, it effectively disassociates 
the interface identified with said entry from the mapping 
identified with said entry. It is an implementation specific 
matter as to whether the agent removes an Invalidated 
entry from the table. Accordingly, management stations 
must be prepared to receive tabular information from 
agents that corresponds to entries not currently in use. 
Proper interpretation of such entries requires 
examination of the relevant ipNetToMediaType object. 

RDNSLookup System.String Result of DNS lookup on IPAddress. 

NodeID System.String 

A SWIS-generated unique identifier of a network node 
in the current inventory. (Instances of this property recur 
in this table according to the number of interfaces for 
which ARP data is reported.) 

LastDiscovery System.DateTime 
A SWIS-generated date and time marker for when NCM 
last discovered the device during inventory. 

FirstDiscovery System.DateTime 
A SWIS-generated date and time marker for when NCM 
first discovered the device during inventory. 

NCM.ARPTables Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsArpTables (System.Hosting) 

 

NCM.BridgePorts 

Property Name Datatype Description 

InterfaceIndex System.Int32 
The value of the instance of the ifIndex object, defined 
in MIB-II, for the interface corresponding to this port. 

Port System.Int32 
The port number of the port for whichthis entry contains 
bridge management information. 

SpanningTreeEnabled System.String 
The enabled/disabled status of the port. 
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Property Name Datatype Description 

Possible Values: 
Enabled (1) 
Disabled (2) 

SpanningTreeState System.String 

The port's current state as defined by application of the 
Spanning Tree Protocol. This state controls what action 
a port takes on reception of a frame. If the bridge has 
detected a port that is malfunctioning it will place that 
port into the broken(6) state. For ports which are 
disabled (see dot1dStpPortEnable), this object will 
have a value of disabled(1). 

VlanType System.String 

The type of VLAN membership assigned to this port. A 
port with static VLAN membership is assigned to a 
single VLAN directly. A port with dynamic membership 
is assigned a single VLAN based on content of packets 
received on the port and through VQP queries to 
VMPS. A port with multiple VLAN membership may be 
assigned to one or more VLANs directly. A static or 
dynamic port membership is specified by the value of 
vmVlan. A multiVlan port membership is specified by 
the value of vmVlans. 
 
Possible Values: 
Static(1) 
Dynamic(2) 
MultiVlan(3) 

VLANID System.Int32 

The VLAN id of the VLAN the port is assigned to  
 when vmVlanType is set to static or dynamic. This 
object is not instantiated if not applicable.  
  
 The value may be 0 if the port is not assigned to a 
VLAN. 

PortStatus System.String 

An indication of the current VLAN status of the port. A 
status of inactive(1) indicates that a dynamic port does 
not yet have a VLAN assigned, or a port is assigned to 
a VLAN that is currently not active. A status of active(2) 
indicates that the currently assigned VLAN is active. A 
status of shutdown(3) indicates that the port has been 
disabled as a result of VQP shutdown response. 
 
Possible Values: 
inactive(1) 
active(2) 
shutdown(3) 

NodeID System.String 

A SWIS-generated unique identifier of a network node 
in the current inventory. (Instances of this property 
recur in this table according to the number of interfaces 
for which bridge port data is reported.) 

LastDiscovery 
System.DateT
ime 

A SWIS-generated date and time marker for when 
NCM last discovered the device during inventory. 

FirstDiscovery 
System.DateT
ime 

A SWIS-generated date and time marker for when 
NCM first discovered the device during inventory. 

 

NCM.BridgePorts Entity Relationships 
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Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsBridgePorts (System.Hosting) 

NCM.CatalystCards 

Property Name Datatype Description 

CardIndex System.Int32 
A unique value for each module within the  
 chassis. 

CardType System.Int32 

The type of module. 
 
Possible Values: 
notdefined(0), version1(1), version2(2), 
version3(3),version4(4),version5(5),version6(6),version7(
7),version8(8),version9(9),version10(10),vi2(11), vi4(12), 
vi30(13), s1b(14), sa2(15), as16(16), new8as(17), 
lsa(18), fxs2(19), fxo2(20), em2(21), fxs4(22), fxo4(23), 
em4(24), sab(25), e1vi(26), am12(27), am6(28), 
ndec(29), newsa2(30), aux(31), console(32), sic-wan(33), 
sic-1fe(34), sic-1sa(35), sic-3as(36), sic-1e1(37), sic-
1t1(38), sic-1bu(39), sic-2bu(40), sic-1bs(41), sic-2bs(42), 
sic-1am(43), sic-2am(44), sic-1em(45), sic-2em(46), sic-
1fxs(47), sic-2fxs(48), sic-1fxo(49), sic-2fxo(50), 
fcm6(51), sa8(52), t11(53), t12(54), t14(55), t1vi(56), 
fcm4(57), fcm2(58), rtb21ce3(59), ame6(60), ame12(61), 
wsx5162(62), e11-f(65), e12-f(66), e14-f(67), t11-f(68), 
t12-f(69), t14-f(70), e11-f-17(71), t11-f-17(72), 
rtb21ct3(73), atmadsl1(74), atmadsl2(75), atm155m(76), 
ase8(77), ase16(78), sae4(79), sae2(80), wsx5012a(81), 
wsx5167(82), wsx5239(83), wsx5168(84), wsx5305(85), 
wsx5550(87), wsf5541(88), atmshdsl1(90), 
atmshdsl2(91), atmshdsl4(92), atm25m(93), atme3(94), 
atmt3(95), xdsl-fec(96), xdsl-adsl(97), xdsl-gshdsl(98), 
xdsl-bri(99), xdsl-scc(100), ge1(101), pos155m(102), 
cpos(103), fe1op(104), sae8(105), atm155m-mm(106), 
atm155m-sm(107), atm155m-sml(108), fe1op-sfx(109), 
fe1op-mfx(110), cpos-t1(111), ge1-op(112), ge2-op(113), 
ge2(114),fix-1wan(115), fix-1sae(116), cavium(117), sic-
1Eth(118), atm1ADSLI(119), atm2ADSLI(120), fix-
e11(121), fix-t11(122), e18-75(123), e18-120(124), 
t18(125),  sic-1vifxs(126), sic-1vifxo(127), sic-2vifxs(128), 
sic-2vifxo(129), xdsl-fec-new(130), xdsl-sa(131), 
bs4(132), ima-8e175(133), ima-8e1120(134).ima-
4e175(135),ima-4e1120(136), ima-8t1(137), ima-
4t1(138), sic-1t1f(139), sic-1e1f(140). fe4(149), 
atm1shdsl4wire(151), atmIma4shdsl(152). ls4(153). 
ls8(154), ls16(155). sic-adls2plus-isdn(156). sic-
adls2plus-pots(157), ft3(158), ce32(159), bsv2(160), 
bsv4(161). rpu(162). erpu(163). ssl(164), nsa(165), 
wsx6ksup12ge(200), wsx6408gbic(201). 
wsx6224mmmt(202). wsx6248rj45(203). 
wsx6248tel(204). wsx6302msm(206), wsf6kmsfc(207), 
wsx6024flmt(208), wsx6101oc12mmf(209), 
wsx6101oc12smf(210), wsx6416gemt(211), 
wsx61822pa(212), osm2oc12AtmMM(213), 
osm2oc12AtmSI(214), osm4oc12PosMM(216), 
osm4oc12PosSI(217), osm4oc12PosSL(218), 
wsx6ksup1a2ge(219), fe18-75(220). fe18-120(221). 
ft18(222), cf-card(223), bsv2-v2(224).  e1vi1-v2(225), 
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Property Name Datatype Description 

e1vi2(226), t1vi1-v2(227), t1vi2(228). osm(229), 
sd707(230), dm-epri(231), dm-tpri(232), erpu-h(233), 
wsf6kmsfc2(234), wsx6324mmmt(235), 
wsx6348rj45(236), wsx6ksup22ge(237), 
wsx6324sm(238), wsx6516gbic(239), 
osm4geWanGbic(240), osm1oc48PosSS(241), 
osm1oc48PosSI(242), osm1oc48PosSL(243), 
wsx6381ids(244), wsc6500sfm(245), 
osm16oc3PosMM(246), osm16oc3PosSI(247), 
osm16oc3PosSL(248), osm2oc12PosMM(249), 
osm2oc12PosSI(250), osm2oc12PosSL(251), 
wsx650210ge(252), osm8oc3PosMM(253), 
osm8oc3PosSI(254), osm8oc3PosSL(255), 
wsx6548rj45(258), wsx6524mmmt(259), 
wsx6066SlbApc(260), wsx6516getx(261), 
osm2oc48OneDptSS(265), osm2oc48OneDptSI(266), 
osm2oc48OneDptSL(267), 
osm2oc48OneDptSSDual(268), 
osm2oc48OneDptSIDual(269), 
osm2oc48OneDptSLDual(270), wsx6816gbic(271). 
osm4choc12T3MM(272), osm4choc12T3SI(273), 
osm8choc12T3MM(274), osm8choc12T3SI(275), 
osm1choc48T3SS(276), osm2choc48T3SS(277). 
wsx6500sfm2(278). osm1choc48T3SI(279), 
osm2choc48T3SI(280), wsx6348rj21(281), 
wsx6548rj21(282), wsSvcCmm(284), 
wsx650110gex4(285), osm4oc3PosSI(286). 
osm4oc3PosMM(289), wsSvcIdsm2(290), 
wsSvcNam2(291), wsSvcFwm1(292), wsSvcCe1(293). 
wsSvcSsl1(294). osm8choc3DS0SI(295), 
osm4choc3DS0SI(296), osm1choc12T1SI(297). 
wsx4012(300). wsx4148rj(301). wsx4232gbrj(302), 
wsx4306gb(303), wsx4418gb(304), wsx44162gbtx(305), 
wsx4912gb(306), wsx2948gbrj(307), wsx2948(309), 
wsx4912(310), wsx4424sxmt(311). wsx4232rjxx(312). 
wsx4148rj21(313), wsx4124fxmt(317), wsx4013(318). 
wsx4232l3(319), wsx4604gwy(320). wsx44122Gbtx(321). 
wsx2980(322), wsx2980rj(323), wsx2980gbrj(324). 
wsx4019(325). wsx4148rj45v(326), wsx4424gbrj45(330), 
wsx4148fxmt(331), wsx4448gblx(332), 
wsx4448gbrj45(334), wsx4148lxmt(337), 
wsx4548gbrj45(339). wsx4548gbrj45v(340). 
wsx4248rj21v(341), wsx4302gb(342), 
wsx4248rj45v(343), wsx2948ggetx(345), 
wsx2948ggetxgbrj(346), wsx6516aGbic(502), 
wsx6148getx(503), wsx6148x2rj45(506), 
wsx6196rj21(507), wssup32ge3b(509), 
wssup3210ge3b(510), mec6524gs8s(511), 
mec6524gt8s(512), me6524msfc2a(598), 
osm12ct3T1(600), osm12t3e3(601). osm24t3e3(602), 
osm4GeWanGbicPlus(603), osm1choc12T3SI(604). 
osm2choc12T3SI(605), osm2oc12AtmMMPlus(606), 
osm2oc12AtmSIPlus(607), osm2oc12PosMMPlus(608), 
osm2oc12PosSIPlus(609). osm16oc3PosSIPlus(610), 
osm1oc48PosSSPlus(611), osm1oc48PosSIPlus(612), 
osm1oc48PosSLPlus(613), osm4oc3PosSIPlus(614). 
osm8oc3PosSLPlus(615), osm8oc3PosSIPlus(616), 
osm4oc12PosSIPlus(617), wsSvcIpSec1(903), 
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Property Name Datatype Description 

wsSvcCsg1(911), wsx6148rj45v(912), 
wsx6148rj21v(913), wsSvcNam1(914), 
wsx6548getx(915), wsx6066SlbSk9(920), 
wsx6148agetx(921), wsx6148arj45(923), 
wsSvcWlan1k9(924), wsSvcAon1k9(925), 
ace106500k9(926). wsSvcWebVpnk9(927). 
wsx6148FeSfp(928), wsSvcAdm1k9(929), 
wsSvcAgm1k9(930), ace046500k9(936), 
wssup720(1001), wssup720base(1002). 
m7600Sip600(1004). wsx6748getx(1007). 
wsx670410ge(1008). wsx6748sfp(1009). 
wsx6724sfp(1010), wsx670810ge(1016). 
wsx65822pa(1101), m7600Sip200(1102). 
m7600Sip400(1103). c7600ssc400(1104). 
c7600ssc600(1105). esm2x10ge(1106), rsp720(1800). 
rsp720base(1801). c7600msfc4(1805)     

CardName System.String 
A descriptive string used by the network administrator to 
name the module. 

ModuleModel System.String The manufacturer's model number for the module. 

CardSerial System.String 

The serial number of the module. This MIB object will 
return the module serial number for any module that 
either a numeric or an alphanumeric serial number is 
being used. 

HWVersion System.String The hardware version of the module. 

FWVersion System.String The firmware version of the module. 

SWVersion System.String The software version of the module. 

Slot System.Int32 
This value is determined by the chassis slot number 
where the module is located. Valid entries are 1 to the 
value of chassisNumSlots 

Parent System.Int32 
The value of the instance of the entPhysicalIndex object, 
defined in ENTITY-MIB, for the entity physical index 
corresponding to this module 

OperStatus System.String 

The operational status of the module. If the status is not 
ok, the value of moduleTestResult gives more detailed 
information about the module's failure condition(s). 
 
Possible Values: 
other(1) 
ok(2) 
minorFault(3) 
majorFault(4) 

SlotsOnCard System.Int32 The number of ports supported by the module. 

NodeID System.String 

A SWIS-generated unique identifier of a network node in 
the current inventory. (Instances of this property recur in 
this table according to the number of interfaces for which 
card data is reported.) 

LastDiscovery System.DateTime 
A SWIS-generated date and time marker for when NCM 
last discovered the device during inventory. 

FirstDiscovery System.DateTime 
A SWIS-generated date and time marker for when NCM 
first discovered the device during inventory. 

NCM.CatalystCards Entity Relationships 
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Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsCatalystCards (System.Hosting) 

NCM.CiscoCards 

Property 
Name 

Datatype Description 

CardIndex System.Int32 
Index into cardTable (not physical chassis  
 slot number). 

CardType System.Int32 Functional type of this card. (integer value) 

CardName System.String 
Functional type of this card. (Parsed from type name 
value). 

CardDescr System.String Text description of this card. 

CardSerial System.String The serial number of this card, or zero if unavailable. 

HWVersion System.String 
Hardware revision level of this card, or an empty string if 
unavailable. 

SWVersion System.String 
Version of the firmware or microcode installed on this card, 
or an empty string if unavailable. 

Slot System.Int32 
Number of slots on this card, or 0 if no slots or not 
applicable, or -1 if not determinable. 

Parent System.Int32 

cardIndex of the parent card which  directly contains this 
card, or 0 if  
 contained by the chassis, or -1 if not  applicable nor 
determinable. 

OperStatus System.String 

The operational status of the card. cardOperStatus is up 
when a card is  recognized by the device and is enabled for 
operation. cardOperStatus is down if the card is not 
recognized by the device, or if it is not enabled for 
operation. cardOperStatus is standby if the card is enabled 
and acting as a standby slave. 
 
Possible Values: 
not-specified(1) 
up (2) 
down (3) 
standby (4) 
standbyMaster (5) 
activeMaster (6) 
outOfService (7) 
 masterBooting(8) 
activeMasterBooting(9) 
standbyMasterBooting(10) 
slaveBooting(11) 

SlotsOnCard System.Int32 
Number of slots on this card, or 0 if no slots or not 
applicable, or -1 if not  determinable 

NodeID System.String 

A SWIS-generated unique identifier of a network node in 
the current inventory. (Instances of this property recur in 
this table according to the number of interfaces for which 
card data is reported.) 

LastDiscovery System.DateTime 
A SWIS-generated date and time marker for when NCM 
last discovered the device during inventory. 

FirstDiscovery System.DateTime 
A SWIS-generated date and time marker for when NCM 
first discovered the device during inventory. 
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NCM.CiscoCards Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsCiscoCards (System.Hosting) 

NCM.CiscoCdp 

Property Name Datatype Description 

ifIndex System.Int32 
An indication of the type of address contained in 
the corresponding instance of cdpCacheAddress 
(parse just ifIndex from value for example 1,2,3) 

CDPIndex System.String 
An indication of the type of address contained in 
the corresponding instance of cdpCacheAddress 
(full value. For example 1.6, 2.108, 2.3 

RemoteDevice System.String 

The Device-ID string as reported in the most 
recent CDP message. The zero-length string 
indicates no Device-ID field (TLV) was reported in 
the most recent CDP message. 

RemoteIPAddress System.String 

The (first) network-layer address of the device's 
SNMP-agent as reported in the most recent CDP 
message. For example, if the the corresponding 
instance of cacheAddressType had the value 
'ip(1)', then this object would be an IP address. 

RemoteVersion System.String 

The Version string as reported in the most recent 
CDP message. The zero-length string indicates no 
Version field (TLV) was reported in the most 
recent CDP message. 

RemotePort System.String 

The Port-ID string as reported in the most recent 
CDP message. This will typically be the value of 
the ifName object (e.g., 'Ethernet0'). The zero-
length string indicates no Port-ID field (TLV) was 
reported in the most recent CDP message 

RemoteCapability System.String 

The Device's Functional Capabilities as reported 
in the most recent CDP message. For latest set of 
specific values, see the latest version of the CDP 
specification. The zero-length string indicates no 
Capabilities field (TLV) was reported in the most 
recent CDP message. 

RemotePlatform System.String 

The Device's Hardware Platform as reported in 
the most recent CDP message. The zero-length 
string indicates that no Platform field (TLV) was 
reported in the most recent CDP message. 

RemoteDuplex System.String 

The remote device's interface's duplex mode, as 
reported in the most recent CDP message. The 
value unknown(1) indicates no duplex mode field 
(TLV) was reported in the most recent CDP 
message. 
 
Possible Values: 
unknown(1) 
halfduplex(2) 
fullduplex(3) 

RemoteNativeVLAN System.Int32 

The remote device's interface's native VLAN, as 
reported in the most recent CDP message. The 
value 0 indicates no native VLAN field (TLV) was 
reported in the most recent CDP message 

NodeID System.String 
A SWIS-generated unique identifier of a network 
node in the current inventory. (Instances of this 
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Property Name Datatype Description 

property recur in this table according to the 
number of remote devices for which remote 
device data is reported.) 

LastDiscovery System.DateTime 
A SWIS-generated date and time marker for when 
NCM last discovered the device during inventory. 

FirstDiscovery System.DateTime 
A SWIS-generated date and time marker for when 
NCM first discovered the device during inventory. 

NCM.CiscoCdp Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsCiscoCdp (System.Hosting) 
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NCM.CiscoChassis 

Property Name Datatype Description 

chassisType System.Int32 

Chassis type (integer value). 
 
Possible Values: 
unknown(1) 
 multibus(2) 
agsplus(3) 

chassisName System.String 

Chassis type (parsed string value). 
 
Possible Values: 
unknown(1) 
multibus(2) 
agsplus(3) 

chassisVersion System.String 
Chassis hardware revision level, or an 
empty string if unavailable. 

chassisID System.String 
Unique ID string. Defaults to chassis serial 
number if available, otherwise empty. Can 
also be set with 'snmp-server chassis-id'. 

chassisSerialNumberString System.String 

The serial number of the chassis. This MIB 
object will return the chassis serial number 
for any chassis that either a numeric or an 
alphanumeric serial number is being used. 

romVersion System.String ROM monitor version. 

romSysVersion System.String 
ROM system software version or an empty 
string if unavailable. 

processorRAM System.Int32 Bytes of RAM available to CPU. 

nvRAMSize System.Int32 Bytes of nonvolatile configuration memory. 

nvRAMUsed System.Int32 
Bytes of non-volatile configuration memory  
 in use. 

chassisSlots System.Int32 
Number of slots in this chassis, or -1 of 
neither applicable nor determinable. 

romID System.String 
This variable contains a printable octet 
string which contains the System Bootstrap 
description and version identification. 

whyReload System.String 
This variable contains a printable octet 
string which contains the reason why the 
system was last restarted. 

freeMem System.Int32 

Return the amount of free memory in bytes.  
 
Note: This MIB object is obsolete as of IOS 
release 11.1. IOS release 11.1 introduced 
the CISCO-MEMORY-POOL-MIB which 
better instruments all of the memory pools. 

NodeID System.String 

A SWIS-generated unique identifier of a 
network node in the current inventory. 
(Instances of this property recur in this table 
according to the number of nodes for which 
data is reported.) 

LastDiscovery System.DateTime 
A SWIS-generated date and time marker 
for when NCM last discovered the device 
during inventory. 

FirstDiscovery System.DateTime 
A SWIS-generated date and time marker 
for when NCM first discovered the device 
during inventory. 
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NCM.CiscoChassis Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsCiscoChassis (System.Hosting) 

NCM.CiscoFlash 

Property Name Datatype Description 

FlashSize System.Int32 
Total size of the Flash device. For a removable device, 
the size will be zero if the device has been removed. 

Name System.String 

Flash device name. This name is used to refer to the 
device within the system. Flash operations get directed 
to a device based on this name. The system has a 
concept of a default device. This would be the primary 
or most used device in case of multiple devices. The 
system directs an operation to the default device 
whenever a device name is not specified. The device 
name is therefore mandatory except when the 
operation is being done on the default devic, or the 
system supports only a single Flash device. The 
device name will always be available for a removable 
device, even when the device has been removed. 

FlashDescription System.String 

Description of a Flash device. The description is meant 
to explain what the Flash device and its purpose is. 
Current values are: System flash - for the primary 
Flash used to store full system images. Boot flash: for 
the secondary Flash used to store bootstrap images. 
The ciscoFlashDeviceDescr, 
CiscoFlashDeviceController (if applicable), and 
ciscoFlashPhyEntIndex objects are expected to 
collectively give all information about a Flash device. 
The device description will always be available for a 
removable device, even when the device has been 
removed. 

PartitionCount System.Int32 

Flash device partitions actually present. Number of 
partitions cannot exceed the minimum of 
ciscoFlashDeviceMaxPartitions and 
(ciscoFlashDeviceSize / 
ciscoFlashDeviceMinPartitionSize). Will be equal to at 
least 1, the case where the partition spans the entire 
device (actually no partitioning). A partition will contain 
one or more minimum partition units (where a 
minimum partition unit is defined by 
ciscoFlashDeviceMinPartitionSize). 
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Property Name Datatype Description 

MinPartitionSize System.Int32 

This object will give the minimum partition size 
supported for this device. For systems that execute 
code directly out of Flash, the minimum partition size 
needs to be the bank size. (Bank size is equal to the 
size of a chip multiplied by the width of the device. In 
most cases, the device width is 4 bytes, and so the 
bank size would be four times the size of a chip). This 
has to be so because all programming commands 
affect the operation of an entire chip (in our case, an 
entire bank because all operations are done on the 
entire width of the device) even though the actual 
command may be localized to a small portion of each 
chip. So when executing code out of Flash, one needs 
to be able to write and erase some portion of Flash 
without affecting the code execution. For systems that 
execute code out of DRAM or ROM, it is possible to 
partition Flash with a finer granularity (for eg., at erase 
sector boundaries) if the system code supports such 
granularity.  
  
This object will let a management entity know the 
minimum partition size as defined by the system. If the 
system does not support partitioning, the value will be 
equal to the device size in ciscoFlashDeviceSize. The 
maximum number of partitions that could be 
configured will be equal to the minimum of 
ciscoFlashDeviceMaxPartitions and 
(ciscoFlashDeviceSize / 
CiscoFlashDeviceMinPartitionSize) 

Controller System.String 

Flash device controller. The h/w card that actually 
controls Flash read/write/erase. Relevant for the AGS+ 
systems where Flash may be controlled by the MC+, 
STR or the ENVM cards, cards that may not actually 
contain the Flash chips. For systems that have 
removable PCMCIA flash cards that are controlled by 
a PCMCIA controller chip, this object may contain a 
description of that controller chip. Where irrelevant 
(Flash is a direct memory mapped device accessed 
directly by the main processor), this object will have an 
empty (NULL) string. 
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Property Name Datatype Description 

WriteProtectJumper System.String 

This object gives the state of a jumper (if present and 
can be determined) that controls the programming 
voltage called Vpp to the Flash device. Vpp is required 
for programming (erasing and writing) Flash. For 
certain older technology chips it is also required for 
identifying the chips (which in turn is required to 
identify which programming algorithms to use; different 
chips require different algorithms and commands). The 
purpose of the jumper, on systems where it is 
available, is to write protect a Flash device. On most of 
the newer remote access routers, this jumper is 
unavailable since users are not expected to visit 
remote sites just to install and remove the jumpers 
when upgrading software in the Flash device. The 
unknown(3) value will be returned for such systems 
and can be interpreted to mean that a programming 
jumper is not present or not required on those 
systems. On systems where the programming jumper 
state can be read back through a hardware register, 
the installed (1) or notInstalled (2) value will be 
returned. This object is expected to be used in 
conjunction with the ciscoFlashPartitionStatus object 
whenever that object has the readOnly(1) value. In 
such a case, this object will indicate whether the 
programming jumper is a possible reason for the 
readOnly state. 
 
Possible Values: 
installed(1) 
notInstalled(2) 
unknown(3) 

MaxPartitions System.Int32 

Max number of partitions supported by the system for 
this Flash device. Default will be 1, which actually 
means that partitioning is not supported. Note that this 
value will be defined by system limitations, not by the 
flash device itself (for eg., the system may impose a 
limit of 2 partitions even though the device may be 
large enough to be partitioned into 4 based on the 
smallest partition unit supported). On systems that 
execute code out of Flash, partitioning is a way of 
creating multiple file systems in the Flash device so 
that writing into or erasing of one file system can be 
done while executing code residing in another file 
system. For systems executing code out of DRAM, 
partitioning gives a way of sub-dividing a large Flash 
device for easier management of files. 
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Property Name Datatype Description 

Initialized System.DateTime 

System time at which device was initialized. For fixed 
devices, this will be the system time at boot up. For 
removable devices, it will be the time at which the 
device was inserted, which may be boot up time, or a 
later time (if device was inserted later). If a device 
(fixed or removable) was repartitioned, it will be the 
time of repartitioning. The purpose of this object is to 
help a management station determine if a removable 
device has been changed. The application should 
retrieve this object prior to any operation and compare 
with the previously retrieved value. Note that this time 
will not be real time but a running time maintained by 
the system. This running time starts from zero when 
the system boots up.  For a removable device that has 
been removed, this value will be zero. 

Removable System.String 

Whether Flash device is removable. Generally, only 
PCMCIA Flash cards will be treated as removable. 
Socketed Flash chips and Flash SIMM modules will 
not be treated as removable. Simply put, only those 
Flash devices that can be inserted or removed without 
opening the hardware casing will be considered 
removable. Further, removable Flash devices are 
expected to have the necessary hardware support: 1) 
on-line removal and insertion; 2) interrupt generation 
on removal or insertion. 

NodeID System.String 

A SWIS-generated unique identifier of a network node 
in the current inventory. (Instances of this property 
recur in this table according to the number of Cisco 
devices for which data is reported.) 

LastDiscovery System.DateTime 
A SWIS-generated date and time marker for when 
NCM last discovered the device during inventory. 

FirstDiscovery System.DateTime 
A SWIS-generated date and time marker for when 
NCM first discovered the device during inventory. 

NCM.CiscoFlash Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsCiscoFlash (System.Hosting) 

NCM.CiscoFlashFiles 

Property Name Datatype Description 

FlashFileName System.String 

Flash file name as specified by the user copying in the 
file. The name should not include the colon (:) character 
as it is a special separator character used to delineate 
the device name, partition name, and the file name. 

FlashFileSize System.Int32 
Size of the file in bytes. Note that this size does not 
include the size of the filesystem file header. File size will 
always be non-zero. 

FlashCheckSum System.String 

File checksum stored in the file header. This checksum is 
computed and stored when the file is written into Flash. It 
serves to validate the data written into Flash. Whereas 
the system will generate and store the checksum 
internally in hexadecimal form, this object will provide the 
checksum in a string form. The checksum will be 
available for all valid and invalid-checksum files. 
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Property Name Datatype Description 

FlashFileStatus System.String 

Status of a file. A file could be explicitly deleted if the file 
system supports such a user command facility. 
Alternately, an existing good file would be automatically 
deleted if another good file with the same name were 
copied in. Note that deleted files continue to occupy 
prime Flash real estate. 
 
A file is marked as having an invalid checksum if any 
checksum mismatch was detected while writing or 
reading the file. Incomplete files (files truncated either 
because of lack of free space or a network download 
failure) are also written with a bad checksum and marked 
as invalid. 
 
Possible Values: 
deleted(1) 
invalidChecksum(2) 
valid(3) 

NodeID System.String 

A SWIS-generated unique identifier of a network node in 
the current inventory. (Instances of this property recur in 
this table according to the number of Cisco devices for 
which data is reported.) 

LastDiscovery System.DateTime 
A SWIS-generated date and time marker for when NCM 
last discovered the device during inventory. 

FirstDiscovery System.DateTime 
A SWIS-generated date and time marker for when NCM 
first discovered the device during inventory. 

NCM.CiscoFlashFiles Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsCiscoFlashFiles (System.Hosting) 

NCM.CiscoImageMIB 

Property Name Datatype Description 

Name System.String The string of this entry. 

Value System.String The string of this entry. 

NodeID System.String 

A SWIS-generated unique identifier of a 
network node in the current inventory. 
(Instances of this property recur in this 
table according to the number of Cisco 
devices for which data is reported.) 

LastDiscovery System.DateTime 
A SWIS-generated date and time marker 
for when NCM last discovered the device 
during inventory. 

FirstDiscovery System.DateTime 
A SWIS-generated date and time marker 
for when NCM first discovered the device 
during inventory. 

NCM.CiscoImageMIB Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsCiscoImageMIB (System.Hosting) 
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NCM.CiscoMemoryPools 

Property Name Datatype Description 

PoolName System.String 

A textual name assigned to the memory 
pool. This object is suitable for output to a 
human operator, and may also be used to 
distinguish among the various pool types, 
especially among dynamic pools. 

PoolUsed System.Int32 
Indicates the number of bytes from the 
memory pool that are currently in use by 
applications on the managed device. 

PoolFree System.Int32 

Indicates the number of bytes from the 
memory pool that are currently unused on 
the managed device. Note that the sum of 
ciscoMemoryPoolUsed and 
ciscoMemoryPoolFree is the total amount 
of memory in the pool 

PoolLargestFree System.Int32 
Indicates the largest number of contiguous 
bytes from the memory pool that are 
currently unused on the managed device. 

NodeID System.String 

A SWIS-generated unique identifier of a 
network node in the current inventory. 
(Instances of this property recur in this 
table according to the number of Cisco 
devices for which data is reported.) 

LastDiscovery System.DateTime 
A SWIS-generated date and time marker 
for when NCM last discovered the device 
during inventory. 

FirstDiscovery System.DateTime 
A SWIS-generated date and time marker 
for when NCM first discovered the device 
during inventory. 

NCM.CiscoMemoryPools Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes 
NCM.NodeHostsCiscoMemoryPools 
(System.Hosting) 

NCM.EntityLogical 

Property Name Datatype Description 

Name System.String 

A textual description of the logical entity. This 
object should contain a string which identifies the 
manufacturer's name for the logical entity , and 
should be set to a distinct value for each version of 
the logical entity. 

TDomain System.String 

Indicates the kind of transport service by which 
thelogical entity receives network management 
traffic. Possible values for this object are presently 
found in the Transport Mappings for SNMPv2 
document (RFC 1906 [RFC1906]). 
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Type System.String 

An indication of the type of logical entity. This will 
typically be the OBJECT-IDENTIFIER name of the 
node in the SMI's naming hierarchy which 
represents the major MIB module, or the majority of 
the MIB modules, supported by the logical entity. 
For example: a logical entity of a regular 
host/router > mib-2 a logical entity of a 802.1d 
bridge -> dot1dBridge a logical entity of a 802.3 
repeater -> snmpDot3RptrMgmt If an appropriate 
node in the SMI's naming hierarchy cannot be 
identified , the value 'mib-2' should be used. 

Community System.String 

An SNMPv1 or SNMPv2C community-string which 
can be used to access detailed management 
information for this logical entity. The agent should 
allow read access with this community string (to an 
appropriate subset of all managed objects) and 
may also return a community string based on the 
privileges of the request used to read this object. 
Note that an agent may return a community string 
with read-only privileges, even if this object is 
accessed with a read-write community string. 
However, the agent must take care not to return a 
community string which allows more privileges than 
the community string used to access this object.  

TAddress System.String 

The transport service address by which the logical 
entity receives network management traffic, 
formatted according to the corresponding value of 
entLogicalTDomain. For snmpUDPDomain, a 
TAddress is 6 octets long, the initial 4 octets 
containing the IP-address in network-byte order 
and the last 2 containing the UDP port in network-
byte order. Consult 'Transport Mappings for 
Version 2 of the Simple Network Management 
Protocol' (RFC 1906 [RFC1906]) for further 
information on snmpUDPDomain. 

NodeID System.String 

A SWIS-generated unique identifier of a network 
node in the current inventory. (Instances of this 
property recur in this table according to the number 
of Cisco devices for which data is reported.) 

LastDiscovery System.DateTime 
A SWIS-generated date and time marker for when 
NCM last discovered the device during inventory. 

FirstDiscovery System.DateTime 
A SWIS-generated date and time marker for when 
NCM first discovered the device during inventory. 

NCM.EntityLogical Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsEntityLogical (System.Hosting) 
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NCM.EntityPhysical 

Property Name Datatype Description 

EntityName System.String 

The textual name of the physical entity. The value of 
this object should be the name of the component as 
assigned by the local device and should be suitable 
for use in commands entered at the device's 
`console'. This might be a text name, such as 
`console' or a simple component number (e.g. port or 
module number) , such as `1' , depending on the 
physical component naming syntax of the device. 
 
If there is no local name, or this object is otherwise 
not applicable, then this object contains a zero-length 
string. 
 
Note: The value of entPhysicalName for two physical 
entities will be the same in the event that the console 
interface does not distinguish between them, e.g., 
slot-1 and the card in slot-1. 

EntityDescription System.String 

A textual description of physical entity. This object 
should contain a string which identifies the 
manufacturer's name for the physical entity, and 
should be set to a distinct value for each version or 
model of the physical entity. 

EntityType System.String 

An indication of the vendor-specific hardware type of 
the physical entity. Note that this is different from the 
definition of MIB-II's sysObjectID. 
 
An agent should set this object to a enterprise-specific 
registration identifier value indicating the specific 
equipment type in detail. The associated instance of 
entPhysicalClass is used to indicate the general type 
of hardware device. 
 
If no vendor-specific registration identifier exists for 
this physical entity, or the value is unknown by this 
agent then the value { 0 0 } is returned. 

ContainedIn System.String 

The value of entPhysicalIndex for the physical entity 
which 'contains' this physical entity. A value of zero 
indicates this physical entity is not contained in any 
other physical entity. Note that the set of 'containment' 
relationships define a strict hierarchy; that is, 
recursion is not allowed. 
 
In the event a physical entity is contained by more 
than one physical entity (e.g. , double-wide modules) , 
this object should identify the containing entity with 
the lowest value of entPhysicalIndex. 

EntityClass System.String 

An indication of the general hardware type of the 
physical entity. An agent should set this object to the 
standard enumeration value which most accurately 
indicates the general class of the physical entity or the 
primary class if there is more than one. If no 
appropriate standard registration identifier exists for 
this physical entity, then the value 'other(1)' is 
returned. If the value is unknown by this agent, then 
the value 'unknown(2)' is returned. 
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Property Name Datatype Description 

Position System.Int32 

An indication of the relative position of this 'child' 
component among all its 'sibling' components. Sibling 
components are defined as entPhysicalEntries which 
share the same instance values of each of the 
entPhysicalContainedIn and entPhysicalClass 
objects.  

HardwareRevision System.String 

The vendor-specific hardware revision string for the 
physical entity. The preferred value is the hardware 
revision identifier actually printed on the component 
itself (if present). 
 
Note that if revision information is stored internally in 
a non-printable (e.g. binary) format, then the agent 
must convert such information to a printable format, in 
an implementation-specific manner. If no specific 
hardware revision string is associated with the 
physical component, or this information is unknown to 
the agent, then this object will contain a zero-length 
string. 

FirmwareRevision System.String 

The vendor-specific firmware revision string for the  
 physical entity. 
 
Note that if revision information is stored internally in 
a non-printable (e.g., binary) format , then the agent 
must convert such information to a printable format , 
in an implementation-specific manner. If no specific 
firmware programs are associated with the physical 
component, or this information is unknown to the  
 agent, then this object will contain a zero-length 
string. 

SoftwareRevision System.String 

The vendor-specific software revision string for the  
 physical entity. 
 
Note that if revision information is stored internally in 
a non-printable (e.g., binary) format, then the agent 
must convert such information to a printable format , 
in an implementation-specific manner. If no specific 
software programs are associated with the physical 
component, or this information is unknown to the 
agent, then this object will contain a zero-length 
string. 

Serial System.String 

The vendor-specific serial number string for the 
physical entity. The preferred value is the serial 
number string actually printed on the component itself 
(if present).  

Manufacturer System.String 

The name of the manufacturer of this physical 
component. The preferred value is the manufacturer 
name string actually printed on the component itself (if 
present).  

Model System.String 

The vendor-specific model name identifier string 
associated with this physical component. The 
preferred value is the customer-visible part number, 
which may be printed on the component itself. If the 
model name string associated with the physical 
component is unknown to the agent, then this object 
will contain a zero-length string. 

Alias System.String This object is an 'alias' name for the physical entity as 
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Property Name Datatype Description 

specified by a network manager, and provides a non-
volatile 'handle' for the physical entity. 

AssetID System.String 

This object is a user-assigned asset tracking identifier 
for the physical entity as specified by a network 
manager, and provides non-volatile storage of this 
information.  

FieldReplaceable System.String 

This object indicates whether or not this physical 
entity is considered a 'field replaceable unit' by the 
vendor. If this object contains the value 'true(1)' then 
this entPhysicalEntry identifies a field replaceable 
unit. For all entPhysicalEntries which represent 
components that are permanently contained within a 
field replaceable unit, the value 'false(2)' should be 
returned for this object. 

NodeID System.String 

A SWIS-generated unique identifier of a network node 
in the current inventory. (Instances of this property 
recur in this table according to the number of Cisco 
devices for which data is reported.) 

LastDiscovery 
System.DateTi
me 

A SWIS-generated date and time marker for when 
NCM last discovered the device during inventory. 

FirstDiscovery 
System.DateTi
me 

A SWIS-generated date and time marker for when 
NCM first discovered the device during inventory. 

NCM.EntityPhysical Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsEntityPhysical (System.Hosting) 

NCM. Interfaces 

Property Name Datatype Description 

InterfaceID System.String [Swis] 

InterfaceIndex System.Int32 

A unique value, greater than zero, for each 
interface. It is recommended that values are 
assigned contiguously starting from 1. The value 
for each interface sub-layer must remain 
constant at least from one reinitialization of the 
entity's network management system to the next 
reinitialization. 

InterfaceDescription System.String 

A textual string containing information about the 
interface. This string should include the name of 
the manufacturer, the product name and the 
version of the interface hardware/software. 

VLANID System.Int32 

The set of the device's member ports that belong 
to the VLAN. Each octet within the value of this 
object specifies a set of eight ports, with the first 
octet specifying ports 1 through 8, the second 
octet specifying ports 9 through 16, etc. Within 
each octet, the most significant bit represents 
the lowest numbered port, and the least 
significant bit represents the highest numbered 
port. Thus, each port of the VLAN is represented 
by a single bit within the value of this object. If 
that bit has a value of '1' then that port is 
included in the set of ports ; the port is not 
included if its bit has a value of '0'. A port 
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Property Name Datatype Description 

number is the value of dot1dBasePort for the 
port in the BRIDGE-MIB (RFC 1493). 

PortStatus System.String 

An indication of the current VLAN status of the 
port. A status of inactive(1) indicates that a 
dynamic port does not yet have a VLAN 
assigned, or a port is assigned to a VLAN that is 
currently not active. A status of active(2) 
indicates that the currently assigned VLAN is 
active. A status of shutdown(3) indicates that the 
port has been disabled as a result of VQP 
shutdown response. 
 
Possible Values: 
inactive(1) 
active(2) 
shutdown(3) 

VLANType System.Int32 The type of this VLAN 

InterfaceName System.String 

The textual name of the interface. The value of 
this object should be the name of the interface 
as assigned by the local device and should be 
suitable for use in commands entered at the 
device's `console'. This might be a text name, 
such as `le0' or a simple port number, such as 
`1' , depending on the interface naming syntax of 
the device. If several entries in the ifTable 
together represent a single interface as named 
by the device, then each will have the same 
value of ifName. If there is no local name, or this 
object is otherwise not applicable, then this 
object contains a 0-length string. 

InterfaceAlias System.String 
This object is an 'alias' name for the interface as 
specified by a network manager, and provides a 
non-volatile 'handle' for the interface.  

InterfaceType System.Int32 

The type of interface. Additional values for ifType 
are assigned by the Internet Assigned Numbers 
Authority (IANA), through updating the syntax of 
the IANAifType textual convention. 

InterfaceTypeName System.String 

The type of interface. Additional values for ifType 
are assigned by the Internet Assigned Numbers 
Authority (IANA), through updating the syntax of 
the IANAifType textual convention. 

InterfaceTypeDescription System.String 

The type of interface. Additional values for ifType 
are assigned by the Internet Assigned Numbers 
Authority (IANA), through updating the syntax of 
the IANAifType textual convention. 

InterfaceSpeed System.Single 

An estimate of the interface's current bandwidth 
in bits per second. For interfaces which do not 
vary in bandwidth or for those where no accurate 
estimation can be made, this object should 
contain the nominal bandwidth. If the bandwidth 
of the interface is greater than the maximum 
value reportable by this object then this object 
should report its maximum value (4, 294, 967, 
295) and ifHighSpeed must be used to report the 
interace's speed. For a sub-layer which has no 
concept of bandwidth, this object should be zero. 

MACAddress System.String The interface's address at its protocol sublayer. 
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Property Name Datatype Description 

The interface's media specific MIB must define 
the bit and byte ordering and format of the value 
contained by this object. For interfaces which do 
not have such an address (e.g. a serial line), this 
object should contain an octet string of zero 
length. 

AdminStatus System.String 

The desired state of the interface. The testing(3) 
state indicates that no operational packets can 
be passed. When a managed system initializes, 
all interfaces start with ifAdminStatus in the 
down(2) state. As a result of either explicit 
management action or per configuration 
information retained by the managed system, 
ifAdminStatus is then changed to either the up 
(1) or testing (3) states (or remains in the down 
(2) state). 

OperStatus System.String 

The current operational state of the interface. 
The testing (3) state indicates that no operational 
packets can be passed. If ifAdminStatus is down 
(2) then ifOperStatus should be down (2). If 
ifAdminStatus is changed to up (1) then 
ifOperStatus should change to up (1) if the 
interface is ready to transmit and receive 
network traffic; it should change to dormant(5) if 
the interface is waiting for external actions (such 
as a serial line waiting for an incomming 
connection) ; it should remain in the down (2) 
state if and only if there is a fault that prevents if 
from going to the up (1) state. 

InterfaceMTU System.Int32 

The size of the largest packet which can be 
sent/received on the interface, specified in 
octets. For interfaces that are used for 
transmitting network datagrams, this is the size 
of the largest network datagram that can be sent 
on the interface. 

LastChange 
System.DateTim
e 

The value of sysUpTime at the time the interface 
entered its current operational state. If the 
current state was entered prior to the last re-
initialization of the local network management 
subsystem, then this object contains a zero 
value. 

PhysicalInterface System.Char 
This object has the value 'true(1)' if the interface 
sublayer has a physical connector and the value 
'false(2)' otherwise. 

Promiscuous System.Char 

This object has a value of false(2) if this interface  
 only accepts packets/frames that are addressed 
to this station. This object has a value of true(1) 
when the station accepts all packets/frames 
transmitted on the media. The value true(1) is 
only legal on certain types of media. If legal, 
setting this object to a value of true(1) may 
require the interface to be reset before becoming 
effective. 
 
The value of ifPromiscuousMode does not affect 
the reception of broadcast and multicast 
packets/frames by the interface. 
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Property Name Datatype Description 

NodeID System.String 

A SWIS-generated unique identifier of a network 
node in the current inventory. (Instances of this 
property recur in this table according to the 
number of Cisco devices for which data is 
reported.) 

LastDiscovery 
System.DateTim
e 

A SWIS-generated date and time marker for 
when NCM last discovered the device during 
inventory. 

FirstDiscovery 
System.DateTim
e 

A SWIS-generated date and time marker for 
when NCM first discovered the device during 
inventory. 

 

NCM.Interfaces Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsInterfaces (System.Hosting) 

IpAddresses NCM.IpAddresses NCM.InterfaceHostsIpAddresses (System.Hosting) 

NCM.IpAddresses 

Property Name Datatype Description 

InterfaceIndex System.Int32 

The index value which uniquely identifies 
the interface to which this entry is 
applicable. The interface identified by  
 a particular value of this index is the same 
interface as  identified by the same value 
of RFC 1573's ifIndex. 

IPAddress System.String 
The IP address to which this entry's 
addressing information  
 pertains. 

IPAddrIPSort System.Double Store IP address in double representation 

SubnetMask System.String 

The subnet mask associated with the IP 
address of this entry. The value of the 
mask is an IP address with all the network 
bits set to 1 and all the hosts bits set to 0. 

InterfaceID System.String InterfaceId from interfaces table 

NodeID System.String 

A SWIS-generated unique identifier of a 
network node in the current inventory. 
(Instances of this property recur in this 
table according to the number of Cisco 
devices for which data is reported.) 

LastDiscovery System.DateTime 
A SWIS-generated date and time marker 
for when NCM last discovered the device 
during inventory. 

FirstDiscovery System.DateTime 
A SWIS-generated date and time marker 
for when NCM first discovered the device 
during inventory. 
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NCM.IpAddresses Entity Relationships 

Type Entity Joined Data Entity 

Interfaces NCM.Interfaces NCM.InterfaceHostsIpAddresses (System.Hosting) 

NCM.MacForwarding 

Property Name Datatype Description 

Port System.Int32 

Either the value '0' , or the port number of 
the port on which a frame having a source 
address equal to the value of the 
corresponding instance of 
dot1dTpFdbAddress has been seen. A 
value of '0' indicates that the port number 
has not been learned but that the bridge 
does have some forwarding/filtering 
information about this address (e.g. in the 
dot1dStaticTable). Implementors are 
encouraged to assign the port value to this 
object whenever it is learned even for 
addresses for which the corresponding 
value of dot1dTpFdbStatus is not 
learned(3). 

MAC System.String 
A unicast MAC address for which the 
bridge has forwarding and/or filtering 
information. 

Source System.String 

The status of this entry. The meanings of 
the values are: other(1) : none of the 
following. This would include the case 
where some other MIB object (not the 
corresponding instance of 
dot1dTpFdbPort, nor an entry in the 
dot1dStaticTable) is being used to 
determine if and how frames addressed to 
the value of  the corresponding instance of 
dot1dTpFdbAddress are being forwarded.  

NodeID System.String 

A SWIS-generated unique identifier of a 
network node in the current inventory. 
(Instances of this property recur in this 
table according to the number of Cisco 
devices for which data is reported.) 

LastDiscovery System.DateTime 
A SWIS-generated date and time marker 
for when NCM last discovered the device 
during inventory. 

FirstDiscovery System.DateTime 
A SWIS-generated date and time marker 
for when NCM first discovered the device 
during inventory. 

NCM.MacForwarding Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsMacForwarding (System.Hosting) 

NCM.Nodes 

Property Name Datatype Description 

AgentIP System.String 
Ip address of device entered by customer 
manually 
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Property Name Datatype Description 

Status System.Byte 

NCM only specific status of device: 
Unknown = 0 (not polled yet) 
Up = 1 (based on ICMP pool) 
Down = 2 (based on ICMP pool) 
Warning = 3 (based on ICMP pool) 
MonitoringDisabled = 10 (NCM node 
monitoring is disabled by user) 
UnManaged = 9 (device is unmanaged in 
NCM) 

Community System.String SNMP community string entered by user 

ReverseDNS System.String DNS name of device 

SysName System.String 
An administratively-assigned name for this 
managed node. By convention, this is the 
node's fully-qualified domain name. 

SysDescr System.String 

A textual description of the entity. This 
value should include the full name and 
version identification of the system's 
hardware type, software operating-system, 
and networking software. It is mandatory 
that this only contains printable ASCII 
characters. 

SysContact System.String 

The textual identification of the contact 
person for this managed node , together 
with information on how to contact this 
person 

SysLocation System.String 
The physical location of this node (e.g., 
`telephone closet, 3rd floor'). 

SystemOID System.String 

The vendor's authoritative identification of 
the network management subsystem 
contained in the entity. This value is 
allocated within the SMI enterprises 
subtree (1.3.6.1.4.1) and provides an easy 
and unambiguous means for determining 
`what kind of box' is being managed. For 
example, if vendor `Flintstones , Inc.' was 
assigned the subtree 1.3.6.1.4.1.4242 , it 
could assign the identifier 
1.3.6.1.4.1.4242.1.1 to its `Fred Router'. 

Vendor System.String 
Vendor of device- determined based on 
SystemOID. 

VendorIcon System.String 
Vendor icon of device- determined based 
on SystemOID. 

MachineType System.String 
Machine Type - determined based on 
SystemOID. 

LastBoot System.DateTime 
The time (in hundredths of a second) 
since the network management portion of 
the system was last re-initialized. 

OSImage System.String Determined based on SysDescr 

OSVersion System.String Determined based on SysDescr 

SNMPLevel System.Byte SNMP version selected by user (1,2 or 3) 

SNMPContext System.String SNMPv3 credentials entered by user 

SNMPUsername System.String SNMPv3 credentials entered by user 

SNMPAuthType System.String SNMPv3 credentials entered by user 

SNMPAuthPass System.String SNMPv3 credentials entered by user 

SNMPEncryptType System.String SNMPv3 credentials entered by user 

SNMPEncryptPass System.String SNMPv3 credentials entered by user 
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Property Name Datatype Description 

SNMPStatus System.String 
status of SNMP connection to device 
(OK,No SNMP support, SNMP error 
description if any)  

NodeID System.String 

A SWIS-generated unique identifier of a 
network node in the current inventory. 
(Instances of this property recur in this 
table according to the number of devices 
for which data is reported.) 

LastDiscovery System.DateTime 
A SWIS-generated date and time marker 
for when NCM last discovered the device 
during inventory. 

FirstDiscovery System.DateTime 
A SWIS-generated date and time marker 
for when NCM first discovered the device 
during inventory. 

NCM.Nodes Entity Relationships 

Type Entity Joined Data Entity 

Interfaces NCM.Interfaces NCM.NodeHostsInterfaces (System.Hosting)  

MacForwarding NCM.MacForwarding 
NCM.NodeHostsMacForwarding 
(System.Hosting)  

VLANs NCM.VLANs NCM.NodeHostsVLANs (System.Hosting)  

BridgePorts NCM.BridgePorts 
NCM.NodeHostsBridgePorts 
(System.Hosting)  

ArpTables NCM.ArpTables 
NCM.NodeHostsArpTables 
(System.Hosting)  

CiscoCards NCM.CiscoCards 
NCM.NodeHostsCiscoCards 
(System.Hosting)  

CiscoCdp NCM.CiscoCdp NCM.NodeHostsCiscoCdp (System.Hosting)  

CiscoChassis NCM.CiscoChassis 
NCM.NodeHostsCiscoChassis 
(System.Hosting)  

CiscoFlash NCM.CiscoFlash 
NCM.NodeHostsCiscoFlash 
(System.Hosting)  

CiscoFlashFiles NCM.CiscoFlashFiles 
NCM.NodeHostsCiscoFlashFiles 
(System.Hosting)  

CiscoImageMIB NCM.CiscoImageMIB 
NCM.NodeHostsCiscoImageMIB 
(System.Hosting)  

CiscoMemoryPools NCM.CiscoMemoryPools 
NCM.NodeHostsCiscoMemoryPools 
(System.Hosting)  

EntityLogical NCM.EntityLogical 
NCM.NodeHostsEntityLogical 
(System.Hosting)  

EntityPhysical NCM.EntityPhysical 
NCM.NodeHostsEntityPhysical 
(System.Hosting)  

PortsTcp NCM.PortsTcp NCM.NodeHostsPortsTcp (System.Hosting)  

PortsUdp NCM.PortsUdp NCM.NodeHostsPortsUdp (System.Hosting)  

RouteTable NCM.RouteTable 
NCM.NodeHostsRouteTable 
(System.Hosting)  

NCM.PortsTcp 

Property Name Datatype Description 

NodeID System.String 
The unique identifier of a network node 
subject to configuration actions. 

LastDiscovery System.DateTime Date and time NCM last discovered the 



 

 
Working with Command Scripts  189 

device during inventory. 

FirstDiscovery System.DateTime 
Date and time NCM first discovered the 
device during inventory. 

TCPLocalAddress System.String 

The local IP address for this TCP 
connection. In the case of a connection in 
the listen state which is willing to accept 
connections for any IP interface 
associated with the node , the value 
0.0.0.0 is used. 

TCPLocalPort System.Int32 
The local port number for this TCP 
connection. 

TCPLocalPortName System.String 
Port description based on TCPLocalPort 
value 

TCPRemoteAddress System.String 
The remote IP address for this TCP 
connection. 

TCPRemotePort System.Int32 
The remote port number for this TCP 
connection. 

TCPState System.String 

The state of this TCP connection.  
The only value which may be set by a 
management station is deleteTCB(12). 
Accordingly, it is appropriate for an agent 
to return a `badValue' response if a 
management station attempts to set this 
object to any other value. 
 
If a management station sets this object to 
the value deleteTCB(12) , then this has 
the effect of deleting the TCB (as defined 
in RFC 793) of the corresponding 
connection on the managed node, 
resulting in immediate termination of the  
connection.  
 
As an implementation-specific option, a 
RST segment may be sent from the 
managed node to the other TCP endpoint 
(note however that RST segments are not 
sent reliably). 

TCPRemotePortName System.String 
Port description based on 
TCPRemotePort value 

NCM.PortsTcp Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsPortsTcp (System.Hosting) 

NCM.PortsUdp 

Property Name Datatype Description 

NodeID System.String 
The unique identifier of a network node 
subject to configuration actions. 

LastDiscovery System.DateTime 
Date and time NCM last discovered the 
device during inventory. 

FirstDiscovery System.DateTime 
Date and time NCM first discovered the 
device during inventory. 

UDPAddress System.String 
The local IP address for this UDP listener. 
In the case of a UDP listener which is 
willing to accept datagrams for any IP 
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Property Name Datatype Description 

interface associated with the node, the 
value 0.0.0.0 is used. 

UDPPort System.Int32 
The local port number for this UDP 
listener. 

UDPPortName System.String 
Port description based on UDPPort value 
(like 161- SNMP) 

NCM.PortsUdp Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsPortsUdp (System.Hosting) 

NCM.RouteTable 

Property Name Datatype Description 

NodeID System.String 
The unique identifier of a network node 
subject to configuration actions. 

LastDiscovery System.DateTime 
Date and time NCM last discovered the 
device during inventory. 

FirstDiscovery System.DateTime 
Date and time NCM first discovered the 
device during inventory. 

InterfaceIndex System.Int32 

The index value which uniquely identifies 
the local interface through which the next 
hop of this route should be reached. The 
interface identified by a particular value of 
this index is the same interface as 
identified by the same value of ifIndex. 

InterfaceID System.String 

Indicate the mask to be logical-ANDed 
with the destination address before being 
compared to the value in the ipRouteDest 
field. For those systems that do not 
support arbitrary subnet masks , an agent 
constructs the value of the ipRouteMask 
by determining whether the value of the 
correspondent ipRouteDest field belong to 
a class-A , B , or C network , and then 
using one of:  
  
mask network  
255.0.0.0 class-A  
255.255.0.0 class-B  
255.255.255.0 class-C  
 
If the value of the ipRouteDest is 0.0.0.0 
(a default route) , then the mask value is 
also 0.0.0.0. It should be noted that all IP 
routing subsystems implicitly use this 
mechanism. 
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Property Name Datatype Description 

Destination System.String 

The type of route. Note that the values  
 direct(3) and indirect(4) refer to the notion 
of direct and indirect routing in the IP 
architecture. Setting this object to the 
value invalid(2) has the effect of 
invalidating the corresponding entry in the 
ipRouteTable object. That is, it effectively 
dissasociates the destination identified 
with said entry from the route identified 
with said entry. It is an implementation-
specific matter as to whether the agent 
removes an invalidated entry from the 
table. 
 
Accordingly, management stations must 
be prepared to receive tabular information 
from agents that corresponds to entries 
not currently in use. Proper interpretation 
of such entries requires examination of the 
relevant ipRouteType object. 
 
Possible Values: 
other(1) 
invalid(2) 
direct(3) 
indirect(4) 

Mask System.String 

The routing mechanism via which this 
route was learned. Inclusion of values for 
gateway routing protocols is not intended 
to imply that hosts should support those 
protocols. 
 
Possible Values: 
other(1) 
local(2) 
netmgmt(3) 
icmp(4) 
egp(5) 
ggp(6) 
hello(7) 
rip(8) 
is-is(9) 
es-is(10) 
ciscoIgrp(11) 
bbnSpfIgp(12) 
ospf(13) 
bgp(14) 

NextHop System.String 

The number of seconds since this route 
was last updated or otherwise determined 
to be correct. Note that no semantics of 
`too old' can be implied except through 
knowledge of the routing protocol by 
which the route was learned. 

RouteType System.String 

The IP address of the next hop of this 
route. (In the case of a route bound to an 
interface which is realized via a broadcast 
media, the value of this field is the agent's 
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Property Name Datatype Description 

IP address on that interface.) 

RouteProtocol System.String 

The primary routing metric for this route. 
The semantics of this metric are 
Zetermined by the routing-protocol 
specified in the route's ipRouteProto 
value. If this metric is not used, its value 
should be set to -1. 

RouteAge System.Int32 

An alternate routing metric for this route. 
The semantics of this metric are 
determined by the routing-protocol 
specified in the route's ipRouteProto 
value. If this metric is not used, its value 
should be set to -1. 

NextHopAS System.Int32 

An alternate routing metric for this route. 
The semantics of this metric are 
determined by the routing-protocol 
specified in the route's ipRouteProto 
value. If this metric is not used, its value 
should be set to -1. 

Metric1 System.Int32 

An alternate routing metric for this route. 
The semantics of this metric are 
determined by the routing-protocol 
specified in the route's ipRouteProto 
value. If this metric is not used, its value 
should be set to -1. 

Metric2 System.Int32 

An alternate routing metric for this route. 
The semantics of this metric are 
determined by the routing-protocol 
specified in the route's ipRouteProto 
value. If this metric is not used, its value 
should be set to -1. 

Metric3 System.Int32 

The index value which uniquely identifies 
the local interface through which the next 
hop of this route should be reached. The 
interface identified by a particular value of 
this index is the same interface as 
identified by the same value of ifIndex. 
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Property Name Datatype Description 

Metric4 System.Int32 

Indicate the mask to be logical-ANDed 
with the destination address before being 
compared to the value in the ipRouteDest 
field. For those systems that do not 
support arbitrary subnet masks, an agent 
constructs the value of the ipRouteMask 
by determining whether the value of the 
correspondent ipRouteDest field belong to 
a class-A, B, or C network, and then using 
one of:  
  
 mask network  
 255.0.0.0 class-A  
 255.255.0.0 class-B  
 255.255.255.0 class-C  
  
 If the value of the ipRouteDest is 0.0.0.0 
(a default route) , then the mask value is 
also 0.0.0.0. It should be noted that all IP 
routing subsystems implicitly use this 
mechanism. 

Metric5 System.Int32 

The type of route. Note that the values 
direct(3) and indirect(4) refer to the notion 
of direct and indirect routing in the IP 
architecture.  
  
Setting this object to the value invalid(2) 
has the effect of invalidating the 
corresponding entry in the ipRouteTable 
object. That is, it effectively dissasociates 
the destination identified with said entry 
from the route identified with said entry. It 
is an implementation-specific matter as to 
whether the agent removes an invalidated 
entry from the table. Accordingly, 
management stations must be prepared to 
receive tabular information from agents 
that corresponds to entries not currently in 
use. Proper interpretation of such entries 
requires examination of the relevant 
ipRouteType object. 
 
Possible Values: 
other(1) 
invalid(2) 
direct(3) 
indirect(4) 

NCM.RouteTable Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsRouteTable (System.Hosting) 

NCM.VLANs 

Property Name Datatype Description 

NodeID System.String The unique identifier of a network node 
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Property Name Datatype Description 

subject to configuration actions. 

LastDiscovery System.DateTime 
Date and time NCM last discovered the 
device during inventory. 

FirstDiscovery System.DateTime 
Date and time NCM first discovered the 
device during inventory. 

VLANID System.Int32 

The set of the device's member ports that 
belong to the VLAN. Each octet within the 
value of this object specifies a set of eight 
ports, with the first octet specifying ports 1 
through 8, the second octet specifying ports 
9 through 16, etc. Within each octet, the 
most significant bit represents the lowest 
numbered port, and the least significant bit 
represents the highest numbered port. 
Thus, each port of the VLAN is represented 
by a single bit within the value of this object. 
If that bit has a value of '1' then that port is 
included in the set of ports ; the port is not 
included if its bit has a value of '0'. A port 
number is the value of dot1dBasePort for 
the port in the BRIDGE-MIB (RFC 1493). 

VLANName System.String 
The name of this VLAN. This name is used 
as the ELAN-name for an ATM LAN-
Emulation segment of this VLAN. 

VLANMTU System.Int32 

The MTU size on this VLAN, defined as the 
size of largest MAC-layer (information field 
portion of the) data frame which can be 
transmitted on the VLAN. 

VLANType System.Int32 The type of this VLAN 

VLANState System.Int32 

The state of this VLAN.  
  
Possible Values: 
operational(1) 
suspended(2) 
mtuTooBigForDevice(3) 
mtuTooBigForTrunk(4) 

NCM.VLANs Entity Relationships 

Type Entity Joined Data Entity 

Node NCM.Nodes NCM.NodeHostsVLANs (System.Hosting) 
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Chapter 9 

Managing Inventory 

The robust inventory engine of Orion Network Configuration Manager 
compliments the configuration management functions of the product. Inventory 
can be performed on all of your nodes, on node groups, or on single nodes. You 
can view collected inventory statistics in the detail view of each device. 

Running a Complete Inventory Scan 

To perform an inventory of all nodes managed by Orion Network Configuration 
Manager, click Inventory > Start Full Inventory. 

Note: A full inventory scan can take anywhere from a few minutes to several 
hours to complete. The time period varies based on the number of nodes and the 
type of statistics you want to collect. For more information on how to establish 
which statistics are collected, see “Adjusting Inventory Settings” on page 198. 

Running Inventory Scans 

Complete the following procedure to run an individual inventory scan. 

To complete an individual inventory scan: 

1. Click a node or a group of nodes in the left pane. 

2. Click Inventory > Inventory Selected Nodes. 

Scheduling an Inventory Scan 

A full inventory scan can be set to run on a schedule. Scheduled inventory scans 
are referred to as inventory jobs. 

To create a new inventory job: 

1. Click Inventory > Schedule Inventory. 

2. Type a name for the job, and then click Continue. 

3. Select the frequency of your job from the Schedule Job list. 

4. Type or select a time in the Start Time field. 

5. Type or select a date in the Starting On field. 
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6. Type or select a date in the Ending On field. To assign a job to run with no 
end date, leave this field blank. 

7. If you want to run the job daily, type a number in the Every days field to 
set the daily frequency. 

8. If you want to run the job weekly, complete the following procedure: 

a. Type a number in the Every weeks on field to set the frequency. 

b. Check the days of the week on which you want to run your job. 

9. If you are running your job monthly, complete the following procedure: 

a. Type a number in the Every months on field to set the frequency. 

b. Check each month in which you want to run your job. 

10. Click Continue. 

11. Type the Windows account name used to run the job. 

12. Type the password for the Windows account in the appropriate password 
fields. 

13. Click Finish. 

14. Type any comments in the Comments field. 

15. Click the Nodes tab. 

16. If you want to select the nodes on which the job will be run, complete 
the following procedure: 

a. Click All Nodes in the Database. 

b. Click Select Nodes Directly. 

c. Click Add Devices. 

d. Select the devices you want to add to the list. 

e. Click OK. 

17. If you want to run the job on a group of nodes that meet specific 
criteria, complete the following procedure: 

a. Click Select All Nodes in the Database. 

b. Click Specify a Selection Criteria. 

c. Click Browse, and then click Add a Simple Condition. 

d. Click the first asterisk, and then click the appropriate field. 



 

 
Managing Inventory  197 

e. If you want to change the comparison operator, click is equal to, and 
then click the comparison operator you want to use. 

f. Click the second asterisk, and then type the value or select it from the 
list. 

Note: All values currently in the database for the field are displayed 
when you browse the list. 

18. Click the Notifications tab. 

19. If you want to print the results, complete the following procedure: 

a. Check Print Results. 

b. Select a printer from the Printer list on the Printer Settings tab. 

20. If you want to write the results to a file, do the following 

a. Check Save Results To File. 

b. Click the File Settings tab. 

c. Type or browse to the file in which you want to write the results in the 
Path and Filename field. 

d. If you want to ignore results that do not contain errors, check Only 
save results if this job encounters an error during execution. 

21. If you want to email the results, complete the following procedure: 

a. Check E-Mail Results. 

b. Click the Email Settings tab. 

c. Type the email addresses to which you want to send the results in the 
To, CC and BCC fields. Use a semicolon to separate multiple email 
addresses. 

d. Type the subject of the email in the Subject field. 

22. If you want to log the job steps to a log file, check Log job steps to JOB-
#####.log. 

23. If you want to ensure that all Notification settings are configured 
properly, click Test Notifications. 

24. If you need to change the Windows account information, complete the 
following procedure: 

a. Click the Security tab. 

b. Type the Windows account name that will be used to run the job. 

c. Click Set Password. 

d. Type the password for the Windows account in the appropriate password 
fields, and then click OK. 
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Adjusting Inventory Settings 

Complete the following procedure to change your inventory settings. 

To change the statistics to collect during an inventory scan: 

1. Click Inventory > Inventory Settings. 

2. Check the statistics you want to collect, and then click OK. 

3. Click Inventory Engine Settings in the left pane. 

4. Adjust the slider to set the number of devices you want Orion Network 
Configuration Manager to scan concurrently. 

Note: Increasing the number of devices Orion Network Configuration 
Manager can scan concurrently increases the amount of system resources 
need during a scan. 

Viewing Inventory 

Complete the following procedure to view your inventory statistics. For more 
information, see “Running Inventory Scans” on page 195. 

To view your inventory statistics: 

1. Click a node in the left pane, and then click Nodes > Edit Selected Node. 

2. Click the Inventory tab. 

3. Click Inventory Details, and then click an inventory category. 
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Chapter 10 

Managing Inventory Reports 

Orion Network Configuration Manager includes several standard reports. These 
reports display configuration information for each node and statistics collected by 
the inventory engine. 

Viewing Reports 

Complete the following task to view a report. 

To view a report:  

1. Open the Orion Network Configuration Manager application. 

Note: If you do not have administrator privileges you may not be able to see 
some nodes or settings. 

2. Click Reports > View Report. 

3. Click the report you want to view, and then click OK. 

The available reports include the following: 

 Node Details 

o All Nodes 

o Current IOS Image and Version 

o Last Boot Time for each Device 

o Last Inventory of each Device 

o Backup Status of Running Config 

o Backup Status of Startup Config 

o System Information of each Device 

 Cisco Inventory 

o Cisco Card Data 

o Cisco Discovery Protocol 

o Cisco 3750 Stack – Physical Entity 

o Old Cisco Cards 

o Cisco Catalyst Cards 

o Cisco Chassis IDs 
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o Cisco Flash File System 

o Cisco Flash Memory 

o Cisco IOS Image Details 

o Memory in Cisco Devices 

o Cisco Memory Pools 

o ROM bootstrap for Cisco devices 

 Inventory 

o ARP Tables 

o IP Addresses on each Interface 

o Last status change for each Interface 

o Interfaces 

o Logical Entities 

o Physical Entities 

o Switch Ports 

o TCP Services 

o UDP Services 

 Audit 

o User Activity Tracking Report 

o Syslog Tracking Report 

 Security 

o Community Strings for each Node 

o Login Failure Report 

o Login information for each Device 

o Login Status 

 Polling Status 

o Device Polling Details 

o Down Nodes 

o Devices that do not respond to SNMP 

 Route Tables Inventory 
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o Route Tables 

 Windows Servers Inventory 

o Windows Accounts 

o Installed Services 

o Installed Software 

Creating and Editing Reports 

If the report you are looking for is not included with Orion Network Configuration 
Manager, new reports can be created. Complete the following procedure to 
create and modify your reports. 

To create a new report or edit an existing report: 

1. Open the Orion Network Configuration Manager application. 

Note: If you do not have administrator privileges you may not be able to see 
some nodes or settings. 

2. If you want to create a new report, complete the following procedure: 

a. Click Reports > New Report. 

b. Click Browse next to the Filename field 

c. Browse to a folder, and then type a filename. 

d. Click Save. 

Note: For a report to be included with the list of existing reports, it must 

be saved in the default folder (\Reports). 

3. If you want to edit an existing report, complete the following procedure: 

a. Click Reports > View Report. 

b. Click the report you want to view, and then click OK. 

c. Click Modify Report. 

4. Type a name for the report in the Report Title field. 

5. If you want a subtitle for your report, type the subtitle it in the Sub Title 
field. 

6. Type the name of the category into which you want to group the report in the 
Category field. 

7. If you want to add a description of the report, type a description and any 
other comments in the Description field. 

8. Click Portrait or Landscape to set the print orientation. 
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9. If you want to include device status in your report, click Display current 
device Up/Down Status  

10. If you want to group rows containing like values, click Group/Merge 
similar rows. 

11. Click Horizontal Lines, and then click the option you want to use in your 
report. 

12. Click the Select Fields tab. 

13. Click Type of Report, and then click the type of report you want to run. 

14. Click Group the Routers/Switches by, and then click a category by which 
to group your devices. You can use custom node properties when grouping 
nodes. For more information on how to add custom properties, see “Adding 
Custom Node Properties” on page 72. 

15. Select the properties you want to add in the All Properties list, and then click 
the Right Arrow to add them to the Selected Properties list. 

16. If you want to filter the results of your report, complete the following 
procedure: 

a. Click the Filter Results tab. 

b. Click Add Condition, and then click Add a Simple Condition. 

c. Click the first asterisk, and then click the appropriate field. 

d. If you want to change the comparison operator, click is equal to, and 
then click the comparison operator you want to use. 

e. Click the second asterisk, and then type the value or select it from the 
list. 

Note: All values currently in the database for the field are displayed 
when you browse the list. 

f. If you want to see the list of filtered nodes, click View Selected 
Nodes. 

g. If you want to limit the number of records by count, click Show only 
the Top XX Records, and then type the number of records you want to 
display. 

h. If you want to limit the number of records by percentage, click Show 
the Top ##% of Records to display, and then type the percentage of 
records you want to display. 

17. Click OK. 

18. If you want to save the report, click Save Changes. 
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Scheduling Reports 

Orion Network Configuration Manager allows you to schedule reports enabling 
you to send/receive email reports regularly. Complete the following task to 
schedule a report. 

To schedule a report: 

1. Open the Orion Network Configuration Manager application. 

Note: If you do not have administrator privileges you may not be able to see 
some nodes or settings. 

2. Click Reports > Schedule Report. 

3. Type a name for the job, and then click Next. 

4. Select the frequency of your job from the Schedule Job list. 

5. Type or select a time in the Start Time field. 

6. Type or select a date in the Starting On field. 

7. Type or select a date in the Ending On field. To assign a job to run with no 
end date, leave this field blank. 

8. If you want to run the job daily, type a number in the Every days field to 
set the daily frequency. 

9. If you want to run the job weekly, complete the following procedure: 

a. Type a number in the Every weeks on field to set the frequency. 

b. Check the days of the week on which you want to run your job. 

10. If you are running your job monthly, complete the following procedure: 

a. Type a number in the Every months on field to set the frequency. 

b. Check each month in which you want to run your job. 

11. Click Next. 

12. Type the Windows account name that will be used to run the job. 

13. Type the password for the Windows account in the appropriate password 
fields. 

14. Click Finish. 

15. Type any comments in the Comments field. 

16. Click the Report tab. 

17. Select the appropriate report. Only one report can be executed at a time. To 
execute more than one report, create a job for each additional report. 

18. Click the Report Destinations tab. 
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19. If you want to print the results, complete the following procedure: 

a. Check Print Results. 

b. Select a printer from the Printer list on the Printer Settings tab. 

20. If you want to write the results to a file, complete the following procedure: 

a. Check Save Results To File. 

b. Click the File Settings tab. 

c. Type or browse to the file in which you want to write the results in the 
Path and Filename field. 

d. If you want to ignore results that do not contain errors, check Only 
save results if this job encounters an error during execution. 

21. If you want to email the results, complete the following procedure: 

a. Check E-Mail Results. 

b. Click the Email Settings tab. 

c. Type the email addresses to which you want to send the results in the 
To, CC and BCC fields. Use a semicolon to separate multiple email 
addresses. 

d. Type the subject of the email in the Subject field. 

e. If you want to attach a PDF copy of the report, check Attach copy of 
Report in PDF format, and then specify a name for the pdf file. The 
name you provide will be the name of the generated pdf file. 

22. If you want to log the job steps to a log file, check Log job steps to JOB-
#####.log. 

23. If you want to ensure that all notification settings are configured 
properly, click Test Notifications. 

24. If you need to change the Windows account information, complete the 
following procedure: 

a. Click the Security tab. 

b. Type the Windows account name that will be used to run the job. 

c. Click Set Password. 

d. Type the password for the Windows account in the appropriate password 
fields. 

25. Click OK. 
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Deleting Reports 

Complete the following procedure to delete a report. 

To delete an existing report: 

1. Open the Orion Network Configuration Manager application. 

Note: If you do not have administrator privileges you may not be able to see 
some nodes or settings. 

2. Click Reports > View Report. 

3. Click the report you want to delete, and then click Delete Selected Reports. 

Exporting Reports 

 Complete the following procedure to export a report. 

To export report results: 

1. Launch the Orion NCM client application on your Orion NCM server.  

2. Click Reports > View Report.  

3. Select the report you want to export, and then click OK.  

4. Click File > Export, and then select the type of export you want. For 
example, click Export to Text File.  

5. Check or clear the appropriate fields, and then click OK.  

6. Provided a name and location for the exported file, and then click Save.  

7. Click OK on the Export status window.  

Printing Reports 

 Complete the following procedure to print a report. 

To print report results: 

 1. Launch the Orion NCM client application on your Orion NCM server.  

2. Click Reports > View Report.  

3. Select the report you want to print, and then click OK.  

4. Click File > Print.  

5. If you want to select specific columns to print, click File > Print Preview.  

1. Check or clear the appropriate fields, and then click OK.  

2. Review the Print Preview, and then click Print.  
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Chapter 11 

Managing Policy Reports 

Policy reports help ensure device configurations conform to both internal 
business practices and federal regulations, such as Sarbanes-Oxley Act (SOX), 
Health Insurance Portability and Accountability (HIPAA), and Computer Inventory 
of Survey Plans (CISP). Policy reports scan configuration files and report any 
discovered rule violations. For example, a rule requires configurations do not 

include the read-only community string public. You can run a report on your 

configuration files, and then display any configurations that violate the rule. Your 
policy report lists violations, including the line number where the violation 
occurred if applicable. Several example reports, policies, and rules are included 
with Orion Network Configuration Manager. 

Creating a Policy Report 

A policy report is a report that includes a collection of policies. A policy is a 
collection of rules. A report can contain several policies which, in turn, can 
contain several rules. 

 

To create a policy report: 

1. Log on to the Orion Web Console with an administrator account.  

2. Click Configs on the modules menu and select the Compliance view.  

3. Click Manage Policy Reports and then Add New Report. 

4. Type a name for your new report in Policy report name. 

5. Type a description in Description. 

6. If you want to assign this report to a folder, type a name in New folder 
name or select an existing folder from the Save in folder list. 

7. If you want to display a summary with the report, .check Include report 
summary.  
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8. If you want to also display rules without violations, check Show rules 
without violation. 

9. If you do not see your policy in the All Policies window (existing folders 
and subfolders), click Create a Policy. 

10. Click relevant policies from folders in All Policies and click Add.   

 The policies are placed in the Assigned Policies window. 

11. Click Submit.  

Creating a Policy 

A policy is a collection of rules against which device configurations are reviewed 
for compliance. Policies are used in producing reports on device compliance. 

To create a policy: 

1. Log on to the NCM Web Console with an administrator account. 

2. Select Configs on the modules menu and select the Compliance view. 

3. Click Manage Policy Reports. 

4.  Click Add New Policy onthe Manage Policies tab. 

5. Type a name for your new policy in Policy name. 

6. Type a description in Description. 

7. Select from the list the type of configuration you want to search with this 
policy. 

8. If you do not see your rule in the All Policy Rules window (existing 
folders and subfolders), click Create a Rule. 

9. Click relevant rules from folders in All Policy Rules and click Add.   

 The rules are placed in the Assigned Policy Rules window. 

10. Click Submit.  

 See these steps to include this policy in a report.  

Creating a Policy Rule 

A rule verifies policy compliance of a device by specifying a string that either 
must or must not be present in a configuration file. Rules are collected into 
policies and applied to specific network devices. Reports of policy violations are 
generated based on a schedule.  
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To create a rule: 

1. Log on to the Orion Web Console website with an administrator account. 

2. Click Configs on the modules menu and select the Compliance view.  

3. Click Manage Policy Reports . 

4. Click Add New Rule on the Manage Rules tab. 

5. Type a name for your new rule in Rule name. 

6. Type a description in Description. 

7. Click the alert level to associate with this rule. 

8. If you want to assign this rule to a folder, type a name in New folder 
name or select an existing folder from the Save in folder list. 

9. Click the type of alert trigger to associate with this alert. 

10. If you want to search the device config for a simple string, click the 
appropriate String Type and enter the text in the box. Otherwise, go to step 
10.  

11. If you want to search the device config for a text block, or by a regular 
expression, click Advanced Config Search. 
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a. Select the appropriate delimiter from the Must/Must Not Contain list.  

b. Select the appropriate type in the String Type list. 

c. Type your string or expression in the String box. 

 See Regular Expression Pattern Matching Examples for help with regular 
expressions.  

d. If you want to build conditions into your search, click Add Another 
String and create the string, as before.  

 Repeat this step for as many strings as you need to define your search. 

e. If needed, adjust the operators (And/Or) to determine relationships 
between strings in the execution of your search.  

 The default operator is ‘and’. 

f. If needed, use parentheses to group strings into conditional relationships 
and to establish relationships between string groups. 

 For example, if you had three strings defined, you might put opening and 
closing parentheses around the first two strings, linking the two with the 
‘and’ operator. And then you might use the ‘or’ operator to evaluate the 
last string by itself. The result will be a search that looks for both of the 
first two configs. If it finds them, the alert is triggered; if it doesn’t find 
them, but the last string is found, the alert is also triggered. Finally, the 
alert is triggered if both the first two strings and the last string are found. 

12. Select the search context under Search Config File/Block. 

13. As needed, create a script in the Remediation box to modify the lines of 
configuration if they do not comply with the policy rule. 

To function properly, a remediation script must include CLI statements that 
run on the relevant devices. When executed, the script runs through the 
default communication protocol (Telnet, SSH). Essentially, your script should 
put the device into configuration mode, make a series of config commands, 
and then logout. 

14. Click Test to validate the rule against a device configuration. 

a. Select a node and config against which to test the rule. 

b. Click Test Rule Against Selected Config.  

Notes:  

The rule testing feature is available only in the Orion Web Console 
integration. 

Test your rule against at least two nodes and configurations, one known to 
comply the rule, the other known not to comply.  
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In testing a rule against a non-compliant configuration, you see a result that 
includes the rule and its violation. For example, if you were attempting to 
disable Reverse-Telnet with your rule, you would see something like this in 
case the config under test violates the rule: 

Pattern ‘line con 0.*\n(.*\n)*.*transport input none’ was not 

found 

This tells you that the NCM policy software used the regular expression 
specified under String Matching to search the specified config file and no 
matches were found. Since it expected to find the specified string, the 
software generates an alert. 

c. Click Select Different Config to continue your rule test on another 
node/config. Repeat this step for as many spot checks you need to do 
among your network devices and configs. 

d. Click Close when your are finished testing with the rule. 

15. When you are ready to save the rule, click Submit. 

 See these steps to include this rule in a policy.  

Executing a Policy Report 

A policy report shows rule violations contained within the policies of the report. 

To execute a policy report: 

1. Select the policy report you want to execute in the Policy Reports list. 

2. Click Reports > Execute Selected Reports. 

Note: When viewing a report, mouse over any rule or violation icon to display 
a description of the item. 

3. To display and make changes to a configuration file that has violated a rule, 
right-click the violation icon, and then click View / Edit Config. 

4. If you find a violation and want to execute a script on the device to 
make a change, right-click the device name, and then click Remediate Rule 
Violation. For more information, see “Executing Command Scripts” on 
page 137. 
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Rules 

Rules describe what is to be found (or not found) in device configuration files. 
Rules contain the following properties: 

Property Description 

Name How the rule will be shown in display lists and Reports 

Description Description of the rule 

Alert Level Severity of the alert (informational, warning, critical) 

Grouping Folder to which the rule belongs 

Pattern Must Exist Whether the pattern should be found or not 

String Regular expression or string that defines the search object 

String Type Type of search expression (regular expression or find string) 

 

If the Advanced Config Search feature is activated, string matching includes 
these additional properties: 

Property Description 

And/Or Operator that defines the relationship between two strings 

Parentheses Operator that logically groups strings 

Must/Must Not 
Contain 

Determines if the alert triggers based on the presence or 
absence of a string 

String Regular expression or string that defines the search object 

String Type Type of search expression (regular expression or find string) 

 

Editing a Policy Rule 

If you need to modify a rule to update a change in your policies, you will need to 
edit the rule. Complete the following procedure to modify your rule. 

To edit a rule: 

1. Log on to the Orion Web Console website with an administrator account. 

2. Click Configs on the modules menu and select the Compliance view.  

3. Click Manage Policy Reports. 

4. Click the Manage Rules tab. 

5. Select the rule you want to edit, then click Edit.  

6. Edit the appropriate values. 
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 See Creating a Rule for information on working with the rule template. 

7. Review the rule details, and then click Submit. 

Deleting a Policy Rule 

Complete the following procedure to delete a rule. 

To delete an existing rule: 

1. Log on to the Orion Web Console website with an administrator account. 

2. Click Configs on the modules menu and select the Compliance view.  

3. Click Manage Policy Reports. 

4. Click the rule you want to delete, then click Delete.  

5. Click Yes. 

Policies 

A policy is a collection of one or more rules. These rules define the type of 
configuration file to search and the nodes that are included in the search. 

Editing a Policy 

If you need to modify a policy, complete the following procedure. 

To edit a policy: 

1. Log on to the Orion Web Console website with an administrator account. 

2. Click Configs on the modules menu and select the Compliance view.  

3. Click Manage Policy Reports. 

4.  Click the policy you want to edit, then click Edit.  

5. Edit the appropriate values. 

 See Creating a Policy for information on working with the policy template. 

6. Review the policy details, and then click Submit. 

Deleting a Policy 

Complete the following procedure to delete a policy. 

To delete a policy: 

1. Log on to the Orion Web Console website with an administrator account. 

2. Click Configs on the modules menu and select the Compliance view.  
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3. Click Manage Policy Reports. 

4.  Click the policy you want to delete, then click Delete.  

5. Click Yes. 

Policy Reports 

Reports provide a way to group policies, either by the devices that they will be 
executed against or by the type of report in which they are used. Report 
properties include Name, Comment, Grouping, and the policies included in the 
Report. 

Editing a Policy Report 

If you need to modify a report to update a change in your policies, complete the 
following procedure. 

To edit a report: 

1. Log on to the Orion Web Console website with an administrator account. 

2. Click Configs on the modules menu and select the Compliance view.  

3. Click Manage Reports, check the report you want to edit, then click Edit.  

4. Edit the appropriate values. 

 See Creating a Report for information on working with the policy template. 

5. Review the report details, and then click Submit  when you are satisfied with 
the new values. 

Note: When viewing a report, mouse over any rule or violation icon to display 
a description of the item. 

6. To display and make changes to a configuration file that has violated a rule, 
right-click the violation icon, and then click View / Edit Config. 

Generating a Policy Report 

Whenever you want to review a report for current compliance status, complete 
the following procedure. 

To generate a policy report: 

1. Log on to the Orion Web Console website with an administrator account. 

2. Click Configs on the modules menu and select the Compliance view.  

3. Click Manage Reports, then click the report in the list to generate a current 
version.  
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When viewing a report, mouse over any rule or violation icon to display a 
description of the item. 

4. Click View Config if you need or want to see the entire configuration file on 
which the report for this node is based. 

5. If you want to execute a remediation script for the specific node, click 
Execute Remediation Script on this Node. 

a. In the Execute Traffic Remediation Script resource, enter or modify the 
script so that it includes commands that will be accepted by your device. 

b.  Click Execute Script when you are ready to run the remediation script 
on the selected node. 

6. If you want to execute a remediation script for all nodes in violation of 
the specific rule, click Execute Remediation Script on All Nodes. 

a. In the Execute Traffic Remediation Script resource, enter or modify the 
script so that it includes commands that will be accepted by your 
devices. 

b. Click Select Nodes to confirm or modify the nodes against which your 
script will run. 

c. Click Execute Script when you are ready to run the remediation script 
on the selected nodes. 

 

Exporting a Policy Report (to thwack) 

 Use the following steps to share a policy report with your user community on 
thwack.com.  

To export a policy report: 

1. Log on to the Orion Web Console website with an administrator account. 

2. Click Configs on the modules menu and select the Compliance view.  

3. Check the relevant report in the folders under Manage Reports. 

4. Click Export to thwack. 

5. Enter your thwack credentials if prompted. 

6. Click Close. 

Exporting a Policy Report (as a file) 

 Use the following steps to a policy report on a file system.  

To export a policy report: 
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1. Log on to the Orion Web Console website with an administrator account. 

2. Click Configs on the modules menu and select the Compliance view.  

3. Check the relevant report in the folders under Manage Reports. 

4. Click Export as File. 

5. Find an appropriate location for the file on your computer and then click 
Save.  

Deleting a Report 

Complete the following procedure to delete a report. 

To delete an existing report: 

1. Log on to the Orion Web Console website with an administrator account. 

2. Click Configs on the modules menu and select the Compliance view.  

3. Click Manage Reports, click the report you want to edit, then click Delete.  

4. Click Yes. 

Scheduling a Policy Report 

A policy report can be scheduled to run at any time. 

To schedule a policy report: 

1. Open Orion Network Configuration Manager in the SolarWinds program 
group. 

2. Click Reports > Schedule Report.  

3. Type a name for the job, and then click Next. 

4. Select the frequency of the job from the Schedule Job list. 

5. Type or select a time in the Start Time field. 

6. Type or select a date in the Starting On field. 

7. Type or select a date in the Ending On field. To assign a job to run with no 
end date, leave this field blank. 

8. If you want to run the job daily, type a number in the Every days field to 
set the daily frequency. 

9. If you want to run the job weekly, complete the following procedure: 

a. Type a number in the Every weeks on field to set the frequency. 

b. Check the days of the week you want to run your job. 
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10. If you are running your job monthly, complete the following procedure: 

a. Type a number in the Every months on field to set the frequency. 

b. Check each month you want to run your job. 

11. Click Next. 

12. Type the Windows user account name for the job. 

13. Type the password for the user account in the appropriate password fields. 

14. Click Finish. 

15. Type any comments in the Comments field. 

16. Click Report. 

17. Select the policy report that is to be executed when the job is run. 

18. Click Report Destinations. 

19. If you want to print the results, complete the following procedure: 

a. Check Print Results. 

b. Select a printer from the Printer list on the Printer Settings tab. 

20. If you want to write the results to a file, complete the following procedure: 

a. Check Save Results To File. 

b. Click the File Settings tab. 

c. Type or browse to the file in which you want to write the results in the 
Path and Filename field. 

d. If you want to ignore results that do not contain errors, check Only save 
results if this job encounters an error during execution. 

21. If you want to email the results, complete the following procedure: 

a. Check E-Mail Results. 

b. Click the Email Settings tab. 

c. Type the email addresses to which you want to send the results in the 
To, CC and BCC fields. Use a semicolon to separate multiple email 
addresses. 

d. Type the subject of the email in the Subject field. 

22. If you want to log the job steps to a log file, check Log job steps to JOB-
#####.log. 

23. If you want to ensure that all Notification settings are configured 
properly, click Test Notifications. 
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24. If you need to change the Windows account information, complete the 
following procedure: 

a. Click the Security tab. 

b. Type the Windows account name that will be used to run the job. 

c. Click Set Password. 

d. Type the password for the Windows account in the appropriate password 
fields. 

25. Click OK. 

Modifying Policy Reporter Settings (Application) 

Complete the following procedure to modify the Orion Network Configuration 
Manager Policy Reporting settings. 

To adjust policy reporting settings: 

1. Open the Orion Network Configuration Manager Policy Reporter in the 
SolarWinds program group.  

2. Click File > Settings. 

3. Check the tabs you want to display on startup in the Startup Options group. 

4. If you want to group reports by the report group, check Use Grouping 
on Report List. 

5. Check the report display options you want to enable in the Report Options 
group. 

Understanding the Policy Cache 

The policy cache is automatically updated at 11:55 pm every evening. This 
refresh time is not modifiable. The policy cache data is used to display policy and 
compliance information in the Web Console.  

You can immediately refresh the policy cache and display the most up-to-date 
information on the Orion Web Console.  

To manually refresh the policy cache: 

1. On the Orion Web Console, select the Configs modules bar, then click the 
Compliance view. 

2. Click Update All to refresh the policy cache. 

When you run a policy report or a scheduled job from the Orion NCM application, 
the data returned is a snapshot of current policy compliance and does not rely on 
the policy cache.   
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Using the Policy Creation Wizard (Application Only) 

The Orion Network Configuration Manager Policy Reporting application is 
launched by clicking Reports > Orion Network Configuration Manager Policy 
Reporter from the Orion Network Configuration Manager application. 

The Policy Creation wizard allows you to create a complete policy report, 
including the creation of rules and policies. Complete the following procedure to 
create a policy report using the Policy Creation wizard. 

To create a policy report: 

1. Click File > Policy Creation Wizard. 

2. Review the welcome text, and then click Next. 

3. Review the introduction to rules, and then click Next. 

4. Click Walk me through creating a new Rule, and then click Next. 

5. Type a name for your new rule, and then click Next. 

6. Type any comments in the Comment field. 

7. If you want to assign this rule to a group, type a new group name in the 
Grouping field or select an existing group from the list. 

8. Click Next. 

9. If you want to use a regular expression for your search pattern, 
complete the following procedure: 

a. Set the Search Pattern Type to RegEx Expression. 

b. Type the expression in the Search Pattern field. For more information 
see “Regular Expression Pattern Matching” on page 309. 

Note: To view examples, click Example Search Patterns. 

10. If you want to use a simple expression for your search pattern, complete 
the following procedure: 

a. Select Simple Find for the search pattern type. The simple find 
expressions allow you to use the asterisk and question mark (?) 
characters as wildcard characters. 

b. Type the expression in the Search Pattern field.  

11. Click Found or Not Found to determine how violation is defined, and then 
click Next. 

12. Click Informational, Warning, or Critical to set the severity of your rule, and 
then click Next. 

13. Review the Rule Details, check Save This Rule, and then click Next. 
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14. Review the introduction to policies, and then click Next. 

15. Click Yes, Let’s Create a New Policy, and then click Next. 

16. Type a name for your new policy. 

17. Type any comments in the Comment field. 

18. If you want to assign this policy to a group, type a new group name in the 
Grouping field or select an existing group from the list. 

19. Click Next. 

20. If you want to select which devices the policy applies to, complete the 
following procedure: 

a. Click Add Devices. 

b. Select the devices you want to add to the list. 

c. Click OK. 

21. If you want your policy to apply to all devices, click Select Nodes 
Directly, and then click All Nodes in the Database. 

22. If you want your policy to apply to a specific group of nodes, complete 
the following procedure: 

a. Click Select Nodes Directly 

b. Click Specify Selection Criteria. 

c. Click Browse, and then click Add a Simple Condition. 

d. Click the first asterisk, and then click the appropriate field. 

e. If you want to change the comparison operator, click is equal to, and 
then click the comparison operator you want to use. 

f. Click the second asterisk, and then type the value or select it from the 
list. 

Note: All values currently in the database for the field are displayed 
when you browse the list. 

23. Click Next, and then check the configuration file types you want to search 
when executing this policy. Any searches the last downloaded configuration 
file, regardless of type. 

24. Click Next, and then select the rules in the All Rules list you want to add to 
your policy, and then click the Right Arrow to add the rules to the Assigned 
Rules list. 

25. Click Next, and then click Yes to save the new policy. 

26. Click Next, and then click Yes, Let’s Create a New Report, and then click 
Next. 
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27. Type a name for your new report. 

28. Type any comments in the Comment field. 

29. If you want to assign this report to a group, type a new group name in the 
Grouping field or select an existing group from the list. 

30. Click Next, and then select the policies in the All Policies list you want to 
add to your report, and then click the Right Arrow to add your selection to 
the Assigned Policies list. 

31. Click Next, and then click Yes to save the new report. 

32. Click Exit. 
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Chapter 12 

Scheduling Jobs 

Orion Network Configuration Manager provides configuration management job 
scheduling to help automate the management of network devices. 

You can schedule numerous operations, including configuration file uploads and 
downloads, node reboots, and command script execution. 

Creating a New Job 

Complete the following procedure to create a new job. Orion Network 
Configuration Manager takes advantage of proven Microsoft task scheduling 
technology and leverages it for the management of scheduled jobs. 

To create a new job: 

1. Click Schedule > Create New Job. 

2. Click the type of job you want to create, and then click Continue. 

3. Type a name for the job, and then click Continue. 

4. Select the frequency of the job from the Schedule Job list. 

5. Type or select a time in the Start Time field. 

6. Type or select a date in the Starting On field. 

7. Type or select a date in the Ending On field. 

Note: To assign a job to run with no end date, leave the Ending On field 
blank. 

8. If you want to run the job daily, type a number in the Every days field to 
set the daily frequency. 

9. If you want to run the job weekly, complete the following procedure: 

a. Type a number in the Every weeks on field to set the frequency. 

b. Check the days of the week on which you want to run your job. 

10. If you are running your job monthly, complete the following procedure: 

a. Type a number in the Every months on field to set the monthly-
frequency. 

b. Check each month in which you want to run your job. 

11. Click Next. 
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12. Type the Windows account name that will be used to run the job. 

13. Type the password for the Windows account in the appropriate password 
fields. 

14. Click Finish. 

15. Type any comments in the Comments field. 

16. If the job you are editing does not have a Nodes tab, skip to Step 20. 

17. Click the Nodes tab. 

18. If you want to select the nodes on which the job will run, complete the 
following procedure: 

a. Click All Nodes in the Database. 

b. Click Select Nodes Directly. 

c. Click Add Devices. 

d. Select the devices you want to add to the list. 

e. Click OK. 

19. If you want to run the job on a group of nodes that meet specific 
criteria, complete the following procedure: 

a. Click Select All Nodes in the Database. 

b. Click Specify Selection Criteria. 

c. Click Browse, and then click Add a Simple Condition. 

d. Click the first asterisk, and then click the appropriate field. 

e. If you want to change the comparison operator, click is equal to, and 
then click the comparison operator you want to use. 

f. Click the second asterisk, and then type the value or select it from the 
list. 

Note: All values currently in the database for the field are displayed 
when you browse the list. 

20. If the job you are editing does not have a Download Config tab, skip to 
step 33. 

21. Click the Download Config tab. 

22. Check the configuration types you want to download. 

23. If you want to be notified when the downloaded configuration file is 
different from the last configuration, check Last Config. 

24. If you want to be notified when the downloaded configuration file is 
different from the baseline configuration, check Baseline Config. 
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25. Check Send config change notification details in a separate text email 
and Send config change notification details in a separate HTML email as 
appropriate. These options allow you to separate change details from change 
notification. 

26. If you want the notification to ignore specific changes, complete the 
following procedure: 

a. Click Edit Comparison Criteria. 

b. Check the exclusions you want to enable. 

c. If you want to create a new exclusion, see “Creating New Config 
Change Report Exclusions” on page 100. 

d. Click Done. 

27. If you only want to save the configuration file when changes are found, 
check Only save Configs that have changed. 

28. If the job you are editing does not have a Command Script tab, skip to 
step 37. 

29. Click the Command Script tab. 

30. If you want to type a new script, type the command script that is to be 
executed in the text box provided. 

31. If you want to load an existing command script, complete the following 
procedure: 

a. Click Load Script From File. 

b. Browse to your command script file, and then click Open. 

32. If the job you are editing does not have a Reports tab, skip to step 40. 

33. Click the Reports tab. 

34. Select the report that is to be executed. 

Note: Only one report can be executed at a time. To execute more than one 
report, a new job will have to be created for each additional report. 

35. If the job you are editing does not have a Config Archive tab, skip to 
step 46. 

36. Click the Config Archive tab. 

37. Type a path for exporting the configuration files. 

38. Set the template for the filename structure. 

39. Select the types of configuration file to export. 

40. Choose whether to export all configurations, or only the last downloaded for 
each node. 
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41. If the job you are editing does not have a Program tab, skip to step 49. 

42. Click the Program tab. 

43. Click Browse, browse to the application that must be executed, and then click 
Open. 

44. If the job you are editing does not have a Config Change Report tab, 
skip to step 54. 

45. Click the Config Change Report tab. 

46. Select the type of config change report to generate. The choices are as 
follows: 

 Compare most recent Download to the last Baseline Config: This will 
display all the differences between the most recent baseline 
configuration, and the last downloaded configuration file. 

 Compare the most recent Download to the Configuration on: This will 
show you all differences between the most recent downloaded 
configuration file and a configuration file from the specified date. 

Note: If no configuration file was downloaded on the specified date, the 
next configuration file downloaded after that date will be used. 

 Show changes made over the past ## days: Shows you all changes that 
were made over the specified amount of days. 

 Show changes made between: Shows you all changes that were made 
over the specified date range. 

47. If you want the config change report to ignore specific changes, 
complete the following procedure: 

a. Click Edit Comparison Criteria. 

b. Check the exclusions you want to enable. 

c. If you want to create a new exclusion, see “Creating New Config 
Change Report Exclusions” on page 100. 

d. Click Done. 

48. If you want to see detailed changes between each configuration file, 
check Show detailed changes. 

Note: This will show each change from one configuration file to the next. For 
example, if there were 4 configuration changes made within a specific date 
range, the report will show the differences in the first configuration file as 
compared to the second configuration, and then show the differences in the 
second configuration file as compared to the third, and so on. 

49. If the job you are editing does not have a Policy Report tab, skip to 
Step 59. 
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50. Click the Policy Report tab. 

51. Select the policy report that is to be executed when the job is run. 

52. If you want to suppress notifications when no violations are found, 
check Send Notification only when Policy Violations are present. 

53. If you want to launch the Policy Reporting application, click Edit Policy 
Reports. 

54. If the job you are editing does not have an Inventory Settings tab, go to 
Step 61. 

55. Check the information types you want to include in your Inventory job. 

56. Click the Notifications tab. 

57. If you want to print the results, complete the following procedure: 

a. Check Print Results. 

b. Select a printer from the Printer list on the Printer Settings tab. 

58. If you want to write the results to a file, complete the following procedure: 

a. Check Save Results To File. 

b. Click the File Settings tab. 

c. Type or browse to the file in which you want to write the results in the 
Path and Filename field. 

d. If you do not want to write the results when no changes are found, 
check Only save results if this job encounters an error during 
execution. 

59. If you want to email the results, complete the following procedure: 

a. Check E-Mail Results. 

b. Click the Email Settings tab. 

c. Type the email addresses to which you want to send the results in the 
To, CC and BCC fields. Use a semicolon to separate multiple email 
addresses. 

d. Type the subject of the email in the Subject field. 

60. If you want to log the job steps to a log file, check Log job steps to JOB-
#####.log. 
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61. If you want to ensure that all Notification settings are configured 
properly, click Test Notifications. 

62. If you want to change the Windows account information, complete the 
following procedure: 

a. Click the Security tab. 

b. Type the Windows account name that will be used to run the job. 

c. Click Set Password. 

d. Type the password for the Windows account in the appropriate password 
fields. 

Notes:  

 The Windows account you specify must must be an Administrator on the 
NCM server host. 

 The Windows account is set to reflect the credentials of the last 
individual to edit the job. Orion NCM also uses the device credentials 
associated with the last individual to edit the job when logging onto the 
device. For example, the scheduled job runs as AustinLocal\User123 
and the credentials used to Log onto the devices are those credentials 
associated with the AustinLocal\User123 user account. 

63. Click OK. 

Creating a Configuration Download Job 

You can easily setup and use Orion NCM to download configuration files on a 
schedule from your nodes. Complete the following procedure to automate one of 
the most common network configuration tasks. 

To create a configuration download job: 

1. Click Schedule > Create New Job. 

2. Click Download Configs from Devices. 

3. Type a name for the job, and then click Continue. 

4. Select the frequency of the job from the Schedule Job list. 

5. Type or select a time in the Start Time field. 

6. Type or select a date in the Starting On field. 

7. Type or select a date in the Ending On field. 

Note: To assign a job to run with no end date, leave the Ending On field 
blank. 
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8. If you want to run the job daily, type a number in the Every days field to 
set the daily frequency. 

9. If you want to run the job weekly, complete the following procedure: 

a. Type a number in the Every weeks on field to set the frequency. 

b. Check the days of the week on which you want to run your job. 

10. If you are running your job monthly, complete the following procedure: 

a. Type a number in the Every months on field to set the monthly-
frequency. 

b. Check each month in which you want to run your job. 

11. Click Next. 

12. Type the Windows account name that will be used to run the job. 

13. Type the password for the Windows account in the appropriate password 
fields, and then click Finish. 

14. Type any comments in the Comments field, and then click the Nodes tab. 

15. If you want to select the nodes on which the job will run, complete the 
following procedure: 

a. Click All Nodes in the Database. 

b. Click Select Nodes Directly. 

c. Click Add Devices. 

d. Select the devices you want to add to the list. 

e. Click OK. 

16. If you want to run the job on a group of nodes that meet specific 
criteria, complete the following procedure: 

a. Click Select All Nodes in the Database. 

b. Click Specify Selection Criteria. 

c. Click Browse, and then click Add a Simple Condition. 

d. Click the first asterisk, and then click the appropriate field. 

e. If you want to change the comparison operator, click is equal to, and 
then click the comparison operator you want to use. 

f. Click the second asterisk, and then type the value or select it from the 
list. 

Note: All values currently in the database for the field are displayed 
when you browse the list. 
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17. Click the Download Config tab, and then check the configuration types you 
want to download. 

18. If you want to be notified when the downloaded configuration file is 
different from the last configuration, check Last Config. 

19. If you want to be notified when the downloaded configuration file is 
different from the baseline configuration, check Baseline Config. 

20. Check Send config change notification details in a separate text email 
and Send config change notification details in a separate HTML email as 
appropriate. These options allow you to separate change details from change 
notification. 

21. If you want the notification to ignore specific changes, complete the 
following procedure: 

a. Click Edit Comparison Criteria. 

b. Check the exclusions you want to enable. 

c. If you want to create a new exclusion, see “Creating New Config 
Change Report Exclusions” on page 100. 

d. Click Done. 

22. If you only want to save the configuration file when changes are found, 
check Only save Configs that have changed. 

23. Click the Notifications tab. 

24. If you want to print the results, complete the following procedure: 

a. Check Print Results. 

b. Select a printer from the Printer list on the Printer Settings tab. 

25. If you want to write the results to a file, complete the following procedure: 

a. Check Save Results To File. 

b. Click the File Settings tab. 

c. Type or browse to the file in which you want to write the results in the 
Path and Filename field. 

d. If you do not want to write the results when no changes are found, 
check Only save results if this job encounters an error during 
execution. 

26. If you want to email the results, complete the following procedure: 
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a. Check E-Mail Results. 

b. Click the Email Settings tab. 

c. Type the email addresses to which you want to send the results in the 
To, CC and BCC fields. Use a semicolon to separate multiple email 
addresses. 

d. Type the subject of the email in the Subject field. 

27. If you want to log the job steps to a log file, check Log job steps to JOB-
#####.log. 

28. If you want to ensure that all Notification settings are configured 
properly, click Test Notifications. 

29. If you want to change the Windows account information, complete the 
following procedure: 

a. Click the Security tab. 

b. Type the Windows account name that will be used to run the job. 

c. Click Set Password. 

d. Type the password for the Windows account in the appropriate password 
fields. 

Notes:  

 The Windows account you specify must must be an Administrator on the 
NCM server host. 

 The Windows account is set to reflect the credentials of the last 
individual to edit the job. Orion NCM also uses the device credentials 
associated with the last individual to edit the job when logging onto the 
device. For example, the scheduled job runs as AustinLocal\User123 
and the credentials used to Log onto the devices are those credentials 
associated with the AustinLocal\User123 user account. 

30. Click OK. 

Viewing Job Logs 

If you ever need to verify that a job was run as scheduled, or to view the history 
of the job, view the job log. 

To view a job log: 

1. Click Schedule > Display/Edit Jobs. 

2. Click the job, and then click Schedule > View Selected Job’s Log. 



 

 
232  Scheduling Tasks 

Viewing and Modifying Scheduled Jobs 

Any job created with Orion Network Configuration Manager can be viewed and 
modified with the Windows Task Scheduler. You can launch the Windows Task 
Scheduler from the Control panel. For more information, see your Windows 
documentation. 
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Chapter 13 

Approving Device Configuration Changes 

Orion Network Configuration Manager enables you to define a semi-automated 
approval process for making configuration changes on network devices. 

Orion NCM uses roles to determine which Orion accounts are able to perform the 
tasks of changing device configurations (WebUploader), approving those 
changes (Administrator), and changing the roles of Orion accounts (Engineer, 
Administrator). 

Orion NCM uses email to relay config change approval requests. As part of 
setting up the config change approval system, you must provide SMTP 
information.  

The following sections cover topics related to using the device configuration 
change  approval system. 

Enabling and Disabling Config Change Approval 

 

Orion NCM uses the Windows Job Scheduler to perform scheduled work. When 
you enable the change approval system, Orion NCM prevents the system from 
executing device uploads—keeping them in a disabled state—until an NCM 
Administrator has manually approved the scheduled job.  

When you disable the system, Orion NCM processes device configuration 
changes normally, either as scheduled or immediately, depending on the actions 
of the relevant team member with the WebLoader account privileges. 

You must setup the system before the change request approval queue can be 
processed. To setup the system, refer to “Setting-up the Config Change Approval 
System”. 

To enable the change approval system: 

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and then click NCM Settings. 

3. Click Enable Approval System in the Config Management Change Approval 
group. 
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To disable the change approval system: 

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and then click NCM Settings. 

3. Click Disable Approval System in the Config Management Change 
Approval group. 

Setting-up the Config Change Approval System 

 

Orion NCM uses email to relay config change approval requests. The Setup 
Wizards guides you through the process of setting up the email server the 
system will use, the addresses of Administrator who will receive change 
configuration approval requests, and the user accounts of team members who 
either manage device configurations or approve their changes.  

To setup the change approval system:  

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and then click NCM Settings. 

3. Click Setup Wizard in the Config Management Change Approval group of 
features. 

4. Enter SMTP settings. 

a. Enter your  E-mail Server Address and Port Number on the SMTP setup 
page. 

b. Check SSL if needed. 

c. Select an Authentication type and enter credentials if needed. 

d. Click Submit. 

5. Enter Email settings. 

a. Enter an appropriate email address or list of email addresses in the 
To: box. 

The address(es) in this box will receive notifications of pending 
device config changes.  

b. Enter an address in the From: line. 

This address will be shown as the sending address for config change 
approval requests.  
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c. Enter a description (for example, “NCM Approval Needed”) in the 
Subject: line. 

This description will appear in the subject line of config change approval 
requests.  

d. Add an additional message regarding config change approval requests.  

This note should inform approvers of the standard action to take. For 
example: “An approval request has been submitted in NCM. Please 
login to NCM and manage the request.” 

e. Click Submit. 

6. Click MANAGE USERS.  

7. If the account you want to manage does not appear in the list under 
Individual Accounts, click Add New Account. 

f. Click Orion individual account. 

g. Enter a User Name and Password. 

h. Assign appropriate settings for this Orion individual account. 

Note: Specifically decide if this account should have Administrator Rights 
and Node Management Rights. 

i. Assign appropriate account limitations.  

For information on setting up account limitations, search the Help system 
for ‘account limitations’. 

j. Accept the current defaults under Default Menu Bar and Views. 

This account holder will be able to access these settings after account 
setup and customize them as preferred. 

k. Assign a role appropriate role to the account under Network 
Configuration Manager Settings.  

Note: The account must at least be a WebUploader for the account 
holder to make configuration changes to network devices. 

l. Accept the defaults for other Network Configuration Manager Settings 
and Orion General Settings. 

Besides the role setting, the account holder will be able to access all 
other settings after account setup. 

m. Click Submit.  

8. If the account you want to manage appears on the list under Individual 
Accounts, click Edit. 
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a. Assign appropriate settings for this account. 

Note: Specifically decide if this account should have Administrator Rights 
and Node Management Rights. 

b. Assign any appropriate account limitations.  

For information on setting up account limitations, search the Help system 
for ‘account limitations’. 

c. Accept the current defaults under Default Menu Bar and Views. 

This account holder will be able to access these settings after account 
setup and customize them as preferred. 

d. Assign a role appropriate role to the account under Network 
Configuration Manager Settings.  

Note: The account must at least be a WebUploader for the account 
holder to make configuration changes to network devices. 

e. Accept the defaults for other Network Configuration Manager Settings 
and Orion General Settings. 

The account holder will be able to customize the appearanc e of the 
Orion NCM Web Console. 

f. Click Submit.  

Creating and Editing an NCM Account 

Orion accounts are setup for NCM mainly in terms of the NCM role associated 
with them. The roles roles currently available in NCM are: 

Administrator 

This role has unlimited access to NCM functionality, including device 
configuration management, user account management, configuration change 
approvals. 

Engineer 

This role has Administrator privileges but cannot view the device 
configuration transfer status for all users. 

WebUploader 

This role has read/write access on network devices but cannot change 
device configurations without Administrator approval. 

WebDowloader 

This role can download can read and download network device 
configurations.  
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WebViewer 

This role can only read network device configurations. 

None 

This role cannot access NCM features and functions. 

 

Use the following procedures to create or edit an Orion account for use with 
Orion NCM. 

Creating and Editing an NCM Account 

Only a user with Administrator privileges can create a a new account. Use the 
following procedures to create, edit, or remove an account. 

To create a new account:  

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and then click NCM Settings. 

3. Click MANAGE USERS.  

4. Click Add New Account. 

5. Click Orion individual account. 

6. Enter credentials for the new account. 

7. Click Next. 

8. Assign appropriate settings for this Orion individual account. 

Note: Specifically decide if this account should have Administrator Rights 
and Node Management Rights. 

9. Assign appropriate account limitations as needed.  

For information on setting up account limitations, refer to the SolarWinds 
Orion Core Administrator Guide. 

10. Accept the current defaults under Default Menu Bar and Views. 

The account holder will be able to customize these settings. 

11. Assign the role under the Network Configuration Manager Settings that 
allows the account holder to perform the tasks relevant to their job.  

Note: The account must at least be a WebUploader for the account holder 
to make configuration changes to network devices. 
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12. Accept the defaults for other Network Configuration Manager Settings and 
Orion General Settings. 

The  account holder will be able to customize these settings. 

13. Click Submit.  

To edit an existing Orion NCM account:  

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and then click NCM Settings. 

3. Click MANAGE USERS.  

4. Select an account by name and click Edit. 

5. Click Orion individual account. 

6. Enter a User Name and Password. 

7. Assign appropriate settings for this Orion individual account. 

Note: Specifically decide if this account should have Administrator Rights and 
Node Management Rights. 

8. Assign appropriate account limitations.  

For information on setting up account limitations, search the Help system for 
‘account limitations’. 

9. Accept the current defaults under Default Menu Bar and Views. 

This account holder will be able to access these settings after account setup 
and customize them as preferred. 

10. Assign a role appropriate role to the account under Network Configuration 
Manager Settings.  

Note: The account must at least be a WebUploader for the account holder to 
make configuration changes to network devices. 

11. Accept the defaults for other Network Configuration Manager Settings and 
Orion General Settings. 

Besides the role setting, the account holder will be able to access all other 
settings after account setup. 

12. Click Submit.  
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To edit an existing Orion NCM account:  

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and then click NCM Settings. 

3. Click MANAGE USERS.  

4. Select an account by name and click Edit. 

5. Click Orion individual account. 

6. Enter a User Name and Password. 

7. Assign appropriate settings for this Orion individual account. 

Note: Specifically decide if this account should have Administrator Rights and 
Node Management Rights. 

8. Assign appropriate account limitations.  

For information on setting up account limitations, search the Help system for 
‘account limitations’. 

9. Accept the current defaults under Default Menu Bar and Views. 

This account holder will be able to access these settings after account setup 
and customize them as preferred. 

10. Assign a role appropriate role to the account under Network Configuration 
Manager Settings.  

Note: The account must at least be a WebUploader for the account holder to 
make configuration changes to network devices. 

11. Accept the defaults for other Network Configuration Manager Settings and 
Orion General Settings. 

Besides the role setting, the account holder will be able to access all other 
settings after account setup. 

12. Click Submit.  

 

To delete an account:  

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and then click NCM Settings. 

3. Click MANAGE USERS.  

4. Select an account and click Delete. 
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Managing NCM Approval Requests 

 This resource enables NCM users to view requests and NCM adminsitrators to 
view, approve and decline them.  

To approve or decline request: 

1. Log on to the Orion Web Console with an administrator account. 

2. Click Configs on the modules menu and then click NCM Settings. 

3. Click Pending Approval in the Config Mnagement Change Approval section. 

4. If you are looking for a specific request, enter the requester’s NCM username 
in the Search window and click the icon. 

5. Check the appropriate request(s) in the list and then click Approve or 
Decline, as needed. 
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Chapter 14 

Understanding the Web Console 

The Web Console, provided with Orion Network Configuration Manager, offers 
you access to your device configs without requiring physical access to your Orion 
NCM server. Through the Web Console, you gain flexibility and power. You can 
perform any of the following actions, provided you have the appropriate role: 

 View configurations 

 Check configuration backup status 

 Compare configurations and view differences 

 Download configurations 

 Upload configurations 

 Execute scripts on nodes 

 Create and manage config change templates 

Launching and Logging On to the Web Console 

To launch the Web Console, you can either log on to the Orion NCM server and 
click Start > Program Files > SolarWinds Orion Network Configuration Manager > 
Orion NCM Web Console or point any remote browser to the Orion NCM server: 
http://hostnameOrIPAddress:port. Where, hostnameOrIPAddress is either 

the hostname or IP address of the Orion NCM server and port is the Web 
Console port defined for the website. 

To log on to the Web Console, you can use either Windows credentials or an 
Orion NCM credential set. You must have previously defined the credentials 
using the user access control settings and associated the credentials with the 
Web Viewer role.  

Understanding Web Console Resources 

Each view within the Web Console provides a number of resources. The 
following sections are divided by the view on which the resources can be 
displayed. You can customize your views, adding and removing resources based 
on the account with which you Log on. For more information about customizing 
your views, see “Personalizing the Web Console” on page 246. 
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Home 

The Home view allows you to display the following resources. For more 
information about any of these resources, click Help on the resource in the Web 
Console. 

All Nodes 

Provides an expandable and customizable list of the nodes which have been 
added to Orion NCM. Expanding groups, and then devices, allows you to 
reveal individual configurations. 

Devices Backed Up vs. Not Backed Up 

Provides a pie chart representing the percentage of backed up devices 
versus devices which have not been backed up over a specific period of 
time. 

Configuration History 

Allows you to set a time period and see an overview of the events that 
occurred during that time period. 

Custom HTML 

Allows you to add your own iframe web resource to the Orion NCM Web 
Console. 

Baseline vs. Running Config Conflicts 

Provides a pie chart representing the percentage of baseline configs versus 
running config conflicts over a specific period of time. 

Configurations Changes Snapshot 

Provides a pie chart representing the percentage of changed versus 
unchanged configurations over a specific period of time. 

Last 10 Config Changes 

Provides a list of detected configuration changes, listing the user committing 
the change, the time of upload, and the type of configuration. 

Devices Backed Up vs. All Devices 

Provides a pie chart designating the percentage of device that have been 
backed up using the Orion NCM application in comparison to those that have 
not been backed up. 

Most Recent Orion NCM Thwack Posts 

Provides an RSS feed driven list of the most recent Thwack posts for Orion 
NCM. 
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Policy Report Violations 

Provides a stacked bar chart of status of your devices in relation to a specific 
policy report. 

Policy Violations 

Provides a list of the policy reports available and a brief overview of the 
contents of each report. 

Running vs. Startup Config Conflicts 

Provides a pie chart designating the percentage of devices running different 
configurations than their startup configurations. 

Devices Inventoried vs. Not Inventoried 

Provides a pie chart designating the percentage of devices inventoried in 
relation to those that have not. 

Node Details Pages 

The Node Details view allows you to display the following resources. You 
navigate to the Node Details view by clicking the name of a node in the Orion 
NCM Web Console. For more information about any of these resources, click 
Help on the resource in the Web Console. 

Node Details 

Provides an overview of the device you selected, including the IP Address, 
OS Version, Location, OS image, among other information. 

Config List 

Provides a list of the last X number of configurations downloaded from this 
device. 

Download Config 

Allows you to download the startup or running configuration from the current 
node. 

Execute Script 

Allows you to execute a script against the current node.  

Upload Config 

Allows you to upload a configuration file you have previously downloaded 
from the selected node. 

Inventory Details 

Provides a list of inventory reports that pertain to the selected device. 
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Policy Violations 

Provides a list of the policy reports available that pertain to the selected 
device. 

Last 10 Config Changes 

Provides a list of detected configuration changes, listing the user committing 
the change, the time of upload, and the type of configuration. 

Compare Configurations 

Allows you to select two configurations from different time periods to 
compare to one another. 

Config Change Report 

Allows you to specify a time period and a node, and then display a change 
report that covers the set time range. 

NCM Events 

Allows you to set a time period and see an overview of the Orion NCM 
events that occurred during that time period. 

Configuration Management 

The Configuration Managment view allows you to display the following 
resources. For more information about any of these resources, click Help on the 
resource in the Web Console. 

View Changes 

Allows you to specify a time period and a node, and then display a change 
report that covers the set time range. 

Note: Consult this SolarWinds Orion NCM Knowledge Base article for 
special setup needed to ensure the accuracy of Config Change Reports 
based on a date range. 

Compare Selected Configs 

Allows you to select any two configurations to compare to one another. You 
can select configurations from the same device archived at different times, a 
startup versus a running configuration, or you can select configuration from 
differing devices. 

Compare to Baseline 

Allows you to select a single configuration to compare to a set baseline. You 
must set a baseline to use this feature. For more information, see 
"Understanding Baselines" on page 98. 

http://knowledgebase.solarwinds.com/kb/questions/2162/NCM+Requires+Special+Setup+to+Correctly+Report+on+Some+Config+Changes
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Download Config 

Allows you to select nodes and download running, startup, or custom 
configurations for those nodes. 

Execute Script 

Allows you to enter or load a script from a text file to execute against the 
nodes you select. 

Upload Config – Multi Node 

Allows you to select a configuration you want to upload to multiple nodes. 

Upload Config – Single Node 

Allows you to select a configuration you want to upload to the source node. 

Transfer Status 

Provides the most recent actions taken on a node. 

Config Change Templates 

The Config Change Templates view allows you to display the following 
resources. For more information about these resources, click Help or see 
Working with Config Change Templates. 

Config Change Templates 

Allows you to create, edit, import, export, tag, and delete config change 
templates. 

Shared Config Change Templates on thwack 

Allows you to view and download config change templates from thwack. 

Inventory 

The Inventory view allows you to view both the supplied inventory reports and 
those you have created with the Orion NCM application. Orion NCM provides 40 
unique inventory reports and allows you to create your own. For more 
information, see “Managing Inventory Reports” on page 199. 

Compliance 

The Compliance view allows you to view both the supplied policy reports and 
those you have created with the Orion NCM application. Orion NCM provides 
numerous policy compliance tests, while also allowing you to create your own. To 
ensure you are viewing the most up-to-date information, click Update Now on 
the Compliance view. For more information, see “Managing Policy Reports” on 
page 207. 



 

 
246  Understanding the Web Console 

Searching 

The Advanced Search function allows you to search node properties, specific 
node configurations, all node configurations, and only the most recent 
downloaded configurations for specific text. You can also search within your 
search results. 

Personalizing the Web Console 

You can select the resource you want to display on a particular view. To do so, 
click Personalize on the view you want to customize. You can then check the 
resources to include, drag-and-drop them from one column to another, or drag-
and-drop them in a different order in the same column. Changes are saved as 
preferences associated with the logged on user account. For more information 
about user accounts and roles, see “Managing Web Accounts”. 

Integrating with Engineer’s Toolset 

When you navigate to a Node Details page, if you have the Toolset installed on 
the local computer, you can take advantage of a number of integration points, 
including the following: 

 Web browse to the selected node 

 Telnet to the selected node 

 Ping the selected node 

 Run a trace route to the selected node 

 Remote desktop to the selected node 
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Chapter 15 

Integrating NCM Actions into Orion Alerts 

 

Orion alerting software can alert on polled, syslog, and trap data. Alerts are 
defined in terms of thresholds related to data in the Orion database. Scans in the 
form of SQL queries at set intervals detect recorded values that exceed 
thresholds, triggering an alert if relevant conditions pertain.  

When an Orion alert is triggered, the software evaluates suppression criteria. If 
an alert is not qualified to be suppressed, the software executes a defined action. 
If no action is defined, the software merely displays the alert on the web console.  

Throughout this workflow  timers are used to allow the software to do its work at 
each step and to ensure that the alerting workflow had appropriate redundancy 
for timely reporting of alerts. 

For an excellent overview of alerting in Orion advanced alerts, see 
Understanding Orion Advanced Alerts. For all specific information on advanced 
alerts, including detailed instructions for creating and managing them with the 
Orion Alert Manager, see “Using the Advanced Alert Manager”. 

Types of NCM Alert Actions 

 

You can use three types of NCM actions in processing an Orion advanced alert: 

 Backup Running Config 

 Execute Config Script 

 Show Last Config Changes 

 

 Backup Running Config 

With this action NCM simply downloads the latest configuration from the context 
node. It is the same as running Nodes > Download Configs for a selected node. 
Unlike a normal execution of this action, however, the results of this download 
are written to an alerts table in the Orion database and this data is used when an 
alert is processed.  

http://www.solarwinds.com/support/Orion/docs/UnderstandingOrionAdvancedAlerts.pdf
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Execute Config Script 

With this action NCM executes the command(s) that you have entered into the 

Command Script to Execute field. For example, if you enter show version,and 

include it as a Trigger Action on an alert, NCM will run the show command as 

part of alert processing and include the results with the alert notification. 

Show Last Config Changes 

With this action NCM performs a SQL query to find the most recent changes and 
compares those changes either to the baseline config or the penultimately 
downloaded config, depending on how you setup your alert action. 

When the alert triggers, the results of the NCM action are stored in the Orion 

database (in ${Notes}) and used as part of runtime processing of an alert. You 

can also view this information as part of the Alert Details on any relevant alert 
reported through the Orion Web Console (Home > Alerts). For detailed 
information, see “Viewing Alerts in the Orion Web Console”. 

If an alert is triggered for a node without relevant config history, NCM cannot 
contribute any data and the Orion alert is processed without it. So selecting this 
action only makes sense if you already have a history of device configurations. 

Using the Default NCM Alert 

 

When you install Orion NCM 7.0, the software automatically creates in the Orion 
Alert Manager a predefined alert called “Alert me and trigger an NCM action”. 

The primary purpose of this alert is to determine if the changes in device 
configuration are responsible for the alert triggering issue.  

Accordingly, by default, this predefined alert does these three things in order: 

 Backs up the running config on the alerting device 

 Determines the last config changes made on the device 

 Sends an email regarding the alert to a relevant administrator that includes 
the results of both NCM actions 

The instructions in this section assume you are familiar with the Orion Alert 
Manager and already know how to setup an advanced alert.  

For steps on creating an advanced alert see the sections on advanced alerts in 
“Using Orion Advanced Alerts”. 

To use the default NCM alert:  

1. Open the Orion Alert Manager in the Orion program group. 
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2. Navigate to the Manage Alerts resource resource (View > Configure Alerts). 

3. Select “Alert me and trigger an NCM action” and click Edit. 

a. On General, check Enable this Alert and select an appropriate Alert 
Evalutation Frequency. 

b. On Trigger Condition, define the conditions in which the software 
launches the alert. 

The default condition is a node that responds in 200 ms or more. You 
can adjust this condition or add conditions. 

 c. On Reset Condition, define the conditions in which the software resets 
the alert. 

The default condition the node responds in 100 ms or less. You can 
adjust this condition or add conditions. 

d. On Alert Suppression, define the conditions in which the software 
suppresses the alert. 

The default condition is no suppression. 

e. On Time of Day, define the days and times during which the software 
actively evaluates the database for trigger conditions. 

The default range is 24/7. 

f. On Trigger Actions, create actions to execute when the software triggers 
the alert, and enter your NCM credentials. 

As discussed, the default actions are to back up the config running on 
the alerting device, determine the last config changes, and send an email 
to an appropriate contact. 

g. On Reset Conditions, define actions to execute when the software resets 
the alert.  

4. Click OK and then click Done. 

Adding Scripted Commands to the Default NCM Alert 

 

You can modify the default NCM advanced alert to execute specific command 
scripts at the time the alert is triggered.  

The following example adds a simple show version command as a scripted 

action.  

To add a scripted command to the default NCM alert: 
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1. Open the Orion Alert Manager in the Orion program group. 

2. Navigate to the Manage Alerts resource resource (View > Configure Alerts). 

3. Select “Alert me and trigger an NCM action” and click Edit. 

4. On Trigger Actions, click Execute Config Script and enter the relevant 
command in Command Script to Execute. 

 show version 

When executed, this command runs on the context node, receives detailed 

software and hardware information, and includes it in the ${Notes}macro of 

an Orion database alerts table. 

5. Use the up/down arrows to move the new action into the desired position in 
the list. 

By default, the software positions a new action at the end of the action list. In 
this case, it makes sense to position this action third, after NCM backs up the 
running config and determines the last config changes. 

6. Click OK, then click Done. 

Using Orion Advanced Alerts 

Alerts are generated for network events, and they may be triggered by the simple 
occurrence of an event or by the crossing of a threshold value for a monitored 
Interface, Volume, or Node. Alerts can be set to notify different people on 
different days, different times of the day, different people for different events, or 
any combination of times, events, and people. Alerts may be configured to notify 
the people who need to know about the emergent event by several mediums, 
including: 
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 Sending an e-mail or page 

 Playing a sound on the Orion Network Performance Monitor server 

 Logging the alert details to a file 

 Logging the alert details to the Windows Event Log 

 Logging the alert details to the NetPerfMon Event Log 

 Sending a Syslog message 

 Executing an external program 

 Executing a Visual Basic script 

 E-mailing a web page 

 Playing text-to-speech output 

 Sending a Windows Net Message 

 Dialing a paging or SMS service 

 Sending an SNMP trap 

 GETting or POSTing a URL to a web server 

Creating and Configuring Advanced Alerts 

Orion NCM allows you to configure advanced alerts with the following features: 

 Sustained state trigger and reset conditions 

 Multiple condition matching 

 Automatic alert escalation 

 Separate actions for triggers and resets 

Advanced alerts are configured using the Advanced Alert Manager, as shown in 
the following section. 

Note: If you want to configure advanced alert features, such as timed alert 
checking, delayed alert triggering, timed alert resets, or alert suppression, check 
Show Advanced Features at the lower left of any Advanced Alert windows. For 
the purposes of this document, Show Advanced Features is always enabled. 

Creating a New Advanced Alert 

The following procedure creates a new advanced alert. 

To create a new advanced alert: 
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1. Click Start > SolarWinds Orion > Alerting, Reporting, and Mapping > 
Advanced Alert Manager. 

2. Click View > Configure Alerts. 

 

 

3. Click New. 

 

 

The Edit Alert window displays, providing an array of configurable alerting 
options, including trigger and reset conditions, suppressions, and date and time 
limitations. The following sections provide more information about configuring 
alert options. 

Naming, Describing, and Enabling an Advanced Alert 

Use the following steps, after clicking New, Copy, or Edit from the Manage 
Alerts Window, to name and describe an advanced alert. 

To name and describe an advanced alert: 

1. Click Start > SolarWinds Orion > Alerting, Reporting, and Mapping > 
Advanced Alert Manager. 
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2. Click View > Configure Alerts. 

3. If you want to create a new alert, click New. 

4. If you want to copy or edit an existing alert, select an alert from the list, 
and then click Copy or Edit, as appropriate. 

 

 

5. Click General, type the name of your alert in the Name of Alert field, and 
then type a description of your alert in the description field. 

 

6. Check Enable this Alert. 
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7. Type the Alert Evaluation Frequency and select Seconds, Minutes, or Hours 
from the list to set the checking interval for your alert. 

 

 

8. Click Trigger Condition to set the trigger condition for your alert. For more 
information, see “Setting a Trigger Condition for an Advanced Alert”. 

 

Setting a Trigger Condition for an Advanced Alert 

You can set the specific conditions for triggering an advanced alert with the 
following procedure. 

Note: Properly defining alert trigger conditions to address specifc network 
conditions on selected network objects can eliminate the need for alert 
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suppression conditions. SolarWinds recommends the use of appropriately 
specific trigger conditions to define alerts instead of suppression conditions, if 
possible. For more information about defining conditions, see “Understanding 
Condition Groups”. 

To set the trigger conditions for an advanced alert: 

1. Click Start > SolarWinds Orion > Alerting, Reporting, and Mapping > 
Advanced Alert Manager. 

2. Click View > Configure Alerts. 

3. If you want to create a new alert, click New. 

4. If you want to copy or edit an existing alert, select an alert from the list, 
and then click Copy or Edit, as appropriate. 

5. Click Trigger Condition. 

6. Select the Type of Property to Monitor from the list. 

Note: The following image is a screen capture from an Orion Network 
Performance Monitor installation. Other modules will look similar, but 
different objects may be present. 

 

 

7. If you select Custom SQL Alert, complete the following steps: 

a. Select the object on which you want to alert in the Set up your Trigger 
Query field. 

b. Provide your custom SQL in the field below the object selection query. 

c. If you want to delay the trigger of this alert, provide the value and unit 
of your desired alert trigger delay. 

d. If you want to confirm your provided SQL, click Validate SQL. 

8. If you select a type of monitored object, complete the following steps: 
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a. Generate trigger conditions in the text field by selecting appropriate 
descriptors from the linked context menus and by clicking Browse (…) 
on the left of the text field. 

b. Click the linked text to select the number of conditions that you want to 
apply (all, any, none, not all). For more information about linked text 
conditions, see “Understanding Condition Groups”. 

 

 

c. Click Browse (…) to view the following condition options: 

Note: The has changed condition is only valid for the Last Boot, IOS 
Version, and IOS Image Family device characteristics. 

 

 

 To generate a condition based on a comparison of device states, 
click Add a Simple Condition. 

 

 

 To generate a condition based on a comparison of device fields and 
values, click Add a Complex Condition. 

 To define more conditions, click Add a Condition Group. 

 To remove a selected condition, click Delete Current Condition. 

 To change the order of your conditions, click Move Down or Move 
Up, as appropriate. 
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d. If you need an additional condition, click Browse (…), and then click 
Add ConditionType, as appropriate for the condition you want to add. 

e. If you need to delete a condition, click Browse (…), next to the 
condition you want to delete, and then click Delete Current Condition. 

Notes:  

 Conditions may be exported for use with other alerts by clicking 
Export Conditions and saving as appropriate. 

 Click Import Conditions to import existing conditions from other 
alerts. Imported trigger conditions automatically overwrite any 
existing trigger conditions. 

f. If you want to specify a time duration for the condition to be valid, 
type the interval and select Seconds, Minutes, or Hours from the list. 

Note: You may need to delay alert trigger actions until a condition has 
been sustained for a certain amount of time. For example, an alert based 
on CPU load would not trigger unless the CPU Load of a node has been 
over 80% for more than 10 minutes. To set up a sustained-state trigger 
condition, at the bottom of the Trigger Condition tab, provide an 
appropriate amount of time the alert engine should wait before any 
actions are performed. By default, the alert triggers immediately, if the 
trigger condition exists. The maximum alert action delay is eight hours 
after the trigger condition is met. 

g. If you are finished configuring your advanced alert, click OK. 

Setting a Reset Condition for an Advanced Alert 

Set specific conditions for resetting an advanced alert using the following steps. 

To set the conditions for resetting an advanced alert: 

1. Click Start > SolarWinds Orion > Alerting, Reporting, and Mapping > 
Advanced Alert Manager. 

2. Click View > Configure Alerts, and then click New or select an alert from 
the list and click Copy or Edit. 

3. Click Reset Condition. 

4. If you want a simple alert reset when trigger conditions no longer exist, 
select Reset when trigger conditions are no longer true. 

5. If you want a conditional alert reset, select Reset this alert when the 
following conditions are met. 

Notes: Generate reset conditions in the text field by selecting appropriate 
descriptors from the linked context menus and by clicking Browse (…). 
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6. If you want to copy the condition used on the Trigger Condition tab, 
click Copy From Trigger. 

7. Click the linked text to select the number of conditions to apply. For more 
information, see “Understanding Condition Groups”. 

8. Click Browse (…) to view the following condition options: 

 To generate a condition based on a comparison of device states, click 
Add a Simple Condition. 

 To generate a condition based on a comparison of device fields and 
values, click Add a Complex Condition. 

 To further define condition application, click Add a Condition Group. 

 To remove a selected condition, click Delete Current Condition. 

 To change the order of your conditions, click Move Down or Move Up. 

9. If you need an additional condition, click Add, and then select the type of 
condition you want to add. 

10. If you need to delete a condition, select the condition from the condition 
list, and then click Delete. 

Notes:  

 Conditions may be exported for use with other alerts by clicking Export 
Conditions and saving as appropriate. 

 Conditions from other alerts may be imported to the current alert by 
clicking Import Conditions. 

Warning: Imported trigger conditions automatically overwrite any 
existing trigger conditions. 

 Because there are many situations where the reset conditions are the 
opposite of, or are very similar to, the trigger conditions, SolarWinds has 
provided a function that copies the trigger conditions to the reset 
conditions. Click Copy From Trigger to add the trigger condition. 

11. If you want to specify a time duration for the condition to be valid, type 
the time interval and select Seconds, Minutes, or Hours from the list. 

Note: It is often appropriate to delay alert reset actions until a condition has 
been sustained for a certain amount of time. For example, an alert based on 
node status would not reset until the node has been up for more than five 
minutes. To establish a sustained-state reset condition, provide an 
appropriate interval at the bottom of the Reset Condition tab for the amount 
of time that the alert engine should wait before any actions are performed. 
The default setting is to reset the alert immediately, once the reset condition 
exists. The maximum interval between when the trigger condition first exists 
and when the corresponding alert action is performed is eight hours. 
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12. If you are finished configuring your advanced alert, click OK. 

Setting a Suppression for an Advanced Alert 

You can set the specific conditions for suppressing an advanced alert using the 
following procedure. 

Notes: 

 Alert Suppression is only available if you have checked Show Advanced 
Features in the lower left of the Edit Advanced Alert window. 

 In many cases, because suppression conditions are checked against all 
monitored objects on your network, properly defining alert trigger conditions 
may eliminate the need for alert suppression. For more information about 
defining alert trigger conditions, see “Setting a Trigger Condition for an 
Advanced Alert” and “Understanding Condition Groups”. 

To set conditions for advanced alert suppression: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click View > Configure Alerts. 

3. Click New or select an alert from the list. 

4. Click Copy or Edit, as appropriate. 

5. Click Alert Suppression. 

Note: Generate suppression conditions in the text field by selecting 
appropriate descriptors from the linked context menus and by clicking 
Browse (…) on the left of the text field. 

6. If you want to copy the condition used on the Trigger Condition tab, 
click Copy From Trigger. 

7. Click the linked text to select the number of conditions that you want to apply 
(all, any, none, not all). For more information about linked text conditions, 
see “Understanding Condition Groups”. 

8. Click Browse (…) to view the following condition options: 

 To generate a condition based on a comparison of device states, click 
Add a Simple Condition. 

 To generate a condition based on a comparison of device fields and 
values, click Add a Complex Condition. 
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 To further define the application of your conditions, click Add a 
Condition Group. 

 To remove a selected condition, click Delete Current Condition. 

 To change the order of your conditions, click Move Down or Move Up. 

9. If you need an additional condition, click Add and then select the type of 
condition you want to add. 

10. If you need to delete a condition, select the condition from the condition 
list, and then click Delete. 

Note: Conditions may be exported for use with other alerts by clicking 
Export Conditions and saving as appropriate. Conditions from other alerts 
may be imported to the current alert by clicking Import Conditions. 

Warning: Imported conditions automatically overwrite existing conditions. 

11. If you are finished configuring your advanced alert, click OK. 

Setting the Monitoring Period for an Advanced Alert 

You can select the specific time periods and days that your advanced alert will 
monitor your network objects with the following procedure. 

To set the monitoring time period and days for an advanced alert: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click View > Configure Alerts. 

3. Click New or select an alert from the list. 

4. Click Copy or Edit. 

5. Click Time of Day. 

6. Enter the time period over which you want to monitor your network. 

Note: Alerts only trigger if the trigger condition is met within this time period. 

7. Select the days on which you want to monitor your network. 

Note: Alerts will only trigger if your trigger condition is met on the days 
selected. 

8. If you are finished configuring your advanced alert, click OK. 

Setting a Trigger Action for an Advanced Alert 

Select actions that will occur when your advanced alert is triggered as follows. 

To set a trigger action for an advanced alert: 
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1. Click Start > SolarWinds Orion > Alerting, Reporting, and Mapping > 
Advanced Alert Manager. 

2. Click View > Configure Alerts. 

3. Click New or select an alert from the list, and then click Copy or Edit, as 
appropriate. 

4. Click Trigger Actions. 

5. If you are adding a new advanced alert action, click Add New Action, 
and then select the actions you want to occur when the alert triggers. 

6. If you are editing an existing advanced alert action, select the existing 
alert action, and then click Edit Selected Action. 

7. Follow the instructions to configure each action.   

Note: Depending on the type of action selected, different options will be 
displayed to configure the alert action. For more information about individual 
alert actions, see “Available Advanced Alert Actions”. 

8. If you need to delete an action, select the action and then click Delete 
Selected Action. 

9. If you are finished configuring your advanced alert, click OK. 

Setting a Reset Action for an Advanced Alert 

Select actions that will occur when your advanced alert is reset with the following 
procedure. 

To set a reset action for an advanced alert: 

1. Click Start > SolarWinds Orion > Alerting, Reporting, and Mapping > 
Advanced Alert Manager. 

2. Click View > Configure Alerts. 

3. Click New Alert, Copy Alert, or Edit Alert, as appropriate. 

4. Click Reset Actions. 

5. If you are adding a new advanced alert action, click Add New Action, 
and then select the actions you want to occur when the alert triggers. 

6. If you are editing an existing advanced alert action, select the existing 
alert action, and then click Edit Selected Action. 

7. Follow the instructions to configure each action.   

Note: Depending on the type of action selected, different options display 
configuring the alert action. For more information about individual alert 
actions, see “Available Advanced Alert Actions”. 
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8. If you need to delete a selected action, click Delete Selected Action. 

9. If you are finished configuring your advanced alert, click OK. 

Alert Escalation 

When editing any trigger or reset action, use the Alert Escalation tab, if it is 
available, to define additional alert action options. Depending on the alert action 
being configured, any or all fo the following options may be available on the Alert 
Escalation tab: 

 To disable the action when the alert has been acknowledged, check Do not 
execute this Action if the Alert has been Acknowledged. 

 To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered and 
then provide an appropriate action execution interval. 

 To delay the execution of the alert action, check Delay the execution of this 
Action and then provide an appropriate interval that the alert engine should 
wait after the alert condition is met before the alert action is executed. 

For more information, see “Escalated Advanced Alerts”. 

Understanding Condition Groups 

A condition group is a set of user-defined rules governing alert triggers and 
resets. By default, the condition group Trigger Alert when all of the 

following apply is added when new alert triggers or reset conditions are 

created. Four different logical descriptors are used to create conditions: all, any, 

none, and not all, and clicking the word all and enables you to select different 

values. The following sections describe these logical descriptors. 

All Condition Group 

Trigger Alert when all of the following apply means that every 

condition in the group must be true before the alert is triggered.  

In the following example, there are three conditions within the condition group: 

 Node Status is equal to Up 

 Percent Loss is greater than or equal to 75 

 CPU Load is greater than or equal to 85 

This alert will not trigger unless the Node is Up, packet loss is greater than or 
equal to 75%, and CPU load is greater than or equal to 85%. 

When setting the condition group to all, picture every condition as being 

separated by an and statement. So, in this example, the alert trigger would read: 
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Alert when: (Node Status = Up) and (Percent Loss >= 75) and (CPU 

Load >= 85) 

Any Condition Group 

Changing the condition group to Trigger Alert when any of the following 

apply changes the logic to or statements. In this example, changing the 

condition group to any would change the alert trigger to: 

Alert when: (Node Status = Up) or (Percent Loss >= 75) or (CPU 

Load >= 85) 

In this situation, if any of the three conditions become true, the alert will trigger. 

None Condition Group 

Changing the condition group to Trigger Alert when none of the 

following apply means that all conditions in the group must be false before the 

alert is triggered. 

In this example the alert trigger would read: 

Alert when: (Node Status = Down) and (Percent Loss <= 75) and 

(CPU Load <= 85) 

Each condition is separated by an and statement just like the all condition 

group; however, the conditions have been inverted (Node Status = Down 

instead of Node Status = Up). 

Not All Condition Group 

Changing the condition group to Trigger Alert when not all of the 

following apply means that any condition in the group must be false before 

the alert is triggered. So, in this example the alert trigger would read: 

Alert when: (Node Status = Down) or (Percent Loss <= 75) or (CPU 

Load <= 85) 

Each condition is separated by an or statement just like the any condition group; 

however, the conditions have been inverted (Node Status = Down instead of 

Node Status = Up). 

Using the Advanced Alert Manager 

The Advanced Alert Manager is an interface used to view network events and 
alerts. You can also use Advanced Alert Manager to create and manage 
advanced alerts. The following procedures introduce the main features of the 
Advanced Alert Manager showing how to configure and view advanced alerts. 
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Current Events Window 

The Current Events window of the Advanced Alert Manager shows the most 
recent network events with their descriptions and other information from the 
events log.  

To use the Current Events window to view network events: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click View > Current Events. 

3. Select an appropriate Group By: criterion for grouping events. 

4. If you want to change the viewable category columns in the Current 
Events window, click Include, and then complete the following procedure: 

a. Click the Event View Columns tab, and then select column IDs from the 
All Columns field. 

b. Click the right arrow to move your column IDs into the Selected 
Columns field. 

c. If there are any column IDs in the Selected Columns field that you 
do not want to view, select them, and then click the left arrow to move 
your selected column IDs to the All Columns field. 

d. Click the up or down arrows to change the order of your selected 
columns accordingly. 

e. Position the slider to set the Event View refresh rate. 

f. Type the number of events that you want to be able to review in the 

Display a maximum of XXXX events in the Event View field. 

g. If you are finished configuring your Current Events View, click OK. 

5. Click Refresh to update the Current Events window with the latest events 
and column IDs. 

6. If you want to acknowledge a network event, click X next to the event. 

Active Alerts Window 

The Active Alerts window of the Advanced Alert Manager shows network alerts 
with their descriptions and other information from the alerts log.  

To use the Active Alerts window to view active network alerts: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click View > Active Alerts. 

3. Select an appropriate Group By: criterion for grouping alerts. 
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4. Click Include, and then check the types of alerts that you want to view: 
Acknowledged, Trigger Pending, Triggered, or Reset Pending. 

5. If you want to change the viewable category columns in the Current 
Events window, click Include > Select Alert Columns, and then complete 
the following procedure: 

a. Select column IDs from the All Columns field. 

b. Click the right arrow to move your column IDs into the Selected 
Columns field. 

c. If there are any column IDs in the Selected Columns field that you 
do not want to view, select them, and then click the left arrow to move 
your selected column IDs to the All Columns field. 

d. Click the up or down arrows to change the order of your selected 
columns accordingly. 

e. Position the slider to set the Alert View refresh rate. 

f. If you are finished configuring your Active Alerts View, click OK. 

6. Click Refresh to update the Active Alerts window with the latest alerts and 
column IDs. 

7. Click Configure Alerts to change the settings for individual alerts. 

8. If you want to acknowledge an active alert, check the alert in the 
Acknowledged column. 

Note: As soon as the alert is acknowledged, the user information and 
date/time is recorded in the database. 

Alert Viewer Settings 

Alert views in the Orion Advanced Alert Manager are configured in the Alert 
Viewer Settings window, as presented in the following procedure. 

To configure alert views in the Advanced Alert Manager: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click File > Settings. 

Note: The Configure Alerts tab of the Alert Viewer Settings window displays 
all available network alerts, and from this window you can create, copy, edit, 
and delete alerts. For more information, see “Creating and Configuring 
Advanced Alerts”. 

3. Click Alert View Columns. 



 

 
266  Understanding the Web Console 

4. Select the information titles that you want to see about your alerts from the 
All Columns list. 

5. Click the right arrow to transfer them to the Selected Columns list. 

Note: The Selected Columns list provides a list of all the information that the 
Alert Viewer will show for each active alert. 

6. If you want to remove titles from the Selected Columns list, select titles 
that you want to remove from the active view in the Selected Columns list, 
and then click the left arrow. 

7. If you want to rearrange the order in which the different pieces of alert 
information are presented in the Alert Viewer, select titles from the 
Selected Columns list and use the up and down arrows to arrange the titles 
accordingly. 

8. Position the slider at the bottom of the tab to set the Alert View refresh rate. 

9. Click Event View Columns. 

10. Select the information titles that you want to see about events from the All 
Columns list. 

11. Click the right arrow to transfer them to the Selected Columns list. 

Note: The Selected Columns list provides a list of all the information that the 
Alert Viewer will show for each recorded event. 

12. If you want to remove titles from the Selected Columns list, select titles 
that you want to remove from the active view in the Selected Columns list, 
and then click the left arrow. 

13. If you want to rearrange the order in which the different pieces of event 
information are presented in the Alert Viewer, select titles from the 
Selected Columns list and use the up and down arrows to arrange the titles 
accordingly. 

14. Position the slider at the bottom of the tab to set the Event View refresh rate. 

15. Enter the number of events that you want to see in the Event View. 

Adding Alert Actions 

SolarWinds provides a variety of actions to signal an alert condition on your 
network. These alert actions are available for both basic and advanced alerts, 
and the following procedure assigns actions to the alert conditions that you have 
defined for your network. 

To add an alert action: 

1. Click Start > All Programs > SolarWinds Orion > Network Performance 
monitor > System Manager. 
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2. Click Alerts > Active Alerts, and then click either Configure Basic Alerts 
or Configure Advanced Alerts, as appropriate. 

3. Check the alert to trigger your action, and then click Edit Alert. 

4. Click Actions, and then select the action you want to edit. 

5. Click Add Alert Action, and then click the action to add to your chosen alert. 

For more information about individual alert actions, see “Available Advanced 
Alert Actions”. 

Available Advanced Alert Actions 

The following sections detail the configuration of available alert actions: 

 Sending an E-mail / Page 

 Playing a Sound 

 Logging an Advanced Alert to a File 

 Logging an Advanced Alert to the Windows Event Log 

 Logging an Advanced Alert to the NetPerfMon Event Log 

 Sending a Syslog Message 

 Executing an External Program 

 Executing a Visual Basic Script 

 Emailing a Web Page 

 Using Text to Speech Output 

 Sending a Windows Net Message 

 Sending an SNMP Trap 

 Using GET or POST URL Functions 

 Dial Paging or SMS Service 

Sending an E-mail / Page 

The following procedure configures an e-mail/page action for an advanced alert. 

Notes: 
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 Confirm that the polling engine you have configured to trigger your alert has 
access to your SMTP server. 

 Emails and pages are sent in plain text. 

To configure an email/page action for an advanced alert: 

1. Click E-mail/Pager Addresses, and then complete the To, CC, BCC, Name, 
and Reply Address fields. 

Note: You must provide at least one email address in the To field, and 
multiple addresses must be separated with commas. Some pager systems 
require a valid reply address to complete the page. 

2. Click Message, and then select your email format (Plain text or HTML). 

3. Type the Subject and Message of your alert trigger email/page. 

Note: Messaging is disabled if both Subject and Message fields are empty. 

4. If you want to insert a variable into the Subject or Message field, click 
the location of the new variable, and then complete the following procedure: 

a. Click Insert Variable. 

b. Select a Variable Category, and then select the variable to add. 

c. If you want to change the parser, check Change Parser, and then 
select the parser you want to use. 

d. If you want to define the SQL variable to copy to the clipboard, 
check Define SQL Variable, and then click Insert Variable From 
Above List. 

e. Click Build Selected Variable. 

Note: For more information on the use of variables, see “Orion Variables 
and Examples”. For more information about messages that use 
variables, see “Example Messages Using Variables”. 

5. Click SMTP Server. 

6. Type the Hostname or IP Address of your SMTP Server and the 
designated SMTP Port Number. 

Note: The SMTP server hostname or IP address field is required. You 
cannot send an email/page alert without identifying the SMTP server. 

7. If you want to use SSL/TLS encryption for your alert email, check 
Enable SSL. 

8. If your SMTP server requires authentication, check This SMTP Server 
requires Authentication. 

9. Click Time of Day. 
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10. Enter the time period over which you want to activate your alert action, and 
then select the days on which you want to activate your alert action. 

11. If you want to enable alert escalation, click the Alert Escalation tab, and 
then check any of the following options, as appropriate for your alert: 

 To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

 To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

 To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

12. If you are finished configuring your email/page alert action, click OK. 

Playing a Sound 

The following procedure configures a sound to play for an advanced alert. 

Note: Due to restrictions on Windows service applications, the Play a Sound 
action is not available to Orion installations on either Windows 7 or Windows 
Server 2008 and higher. 

To configure a play sound action for an advanced alert: 

1. Click Play Sound. 

2. Specify a sound file for the alert trigger by doing either of the following in the 
Sound file to play field: 

 Type the complete directory path and file name. 

 Click Browse (…) to navigate your file system and select the target file. 

3. Click the musical note button to the right of either text field to test the sound 
file you have specified. 

4. Click Time of Day. 

5. Enter the time period over which you want to activate your alert action, and 
then select the days on which you want to activate your alert action. 
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6. If you want to enable alert escalation, click Alert Escalation, and then 
check any of the following options, as appropriate for your alert: 

 To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

 To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

 To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

7. If you are finished configuring your play a sound alert action, click OK. 

Logging an Advanced Alert to a File 

Orion can be configured to log alerts to a designated file. The following 
procedure logs an advanced alert to a designated file 

To configure an alert log file for an advanced alert: 

1. Click Event Log, and then specify an alert log file by doing either of the 
following in the Alert Log Filename field: 

Note: If the file specified does not exist, it will be created with the first alert 
occurrence. 

 Type the complete path and name of the target file. 

 Click Browse (…) to navigate your file system and select the target file. 

2. Type the message you want to log to your alert log file in the Message field. 

3. If you want to insert a variable into the Message field, complete the 
following procedure: 

a. Click Insert Variable, and then select a Variable Category. 

b. Select the variable you want to add. 

c. If you want to change the parser, check Change Parser, and then 
select the parser you want to use. 

d. If you want to define the SQL variable to copy to the clipboard, 
check Define SQL Variable, and then click Insert Variable From 
Above List. 

e. Click Build Selected Variable. 

Note: For more information on the use of variables, see “Orion Variables 
and Examples” . 

4. Click Time of Day. 
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5. Enter the time period over which you want to activate your alert action. 

6. Select the days on which you want to activate your alert action. 

7. If you want to enable alert escalation, click the Alert Escalation tab, and 
then check any of the following options, as appropriate for your alert: 

 To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

 To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

 To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

8. If you are finished configuring your alert log file, click OK. 

Logging an Advanced Alert to the Windows Event Log 

You may specify that an alert be logged to the Windows Event Log either on the 
Orion server or on a remote server. The following procedure logs an advanced 
alert to the Windows Event Log on a designated server. 

To configure advanced alert logging to the Windows Event Log: 

1. Click Windows Event Log. 

2. If you want your alert to write to the Windows Event Log on your Orion 
server, select Use Event Log Message on Network Performance Monitor 
Server. 

3. If you want your alert to write to the Windows Event Log on a remote 
server, select Use Event Log Message on a Remote Server, and then 
provide the Remote Server Name or IP Address. 

4. Type the message you want to log to the Windows Event Log in the 
Message to send to Windows Event Log field. 

5. If you want to insert a variable into the Message field, complete the 
following procedure: 

a. Click Insert Variable. 

b. Select a Variable Category. 

c. Select the variable you want to add. 

d. If you want to change the parser, check Change Parser, and then 
select the parser you want to use. 
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e. If you want to define the SQL variable to copy to the clipboard, 
check Define SQL Variable, and then click Insert Variable From 
Above List. 

f. Click Build Selected Variable. 

Note: For more information on the use of variables, see “Orion Variables 
and Examples”. 

6. Click Time of Day. 

7. Enter the time period and select the days over which you want to activate 
your alert action. 

8. If you want to enable alert escalation, click Alert Escalation, and then 
check any of the following options, as appropriate for your alert: 

 To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

 To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

 To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

9. If you are finished configuring your alert log file, click OK. 

Logging an Advanced Alert to the NetPerfMon Event Log 

You may specify that an alert be logged to the NetPerfMon Event Log either on 
the Orion server or on a remote server. The following procedure logs an 
advanced alert to the NetPerfMon Event Log on a designated server. 

To configure advanced alert logging to the NetPerfMon Event Log: 

1. Click NPM Event Log. 

2. Type the message you want to log to the NetPerfMon Event Log in the 
Message to send to Network Performance Monitor Event Log field. 

3. If you want to insert a variable into the Message field, complete the 
following procedure: 

a. Click Insert Variable. 

b. Select a Variable Category. 

c. Select the variable you want to add. 

d. If you want to change the parser, check Change Parser, and then 
select the parser you want to use. 
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e. If you want to define the SQL variable to copy to the clipboard, 
check Define SQL Variable, and then click Insert Variable From 
Above List. 

f. Click Build Selected Variable. 

Note: For more information on the use of variables, see “Orion Variables 
and Examples”. 

4. Click Time of Day. 

5. Enter the time period and select the days over which you want to activate 
your alert action. 

6. If you want to enable alert escalation, click Alert Escalation, and then 
check any of the following options, as appropriate for your alert: 

 To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

 To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

 To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

7. If you are finished configuring your alert log file, click OK. 

Sending a Syslog Message 

Orion can log received alerts to the Syslog of a designated machine. The 
following procedure configures an advanced alert to send a message to a 
designated Syslog server. 

To configure an advanced alert to send a Syslog message: 

1. Click Syslog Message. 

2. Type the Hostname or IP Address of the Syslog Server to which you want 
to send Syslog messages. 

3. Select the Severity of your alert Syslog message. 

4. Select Facility of your alert Syslog message. 

5. Type the Syslog Message you want to send. 

6. If you want to insert a variable into the Message field, complete the 
following procedure: 

a. Click Insert Variable. 

b. Select a Variable Category. 
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c. Select the variable you want to add. 

d. If you want to change the parser, check Change Parser, and then 
select the parser you want to use. 

e. If you want to define the SQL variable to copy to the clipboard, 
check Define SQL Variable, and then click Insert Variable From 
Above List. 

f. Click Build Selected Variable. 

Note: For more information on the use of variables, see “Orion Variables 
and Examples”. 

7. Click Time of Day. 

8. Enter the time period over which you want to activate your alert action. 

9. Select the days on which you want to activate your alert action. 

10. If you want to enable alert escalation, click Alert Escalation, and then 
check any of the following options, as appropriate for your alert: 

 To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

 To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

 To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

11. If you are finished with the configuration of your send Syslog message 
action, click OK. 

Executing an External Program 

There are several circumstances where you may want to execute a program 
when a specific network event occurs. Use the Edit Execute Program Action 
window to specify the executable that should be started when the specified alert 
is triggered or reset, as shown in the following procedure. 

Note: External programs selected for this action must be executable using a 
batch file called from the command line. 

To configure an advanced alert to execute an external program: 
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1. Click Execute Program. 

2. Specify the batch file to execute, either by typing the complete path and 
name of the target file into the Program to execute field or by clicking 
Browse (…), to browse your folder structure and select the target 
executable. 

3. Click Time of Day, and then enter the time period when you want to execute 
the external program. 

4. Select the days on which you want to execute the external program. 

5. Click Alert Escalation, and then check any of the following options, as 
appropriate for your alert: 

 To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

 To execute the action repeatedly, while the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered, 
and then provide an action execution interval. 

 To delay alert action execution, check Delay the execution of this 
Action, and then provide the interval the alert engine should wait. 

6. If you are finished configuring your external program execution action, 
click OK.  

Executing a Visual Basic Script 

In some situations you may want to execute a Visual Basic (VB) script when a 
network event occurs. The Edit Execute VB Script Action window is used to 
specify the name and complete path of the file that shall be executed when the 
specified alert is triggered or reset.  

To configure alerts to execute a Visual Basic (VB) script: 

1. Click VB Script. 

2. Select an available VB Script Interpreter. 

3. Specify a VB script to execute either by typing the complete path and name 
of the VB script into the VB Script to execute field or by clicking Browse 
(…) to browse your folder structure and select the script. 

4. Click Time of Day, and then enter the time period and select the days on 
which you want to execute the selected VB script. 

5. Click Alert Escalation, and then check any of the following options, as 
appropriate for your alert: 
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 To disable the script when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

 To execute the script repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

 To delay script execution, check Delay the execution of this Action, 
and then provide an appropriate interval the alert engine should wait 
after the alert condition is met before the script executes. 

6. If you are finished configuring your VB script execution action, click OK.  

Emailing a Web Page 

The Edit E-mail Web Page Action window includes several tabs for configuration. 
The following procedure configures an e-mail URL action for an advanced alert. 

Note: Emails are sent in plain text. 

To configure an email web page action for an advanced alert: 

1. Click E-mail a Web Page, and then then click OK.  

2. Complete the To, CC, BCC, Name, and Reply Address fields. 

Note: You must provide at least one address in the To field. When entering 
multiple addresses, you may only separate addresses with a comma. Some 
pager systems require a valid reply address to complete the page. 

3. Click SMTP Server. 

4. Type the Hostname or IP Address of your SMTP Server and the 
designated SMTP Port Number. 

Note: The SMTP server hostname or IP address field is required. You 
cannot email a web page without identifying the SMTP server. 

5. Click URL, and then type the Subject of your alert email. 

Note: Messaging is disabled if both Subject and URL fields are empty. 

6. If you want to insert a variable into the Subject field, click the location of 
the new variable, and then complete the following procedure: 

a. Click Insert Variable, select a Variable Category, and then select the 
variable to add. 

b. If you want to change the parser, check Change Parser, and then 
select the parser you want to use. 
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c. If you want to define the SQL variable to copy to the clipboard, 
check Define SQL Variable, and then click Insert Variable From 
Above List. 

d. Click Build Selected Variable. 

Note: For more information on the use of variables, see “Orion Variables 
and Examples”. For more information about messages that use 
variables, see “Example Messages Using Variables”. 

7. Provide the URL of your alert email. 

Note: Messaging is disabled if both Subject and URL fields are empty. 

8. If the web server of the URL you want to email requires user access 
authentication, provide both the Web Server UserID and the Web Server 
Password in the Optional Web Server Authentication area. 

9. Click Time of Day, and then enter the time period and select the days when 
you want to activate your alert action. 

10. If you want to enable alert escalation, click Alert Escalation, and then 
check any of the following options, as appropriate for your alert: 

 To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

 To execute the action repeatedly, as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

 To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval for the alert engine to 
wait after the alert condition is met before executing the alert action. 

11. If you are finished configuring your URL email alert action, click OK. 

Using Text to Speech Output 

You may specify a phrase that will be spoken upon alert trigger and a separate 
phrase for the alert reset. Orion uses Microsoft Speech Synthesis Engine version 
5.0, as included with Windows 2003 and XP Professional. If you have Orion 
maintenance, you may also install and use other text-to-speech engines by 
visiting the SolarWinds website. The following procedure configures text-to-
speech output for an advanced alert trigger or reset. 

Note: Due to restrictions on Windows service applications, the Text to Speech 
action is not available to Orion installations on either Windows 7 or Windows 
Server 2008 and higher. 

To configure a text-to-speech output action for an advanced alert: 
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1. Click Text to Speech output, and then then click OK.  

2. On the General tab, Select a Speech Engine, and then use the sliders to set 
the required Speed, Pitch and Volume.  

3. On the Phrase tab, type the text you want to output as speech in the Phrase 
to speak field. 

Note: Click Speak to hear the text, as provided, with the options configured 
as set on the General tab. 

4. On the Time of Day tab enter the time period and select the days on which 
you want to activate your alert action. 

5. If you want to enable alert escalation, open the Alert Escalation tab, and 
then check any of the following options, as appropriate for your alert: 

 To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

 To execute the action repeatedly, as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

 To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval for the alert engine to 
wait after the alert condition is met before executing the alert action. 

6. If you are finished configuring your text-to-speech alert action, click OK. 

Sending a Windows Net Message 

Alerts can be configured to display a pop-up Windows Net Message either on a 
specific computer or on all computers in a selected domain or workgroup. The 
following steps configure Windows Net messaging for triggered or reset alerts. 

Note: The only operating systems supporting Windows Net Messaging on which 
SolarWinds supports Orion installations are Windows Server 2003 and Windows 
XP. SolarWinds only supports evaluation installations of Orion on Windows XP. 

To configure Orion to send a Windows Net message upon alert: 

1. Click Send a Windows Net Message, and then then click OK.  

2. On the Net Message tab, enter the Computer Name or IP Address of the 
machine where you want to send a Windows Net message upon an alert 
trigger or reset. 

3. If you want to send the message to all computers in the domain or 
workgroup of your target computer, check Send to all Computers in the 
Domain or Workgroup. 



 

 
Understanding the Web Console  279 

4. Enter the Windows Net message you want to send in the Message to send 
field. 

Note: You may use variables in this message. For more information on the 
use of variables, see “Orion Variables and Examples”. 

5. On the Time of Day tab enter the time period and select the days on which 
you want to activate your alert action. 

6. If you want to enable alert escalation, open the Alert Escalation tab, and 
then check any of the following options, as appropriate for your alert: 

 To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

 To execute the action repeatedly, as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

 To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval for the alert engine to 
wait after the alert condition is met before executing the alert action. 

7. If you are finished configuring your text-to-speech alert action, click OK. 

Sending an SNMP Trap 

The following steps configure an alert to send an SNMP trap on trigger or reset.  

To configure Orion to send an SNMP trap upon alert: 

1. Click Send an SNMP Trap, and then then click OK.  

2. On the SNMP Trap tab, in the SNMP Trap Destinations field, enter the IP 
addresses of the servers to which you want to send your generated SNMP 
traps. 

Note: Use commas to separate multiple destination IP addresses.  

3. Select the type of trap to send on alert trigger from the Trap Template list. 

Note: Some trap templates may use an alert message. You may change any 
provided text, if you want, but it is important that you understand the use of 
variables beforehand. For more information about using variables, see “Orion 
Variables and Examples”. 

4. Enter the SNMP Community String for your network in the designated field. 

5. On the Time of Day tab enter the time period and select the days on which 
you want to activate your alert action. 
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6. If you want to enable alert escalation, open the Alert Escalation tab, and 
then check any of the following options, as appropriate for your alert: 

 To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

 To execute the action repeatedly, as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

 To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval for the alert engine to 
wait after the alert condition is met before executing the alert action. 

7. If you are finished configuring your SNMP trap alert action, click OK. 

Using GET or POST URL Functions 

Orion can be configured to communicate alerts using HTTP GET or POST 
functions. As an example, a URL may be used as an interface into a trouble 
ticket system, and, by correctly formatting the GET function, new trouble tickets 
may be created automatically. The following procedure configures Orion to use 
GET or POST HTTP functions to communicate alert information. 

To configure Orion to use GET or POST URL functions with alerts: 

1. Click Get or Post a URL to a Web Server, and then then click OK.  

2. Select either Use HTTP GET or Use HTTP POST to set the function that you 
want to use to communicate alert information. 

3. If you selected Use HTTP GET, enter the URL you want to GET. 

4. If you selected Use HTTP POST, enter the URL you want to POST, and 
then enter the Body to POST. 

5. On the Time of Day tab enter the time period and select the days on which 
you want to activate your alert action. 

6. If you want to enable alert escalation, open the Alert Escalation tab, and 
then check any of the following options, as appropriate for your alert: 

 To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

 To execute the action repeatedly, as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

 To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval for the alert engine to 
wait after the alert condition is met before executing the alert action. 
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7. If you are finished with the configuration of Orion to use HTTP GET or 
POST URL functions, click OK. 

Dial Paging or SMS Service 

If NotePager Pro is installed Orion can be configured to communicate alerts 
using paging and SMS services. For more information about installation and 
configuration, see “SolarWinds Orion Network Performance Monitor Integration” 
at www.notepage.net. 

Testing Alert Actions 

The Advanced Alert Manager provides an alert action test feature so you can 
confirm the desired function for actions you have configured to fire when Orion 
detects an alert condition on your network. Complete he following procedure to 
test an alert action. 

To test an alert action: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click Configure Alerts. 

3. Click the alert for which the action you want to test is configured. 

4. Click Test. 

5. If the alert is configured to fire on a node condition, select Alert on 
Network Node, and then select the node against which you want to test the 
action. 

6. If the alert is configured to fire on an interface condition, complete the 
following steps: 

Note: Testing alert actions against interfaces is only available if Orion 
Network Performance Monitor is installed and monitoring interfaces on your 
network. For more information, see the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

a. Select Alert on Network Node, and then select the parent node of the 
interface against which you want to test the action. 

b. Select Select Interface on ParentNode, and then select the interface 
against which you want to test the action. 

7. If the alert is configured to fire on a volume condition, complete the 
following steps: 

http://www.notepage.net/solar-winds/orion.htm
http://www.notepage.net/
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a. Select Alert on Network Node, and then select the parent node of the 
volume against which you want to test the action. 

b. Select Select Volume on ParentNode, and then select the volume 
against which you want to test the action. 

8. If you are testing an alert trigger action, click Test Alert Trigger. 

9. If you are testing an alert reset action, click Test Alert Reset. 

10. When the test completes, as indicated by the test log, click Done. 

Confirm that the expected action occurred as a result of the selected alert trigger 
or reset. 

Viewing Alerts in the Orion Web Console 

The Triggered Alerts for All Network Devices page provides a table view of your 
alerts log. You can customize the list view by using the following procedure to 
select your preferred alert grouping criteria. 

To view alerts in the Web Console: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Click Alerts in the Views toolbar. 

3. If you want to filter your alerts table view by device, select the device to 
which you want to limit your alerts view in the Network Object field. 

4. If you want to filter your alerts table by type of device, select the device 
type to which you want to limit your alerts view in the Type of Device field. 

5. If you want to limit your alerts table to show a specific type of alert, 
select the alert type in the Alert Name field. 

6. In the Show Alerts field, provide the number of alerts you want to view. 

7. If you want to show all alerts, even if they have already been cleared or 
acknowledged, check Show Acknowledged Alerts. 

8. Click Refresh to complete your Alerts view configuration. 

Acknowledging Advanced Alerts in the Web Console 

Orion NCM allows you to acknowledge advanced alerts in the Orion Web 
Console, allowing you to eliminate time lost either when multiple users attempt to 
resolve the same issue or when a user tries to address an issue that has already 
been resolved. 

To acknowledge advanced alerts using the Orion Web Console: 
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1. Log in to the Orion Web Console using an account that has been granted 
alert acknowledgement privileges. 

Note: For more information about access privileges for Orion Web Console 
users, see “User Account Access Settings”. 

2. Click Alerts on the Views toolbar. 

3. If you want to limit the list of alerts to only those dealing with a single 
device, select the specific device from the Network Object list. 

Note: This option is only available if alerts fire on multiple network devices. 

4. If you want to limit the list of alerts to only those dealing with a single 
type of device, select the device type from the Type of Device list. 

Note: This option is only available if Orion is monitoring multiple types of 
network devices. 

5. If you want to limit the list of alerts to only those of a single type, select 
the specific alert type from the Alert Name list. 

Note: This option is only available when multiple types of Orion NCM alerts 
have been triggered. 

6. Confirm the number of alerts displayed in the Show Alerts field. 

7. If you want acknowledged alerts to remain in the Alerts view, even after 
they have been acknowledged, check Show Acknowledged Alerts. 

8. Click Refresh to update the alerts list with your new settings. 

9. Check Acknowledged next to the alerts you want to acknowledge. 

10. Click Acknowledge Alerts. 

Escalated Advanced Alerts 

By creating an escalated alert, Orion NCM enables you to customize a series of 
alerts to trigger successive actions as an alert condition persists. The following 
sections provide both a scenario where an escalated alert may be useful and the 
steps required to create one using the Orion Advanced Alert Manager. 

Escalated Alert Example 

WidgetCo is a business with a small IT staff, consisting of two technicians and an 
IT manager. To ensure that issues are addressed appropriately, the IT manager 
has created multiple escalated alerts for a range of potential network events, 
including device failures and excessive disk space or bandwidth usage. Typically, 
the escalated alerts configured by the WidgetCo IT manager proceed as follows: 
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1. Immediately, as soon as Orion NCM recognizes an alert condition, Orion 
NCM generates both an email and a page that are sent to one of the two 
technicians. An entry is also recorded in the Orion events log. 

2. If the alert is not acknowledged in the Orion Web Console within 20 minutes, 
a second alert is fired, generating another email and another page, both sent 
to both technicians. An entry is also recorded in the Orion events log. 

3. If the second alert is not acknowledged within 20 minutes, Orion NCM fires a 
third alert that sends both an email and a page to both technicians and to the 
IT manager. An entry is also recorded in the Orion events log. 

Escalated alerts ensure that everyone on the WidgetCo IT staff is notified of any 
significant network alert conditions within 45 minutes without burdening the IT 
manager with excessive alert notifications. The following section provides a 
procedure to create a similar escalated alert scheme. 

Creating a Series of Escalated Alerts 

The following procedure creates a series of escalated alerts similar to the 
scheme described in the preceding example. 

Note: Repeat these steps to create a separate alert for each notification level. 
The example provided in the previous section uses a three-level escalated alert, 
The following procedure should be completed three times, once for each alert, to 
replicate the escalated alert of the previous section. 

To create an escalated alert: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click Configure Alerts. 

3. Click New, and then click General. 

4. Type Level X , where X is the level corresponding to the currently configured  
alert, as the name of your escalated alert in the Name of Alert field. 

Note: The example provided in the previous section uses a three-level 
escalated alert. 

5. Type a description of your first level escalated alert in the description field, 
and then check Enable this Alert. 

6. Type the Alert Evaluation Frequency and select Seconds, Minutes, or Hours 
from the list to set the checking interval for your alert. 

7. Click Trigger Condition. 

Note: For more information about configuring trigger conditions, see “Setting 
a Trigger Condition for an Advanced Alert”. 
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8. Select Node as the Type of Property to Monitor. 

9. Confirm that the linked text in the alert definition field displays all. 

Note: Click the linked text to select the number of conditions that you want to 
apply (all, any, none, not all). For more information about linked text 
conditions, see “Understanding Condition Groups”. 

10. Click Browse (…), and then click Add a Simple Condition. 

11. Click the first asterisk (*), and then select Network Nodes > Node Details > 
Node Name. 

12. Confirm that is equal to is the linked condition text in the trigger definition. 

Note: Click the linked text to select the condition you want to apply (equal, 
greater, less, …). For more information about linked text conditions, see 
“Understanding Condition Groups”. 

13. Click the second asterisk (*), and then select your production web server 
from the list of monitored nodes. 

14. Click Add, and then click Simple Condition. 

15. Click the first asterisk (*) in the second condition, and then select Network 
Nodes > Node Status > Node Status. 

16. Confirm that is equal to is the linked condition text in the second trigger 
definition. 

Note: Click the linked text condition to select the condition you want to apply 
(equal, greater, less, …). For more information about linked text conditions, 
see “Understanding Condition Groups”. 

17. Click the second asterisk (*) in the second condition, and then select Down. 

18. If you want to apply any reset conditions to your escalated alert, click 
Reset Condition, and then provide appropriate conditions. For more 
information, see “Setting a Reset Condition for an Advanced Alert”. 

19. If you want to apply any alert suppressions to your escalated alert, click  
Alert Suppression, and then provide appropriate suppression conditions. 
For more information, see “Setting a Suppression for an Advanced Alert”. 

20. If you want to restrict when your escalated alert is valid, click Time of 
Day, designate the Valid Time of Day for your escalated alert, and then 
select the Days of the Week on which your escalated alert is valid. For more 
information, see “Setting the Monitoring Period for an Advanced Alert”. 

Note: By default, your escalated alert is always valid. 

21. Click Trigger Actions, and then click Add New Action. 

22. Select Send an E-mail / Page, and then click OK. 
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23. Click E-mail/Pager Addresses, and then complete the To, CC, BCC, Name, 
and Reply Address fields for your Level 1 contact. 

Note: You must provide at least one email address in the To field. When 
entering multiple addresses in a field, y separate addresses with a comma. 

24. Click Message, and then type the Subject and Message of your escalated 
alert email. 

Notes: 

 Messaging is disabled if both Subject and Message fields are empty. 

 For more information about variables in email subjects and messages, 
see “Sending an E-mail / Page”. 

25. Click SMTP Server, and then provide the Hostname or IP Address of your 
SMTP Server and the designated SMTP Port Number. 

Note: The SMTP server hostname or IP address field is required. You 
cannot send an email/page alert without identifying the SMTP server. 

26. If your SMTP server requires authentication, check This SMTP Server 
requires Authentication. 

27. If you want to restrict when your escalated alert is valid, check Execute 
this Action only between specific hours, and then configure the 
appropriate settings. 

Note: By default, your escalated alert is always valid. For more information, 
see “Setting the Monitoring Period for an Advanced Alert”. 

28. Click Alert Escalation. 

29. Check Do not execute this Action if the Alert has been Acknowledged. 

30. If you want to execute the action repeatedly as long as the trigger 
condition exists, check Execute this Action repeatedly while the Alert is 
Triggered, and then provide an appropriate action execution interval. 

31. If you want to delay alert action execution, check Delay the execution of 
this Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

Note: Typically, if you are configuring the first level alert, you should leave 
this option unchecked. If you are configuring the second level alert, check 
this option and provide the desired delay between the first and second 
notifications. If you are configuring the third level alert, check this option and 
provide the desired delay between the first and third notifications. 

32. Click OK. 

33. If you want your escalated alert to perform any actions upon reset, click 
the Reset Action tab, and then configure appropriate actions. For more 
information, see “Setting a Reset Action for an Advanced Alert”. 
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34. If you are finished configuring your escalated alert, click OK. 

Viewing Alerts from Mobile Devices 

Orion NCM is capable of detecting when you are accessing the Orion Web 
Console from a mobile device. This mobile alerts view allows you to view and 
acknowledge existing active alerts. 

To view and acknowledge alerts from a mobile device: 

1. Using a browser on your mobile device, log in to your Orion Web Console as 
a user with alert management rights. 

2. Click Alerts in the Views toolbar. 

Note: If you want to view the mobile alerts view from a desktop or server 

browser, add ?IsMobileView=true to the URL of the Alerts view in your 

Orion Web Console. 

3. Check alerts you want to acknowledge, and then click Acknowledge. 

Clickable links in alert messages provide more information about triggered alerts. 
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Chapter 16 

Configuring TFTP, Secure Copy /SFTP Server 

The following sections describes how to configure the SolarWinds TFTP Server 
and Secure Copy SFTP Server. 

Using the SolarWinds TFTP Server 

 

The SolarWinds Orion NCM TFTP Server ships with the SolarWinds Orion 
Network Configuration Manager. By default, the NCM uses this TFTP server to 
transfer files to and from your network devices. 

To configure TFTP Server: 

1. Open the TFTP Server in the NCM program group. 

2. On the General tab (File > Configuration), if appropriate, start the server as a 
service within the Windows operating system. 

You can also control TFTP as a service from Administrative Tools, setting the 
service to start automatically. 

3. Check Add TFTP Server to Windows System Tray to gain right-click 
control and status of the server. 

4. Define the directory to use as the file transfer point. 

5. Set the IP address from which the server will manage transfers on the Server 
Bindings tab. 

6. Set any relevant restrictions on transfers on the Security tab. 

Using Secure Copy /SFTP Server 

The SFTP/SCP server runs as a service, but some basic configuration may be 
necessary to ensure the SFTP/SCP server behaves in a way that works best 
within your environment. Complete the following procedure to configure your 
server. 

To configure your SFTP/SCP server: 

1.   Start SolarWinds SFTP & SCP Server from the SolarWinds SFTP & SCP 
Server folder. 

2.   Click File > Configure. 
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3.   Type or browse to the location you want to use as your root folder in the Root 
Directory field. 

4.   Select the protocols you want the server to support from the Allowed 
Protocols list. 

5.   Select the options you want to enable in the Permitted File Transfer 
Operations section. 

6.   Click the TCP/IP Settings tab, and then type the port number you want to use 
in the TCP Port field. 

7.   If you want to specify the IP address configuration, click Use Custom IP 
Address Binding, and then select the IP address you want to use. 

8.   If you want to enable user authentication on the server, complete the 
following procedure. 

a.   Click the Users tab. 

b.   Click New User. 

c.   Type the username and password, and then click Apply Changes. 

d.   If you want to remove any users, select the username, and then click 
Remove. 

9.   Click the Startup and System Tray tab. 

10. If you want to start the SFTP/SCP server when Windows starts, check 
Autom atically run this application when I log on to Windows. 

11. Specify if you want the application to close or minimize to the system tray in 
the Clicking the Close Button section. 

12. Click OK. 

Using a Third-Party SCP server. 

 

The following section details the steps necessary to configure NCM to use a 
third-party SCP server for config transfers.  

To configure NCM to use a third-party SCP server: 

1. Click File > Settings. 

2. Select SCP Server from the left menu tree. 

3. Check ‘Use third-party SCP Server’ option on the SCP Server settings 
dialog. 

4. Confirm that valid user credentials are provided on the same screen. 
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5. Validate that the SCP Root Directory is set to be the same as the third-party 
server. 

Note: User must have Receive\Transmit permissions configured in the third-party 
SCP server.  
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Chapter 17 

Managing EnergyWise Entities 

The following sections explore how you can use Orion Network Configuration 
Manager in conjunction with Orion Network Performance Manager to enable and 
manage your Cisco EnergyWise entities.  

What is EnergyWise? 

EnergyWise is Cisco's response to the call to cut energy costs, address 
environmental concerns, and adhere to government directives around green 
technologies. By purchasing EnergyWise capable devices and enabling their 
energy-saving features, you can retain business critical systems in a fully 
powered state while allowing less critical power over ethernet (PoE) devices to 
power down or drop into standby during off hours.  

EnergyWise gives you the ability to control your energy cost. Orion NCM gives 
you the ability to remotely apply recurrence policies and schedule power usage, 
helping you use less power. And, Orion NPM allows you to monitor your energy 
use and power levels. SolarWinds perfectly partners with Cisco and the 
EnergyWise technologies to help you save more and monitor your savings. 

Managing and Enabling EnergyWise Nodes 

Cisco devices that support the EnergyWise technology can be enabled and their 
EnergyWise settings managed through the Orion NCM integration with Orion 
NPM. Before completing the following procedure, you must have installed Orion 
NCM and Orion PM in an integrated setup. For more information on integrated 
setups see Chapter 2, “Installing Orion Network Configuration Manager”. 
EnergyWise nodes must be managed in both Orion NCM and Orion NPM. For 
more information about adding nodes to Orion NCM, see “Adding Nodes”. For 
more information about discovering and adding nodes to Orion NPM, see the 
Orion NPM Administrator Guide.  

To enable or manage EnergyWise on an Orion NPM node: 

1. Navigate to your Orion Web Console. For example, type 
http://NameOfOrionServer in the address bar of your web browser. 

2. Log on to Orion NPM. 

3. Click Settings. 

4. Click Manage Nodes. 

5. Check the Cisco node you want EnergyWise enable, and then click 
More Actions > Manage EnergyWise. 
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6. Click enable EnergyWise on these nodes. 

7. Specify the appropriate values on the Manage EnergyWise Node page. For 
more information about a field, click Help. 

8. Click Execute Config Actions. 

Note: To manage or modify node-level EnergyWise settings, repeat this 
procedure omitting Step 6. 

Managing Your PoE Ports 

Power over ethernet (PoE) devices are connected to your devices on an 
interface and are managed at the interface level. Before completing the following 
procedure, you must have installed the Orion NCM Integration for Orion NPM on 
your Orion NPM server and added your EnergyWise capable nodes to both Orion 
NCM and Orion NPM. For more information about adding nodes to Orion NCM, 
see “Adding Nodes”.  

The following procedure guides you through enabling and configuring your 
EnergyWise interfaces. For more information about recurrence policies or the 
interaction between recurrence importance and entity importance, see the Help. 

To enable or manage EnergyWise on an Orion NPM interface: 

1. Navigate to your Orion NPM Web Console. For example, type 
http://NameOfOrionServer in the address bar of your web browser. 

2. Log on to Orion NPM. 

3. Click Settings in the Views menu bar. 

4. Click Manage Nodes. 

5. Expand the Cisco node contaning the interface you want to configure.  

6. Check the interface you want to EnergyWise enable, and then click 
More Actions > Manage EnergyWise. 

7. Click enable EnergyWise on these nodes. 

8. Specify the appropriate values on the Manage EnergyWise Interface page. 
For more information about a field, click Help. 

9. Click Execute Config Actions. 

Note: To manage or modify interface-level EnergyWise settings, repeat this 
procedure omitting Step 7. 
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Chapter 18 

Common Tasks 

The following sections present example scenarios to help demonstrate how you 
can use Orion Network Configuration Manager in different network environments. 

Customizing the Login Banner of a Device 

You can easily change the login banner for a router, switch, or firewall using 
Orion Network Configuration Manager. This customization can be rolled out to a 
single or multiple devices. The following procedure references other sections of 
the guide: 

 “Downloading Configuration Files” on page 91 

 “Comparing Configurations” on page 97 

 “Executing Command Scripts” on page 137 

To update a login banner: 

1. Back up your running configuration prior to making changes. 

2. Click the node or group of nodes you want to update, and then click Nodes > 
Download Configs. 

3. Click Download. 

4. Click the node or group of nodes you want to update, and then click Nodes > 
Execute Command Script. 

5. Type the following command script: 

config t 

no banner login 

banner login ^Unauthorized use of these systems is punishable 

by law^ 

exit 

wr mem 

Where Unauthorized use of these systems is punishable by law  is 

the new banner. 

6. Click Execute Command Script. 
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7. To verify the script executed successfully using a Telnet session, complete 
the following procedure: 

a. Select the nodes from the node tree. 

b. Click Nodes > Tools > Telnet. A new window with a Telnet session 
command prompt will open, displaying the new login banner. 

8. To verify the script executed successfully by comparing the current 
configuration to the previous configuration, complete the following procedure: 

a. Select the nodes from the node tree. 

b. Click the node or group of nodes you updated, and then click Nodes > 
Download Configs. 

c. Check Compare to last Config Downloaded. 

d. Click Download. When the download completes, a comparison window 
opens. Changes to the login banner are highlighted in yellow if the 
banner is different from a previous login banner. If no login banner was 
previously specified, changes are highlighted in red and green. 

Configuring Automated Nightly Backups 

A powerful feature of Orion Network Configuration Manager is the ability to 
schedule daily configuration file backups. Orion Network Configuration Manager 
installs an example job which downloads the configuration files nightly for all 
nodes in the database. You can modify the example for your specific needs, or 
you can create a new job. The following procedure creates a new nightly 
configuration backup job. For more information on creating jobs, see “Creating a 
New Job” on page 223. 

To setup nightly configuration backups for all nodes: 

1. Click Schedule > Create New Job. 

2. Click Download Configs from Devices, and then click Next. 

3. Type a name for the job, and then click Continue. 

4. Select Daily in the Schedule Job list. 

5. Type or select a time in Start Time. 

6. Type or select a date in Starting On. 

7. Type or select a date in Ending On. To assign a job to run with no end date, 
leave this field blank. 

8. Click Continue. 

9. Type the Windows account name that will be used to run the job. 
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10. Type the password for the Windows account in the appropriate password 
fields. 

11. Click Finish. 

12. Type any comments in the Comments field. 

13. Click the Download Config tab. 

14. Check the configuration types you want to download. 

15. Check Last Config to be notified when the downloaded configuration file is 
different from the last configuration. 

16. Check Baseline Config to be notified when the downloaded configuration 
file is different from the baseline configuration. 

17. Click OK. 

Changing the Community String on Multiple Nodes 

The following procedure replaces the public read-only community string with a 

new read-only community string on several network nodes at the same time. The 
procedure references other sections of the guide: 

 “Downloading Configuration Files” on page 91 

 “Comparing Configurations” on page 97 

 “Executing Command Scripts” on page 137 

To update the community string for a group of nodes: 

1. Back up the running configuration prior to making any changes.  

2. Click the node or group of nodes you want to update, and then click Nodes > 
Download Configs. 

3. Click Download. 

4. Right-click a node or group of nodes, and then click Execute Command 
Script. 

5. Type the following command script: 

config t 

no snmp-server community public RO 

snmp-server community 123@dm1n RO 

exit 

wr mem 

Where 123@dm1n is the new community string. 

6. Click Execute Command Script. 
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7. To verify that the script executed successfully, 

a. Click the node or group of nodes you updated, and then click Nodes > 
Download Configs. 

b. Check Compare to last Config Downloaded. 

c. Click Download. When the download completes, a comparison window 
opens. Changes to the community string are highlighted in red and 
green. 

Changing Wireless Settings on All Access Points 

The following procedure changes the interface for a wireless access point, and 
then pushes that same change to additional access points by uploading only the 
lines in the configuration file that have changed. The procedure references other 
sections of the guide: 

 “Downloading Configuration Files” on page 91 

 “Comparing Configurations” on page 97 

 “Uploading Selected Lines” on page 103 

 “Executing Command Scripts” on page 137 

To change wireless settings on all access points: 

1. Back up the running configuration prior to making any changes.  

2. Click the group of nodes you want to update, and then click Nodes > 
Download Configs. 

3. Click Download. 

4. Click an access point in the node tree, and then click Nodes > Browse 
Node. 

5. Use the web user interface of the access point to make changes, and then 
close the browser tab. 

6. Click the access point in the node tree, and then click Nodes > Download 
Configs. 

7. Check Compare to last Config Downloaded. 

8. Click Download. When the download completes, a comparison window 
opens. Changes to the wireless settings are highlighted in yellow if the 
settings are different from previous. If the settings were not previously 
specified, changes are highlighted in red and green. 

9. Select the lines that changed, and then click Actions > Upload Selected 
Lines. 

10. Click Add Devices. 
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11. Select all the access points you want to update, and then click OK. 

12. Click Create Upload Script. 

13. Click Execute Command Script. 

14. If you want to verify the script executed successfully, complete the 
following procedure: 

a. Right-click the node or group of nodes, and then click Download 
Configs. 

b. Check Compare to last Config Downloaded. 

c. Click Download. 

d. Review the comparison window. Changes to the community string are 
highlighted in red and green. 

Changing an Interface Description 

Updating interface descriptions with Orion Network Configuration Manager saves 
time because you do not have to remember IP addresses or login credentials for 
the device you are updating. Complete the following procedure to modify an 
interface description. The procedure references other sections of the guide: 

  “Downloading Configuration Files” on page 91 

 “Comparing Configurations” on page 97 

 “Executing Command Scripts” on page 137 

To update an interface description on a node: 

1. Back up the running configuration prior to making any changes.  

2. Click the node that is to be updated, and then click Nodes > Download 
Configs. 

3. Click Download. 

4. Click the node that you want to update, and then click Nodes > Execute 
Command Script. 

5. Type the following command script: 

config t 

interface Ethernet0 

no description 

description Link to Upstairs Lab 

exit 

exit 
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wr mem 

Where Link to Upstairs Lab is the new description. 

6. Click Execute Command Script. 

7. Verify the script was executed successfully by complete the following 
procedure: 

a. Click the node that was updated, and then click Nodes > Edit Selected 
Nodes. 

b. Click the Interfaces tab. 

c. Select Interface / Port Configuration in the Interface Details list. 

d. Click Refresh. 

e. Verify that the new description has been applied to the interface you 
modified. 

Upgrading IOS and Firmware 

IOS images can be uploaded using the Orion Network Configuration Manager 
internal scripting engine. You can transfer these image files using TFTP, FTP, 
HTTP, or any other transfer protocol. 

The following example takes advantage of the SolarWinds TFTP Server, 
included with Orion Network Configuration Manager, to transfer an IOS image to 
the router. The TFTP Server must be running and configured to send and receive 
files. Also, the IOS image file must reside in the TFTP Root Directory. 

IOS image management can be very complex. SolarWinds recommends you 
follow the upgrade guidelines outlined by your hardware manufacturer. 

The following procedure references other sections of the guide: 

 “Downloading Configuration Files” on page 91 

 “Executing Command Scripts” on page 137 

To push an IOS image to a network device: 

1. Back up the running configuration prior to making any changes.  

2. Click the node that is to be updated, and then click Nodes > Download 
Configs. 

3. Click Download. 

4. Click the node that is to be updated, and then click Nodes > Execute 
Command Script. 

5. Type the following command script: 
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copy tftp flash 

10.10.2.17 

c2500-i-l.123-9a.bin 

Y 

Where 10.10.2.17 is the location of the IOS image to copy using TFTP. 

6. Click Execute Command Script. 

Note: This script can be scheduled. For more information, see “Scheduling Jobs” 
on page 223. 

Blocking All Private Addresses with an Access List 

Routers connected the Internet are normally configured to discard any traffic 
using private IP addresses. This isolation gives your private network a basic form 
of security as it is not usually possible for the outside world to establish a 
connection directly one of your network devices using these addresses. The 
following procedure updates the access control list (ACL) to block all private IP 
addresses on several devices at the same time. The procedure references other 
sections of the guide: 

 “Downloading Configuration Files” on page 91 

 “Comparing Configurations” on page 97 

 “Executing Command Scripts” on page 137 

To update the ACL for a group of nodes: 

1. Back up the running configuration prior to making any changes. 

2. Click the group of routers that are to be updated, and then click Nodes > 
Download Configs. 

3. Click Download. 

4. Click the group of routers that you want to update, and then click Nodes > 
Execute Command Script. 

5. Type the following command script: 

${EnterConfigMode} 

access-list 102 deny ip 10.0.0.0 0.255.255.255 any log 

access-list 102 deny ip 172.16.0.0 0.15.255.255 any log 

access-list 102 deny ip 192.168.0.0 0.0.255.255 any log 

exit 

write memory 
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Where 102 is the name of the ACL. ${EnterConfigMode} is a variable that is 

equivalent to Config Terminal on Cisco devices. 

6. Verify the script executed successfully by completing the following 
procedure: 

a. Click the router or group of routers you updated, and then click Nodes > 
Download Configs. 

b. Check Compare to last Config Downloaded. 

c. Click Download. When the download completes, a comparison window 
opens. Changes are highlighted in red and green. 

Blocking a MAC Address on a Wireless Access Point 

If you discover a device utilizing unauthorized access through your wireless 
network, you can block the MAC address to prevent future access. The following 
procedure uses an access control list (ACL) on a wireless access point to block a 
specific MAC address. The procedure references other sections of the guide: 

 “Downloading Configuration Files” on page 91 

 “Comparing Configurations” on page 97 

 “Executing Command Scripts” on page 137 

To update the ACL for a node: 

1. Back up the running configuration prior to making any changes. 

2. Click the group of routers that are to be updated, and then click Nodes > 
Download Configs. 

3. Click Download. 

4. Click the group of routers that you want to update, and then click Nodes > 
Execute Command Script. 

5. Type the following command script: 

${EnterConfigMode} 

access-list 724 deny 000e.0ca1.a2b4 0000.0000.0000 

exit 

wr mem 

Where 724 is the ACL you are modifying, and where 000E.0CA1.A2B4 is the 

MAC address to block. ${EnterConfigMode} is a variable that is equivalent 

to Config Terminal on Cisco devices. 
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6. Verify the script executed successfully by complete the following procedure: 

a. Click the node or group of nodes, and then click Download Configs. 

b. Check Compare to last Config Downloaded. 

c. Click Download. 

d. When the download completes, a comparison window opens 
automatically. Changes to the access list are highlighted in red and 
green. 
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Appendix A 

Node and Archive Variables 

Orion Network Configuration Manager uses a variable system that is similar to 
the one used in Orion Network Performance Monitor. Variables always begin with 

a dollar sign and a curly brace (${), and always end with a curly brace (}). 

Variables may be used within almost any custom property. They may also be 
used in any of the user editable system properties. 

Variables can also be nested and recursive. That is, a single variable can refer to 
a Node property that contains more variables that then contain even more 
variables. The following example demonstrates nested variables. 

Node Property Value of Property 

Location Rack ${Rack} on ${Floor} floor of ${Building} - ${SysLocation} 

Building Building C 

SysLocation Data Center A 

Rack 15 

Floor Second 

 

The database value of Location is Rack ${Rack} on ${Floor} floor of 

${Building} - ${SysLocation}. The displayed value of Location is Rack 15 

on Second floor of Building C – Data Center A. 

For more information about Syslog, Trap, and Template variables, see the 
following sections: 

 “Command Template Commands” on page 129 

 "Pre-Command and Command Template Variables” on page 131 

 "Trap Alert Variables” on page 326 

 "Syslog Alert Variables” on page 337 
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Node Variables 

All fields in the nodes table may be used as variables, including any custom 
properties added to your nodes. 

Nodes Table Field Description 

NodeID Unique ID assigned to each Network Node 

NodeCaption 
Displayed name for the node. The default for NodeCaption is a 

variable. ${SysName} 

NodeGroup 

Group to which this node belongs. Some group examples include 

Routers, Accounting, or simply ${Building}. The last 

example refers to a custom property named Building. 

AgentIP 

The IP address used when communicating with the node. A router 
or server may have many IP addresses. This IP address is the one 
used when Orion Network Configuration Manager makes SNMP 
requests or transfers configuration files. 

AgentIPSort 
Numeric equivalent of the AgentIP. Used for sorting by IP address 
in reports. 

ReverseDNS Reverse lookup of the AgentIP 

ResponseTime Current response time of the node in milliseconds 

ResponseError 
OK if the node is responding. Returns an error message if the node 
is not responding. 

Status 
Numeric status of the node. 
1 = Up 
2 = Down 

Community SNMP community string 

SNMPLevel 

The version of SNMP supported by the Node. 
0 = SNMP not supported 
1 = SNMP V1 
2 = SNMP V2 
3 = SNMP V3 

SysName System name of the node. 

SysDescr System description of the node. 

SysContact System contact information collected from the node. 

SysLocation System location information collected from the node. 

SystemOID System OID discovered from the node. 

Vendor Hardware vendor of this network node. 

VendorIcon Name of the vendor icon used. 

MachineType 
Type of hardware. This information is discovered by SolarWinds 
Discovery Engine. 

LastBoot Last time the node rebooted. 
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Nodes Table Field Description 

OSImage Operating system running on the node 

OSVersion Version of the operating system running on the node 

ConfigTypes Types of configuration files supported by this node 

NodeComments Any comments about this node entered by the user. 

NextDiscovery Time for next complete discovery of this node 

NextPoll Time for next poll (up/down and response time) 

Username Login username 

Password Login password 

EnableLevel Enable level used when transferring configs or running scripts 

EnablePassword Enable level password 

ExecProtocol 
The protocol used when executing scripts. This is set to 

${GlobalExecProtocol} by default. 

TransferProtocol 
The protocol used when downloading configs. This is set to 

${GlobalTransferProtocol} by default. 

Configuration Archive Variables 

Orion Network Configuration Manager stores all downloaded configurations in a 
database. It can also store a copy of them in the configuration archive directory. 
The directory structure can be specified using any of the previous variables.  

Additional variables may also be used when specifying the configuration archive 
directory. Many of these variables use the localization settings for the current 
language and region. 

Property Description 

DateTime Local date and time in short date and local time format 

Date Date in short date format 

LongDate Date in long date format 

MediumDate Date in medium date format 

Time Time in short time format 

LongTime Time in long time format 

MediumTime Time in "medium time" format 

ShortTime Time in "short time" format 

DOW Day of the week (spelled out) 

D Day of the month 
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Property Description 

DD Day of the month (with leading zero, if needed) 

ABREVIATEDDOW Day of the week in abbreviated format 

LocalDow Day of the week in the local language 

Month Number of the current month 

M Number of the current month 

MM Number of the current month (with leading zeros, if needed) 

MMM Abbreviated name of the month 

MMMM Name of the month 

LocalMonthName Name of the month in the local language 

DAYOFYEAR Day number of the year 

YYYY 4 digit year 

YY 2 digit year 

YEAR2 2 digit year 

YEAR4 4 digit year 

H Hour 

HH 2 digit hour (with leading zero, if needed) 

N Minute 

NN 2 digit minute (with leading zero, if needed) 

S Seconds 

SS 2 digit seconds (with leading zero, if needed) 

AMPM AM or PM 

CRLF Carriage return - linefeed combination 

ConfigType Type of configuration ( running, startup, etc ) 

Caption Caption of the node (NodeCaption) 
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Appendix B 

Regular Expression Pattern Matching 

When editing comparison criteria, the following regular expressions can be used 
for pattern matching. Examples are provided at the end of this section. 

Characters 

Character Description Example 

Any character 
except 
[,\,^,$,.,|,?,*,+,(,), 

All characters except the listed special 
characters match a single instance of 
themselves. 

a matches a 

\ (backslash) 
followed by any of 
[,\,^,$,.,|,?,*,+,(,), 

A backslash escapes special characters to 
suppress their special meaning. 

\+ matches + 

\xFF where FF are 
2 hexadecimal 
digits  

Matches the character with the specified 
ASCII/ANSI value, which depends on the 
code page used. Can be used in character 
classes. 

\xA9 matches © 
when using the 
Latin-1 code page. 

\n, \r and \t 
Match an LF character, CR character and a 
tab character respectively. Can be used in 
character classes. 

\r\n matches a 
DOS/Windows 
CRLF line break. 
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Character Classes or Character Sets [abc]  

Character Description Example 

[ (opening square 
bracket) 

Starts a character class. A character class 
matches a single character out of all of the 
possibilities offered by the character class. 
Inside a character class, different rules 
apply. The rules in this section are only valid 
inside character classes. The rules outside 
this section are not valid in character 
classes, except \n, \r, \t and \xFF 

  

Any character 
except ^,-,],\ add 
that character to 
the possible 
matches for the 
character class. 

All characters except the listed special 
characters. 

[abc] matches a, b 
or c 

\ (backslash) 
followed by any of 
^,-,],\ 

A backslash escapes special characters to 
suppress their special meaning. 

[\^\]] matches ^ or ] 

- (hyphen) except 
immediately after 
the opening [ 

Specifies a range of characters. (Specifies a 
hyphen if placed immediately after the 
opening [) 

[a-zA-Z0-9] 
matches any letter 
or digit 

^ (caret) 
immediately after 
the opening [ 

Negates the character class, causing it to 
match a single character not listed in the 
character class. (Specifies a caret if placed 
anywhere except after the opening [) 

[^a-d] matches x 
(any character 
except a, b, c or d) 

\d, \w and \s 

Shorthand character classes matching digits 
0-9, word characters (letters and digits) and 
whitespace respectively. Can be used inside 
and outside character classes 

[\d\s] matches a 
character that is a 
digit or whitespace 

 

Dot 

Character Description Example 

. (dot) 
Matches any single character except line 
break characters \r and \n. 

. matches x or 
most any other 
character 
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Anchors 

Character Description Example 

^ (caret) 

Matches at the start of the string to which 
the regular expression pattern is applied. 
Matches a position rather than a character. 
Most regular expression flavors have an 
option to make the caret match after line 
breaks (i.e. at the start of a line in a file) as 
well. 

^. matches a in 
abc\ndef. Also 
matches d in 
"multi-line" mode. 

$ (dollar) 

Matches at the end of the string to which the 
regular expression pattern is applied. 
Matches a position rather than a character. 
Most regular expression flavors have an 
option to make the dollar match before line 
breaks (i.e. at the end of a line in a file) as 
well. Also matches before the very last line 
break if the string ends with a line break. 

.$ matches f in 
abc\ndef. Also 
matches c in 
"multi-line" mode. 

\A 

Matches at the start of the string to which 
the regular expression pattern is applied to. 
Matches a position rather than a character. 
Never matches after line breaks. 

\A. matches a in 
abc 

\Z 

Matches at the end of the string to which the 
regular expression pattern is applied. 
Matches a position rather than a character. 
Never matches before line breaks, except 
for the very last line break if the string ends 
with a line break. 

.\Z matches f in 
abc\ndef 

\z 

Matches at the end of the string to which the 
regular expression pattern is applied. 
Matches a position rather than a character. 
Never matches before line breaks. 

.\z matches f in 
abc\ndef 

 

Word Boundaries 

Character Description Example 

\b 

Matches at the position between a word 
character (anything matched by \w) and a 
non-word character (anything matched by 
[^\w] or \W) as well as at the start and/or 
end of the string if the first and/or last 
characters in the string are word characters. 

.\b matches c in 
abc 

\B 

Matches at the position between two word 
characters (i.e the position between \w\w) 
as well as at the position between two non-
word characters (i.e. \W\W). 

\B.\B matches b in 
abc 
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Alternation 

Character Description Example 

|  
(vertical bar or 
“pipe”) 

Causes the regular expression engine to 
match either the part on the left side or the 
part on the right side. Can be strung 
together into a series of options. 

abc|def|xyz 
matches abc, def 
or xyz 

|  
(vertical bar or 
“pipe”) 

The vertical bar has the lowest precedence 
of all operators. Use grouping to alternate 
only part of the regular expression. 

abc(def|xyz) 
matches abcdef or 
abcxyz 

 

Quantifiers 

Character Description Example 

? (question mark) 
Makes the preceding item optional. The 
optional item is included in the match, if 
possible. 

abc? matches ab 
or abc 

?? 

Makes the preceding item optional. The 
optional item is excluded in the match, if 
possible. This construct is often excluded 
from documentation because of its limited 
use. 

abc?? matches ab 
or abc 

* (star) 

Repeats the previous item zero or more 
times. As many items as possible will be 
matched before trying permutations with 
fewer matches of the preceding item, up to 
the point where the preceding item is not 
matched at all. 

.* matches "def" 
"ghi" in abc "def" 
"ghi" jkl 
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Character Description Example 

*? (lazy star) 

Repeats the previous item zero or more 
times. The engine first attempts to skip the 
previous item before trying permutations 
with ever increasing matches of the 
preceding item. 

.*? matches "def" 
in abc "def" "ghi" 
jkl 

+ (plus) 

Repeats the previous item once or more. As 
many items as possible will be matched 
before trying permutations with fewer 
matches of the preceding item, up to the 
point where the preceding item is matched 
only once. 

.+ matches "def" 
"ghi" in abc "def" 
"ghi" jkl 

+? (lazy plus) 

Repeats the previous item once or more. 
The engine first matches the previous item 
only once, before trying permutations with 
ever increasing matches of the preceding 
item. 

.+? matches "def" 
in abc "def" "ghi" 
jkl 

{n} where n is an 
integer >= 1 

Repeats the previous item exactly n times. a{3} matches aaa 

{n,m} where n >= 1 
and m >= n 

Repeats the previous item between n and m 
times. Will try to repeat m times before 
reducing the repetition to n times. 

a{2,4} matches aa, 
aaa or aaaa 

{n,m}? where n >= 
1 and m >= n 

Repeats the previous item between n and m 
times. Will try to repeat n times before 
increasing the repetition to m times. 

a{2,4}? matches 
aaaa, aaa or aa 

{n,} where n >= 1 

Repeats the previous item at least n times. 
Will try to match as many items as possible 
before trying permutations with fewer 
matches of the preceding item, up to the 
point where the preceding item is matched 
only m times. 

a{2,} matches 
aaaaa in aaaaa 

{n,}? where n >= 1 

Repeats the previous item between n and m 
times. The engine first matches the previous 
item n times before trying permutations with 
ever increasing matches of the preceding 
item. 

a{2,}? matches aa 
in aaaaa 
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Regular Expression Pattern Matching Examples 

The following examples illustrate some of the uses of Regular Expression pattern 
matching. 

snmp-server community public 

Finds any line that includes the text snmp-server community public. There 

can be text before and/or after the string on the same line. 

service tcp-keepalives-in.*\n(.*\n)*.*service tcp-keepalives-out 

Finds the first line service tcp-keepalives-in and then looks for service 

tcp-keepalives-out on any line after that. The regular expression string 

.*\n(.*\n)*.* is used to search any number of lines between strings. 

access-list 105 deny.*tcp any any eq 139 log 

Finds the line with access-list 105 deny, followed by any number of 

characters of any type, followed by tcp any any eq 139 log on the same 

line. The regular expression string .* finds any character, and any number of 

characters on the same line. So, this could be used to find spaces, tabs, 
numbers, letters, or special characters. 

ntp clock-period \d* 

Finds any line that includes ntp clock-period followed by any number. The 

regular expression string \d* will find any number at any length, such as 3, 

48, or 2394887. 

user \x2a 

Finds any line that includes user *. The regular expression string \x 

followed by a hexadecimal value specifies an individual character. In this 

example, \x2a represents the asterisk character, which has a hexadecimal 

value of 2a. 
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Appendix C 

Using the Database Manager 

The Database Manager can be used to perform queries, view database and table 
details, export data, and edit database values. The Database Manager can also 
be used to repair, compact, restore, or back up the database. 

Starting Database Manager 

To perform any maintenance on your database, the Database Manager must be 
used. Complete the following procedure to start the Database Manager. 

To open Database Manager, click Start > All Programs > SolarWinds Orion > 
Advanced Features > SolarWinds Database Manager. 

Adding a Server 

The following procedure adds a SQL server to the SolarWinds Database 
Manager. 

To add a SQL server: 

1. Start Database Manager. 

2. Click File > Add Server. 

3. Select the SQL server from the list or enter the IP address of the SQL Server 
machine. 

4. Provide the appropriate login type: 

 Windows Integrated Security automatically passes Windows account 
credentials to the SQL server 

 SQL Server user ID and password 

5. Click Connect to Database Server. The left pane navigation tree populates 
with your database server information. 
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Creating Database Backups 

It is very important you periodically back up your Orion Network Configuration 
Manager database. Regular backups enable you to recover your Orion Network 
Configuration Manager data in case of hardware failure. For more information 
about scheduling a maintenance plan, see “Creating a Database Maintenance 
Plan” on page 318. 

To create a database backup: 

1. Start Database Manager. For more information, see “Starting Database 
Manager” on page 315. 

2. Click the database in the left pane of the Database Manager window, and 
then click Database > Backup Database. 

3. Type a description of the database backup and specify a path and filename 
for the backup file. 

Note: Ensure the target location for the database backup has sufficient 
available disk space. 

Restoring a Database 

If you need to restore a database due to corruption, disaster recovery, or some 
other unexpected occurrence, Orion Network Configuration Manager allows you 
to do so with the Database Manager. Complete the following procedure to 
restore a database from a backup. 

To restore a database from backup: 

1. Start Database Manager. For more information, see “Starting Database 
Manager” on page 315. 

2. Click Database > Restore Database. 

3. Browse to the location of the appropriate database, or type a valid SQL 
backup database name and path in the text box. Typically the default is 
SolarWinds\Data\ConfigurationManagement.BAK. 

Note: Databases that are currently in use can not be restored. 

4. Click Verify to ensure you have specified a valid SQL backup database 
name. 

5. Click OK to restore the selected database. 
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Compacting your Database 

Run the database compact procedure to remove whitespace, reindex, and shrink 
your database. SolarWinds recommends you compact your database as it 
approaches capacity. If you are using SQL Express, the maximum database size 
is 4GB. 

To compact your database: 

1. Start Database Manager. For more information, see “Starting Database 
Manager” on page 315. 

2. Select a database to compact. 

3. Click Database > Compact Database. 

4. If the before and after sizes are the same value, compact tables within 
your database. For more information, see “Compacting Individual Tables” on 
page 317. 

5. You can review the details of the compacting by viewing the log. By default, 

the log is stored in \SolarWinds\Orion Network Configuration 

Manager\NetPerfMon-Compact-YYYYMMDD.log. 

Compacting Individual Tables 

You can use the Database Manager to compact individual tables. You can use 
this functionality when compacting the database does not shrink the database 
enough. 

To compact a table: 

1. Start Database Manager. For more information, see “Starting Database 
Manager” on page 315. 

2. Drill into your database to display the tables. 

3. Click the appropriate table in the left pane, and then click Table > 
Compact/Rebuild Indexes. 
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Viewing Database Details 

Details about your database can be viewed in Database Manager. To maintain 
peak performance, monitor the value in the Total Space Used field. SolarWinds 
recommends you compact your database as it approaches capacity. If you are 
using SQL Express, the maximum database size is 4GB. For more information, 
see “Compacting your Database” on page 317. 

The Last Backup field should also be noted to ensure you are adhering to a 
regular database maintenance plan. If this field is blank, you do not have a 
backup of your database. For details on how to schedule a regular database 
backup, see “Creating a Database Maintenance Plan” on page 318. 

To view database details: 

1. Start Database Manager. For more information, see “Starting Database 
Manager” on page 315. 

2. Select your database from the Database Manager. 

3. Click Database > Database Details 

4. Review the Properties tab. 

Viewing Table Details 

Details about a table in a selected database can be viewed in Database 
Manager. The Properties tab includes general statistics pertaining to table size 
and creation date. The Columns tab describes table columns, keys, and field 
types. The Indexes tab provides a list of indexes used within the table. 

To view table details: 

1. Start Database Manager. For more information, see “Starting Database 
Manager” on page 315. 

2. Select your table from the Database Manager. 

3. Click Table > Table Details. 

4. Click the Properties, Columns, or Indexes tabs to view details about 
respective aspects of your table. 

Creating a Database Maintenance Plan 

You can create a database maintenance plan to compact and back up the 
database on a schedule. To create a database maintenance plan for the Orion 
Network Configuration Manager database, complete the following procedure. 

Note: SQL Server Agent must be running in order to execute your database 
maintenance plan. 
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To create a database maintenance plan: 

1. Start Database Manager. For more information, see “Starting Database 
Manager” on page 315. 

2. Click the database you want to create a maintenance plan for, and then click 
Database > Database Backup Schedule. 

3. Select the frequency with which to run the backup. 

4. Set the time for the backup to run, and then click Next. 

5. Check Compact and Shrink the database before the backup. 

6. Specify the database backup file and backup report locations. 

7. Click Finish. 
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Appendix D 

Monitoring SNMP Traps 

SNMP traps signal the occurrence of significant events by sending unsolicited 
SNMP messages to a monitoring device. The SolarWinds Trap Server listens for 
incoming trap messages on UDP port 161 and then decodes, displays, and 
stores the messages in the Orion NCM database. The SolarWinds Trap Service 
allows Orion NCM to receive and process SNMP traps from any type of 
monitored network device, and, because the SolarWinds Trap Service is multi-
threaded, it can handle large numbers of simultaneously incoming traps. 

You can view SNMP traps in the Trap Viewer application. The Trap Viewer 
application allows you to configure trap-specific alerts, to view and search traps, 
and to apply powerful trap filtering. 

Note: When configuring devices to send SNMP traps, confirm that traps are sent 
to the IP address assigned to the Orion NCM server. To ensure proper 
configuration, refer to the documentation supplied by the vendor of your devices. 

The SNMP Trap Protocol 

SNMPv1 (Simple Network Management Protocol) and SNMPv2c, along with the 
associated Management Information Base (MIB), allow you to take advantage of 
trap-directed notification. When monitoring a large number of devices, where 
each device may have a large number of its own connected objects, it can 
become impractical to request information from every object on every device. 
Consider having each managed device notify the Orion NCM SNMP Trap Server 
of any issues without solicitation. In this configuration, a problem device notifies 
the server by sending a message. This message is known as a trap of the event. 
After receiving the event, the Trap Viewer displays it, allowing you to choose to 
take action or automatically trigger an action based on the nature of the event. 

Configuring the Trap Viewer 

Before you can monitor SNMP traps, the Microsoft SNMP Trap service must be 
installed and devices must be configure to send traps to the Orion NCM SNMP 
Trap Server. To ensure proper configuration, refer to the documentation supplied 
by the vendor of your network devices. 

If you want to use the Trap Viewer tool or trigger realtime configuration change 
alerts based on traps, ensure the SNMP Trap Service is running. If the SNMP 
Trap Service is not listed as a running service in the service control manager 
(services.msc), you can enable Simple Network Management Protocol in the 

Management and Monitoring Tools through Add/Remove Windows Components 
in the Add/Remove Programs application. 
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Note: The SNMP port used to monitor traps is UDP port 162. 

Trap Viewer Settings 

Use the following procedure to start and configure the Trap Viewer. 

To start and configure the Trap Viewer: 

1. Click Start > All Programs > SolarWinds Orion Network Configuration 
Manager > Orion NCM SNMP Trap Server. 

2. Click File > Settings. 

3. Select the General tab on the Trap Server Settings window. 

4. Adjust the Maximum number of traps to display in Current Traps view to 
the number you want. 

5. If you want to automatically refresh the Current Traps view, check the 
appropriate option, and then adjust the refresh rate. 

6. Adjust the Retain Trap messages for how many days? to set the length of 
time traps remain in the database. 

7. Select the Displayed Columns tab. 

8. Use the arrow keys to select and order the columns of information that you 
want to see in the Current Traps view. 

9. Click the Message Parsing tab. 

10. If you do not need the domain name from your trap messages, check 
Remove Domain Name from DNS Lookups. 

Note: Checking this option will remove the domain name from your trap 
messages, and this will help to reduce the size of the database. 

Configuring Trap Viewer Filters and Alerts 

The Trap Viewer can be configured to trigger alert actions when trap messages 
match defined rules. The following steps establish rules to filter trap messages 
and initiate alert actions as you determine. 

To configure Trap Viewer filters and alerts: 

1. Click Start > All Programs > SolarWinds Orion Network Configuration 
Manager > Orion NCM SNMP Trap Server. 

2. Click View > Alerts / Filter Rules. 

3. If you are creating a new rule, click Add Rule. 

4. If you are editing an existing rule, select the rule, and then click Edit Rule. 

5. Select the General tab, and then type a Rule Name. 
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6. Check Enabled to enable the rule. 

7. Select appropriate servers from the Apply this Rule to list. 

8. Enter the IP addresses or subnets to which this rule applies.  

Note: Use the examples listed on this tab to format the list properly. 

9. If you want the rule to be limited to messages from specific hosts, 
domains, or hostname patterns, click DNS Hostname, and then enter a 
DNS Hostname Pattern. 

Note: When Use Regular Expressions in this Rule is checked, regular 
expressions can be used in place of “like” statements. For more information 
about regular expressions, see “Regular Expression Pattern Matching” on 
page 309. 

10. If you want the rule to be limited to specific community strings or text 
within a trap message, click Message, and then enter rules Community 
String Pattern. 

Notes: 

 Use the examples listed on this tab to format the list properly. 

 When Use Regular Expressions in this Rule is checked, regular 
expressions can be used in place of “like” statements. For more 
information about regular expressions, see “Regular Expression Pattern 
Matching” on page 309. 

11. Select the Conditions tab, and then generate trigger conditions for rule 
application in the text field as follows: 

 Select appropriate object identifiers and comparison functions from the 
linked context menus. 

 Click Browse (…) to insert an or condition, to insert an and condition, or 

to delete a condition. 

For more information about how to configure conditions, see “Configuring 
Realtime Configuration Change Detection” on page 106. 

12. If you want to limit rule application to within a specific period of time, 
select the Time of Day tab, check Enable Time of Day checking, enter the 
time period, and then select days of the week on which to apply the rule. 

Notes: 

 Enabling time of day checking creates more overhead for the CPU. 

 Messages received outside the specified timeframe will not trigger alerts. 
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13. If you want to suppress alert actions until a specified number of traps 
arrive that match the rule, select the Trigger Threshold tab, check Define a 
Trigger Threshold for this Rule, and then enter option values as 
appropriate. 

Note: When Suspend further Alert Actions for is checked, alert actions 
are not sent until the specified amount of time has expired. Once the time 
period has expired, only new alerts are sent. All alerts that are suppressed 
during the time period are discarded. 

14. Select the Alert Actions tab. 

15. If you are associating a new action to the rule, click Add New Action, 
and then select an action from the list to configure. For more information 
about alert actions, see “Available Trap Alert Actions” on page 324. 

16. If you are editing an existing action for the rule, select an action from the 
list, click Edit Action, and then configure the action. For more information 
about alert actions, see “Available Trap Alert Actions” on page 324. 

17. Use the arrow buttons to arrange the order in which actions are performed. 

Note: Actions are processed in the order that they appear in this list, from top 
to bottom. 

18. If you need to delete an action, select the action, and then click Delete 
Action. 

19. Click OK to save all changes and return to Trap Viewer Settings. 

20. Use the arrow buttons to arrange the order in which the rules are applied. 

Note: Rules are processed in the order they appear, from top to bottom. 

Available Trap Alert Actions 

The following list provides definitions of the actions available for each trap alert 
type. For more information about how to assign alert actions, see “Configuring 
Trap Viewer Filters and Alerts” on page 322. 

Discard the Trap 

Allows you to delete unwanted traps sent to the SNMP Trap server. 

Tag the Trap 

Allows you to add a custom tag to received traps. Ensure you include the 
Tag column in the viewer when assigning a tag. 

Flag the Trap with a specific color 

Allows you to assign a specific color to flag traps matching the rule. 

Log the Trap to a file 
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Allows you to specify a file and a series of variables with which to tag traps 
sent to the file. Ensure you have already created the log file you want to use. 
The alert cannot create a file. 

Windows Event Log 

Allows you to write a message to the local Windows Event Log or to a remote 
Windows Event Log. 

Forward the Trap 

Allows you to specify the IP address or hostname and the port on which to 
forward the trap. 

Play a sound 

Allows you to play a sound when a matching SNMP trap is received. 

Text to Speech output 

Allows you to define a specific speech engine, the speed, pitch, volume, and 
message to read. 

Execute an external program 

Allows you to specify an external program to launch. This action is used 
when creating realtime change notifications in Orion NCM. 

Execute an external VB Script 

Allows you to lauch a VB Script using the selected script interpreter engine 
and a saved script file. 

Send a Windows Net Message 

Allows you to send a net message to a specific computer or an entire domain 
or workgroup. 

Send an E-mail / Page 

Allows you to send an email from a specified account to a specified address, 
using a specific SMTP server, and containing a customizable subject and 
message. 

Stop Processing Trap Rules 

Stops the processing of SNMP trap rules for the matching trap. 
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Working with Traps 

Trap Viewer collects traps from your network and presents them in a readily 
reviewable and searchable list so that you can easily monitor network health. The 
following sections provide a guide to working with trap messages within the Trap 
Viewer. 

Viewing Current Traps 

Trap Viewer makes it easy to view trap messages. 

To view current trap messages: 

1. Click Start > All Programs > SolarWinds Orion > Trap Viewer. 

2. Click View > Current Traps. 

Searching for Traps 

Collected trap messages may be searched within Trap Viewer. The following 
steps search for trap messages and format the search results list. 

To search the trap message list: 

1. Click Start > All Programs > SolarWinds Orion Network Configuration 
Manager > Orion NCM SNMP Trap Server. 

2. Click View > Search Traps. 

3. Enter appropriate search criteria, and then click Search Database. 

4. If you want to group messages for easier navigation, select the type of 
grouping from the Grouping list. 

5. If you want to limit the number of messages that are shown, enter or 
select a number in the Maximum number of messages to display field. 

6. If you want to view messages that meet your search criteria as they 

arrive, select a number for the Auto Refresh every number seconds field. 

Note: Auto Refresh is only available when you are viewing current 
messages. The Date/Time Range must be set to Today, Last 24 Hours, 
Last 2 Hours, or Last Hour. 

Trap Alert Variables 

The following variables can be used in trap alert messages with the Orion NCM 
Trap Server. You must begin each variable with a dollar sign and enclose each 

variable identifier in curly braces as, for example, ${VariableName}. 
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Trap Date/Time Variables 

Trap Date/Time 
Variable 

Description 

${AbreviatedDOW} Current day of the week. Three character abbreviation. 

${AbreviatedMonth} Current month of the year. Three character abbreviation. 

${AMPM} AM or PM corresponding to current time (before or after noon) 

${D} Current day of the month 

${DD} Current day of the month (two digit number, zero padded) 

${Date} Current date. (MM/DD/YYYY format) 

${DateTime} Current date and time. (MM/DD/YYYY HH:MM format) 

${Day} Current day of the month 

${DayOfWeek} Current day of the week. 

${DayOfYear} Numeric day of the year 

${H} Current hour 

${HH} Current hour. Two digit format, zero padded. 

${Hour} Current hour. 24-hour format 

${LocalDOW} Current day of the week. Localized language format. 

${LongDate} Current date. (DAY NAME, MONTH DAY, YEAR format) 

${LongTime} Current Time. (HH:MM:SS AM/PM format) 

${M} Current numeric month  

${MM} Current month. Two digit number, zero padded. 

${MMM} Current month. Three character abbreviation. 

${MMMM} Full name of the current month 
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Trap Date/Time 
Variable 

Description 

${MediumDate} Current date. (DD-MMM-YY format) 

${MediumTime} Current timee. (HH:MM AM/PM format) 

${Minute} Current minute. Two digit format, zero padded. 

${MonthName} Full name of the current month 

${S} Current second. 

${Second} Current second. Two digit format, zero padded. 

${Time} Current Time. (HH:MM format) 

${Year} Four digit year 

${Year2} Two digit year 

Other Trap Variables 

Trap Variable Description 

${Application} SolarWinds application information 

${Community} Node community string 

${Copyright} Copyright information 

${DNS} Fully qualified node name 

${IP } IP address of device triggering alert 
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Appendix E 

Monitoring Syslog Messages 

Syslog messages are realtime messages network devices generate to notify you 
about specific device events. The SolarWinds Syslog Service allows you to 
receive and process Syslog messages from any type of network device. Because 
the SolarWinds Syslog Service has the ability to open multiple connections, it can 
handle large numbers of simultaneously incoming Syslog messages. 

The Syslog Server allows you to view, acknowledge, and alert on Syslog 
messages you receive. By utilizing the built-in flexible message filtering, you can 
easily create message-specific alerts. 

Note: When configuring network devices to send Syslog messages, confirm that 
messages are sent to the IP address assigned on which the Syslog Server is 
installed. To ensure proper configuration, refer to the documentation supplied by 
the vendor for each network device. 

Understanding the Syslog Protocol 

The Syslog service listens for incoming Syslog messages on UDP port 514 and 
then decodes, displays, and stores the message in a database. Many network 
devices can be configured to generate Syslog messages, allowing you to receive 
and process the messages generated by these network devices. For details on 
enabling Syslog message on a particular device, refer to the vendor's 
documentation.  

Syslog Priorities 

Included at the beginning of each Syslog message is a priority value. The priority 

value range spans between 0 and 191 and is enclosed in angle bracket (< and >) 

delimiters. The priority value is calculated using the following formula: 

Priority = Facility * 8 + Severity 
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Syslog Facilities 

The facility value is used to determine which process of the machine created the 
message. Since the Syslog protocol was originally written on BSD Unix, the 
Facilities reflect the names of UNIX processes and daemons. The following 
tables list Syslog facilities and levels. 

Number Source Number Source 

0 kernel messages 12 NTP subsystem 

1 user-level messages 13 log audit 

2 mail system 14 log  alert 

3 system daemons 15 clock daemon 

4 security/authorization messages 16 local use 0 (local0) 

5 
messages generated internally 
by Syslog 

17 local use 1 (local1) 

6 line printer subsytem 18 local use 2 (local2) 

7 network news subsytem 19 local use 2 (local3) 

8 UUCP subsystem 20 local use 2 (local4) 

9 clock daemon 21 local use 2 (local5) 

10 security/authorization messages 22 local use 2 (local6) 

11 FTP daemon 23 local use 2 (local7) 

 
Note: If you are receiving messages from a UNIX system, consider using the 

User Facility as your first choice. Local0 through Local7 are not used by UNIX 

and are traditionally used by networking equipment. Cisco routers, for example, 
use Local6 or Local7. 
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Syslog Severities 

The following table provides a list of Syslog severity levels with descriptions and 
suggested actions for each. 

Number Severity Suggested Actions 

0 Emergency 
A "panic" condition affecting multiple applications, servers, or 
sites. System is unusable. Notify all technical staff on call. 

1 Alert 
A condition requiring immediate correction, for example, the 
loss of a backup ISP connection. Notify staff who can fix the 
problem. 

2 Critical 

A condition requiring immediate correction or indicating a 
failure in a primary system, for example, a loss of a primary 
ISP connection. Fix CRITICAL problems before ALERT-level 
problems. 

3 Error 
Non-urgent failures. Relay errors to developers or 
administrators. Each item must be resolved within a given 
time. 

4 Warning 

Warning messages are not errors, but they indicate that an 
error will occur if required action is not taken. An example is a 
file system that is 85% full. Each item must be resolved within 
a given time. 

5 Notice 

Events that are unusual but are not error conditions. These 
items might be summarized in an email to developers or 
administrators to spot potential problems. No immediate 
action is required. 

6 Informational 
Normal operational messages. These may be harvested for 
network maintenance functions like reporting and throughput 
measurement. No action is required. 

7 Debug 
Information useful to developers for debugging an application. 
This information is not useful during operations. 
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Configuring Syslog Server 

You can use the Syslog Server application for viewing, acknowledging, and 
triggering alerts in response to Syslog messages on your network. 

Syslog Server Settings 

Use the following procedure as a guide to starting and configuring the Syslog 
Server.  

To start and configure the Syslog Server: 

1. Click Start > All Programs > SolarWinds Orion Network Configuration 
Manager > Syslog Viewer. 

2. Click File > Settings. 

3. Select the General tab in the Syslog Server Settings window. 

4. Adjust the Maximum number of messages to display in Current 
Messages view to show the number of messages you want. 

5. If you want to Automatically Refresh the Current Messages View, check 
the option accordingly, and then position the middle slider to set the refresh 
rate. 

6. Adjust Retain Syslog messages for how many days? to set the length of 
time Syslog messages should stay in the database. 

7. Select the Displayed Columns tab, and then use the arrow keys to select and 
order the fields of information that you want to see in the Current Messages 
view. 

Note: You can make it easier to acknowledge Syslog messages by selecting 
the Acknowledged column to add to your view. For more information, see 
“Viewing and Acknowledging Current Messages” on page 336. 

8. If you want to wrap Syslog messages text in the Current Messages 
view, check Word wrap long messages. 

9. If you do not expect to use Syslog Server as your primary viewer for 
Syslog messages, select the Message Parsing tab, and then complete the 
following steps: 

Note: The following data points are saved within the Syslog tables in your 
Orion NCM database, removing the added data from each record helps you 
proactively reduce the size of your database. 

a. Check Remove embedded Date/Time from Syslog Messages. 

b. Check Remove Message Type from Syslog Messages. 

c. Check Remove Domain Name from DNS Lookups. 
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Configuring Syslog Viewer Filters and Alerts 

The Syslog Viewer can be configured to signal Orion N alert actions when Syslog 
messages that are received from network devices match defined rules. The steps 
in the following procedure establish rules that filter Syslog messages and initiate 
alert actions as you determine. 

To configure Syslog Viewer filters and alerts: 

1. Click Start > All Programs > SolarWinds Orion Network Configuration 
Manager > Syslog Viewer. 

2. Click File > Settings. 

3. Click View > Alerts/Filter Rules. 

4. If you are creating a new rule, click Add New Rule. 

5. If you are editing an existing rule, select the rule, and then click Edit Rule. 

6. Select the General tab. 

7. Type a Rule Name, and then check Enabled to enable the rule. 

8. Select appropriate servers from the Apply this Rule to list. 

9. Enter the IP addresses or subnets to which this rule applies.  

Note: Use the examples listed on this tab to properly format the list. 

10. If you want to limit the rule to only messages from specific hosts, 
domains, or hostname patterns, select the DNS Hostname tab, and then 
enter a DNS Hostname Pattern. 

Note: When Use Regular Expressions in this Rule is checked, regular 
expressions can be used in place of “like” statements. For more information 
about regular expressions, see “Regular Expression Pattern Matching” on 
page 309. 

11. If you want to limit the rule to only specific message types or text within 
a Syslog message, select the Message tab, and then enter rules for one or 
both of Message Type Pattern and Syslog Message Pattern. 

Notes: 

 Use the examples listed on this tab to format the list properly. 

 When Use Regular Expressions in this Rule is checked, regular 
expressions can be used in place of “like” statements. For more 
information about regular expressions, see “Regular Expression Pattern 
Matching” on page 309. 
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12. Select the Severity / Facility tab, and then check the severity and facility 
types you want to apply. 

Note: By default, all message severities and facilities are selected. 

13. If you want to limit rule application to within a specific period of time, 
select the Time of Day tab, check Enable Time of Day checking, enter the 
time period, and then select days of the week on which to apply the rule. 

Notes: 

 Enabling Time of Day checking creates more overhead for the CPU. 

 Messages received outside the specified timeframe will not trigger alerts. 

14. If you want to suppress alert actions until a specified number of 
messages arrive that match the rule, complete the following procedure: 

a. Select the Trigger Threshold tab. 

b. Check Define a Trigger Threshold for this Rule. 

c. Enter option values as appropriate. 

Note: When Suspend further Alert Actions for is checked, alert actions 
are not sent until the specified amount of time has expired. Once the time 
period has expired, only new alerts are sent. All alerts suppressed during the 
time period are discarded. 

15. Select the Alert Actions tab. 

16. If you are associating a new action to the rule, click Add New Action, 
and then select an action from the list to configure. For more information 
about available actions, see “Available Syslog Alert Actions” on page 335. 

Note: Syslog alerts use a unique set of variables. For more information about 
available Syslog variables, see “Syslog Alert Variables” on page 337. 

17. If you are editing an existing action for the rule, complete the following 
steps: 

a. Select an action from the list. 

b. Click Edit Selected Action. 

c. Configure the action as appropriate. For more information about 
available actions, see “Available Syslog Alert Actions” on page 335. 

Note: Syslog alerts use a unique set of variables. For more information about 
available Syslog variables, see “Syslog Alert Variables” on page 337. 

18. If you need to delete an action, select the action, and then click Delete 
Action. 
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19. Use the arrow buttons to arrange the order in which actions are performed. 

Note: Actions are processed in the order that they appear in this list, from top 
to bottom. 

20. Click OK to save all changes and return to Syslog Viewer Settings. 

21. Use the arrow buttons to arrange the order in which the rules are applied. 

Note: Rules are processed in the order they appear, from top to bottom. 

Available Syslog Alert Actions 

The following list provides definitions of the actions available for each Syslog 
alert type. For more information about how to assign alert actions, see 
“Configuring Syslog Viewer Filters and Alerts” on page 333. 

Discard the Syslog Message 

Allows you to delete unwanted Syslog messages sent to the Syslog server. 

Tag the Syslog Message 

Allows you to add a custom tag to received Syslog messages. Ensure you 
include the Tag column in the viewer when assigning a tag. 

Modify the Syslog Message 

Allows you to modify severity, facility, type and contents of a Syslog 
message. 

Log the Message to a file 

Allows you to specify a file and a series of variables with which to tag Syslog 
messages sent to the file. Ensure you have already created the log file you 
want to use. The alert cannot create a file. 

Windows Event Log 

Allows you to write a message to the local Windows Event Log or to a remote 
Windows Event Log. 

Forward the Syslog message 

Allows you to specify the IP address or hostname and the port on which to 
forward the Syslog event. 

Send a new Syslog message 

Allow you to trigger a new Syslog message to a specific IP address or 
hostname, on a specific port, with a customizable severity, facility, and 
message. 
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Send an SNMP Trap 

Allows you to send a trap to an IP address following a specific trap template 
and using a specific SNMP community string. 

Play a sound 

Allows you to play a sound when a matching Syslog message is received. 

Text to Speech output 

Allows you to define a specific speech engine, the speed, pitch, volume, and 
message to read. 

Execute an external program 

Allows you to specify an external program to launch. This action is used 
when creating realtime change notifications in Orion NCM. 

Execute an external VB Script 

Allows you to lauch a VB Script using the selected script interpreter engine 
and a saved script file. 

Send a Windows Net Message 

Allows you to send a net message to a specific computer or an entire domain 
or workgroup. 

Send an E-mail / Page 

Allows you to send an email from a specified account to a specified address, 
using a specific SMTP server, and containing a customizable subject and 
message. 

Stop Processing Syslog Rules 

Stops the processing of Syslog rules for the matching Syslog message. 

Using Syslog Server 

Syslog Server collects Syslog messages from your network and presents them in 
a readily reviewable and searchable list so that you can easily monitor your 
network. The following sections provide a guide to working with Syslog 
messages within the Syslog Server application. 

Viewing and Acknowledging Current Messages 

The main Syslog Server window, Syslog Viewer, makes it easy to view and 
acknowledge messages. The following procedure views and then acknowledges 
current Syslog messages. 
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To view and acknowledge current Syslog messages: 

1. Click View > Current Messages. 

2. Acknowledge current messages by either of the following methods: 

 Right-click any message, and then select Acknowledge Selected. 

 Add an Acknowledged column to the Syslog Viewer, and then check 
each message that you want to acknowledge. For more information, see 
“Syslog Server Settings” on page 332. 

Searching for Syslog Messages 

Collected Syslog messages may be searched within Syslog Viewer. The 
following steps both search for Syslog messages and format search results. 

To search the Syslog message list: 

1. Click View > Search Messages. 

2. Enter appropriate search criteria, and then click Search Database. 

3. If you want to group messages for easier navigation, select the type of 
grouping from the Grouping list. 

Note: Messages can be acknowledged in the search results just as they can 
be acknowledged in the Current Messages view. For more information, see 
“Viewing and Acknowledging Current Messages” on page 336. 

4. If you want to limit the number of messages that are shown, enter or 
select a number in the Maximum number of messages to display field. 

5. If you want to view messages that meet your search criteria as they 

arrive, select a number for the Auto Refresh every number seconds field. 

Note: Auto Refresh is only available when you are viewing current 
messages. The Date/Time Range must be set to Today, Last 24 Hours, 
Last 2 Hours, or Last Hour. 

Syslog Alert Variables 

The following variables can be used in Syslog alert messages. You must begin 
each variable with a dollar sign and enclose each variable identifier in curly 

braces as, for example, ${VariableName}. 
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Syslog Date/Time Variables 

Syslog Date/Time 
Variable 

Description 

${AbreviatedDOW} Current day of the week. Three character abbreviation. 

${AMPM} AM or PM corresponding to current time (before or after noon) 

${D} Current day of the month 

${DD} Current day of the month (two digit number, zero padded) 

${Date} Current date. (Short Date format) 

${DateTime} 
Current date and time. (Windows control panel defined “Short 
Date” and “Short Time” format) 

${DayOfWeek} Current day of the week. 

${DayOfYear} Numeric day of the year 

${H} Current hour 

${HH} Current hour. Two digit format, zero padded. 

${Hour} Current hour. 24-hour format 

${LocalDOW} Current day of the week. Localized language format. 

${LongDate} Current date. (Long Date format) 

${LocalMonthName} Current month name in the local language. 

${LongTime} Current Time. (Long Time format) 

${M} Current numeric month 

${MM} Current month. Two digit number, zero padded. 

${MMM} Current month. Three character abbreviation. 

${MediumDate} Current date. (Medium Date format) 

${Minute} Current minute. Two digit format, zero padded. 

${Month} Full name of the current month 

${N} Current month and day 

${S} Current second. 

${Second} Current second. Two digit format, zero padded. 

${Time} Current Time. (Short Time format) 

${Year2} Two digit year 

${Year} Four digit year 
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Other Syslog Variables 

Syslog Variable Description 

${Application} SolarWinds application information 

${Copyright} Copyright information 

${DNS} Fully qualified node name 

${Hostname} Host name of the device triggering the alert 

${IP_Address} IP address of device triggering alert 

${Message} Status of device triggering alert 

${MessageType} Assigned alert name 

${Release} Release information 

${Severity} 

A network health score providing 1 point for 
an interface in a warning state, 1000 points 
for a down interface, and 1 million points for a 
down node. 

${Version} Version of the SolarWinds software package 

 

 

 

 

 

 

 

 

 

 
 

Appendix F 

Orion Variables and Examples 

Orion NCM product components, including the Advanced Alert Manager, both the 
Traps Viewer and the Syslog Viewer, and Network Atlas can employ Orion 
variables. These variables are dynamic and, in the case of alerts, parse when the 

alert is triggered or reset. For example, the variable ${ResponseTime} will parse 

with the current response time of the node that is triggering the alert. 
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Note: In some cases, the database table name may be required for alert 

variables, as in ${Nodes.CPULoad}. If a variable does not respond as intended, 

include the relevant table name for the desired variable. 

Variable Modifiers 

The variables in the following sections can be modified by appending any of the 
variable modifiers in the following table. 

Variable Modifier Description 

-Raw 
Displays the raw value for the statistic. For example, if Transmit 
Bandwidth is set to 10 Mbps, then the raw value would be“10000000”. 
The cooked value would be “10 Mbps”. 

-Previous 
Displays the previous value for the statistic before the Alert was 
triggered 

-Cooked 
Displays the cooked value for the statistic. For example, if Transmit 
Bandwidth is set to 10 Mbps, then the raw value would be “10000000” 
and cooked value would be “10 Mbps”. 

-PreviousCooked 
Displays the previous cooked value for the statistic before the Alert 
was triggered 

Advanced Alert Engine Variables 

The following variables can be used in alert messages within Orion NCM and 
Orion Modules. You must begin each variable with a dollar sign and enclose 
each variable identifier in braces as, for example, ${ObjectName}. 

General 

The following are valid, general advanced alert variables. 
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General Variable Description 

${Acknowledged} Acknowledged status 

${AcknowledgedBy} Who the alert was acknowledged by 

${AcknowledgedTime} Time the alert was acknowledged 

${AlertTriggerCount} Count of triggers 

${AlertTriggerTime} 
Date and time of the last event for this Alert. (Windows control 
panel defined “Short Date” and “Short Time”) 

${Application} SolarWinds application information 

${CR} Line Feed – Carriage Return 

${Copyright} Copyright information 

${ObjectName} Description/Name of the object in the alert 

${Release} Release information 

${Version} Version of the SolarWinds software package 

Date/Time 

The following are valid date and time variables. 
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Date/Time Variable Description 

${AMPM} AM/PM indicator 

${AbreviatedDOW} Current day of the week. Three character abbreviation. 

${D} Current day of the month 

${DD} Current day of the month (two digit number, zero padded) 

${Date} Current date. (Short Date format) 

${DateTime} 
Current date and time. (Windows control panel defined “Long 
Date” and “Long Time” format) 

${DayOfWeek} Current day of the week. 

${DayOfYear} Numeric day of the year 

${H} Current hour 

${HH} Current hour. Two digit format, zero padded. 

${Last2Hours} Last two hours 

${Last24Hours} Last 24 hours 

${Last7Days} Last seven days (Short Date format) 

${LastHour} Last hour 

${LocalDOW} Current day of the week. Localized language format. 

${LocalMonthName} Current month name in the local language. 

${LongDate} Current date. (Long Date format) 

${M} Current numeric month 

${MM} Current month. Two digit number, zero padded. 

${MMM} Current month. Three character abbreviation. 

${MMMM} Full name of the current month 

${MediumDate} Current date. (Medium Date format) 

${Minute} Current minute. Two digit format, zero padded. 

${S} Current second. 

${Second} Current second. Two digit format, zero padded. 

${Time} Current Time. (Short Time format) 

${Today} Today (Short Date format) 

${Year} Four digit year 

${Year2} Two digit year 

${Yesterday} Yesterday (Short Date format) 

Group Variables 

The following are valid group variables. 
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Group Variable Description 

${GroupDetailsURL} URL of the Group Details view for a selected group 

${GroupFrequency} 
Interval on which group membership is evaluated 
and group snapshots are taken. 

${GroupID} Designated identifier for a defined group 

${GroupMemberDisplayName} 
Display name of group member type:  Node, 
Volume, Component, Application, etc. 

${GroupMemberDisplayNamePlural} 
Display name of multiple group members of a type: 
Nodes, Components, Applications, etc. 

${GroupMemberFullName} Full name of a group member, including location 

${GroupMemberName} Name of a group member 

${GroupMemberPercentAvailability} 
Percent availability of a group member when group 
member status is Up, Warning, or Critical and 0% if 
status is anything else. 

${GroupMemberSnapshotID} Unique identifier of group member snapshot. 

${GroupMemberStatusID} 
Identifier assigned to a group member indicating its 
status. For more information see “Status Variables” 
on page 344. 

${GroupMemberStatusName} 
Name of group member status. For more 
information see “Status Variables” on page 344. 

${GroupMemberUri} 
Uri used by SolarWinds Information Service (SWIS) 
to refer to the selected group member within the 
web console. 

${GroupName} Name of the group. 

${GroupOwner} Orion product appropriate to the group type 

${GroupPercentAvailability} 
100% when group status is Up, Warning, Critical 
and 0% if status is anything else. 

${GroupStatusCalculatorID} 

Name of roll-up logic calculator that evaluates status 

of group based on member statuses. (0 = Mixed, 1 

= Worst, 2 = Best) 

${GroupStatusCalculatorName} 

Name of roll-up logic calculator that evaluates status 

of group based on member statuses. (Mixed, 

Worst, Best) 

${GroupStatusID} 
Identifier assigned to a group indicating its status. 
For more information see “Status Variables” on 
page 344. 

${GroupStatusName} 
Name of group status. For more information see 
“Status Variables” on page 344. 

${GroupStatusRootCause} A list of all group members that are not Up 

${NodeID} NULL every time - just for legacy support. 

SQL Query 
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Any value you can collect from the database can be generated, formatted, or 
calculated using a SQL query as a variable. To use a SQL query as a variable in 

Orion NCM, use ${SQL:{query}} as shown in the following example that returns 

the results of the SQL query Select Count(*) From Nodes: 

${SQL:Select Count(*) From Nodes} 

Status Variables 

When using the ${Status} variable with a monitored object, status values are 

returned, as appropriate. The following table provides a description for each 
status value. 

Status Value Description 

0 Unknown 

1 Up 

2 Down 

3 Warning 

4 Shutdown 

5 Testing 

6 Dormant 

7 Not Present 

8 Lower Layer Down 

9 Unmanaged 

10 Unplugged 

11 External 

12 Unreachable 

14 Critical 

15 Mixed Availability 

16 Misconfigured 

17 Could Not Poll 

19 Unconfirmed 

22 Active 

24 Inactive 

25 Expired 

26 Monitoring Disabled 

27 Disabled 

28 Not Licensed 

Node Variables 

The following are valid node variables. 
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Node Variable Description 

${AgentPort} Node SNMP port number 

${Allow64BitCounters} Node allows 64-bit counters (1), or not (0) 

${AvgResponseTime} 
Average node response time , in msec, to 
ICMP requests 

${BlockUntil} 
Day, date, and time until which node polling is 
blocked 

${BufferBgMissThisHour} 
Device-dependent count of big buffer misses 
on node in current hour, queried with MIB 
1.3.6.1.4.9.2.1.30 

${BufferBgMissToday} 
Device-dependent count of big buffer misses 
on node in current day, queried with MIB 
1.3.6.1.4.9.2.1.30 

${BufferHgMissThisHour} 
Device-dependent count of huge buffer misses 
on node in current hour, queried with MIB 
1.3.6.1.4.9.2.1.62 

${BufferHgMissToday} 
Device-dependent count of huge buffer misses 
on node in current day, queried with MIB 
1.3.6.1.4.9.2.1.62 

${BufferLgMissThisHour} 
Device-dependent count of large buffer misses 
on node in current hour, queried with MIB 
1.3.6.1.4.9.2.1.38 

${BufferLgMissToday} 
Device-dependent count of large buffer misses 
on node in current day, queried with MIB 
1.3.6.1.4.9.2.1.38 

${BufferMdMissThisHour} 
Device-dependent count of medium buffer 
misses on node in current hour, queried with 
MIB 1.3.6.1.4.9.2.1.22 

${BufferMdMissToday} 
Device-dependent count of medium buffer 
misses on node in current day, queried with 
MIB 1.3.6.1.4.9.2.1.22 

${BufferNoMemThisHour} 
Count of buffer errors due to low memory on 
node in current hour 

${BufferNoMemToday} 
Count of buffer errors due to low memory on 
node in current day 

${BufferSmMissThisHour} 
Device-dependent count of small buffer misses 
on node in current hour, queried with MIB 
1.3.6.1.4.9.2.1.14 

${BufferSmMissToday} 
Device-dependent count of small buffer misses 
on node in current day, queried with MIB 
1.3.6.1.4.9.2.1.14 

${Caption} User friendly node name 

${Community} Node community string 

${Contact} 
Contact information for person or group 
responsible for node 

${CPULoad} Node CPU utilization rate at last poll 

${CustomPollerLastStatisticsPoll} Day, date, and time of last poll attempt on node 



Administrator Guide  SolarWinds Orion Network Configuration Manager 
 

 
346  Configuring Automatic Login 

Node Variable Description 

${CustomPollerLastStatisticsPollSuccess} 
Day, date, and time that node was last 
successfully polled 

${Description} Node hardware and software 

${DNS} Fully qualified node name 

${DynamicIP} 
If node supports dynamic IP address 
assignment via BOOTP or DHCP (1); static IP 
address return (0) 

${EngineID} 
Internal unique identifier of the polling engine 
to which node is assigned 

${GroupStatus} 
Filename of status icon for node and, in Orion 
NPM, its interfaces 

${IOSImage} Family name of Cisco IOS on node  

${IOSVersion} Cisco IOS version on node 

${IP_Address} Node IP address 

${LastBoot} Day, date and time of last node boot 

${LastSync} 
Time and date of last node database and 
memory synchronization 

${Location} Physical location of node 

${MachineType} 
Node manufacturer or distributor and family or 
version information 

${MaxResponseTime} 
Maximum node response time , in msec, to 
ICMP requests 

${MemoryUsed} Total node memory used over polling interval 

${MinResponseTime} 
Minimum node response time , in msec, to 
ICMP requests 

${NextPoll} 
Day, date and time of next scheduled node 
polling 

${NextRediscovery} Time of next node rediscovery 

${NodeID } Internal unique identifier of node 

${ObjectSubType} States if node supports SNMP or is ICMP-only 

${PercentLoss} 
ICMP packet loss percentage when node last 
polled 

${PercentMemoryUsed} 
Percentage of total node memory used over 
polling interval 

${PollInterval} Node polling interval, in seconds 

${RediscoveryInterval} Node rediscovery interval, in minutes 

${ResponseTime} 
Node response time, in milliseconds, to last 
ICMP request 

${RWCommunity} 
Node read/write community string; acts as 
security code for read/write SNMP access 

${RWSNMPV3AuthKey} 
SNMPv3 read/write credential authentication 
key 

${RWSNMPV3AuthKeyIsPwd} 
States if the SNMPv3 read/write credential 
authentication key is the password 
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Node Variable Description 

${RWSNMPV3AuthMethod} 
SNMPv3 read/write credential authentication 
method 

${RWSNMPV3Context} 
SNMPv3 read/write security context 
information 

${RWSNMPV3PrivKey} SNMPv3 read/write credential key 

${RWSNMPV3PrivKeyIsPwd} 
States if the SNMPv3 read/write credential 
privacy key is the password 

${RWSNMPV3PrivMethod} 
SNMPv3 read/write credential privacy 
encryption method 

${RWSNMPV3Username} 
User friendly name for SNMPv3 read/write 
credential 

${Severity} 

A network health score determined additively 
by scoring the status of monitored objects. In 
Orion NPM 1 point is provided for an interface 
in a warning state, 1000 points for a down 
interface, and 1 million points for a down node. 
In Orion APM, 100 points is provided for an 
application in a warning state, 200 points for an 
application in critical state, 500 is status is 
unknown, and 1000 for a down application. 

${SNMPV2Only} 
States if node only supports SNMPv1 or 
SNMPv2 

${SNMPV3AuthKey} SNMPv3 authentication key 

${SNMPV3AuthKeyIsPwd} 
States if node SNMPv3 authentication key is 
password 

${SNMPV3AuthMethod} SNMPv3 authentication type 

${SNMPV3Context} 
Group or domain of user with SNMPv3 access 
to node 

${SNMPV3PrivKey} SNMPv3 credential key 

${SNMPV3PrivKeyIsPwd} 
States if node SNMPv3 credential key is the 
password 

${SNMPV3PrivMethod} SNMPv3 credential key type 

${SNMPV3Username} User friendly name for SNMPv3 credential 

${SNMPVersion} States the version of SNMP used by the node 

${StatCollection} Statistics collection frequency, in minutes 

${Status} 
Numerical node status. For more information, 
see “Node Status Variables” on page 344. 

${StatusDescription} User friendly node status 

${StatusLED} Filename of node status icon 

${SysName} String reply to SNMP SYS_NAME OID request 

${SysObjectID} 
Vendor ID of the network management 
subsystem in OID form. Clearly determines the 
type of node. 

${SystemUpTime} 
Time, in hundredths of a second, since network 
monitoring started 
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Node Variable Description 

${TotalMemory} Total node memory available 

${UnManaged} States if node is currently unmanaged 

${UnManageFrom} 
Day, date, and time when node is set to 
“Unmanaged” 

${UnManageUntil} 
Day, date, and time when node is scheduled to 
be managed 

${Vendor} Node manufacturer or distributor 

${VendorIcon} Filename of node vendor logo 

Volume Variables 

The following are valid volume variables. 
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Volume Variable Description 

${Caption} User friendly volume name 

${FullName} 
User friendly volume name including captions of 
parent node and, in Orion NPM, interface  

${LastSync} 
Time and date volume last synchronized in database 
and memory models 

${NextPoll} Day, date and time of next scheduled volume polling 

${NextRediscovery} Scheduled time of next volume rediscovery 

${NodeID} Internal unique identifier of parent node 

${PollInterval} Volume status polling interval, in seconds 

${RediscoveryInterval} Volume rediscovery interval, in minutes 

${StatCollection} Statistics collection frequency, in minutes 

${Status} 
Numerical volume status: (0=”Unknown”, 1=”Up”, 
2=”Shutdown”, 3=”Testing”) 

${StatusLED} Filename of volume status icon 

${VolumeAllocationFailuresThisHour} 
Number of volume allocation errors for this volume 
in last hour 

${VolumeAllocationFailuresToday} 
Number of volume allocation errors for this volume 
in current day 

${VolumeDescription} User friendly volume description 

${VolumeID} Internal unique identifier of volume 

${VolumeIndex} Unique index of this volume within the parent node 

${VolumePercentUsed} Percentage of volume currently in use 

${VolumeResponding} 
(Y) = volume is currently responding to SNMP 
queries 

${VolumeSize} Size of volume, in bytes 

${VolumeSpaceAvailable} Total space available on volume, in bytes 

${VolumeSpaceUsed} Total space used on volume, in bytes 

${VolumeType} 
Volume type, as reported by hrStorageType OID 
(Removable Disk/Fixed Disk/Compact Disc/Virtual 
Memory/RAM/etc) 

${VolumeTypeIcon} Filename of icon for volume type 

Example Messages Using Variables 

The following examples illustrate some of the uses of variables. 



Administrator Guide  SolarWinds Orion Network Configuration Manager 
 

 
350  Configuring Automatic Login 

 Previous reboot was at ${LastBoot-Previous}. 

 Alert: ${NodeName} has exceptionally high response time. 

Average Response Time is ${AvgResponseTime} and is varying from 

${MinResponseTime} to ${MaxResponseTime}. 

 Current packet loss for ${NodeName} is ${%Loss}. Average 

Response time is ${AvgResponseTime} and is varying from 

${MinResponseTime} to ${MaxResponseTime}. 

 Alert: The SNMP Community string used to query ${NodeName} has 

been changed from ${Community-Previous} to ${Community}. 

 Orion NCM uses the new Community String to query ${NodeName}. 

Syslog Alert Variables 

The following variables can be used in Syslog alert messages within Orion 
Network Configuration Manager applications. You must begin each variable with 
a dollar sign and enclose each variable identifier in curly braces as, for example, 

${ObjectName}. 
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Syslog Date/Time Variables 

Syslog Date/Time 
Variable 

Description 

${AbreviatedDOW} Current day of the week. Three character abbreviation. 

${AMPM} AM or PM corresponding to current time (before or after noon) 

${D} Current day of the month 

${DD} Current day of the month (two digit number, zero padded) 

${Date} Current date. (Short Date format) 

${DateTime} 
Current date and time. (Windows control panel defined “Short 
Date” and “Short Time” format) 

${DayOfWeek} Current day of the week. 

${DayOfYear} Numeric day of the year 

${H} Current hour 

${HH} Current hour. Two digit format, zero padded. 

${Hour} Current hour. 24-hour format 

${LocalDOW} Current day of the week. Localized language format. 

${LongDate} Current date. (Long Date format) 

${LocalMonthName} Current month name in the local language. 

${LongTime} Current Time. (Long Time format) 

${M} Current numeric month 

${MM} Current month. Two digit number, zero padded. 

${MMM} Current month. Three character abbreviation. 

${MediumDate} Current date. (Medium Date format) 

${Minute} Current minute. Two digit format, zero padded. 

${Month} Full name of the current month 

${N} Current month and day 

${S} Current second. 

${Second} Current second. Two digit format, zero padded. 

${Time} Current Time. (Short Time format) 

${Year2} Two digit year 

${Year} Four digit year 

Other Syslog Variables 

Syslog Variable Description 

${Application} SolarWinds application information 

${Copyright} Copyright information 

${DNS} Fully qualified node name 

${IP_Address} IP address of device triggering alert 

${Message} Status of device triggering alert 
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Syslog Variable Description 

${MessageType} Assigned alert name 

${Release} Release information 

${Severity} 
A network health score providing 1 point for an 
interface in a warning state, 1000 points for a down 
interface, and 1 million points for a down node. 

${Version} Version of the SolarWinds software package 

Trap Alert Variables 

The following variables can be used in trap alert messages within Orion products.  
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General Trap Variables  

Trap Variable Description 

${Application} SolarWinds application information 

${Community} Node community string 

${Copyright} Copyright information 

${DNS} Fully qualified node name 

${Hostname} Host name of the device triggering the trap 

${IP} IP address of device triggering alert 

${IP_Address} IP address of device triggering alert 

${Message} 
Message sent with triggered trap and displayed in Trap Details field 
of Trap Viewer 

${MessageType} Name or type of trap triggered 

${Raw} 
Raw numerical values for properties sent in the corresponding 
incoming trap 

${RawValue} 
Raw numerical values for properties sent in the corresponding 
incoming trap. The same as ${Raw} 

Trap Date/Time Variables  

Trap Date/Time 
Variable 

Description 

${AbbreviatedDOW} Current day of the week. Three character abbreviation. 

${AbbreviatedMonth} Current month of the year. Three character abbreviation. 

${AMPM} AM or PM corresponding to current time (before or after noon) 

${D} Current day of the month 

${DD} Current day of the month (two digit number, zero padded) 

${Date} Current date. (MM/DD/YYYY format) 

${DateTime} Current date and time. (MM/DD/YYYY HH:MM format) 

${Day} Current day of the month 

${DayOfWeek} Current day of the week. 

${DayOfYear} Numeric day of the year 

${H} Current hour 

${HH} Current hour. Two digit format, zero padded. 

${Hour} Current hour. 24-hour format 

${LocalDOW} Current day of the week. Localized language format. 

${LongDate} Current date. (DAY NAME, MONTH DAY, YEAR format) 

${LongTime} Current Time. (HH:MM:SS AM/PM format) 

${M} Current numeric month  

${MM} Current month. Two digit number, zero padded. 

${MMM} Current month. Three character abbreviation. 

${MMMM} Full name of the current month 
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Trap Date/Time 
Variable 

Description 

${MediumDate} Current date. (DD-MMM-YY format) 

${MediumTime} Current time. (HH:MM AM/PM format) 

${Minute} Current minute. Two digit format, zero padded. 

${MonthName} Full name of the current month 

${S} Current second. 

${Second} Current second. Two digit format, zero padded. 

${Time} Current Time. (HH:MM format) 

${Year} Four digit year 

${Year2} Two digit year 

 

 

 

 

 

 

 

 

Appendix G 

Creating Custom Properties 

 All Orion product installations have access to the Custom Property Editor, which 
allows you to add a custom property to any monitored device. Custom properties 
are additional fields, such as country, building, asset tag, or serial number, that 
you can define and store in your Orion database. After properties are added, they 
are available for display and filtering both within the Orion Web Console and 
within the Report Writer application.  A few more examples of how custom 
properties may be used are as follows: 
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 Add information to nodes, such as contact, owner, or support contract. 

 Add a custom property that is used as an account limitation on nodes. 

 Add a custom property to nodes for grouping them on the web or in a report. 

 Add a custom property and display it as an annotation on a chart. 

Custom Property Editor lets you choose from a provided collection of the most 
commonly used properties, or you can easily and efficiently build your own 
custom properties. For more information, see “Creating a Custom Property” on 
page 355. 

Once your custom property is defined, the Import Wizard allows you to populate 
your new property from either a text- or comma-delimited file. For more 
information, see “Importing Custom Property Data” on page 357. 

Alternatively, if you only have a few individual changes or additions, you may 
choose to make those changes using the Edit view. For more information, see 
“Editing Custom Properties” on page 358. 

Creating a Custom Property 

The following procedure provides steps required to create a custom property 
using the Custom Property Editor.  

To create a property with Custom Property Editor: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click Add Custom Property. 

3. If you want to add predefined properties, complete the following 
procedure: 

a. Select Add Predefined Properties. 

b. Check Show Advanced Properties to view additional predefined 
properties. 

c. Check the properties you want to add, and then click OK. 

4. If you want to generate a completely new custom property, complete the 
following procedure: 
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a. Select Build a Custom Property from scratch. 

b. Select the Orion database table to which you want to add the new 
custom property. 

c. Provide the new Property Name. 

Notes: 

 To ensure full custom property functionality, do not leave the 
Property Name field empty. 

 Although most non-alphanumeric characters used in custom property 
names are replaced by underscores (_) when names are stored in 

the Orion database, SolarWinds recommends against using 
non-alphanumeric characters in custom property names. Hash 

characters (#) are not allowed in any property name. 

d. Select the Property Type. 

e. Enter a Max. Text length. 

Note: Regardless of the value provided in this field, Orion NCM does not 
support custom properties defined with more than 4000 characters. 

f. Click OK. 

Removing a Custom Property 

Custom properties are easily removed using the Custom Property Editor, as 
shown in the following procedure. 

To remove a custom property: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click Properties > Remove Custom Properties. 

3. Check each property you want to remove. 

4. If you are satisfied with your selections, click OK. 
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Importing Custom Property Data 

Once you have defined custom properties, the Custom Property Editor Import 
tool assists in populating the custom property data. For example, you may 
already possess a spreadsheet listing the asset tags of all your network nodes, 
and you would like to have this information available for reporting and publication 
in the web console. In this scenario, Asset Tag is added as a custom property, 
and then the import wizard is used to populate the asset tag values from the 
spreadsheet. The following steps outline the process for importing custom 
properties data. For more information, see “Creating Custom Properties” on 
page 354. 

To import custom property data: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click File > Import, and then select Import from Comma Delimited File or 
Import from Text File as appropriate. 

3. Navigate to the file that contains your custom property data. 

4. Select the file that contains your custom property data, and then click Open. 

5. Select the delimiter that separates the data in your file.  

6. If your data file contains a header row, check First row contains field 
names. 

7. Specify the characters that may surround text fields in your file, and then 
click Next. 

8. Select the data table that has the custom properties into which you want to 
import your data, and then click click Next. 

9. Use the drop down menus to select the key field from your file on the left and 
the corresponding field of the table on the right. 

Note: Depending on your file data, you may need to specify multiple key 
fields so that the import wizard properly matches your data to the table fields. 

10. Click Next. 

11. Specify the fields from your file on the left that you want to import by clicking 
corresponding blank cell on the right, and then select the target field that you 
want your data field to populate. 

Note: Click the cell to enable a menu. Use the menu items to select the 
target field that you want your data to populate. 

12. If you have specified all cell matches between your data and the Orion 
database, click Import. 
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13. If your import is successful, confirm the count of successfully imported 
rows, and then click OK. 

Custom Property Editor Settings 

The Custom Property Editor Settings window allows you to customize the display 
for nodes and volumes. 

Note: Orion Network Performance Monitor users may also customize the display 
for interfaces. 

To configure Custom Property Editor settings: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click File > Settings. 

3. Click Node Editing and check the system properties you want to see in the 
Edit +- window. Repeat for Volume Editing. 

4. If you want to enable Auto-Search, click Auto-Search, and then check 
Enable Auto-Search. 

Note: With Auto-Search enabled, the current column is searched as you 

type. Select a cell and then press Enter to edit its contents. With Auto-

Search disabled, typing will begin editing the cell. 

Editing Custom Properties 

The Custom Property Editor allows you to easily modify custom properties. 

Note: Orion Network Performance Monitor users may also edit custom properties 
for interfaces. 

To edit a custom property: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click Properties > Edit Object Properties, where Object is Node or 
Volume, as appropriate. 

3. Click the cells in the table that you want to edit, and then enter or modify the 
cell contents, as necessary. 

4. If you want to create or edit a filter for your custom properties, click No 
Active Filter or Filter Active, and then define the filter that you want to 
apply. For more information, see “Using Filters in Edit View” on page 359. 

5. If you are satisfied with your edits, click OK. 



SolarWinds Orion Network Configuration Manager  Administrator Guide 
 

 
Configuring Automatic Login  359 

Using Filters in Edit View 

Filtering is available in the Edit Custom Properties windows for all devices, and 
you can apply filters to manipulate available data views. Custom Property Editor 
allows you to edit the text within custom property fields to which a filter is applied. 
The following procedures show how to use filters within Custom Property Editor. 

Creating Custom Properties Filters 

The following procedure creates a custom properties filter. 

Note: Orion Network Performance Monitor users may also create filters for 
interface custom properties. 

To create a filter: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click Properties > Edit Object Properties, where Object is Node or 
Volume, as appropriate. 

3. Click Filter Active or No Active Filter, and then click Apply Filter. 

Note: The text of the Filter Active / No Active Filter button changes 
dynamically, indicating the filter status for the currently viewed data. 

4. Click the hyperlinked text to select the appropriate criteria. 

5. Click the ellipsis, and then select from the following options: 

Note: The lists of available linked descriptors are dynamically generated in 
consideration of all other variables within the same condition. For more 
information, see “Understanding Condition Groups” on page 262.Click 
Browse (…) to select a condition type. 

 Select Add a new elementary condition to generate a condition that is 
based on a direct comparison of network object data fields. 

 Select Add a new advanced elementary condition to generate a 
condition based on a comparison of device data fields and values. 

 Select Add a new complex condition to define a condition that filters 
other defined conditions. 

 Select Delete current condition to remove a selected condition. 

 Select Move current condition forward or Move current condition 
backward to change the order of your conditions accordingly. 

6. Continue to click hyperlinked text and use the cascading menus to select 
filtering criteria. 
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7. If you have completed the configuration of your filter, click OK. 

Note: The Edit Object Properties view changes, based upon the selected 
filter, and the text of the Filter Active / No Active Filter now displays “Filter 
Active”, indicating that the filter is being applied to the currently viewed 
properties. 

Removing Custom Properties Filters 

The following procedure removes a custom properties filter. 

Note: Orion Network Performance Monitor users may also remove filters for 
interface custom properties. 

To remove a filter: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click Properties > Edit Object Properties, where Object is Node or 
Volume, as appropriate. 

3. Click Filter Active, and then click Remove Filter. 

Note: The Edit Object Properties view now displays all custom properties. 
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Appendix H 

Configuring Automatic Login 

The Orion NCM Web Console allows you to log in using any of the following 
methods: 

 Windows Active Directory Authentication, available in all Orion products 
released after Orion NPM version 10.1.  

 Windows Pass-through Security. If you choose to employ Windows Pass-
through Security, Orion NCM users can be authenticated through Windows 
Security, with no need to log in using a separate Orion NCM Account or User 
Name and Password. For more information, see “Using Windows 
Pass-through Security”. 

 DirectLink. If a DirectLink account is activated, any URL referring directly to 
an Orion Web Console page will bypass the Orion Web Console login page 
by logging the user into the DirectLink account. For more information, see 
“Using the DirectLink Account”. 

 URL Pass-through. For more information, see “Passing Login Information 
Using URL Parameters”. 

Orion NCM prioritizes user login in the following manner: 

1. Windows Active Directory Authentication is enabled. To enable Windows 
Active Directory Authentication, check the Windows Authentication option 
when configuring the Orion Web Console in the Configuration Wizard. 

2. The Account or User ID and Password passed on the URL. 

3. The Account or User ID and Password entered on the login.aspx page. 

4. The Windows User if IIS NT Security is enabled, logging the user in using NT 
Security. 

5. The Windows Domain to which the User belongs, for example, 

Development\Everyone. 

6. The presence of a DirectLink Account. 

Using Windows Pass-through Security 

On all Orion products released before Orion NPM version 10.1, you may take 
advantage of the Windows Pass-through Security functionality when IIS NT 
Security is enabled. Orion NCM users can be authenticated through Windows 
Security, with no need to log in using a separate Orion NCM account or User Id 
and Password. Pass-through Security can be configured to employ either 
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Domain or Local computer security. Both may also be used at the same time. 
The Orion Network Configuration Manager Account or User ID and Passwords 
must then be set up to match the Account or User ID and Passwords that are 
used for the Domain and/or Local computer security. Use the following procedure 
to enable IIS NT Security for logging in to the Orion Web Console with Windows 
Pass-through Security. 

Notes: 

 With the release of Orion NPM 10.1, Orion Web Console users may be 
authenticated using Active Directory. 

 When authenticating users with Windows Security, ensure your Orion server 
uses the NetBIOS domain name, instead of the fully qualified domain name. 

To enable IIS NT security for Windows Pass-through Security: 

1. If you are using NT Domain Authentication Format for pass-through 
accounts, create these pass-through accounts in the Orion Web Console 
Account Manager using Domain\UserID as the User Name, as follows: 

 Washington\Edward 

 StLouis\Bill 

Note: For more information about creating accounts using the Orion Web 
Console Account Manager, see “Creating New Accounts” on page 78. 

2. If you are using Local Computer Authentication Format for 
pass-through accounts, create these accounts in the Orion Web Console 
Account Manager using Computer\UserID as the User Name, as follows: 

 SolarWindsS2\Edward 

 Server3\JonesR 

Note: For more information about creating accounts using the Orion Web 
Console Account Manager, see “Creating New Accounts” on page 78. 

3. Click Start > Control Panel > Administrative Tools > Internet Information 
Services (IIS) Manager. 

4. If you are using Windows Server 2003, complete the following steps: 

a. Expand Internet Information Services > Local Computer > Web Sites 
in the left pane. 

b. Select SolarWinds NetPerfMon. 

c. Click Action > Properties. 

d. Click the Directory Security tab. 
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e. Click Edit within the Authentication and access control area. 

f. Clear Enable anonymous access. 

g. Check Integrated Windows authentication in the Authenticated access 
group. 

h. Click OK to close the Authentication Methods window. 

i. Click Apply, if available, and then click OK to close the SolarWinds 
NetPerfMon Properties window. 

j. Collapse Internet Information Services > Local Computer > Web 
Sites. 

k. Collapse Internet Information Services > Local Computer in the left 
pane. 

l. Click Action > All Tasks > Restart IIS. 

m. Confirm that Restart Internet Services on Local Computer is selected, 
and then click OK. 

n. Close the IIS Manager. 

5. If you are using Windows Server 2008, complete the following steps: 

a. Click Start > Administrative Tools > Server Manager. 

b. Expand Roles. 

c. Click Web Server (IIS). 

d. In the Role Services area, confirm that Web Server > Security > 
Windows Authentication is installed. 

e. If Windows Authentication is not installed, click Add Role Services, 
check Web Server > Security > Windows Authentication, click Next, 
and then complete the service installation. 

f. Click Start > Administrative Tools > Internet Information Services 
(IIS) Manager. 

g. Select your Orion server in the left pane. 

h. Click Authentication in the IIS group of the main pane. 

i. Right-click Anonymous Authentication, and then click Disable. 

j. Right-click Windows Authentication, and then click Enable. 

k. Click your Orion server, and then click Restart in the Actions pane. 

6. Close the IIS Manager. 

7. Log in to the Orion Web Console using the Windows account  credentials 
you have already established. 
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Passing Login Information Using URL Parameters 

The user ID and password can be passed as parameters within the URL. This 
allows you to create a favorite or bookmark within a browser, or on your desktop. 
Create a favorite with a link in the following form to pass the login information: 

http://DOMAIN/Orion/Login.aspx?AccountID=USER&Password=PASSWORD 

Provide the hostname or IP address of your Orion server as the DOMAIN. Provide 

your Orion User ID as the USER, and then provide your Orion user account 

password as the  PASSWORD. 

Warning: HTTP requests are not encrypted, so User IDs and Passwords sent in 
HTTP requests are not secure. For more information about enabling HTTPS on 
your Orion server, consult www.microsoft.com. 

Using the DirectLink Account 

Enabling a DirectLink account allows you to make direct hyperlinks to specific 
web console views available to individuals who do not already have Orion Web 
Console user accounts. Any URL referring directly to an Orion NCM web page  
bypasses the login screen, logging the user into the DirectLink account. The 
DirectLink account is created like any other account, and it can include custom 
views and account limitations. For more information web console accounts, see 
“Creating New Accounts”. 

To enable a DirectLink account for the Orion Web Console: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console, and then click Manage 
Accounts in the Accounts grouping. 

3. Click Add. 

4. Type DirectLink as the new User Name. 

5. Type a Password, confirm it, and then click Submit. 

6. Edit DirectLink account options, as necessary, for your installation of Orion 
Network Performance Monitor. For more information about editing account 
options, see “Editing User Accounts”.  

7. Create a custom view to be used as the home page of the DirectLink 
account. For more information, see “Creating New Views”. 

8. Specify the new DirectLink view as a default view in Account Manger. For 
more information, see “Editing User Accounts”. 

9. If you would like to limit the DirectLink account to specific devices or 
device types, see “Setting Account Limitations” 
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Appendix I 

Browsing MIBs 

Orion Network Configuration Manager Inventory functions use SNMP to 
communicate with the MIBs on your managed devices. If you are running into 
issues or are interested in learning more about the type of changes supported 
and values reported by your devices, the MIB Browser allows you to find and 
explore MIBs. 

The SolarWinds Engineer’s Toolset provides a fully functional MIB Browser tool 
that allows you to log on to devices and change values using a read-write SNMP 
string. For more information, see the SolarWinds website (www.solarwinds.com) 

Browsing a MIB Tree 

Complete the following procedure to begin browsing the MIB tree. 

To browse the MIB tree for a specific device: 

1. Click MIBs > Add/Edit MIBS. 

2. Click New on the Configuration Management Customization window. 

3. Click Browse (…). 

4. Select an OID from the MIB Tree on the left.  

5. If you are not sure which OID to select, complete the following procedure 
to view a number of useful values: 

a. Expand iso > org > dod > internet > mgmt > mib-2. 

b. Expand system. 

c. If you do not see the OID information you want, consider browsing the 
Interfaces folder. 

Searching the MIB Tree 

The MIB Browser incorporates a powerful MIB Tree OID search capability. This 
search capability allows you to search for a specific OID, OID name pattern, or 
keyword in the descriptions.  

To search the MIB Tree: 

1. Click MIBs > Add/Edit MIBS. 

2. Click New on the Configuration Management Customization window. 
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3. Click Browse (…). 

4. Click Search MIB Tree. 

5. Select the appropriate tab: 

 Search by OID 

 Search by Name 

 Search Descriptions 

6. You can use asterisks (*) as a wildcard character. For example, sys* finds 

all OIDs that start with sys, and *number finds all OIDs that end with number. 

7. Type the search criteria, and then click Search. 

8. Click Show in MIB Tree to view the OID in the MIB tree. 

9. If you want to copy or print the OID information you find, click the 
appropriate button. 

Note: When using the description tab, the first 500 OIDs that match the 
pattern will be displayed. Click the OID to display details about it.  
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