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About SolarWinds 

SolarWinds, Inc develops and markets an array of network management, monitoring, and 
discovery tools to meet the diverse requirements of today’s network management and consulting 
professionals. SolarWinds products continue to set benchmarks for quality and performance and 
have positioned the company as the leader in network management and discovery technology. 
The SolarWinds customer base includes over 45 percent of the Fortune 500 and customers from 
over 90 countries. Our global business partner distributor network exceeds 100 distributors and 
resellers. 

Contacting SolarWinds 

You can contact SolarWinds in a number of ways, including the following: 

Team Contact Information 

Sales 
1.866.530.8100 

www.solarwinds.com  

Technical Support www.solarwinds.com/support  

User Forums 
support.solarwinds.net/support you need a customer 
account to access the Customer Support area of the 
website. 

 

Conventions 

The documentation uses consistent conventions to help you identify items throughout the printed 
and online library. 

Convention Specifying 

Bold Window items, including buttons and fields. 

Italics Book and CD titles, variable names, new terms 

Fixed font 
File and directory names, commands and code 
examples, text typed by you 

Straight brackets, as 
in [value] 

Optional command parameters 

Curly braces, as in 
{value} 

Required command parameters 

Logical OR, as in 
value1|value2 

Exclusive command parameters where only one of the 
options can be specified 

 

http://www.solarwinds.com/
http://www.solarwinds.com/support
http://support.solarwinds.net/support
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SolarWinds Web Help Desk Documentation Library 

The following documents are included in the SolarWinds Orion documentation library: 

Document Purpose 

Administrator 
Guide 

Provides detailed setup, configuration, and 
conceptual information. 

Quick Start Guide 
Provides installation, setup, and common 
scenarios for which Orion provides a simple, yet 
powerful, solution. 

Release Notes 
Provides late-breaking information, known issues, 
and updates. The latest Release Notes can be 
found at www.solarwinds.com.  

  

 

 

 

 

 

 

 

 

 

 

 

http://www.solarwinds.com/
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Chapter 1 

Introduction to SolarWinds Web Help Desk 

SolarWinds Web Help Desk (WHD) creates a structured and consistent system 
for help desk processes and communications. Several key features are available 
for Enterprise or Managed Service Provider help desks.  

Key Features of SolarWinds WHD 

Do-It-Yourself Deployment 

Install and configure WHD in less than an hour when preparations have been 
made. No consultants or special equipment are required. 

Manage Multiple Customers 

WHD manages help desk and ticketing processes for multiple customers 
allowing you to separate customer inventories, tickets, and processes. You 
can assign technicians, managers, and processes to one or more customers. 

Automated Asset Discovery 

Save countless hours of manual input, WHD imports client asset information 
by using a variety of asset management system exports.  

Automated email notifications 

WHD sends trouble ticket emails when a ticket is opened, escalated, 
updated, or closed. You control who gets email ticket notifications and the 
text of the message to each party.  

Email Ticket Origination and Updating 

You, your technicians, and your customers can open and update tickets by 
sending an email to the WHD system. WHD then takes predefined actions 
based on the email content.  

Automated Help Desk Procedures 

You can set the procedures for each step of the ticket process from 
origination, dispatch, parts ordering, billing, and escalation through to 
closure, ensuring consistent service.  

Change Control 

WHD contains a per customer change approval process, including roles for 
submitters and multiple levels of approvers.  
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How SolarWinds Web Help Desk Works 

WHD initiates and manages your help desk processes through the WHD web 
console, email, SMS, and built-in procedures. Once you have configured WHD, it 
automatically routes tickets to the proper technician and updates your customer. 
If spare parts are needed, WHD orders them and automatically bills the 
customers for parts and labor costs. WHD accepts email ticket requests and 
opens a ticket based on the information in the email. Tickets can also be updated 
and closed using email.  

Each customer has a web console dedicated to their help desk needs. 
Customers have access to all of their help desk features through a web portal, 
and they cannot see any information about other customers help desks.  

The following depicts the Web Help Desk processes at a very high level. 
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Chapter 2 

Installing SolarWinds Web Help Desk 

When installing Web Help Desk (WHD) for the first time, you should take into 
account the size of the installation, most importantly, the number of technicians 
this installation will service at its largest point. Web Help Desk comes 
prepackaged with a FrontBase© database. If you are installing WHD for less than 
10 technicians the embedded FrontBase database will suffice.  

If installing WHD for an Enterprise or for an MSP deployment, use SQL Server 
for your database. In this case, install and configure the SQL first, then install 
WHD. If you have an existing SQL Server, you have the option to create a WHD 
database instance on the existing server.  

Pre-installation Requirements  

SolarWinds recommends that WHD and the WHD database are installed on its 
own server, with the WHD database hosted separately, on SQL Server or a 
MySQL server. The following sections give minimum requirements for the WHD 
and the WHD database server. 

Database Options 

Careful consideration of the WHD maximum size should be taken, as migration 
between databases is not supported. A FrontBase database is included in the 
WHD download. The WHD installer automatically installs and configures the 
FrontBase database if this option is selected. FrontBase works well for small to 
medium installations.  

For Enterprise or multiple customer installations, SolarWinds highly recommends 
using SQL Server. Install and configure SQL Server before installing WHD. SQL 
Server can reside on the same server as WHD or on a separate server. WHD 
can also use a new SQL database instance on an existing SQL Server.   
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WHD Server 

The following tables list minimum WHD server requirements:  

Software Requirements 

Operating System 

 Windows Server 2003, 2008 or 2008 R2. 64 bit OS is 
recommended for installations with more that 20 technicians.  
 

 Apple © Mac OS X 10.5 or later with Java 6. 
 

 Red Hat Linux or equivalent with RPM package manager. 
 
Note: SolarWinds allows evaluations, but does not support production 
installations of SolarWinds WHD on Windows XP, Vista, or Windows 7 
environments. 

Web Console 
Browser 

 Microsoft Internet Explorer 7 or higher with active scripting 

 Firefox 3.0 or higher 

 Safari 5 or higher 

 

 

Hardware 

CPU  Dual Core, 2.0 GHz or faster 

Hard Drive 
Space 

20 GB 

Mac Architecture 64 bit Intel
©
 

Memory 3 GB (Add 1 GB for each group of 10 additional technicians) 

Application Ports 8081 (or alternate browser port), 1433 (SQL) 
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SQL Server (Optional) 

The following table lists the minimum software and hardware requirements for 
the SQL WHD database server. 

Requirements 

MS SQL Database 

SQL Server 2005 SP1 Express, Standard, or Enterprise 
SQL Server 2008 Express, Standard, or Enterprise 

 SQL authentication must be supported. 

 SQL Server Management Studio Component. 

 TCP/IP must be enabled. 

 SQL Server Database Engine 

 SQL Server Management Tools 
 

CPU Speed Dual core 2.0 GHz or better 

Hard Drive Space 20 GB 

Memory 2 GB (+1GB for every 10 Techs) 

 

MySQL (Optional) 

The following table lists the minimum software and hardware requirements for 
the MySQL WHD database server. 

Requirements 

MySQL Database 
MySQL 5.1 or newer, Community, Cluster , or Enterprise 

 MySQL Workbench Tools 

CPU Speed Dual core 2.0 GHz or better 

Hard Drive Space 20 GB 

Memory 2 GB (+1GB for every 10 Techs) 

 

Virtual Machines and Servers 

WHD installations on VMware Virtual Machines and Microsoft Virtual Servers are 
fully supported if the minimum configuration requirements are met for each virtual 
machine. These requirements are the same as the physical server requirements 
above.  

Server Sizing 

WHD manages help desk operations for networks of any size, from small 
corporate LANs to large enterprise and service provider networks. Most WHD 
systems perform well on 3.0 GHz systems with 3 GB of RAM. However, when a 
large number of technicians are created, you should give additional consideration 
to the hardware used and the system configuration. It is recommended that you 
should add 1GB of memory to the WHD server for every 10 technicians.  
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Installing SolarWinds Web Help Desk 

The following procedure guides you through installing WHD. Ensure that the 
computer on which you install WHD meets or exceeds the stated requirements. 
For more information about hardware and software requirements, see Pre-
installation Requirements . 

If you will be using MS SQL or MySQL as you database, install the database 
engine and management tools according to the product instructions. Once SQL 
server is installed, follow the instructions to configure SQL to work with WHD. 

If the embedded FrontBase database is used, skip to “Using the Windows Web 
Help Desk Installation Wizard” on page 15 and follow the instructions for your 
OS. 

Configuring MS SQL Server  

Depending on the version of SQL Server being used, TCP/IP may need to be 
enabled.  

To enable TCP/IP on your SQL Server: 

1. Open SQL Server Configuration Manager on your SQL Server. 

2. Expand SQL Server Network Configuration section 

3. Click Protocols for SQLXXX, where XXX is your version of SQL Server. 

 

4. If TCP/IP is not enabled in the right pane, right-click TCP/IP, and then 
select Properties. 

5. Click Enable. 
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6. Click Save. 

7. Right-click TCP/IP again. 

8. Click the IP Addresses tab. 

 

9. Ensure that IP is enabled for the server’s network IP address and the 
127.0.0.1 loopback address. Also ensure that TCP Dynamic Ports is blank 
and that TCP Port is set to 1433 for the server’s IP address and the 
127.0.0.1 address.  

10. Click Apply, and then click OK. 

Next, create and configure SQL Server to the WHD database instance.  

To create and configure your SQL database: 

1. Open SQL Server Management Studio on your SQL Server. 

2. Right-click the server name in the Object Explorer pane and select 
Properties.  
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3. Click Security and ensure that SQL Server and Windows Authentication 
mode is selected, and then click OK. 

4. Expand the Security folder and then right-click the Logins folder, and then 
select New Login…. 

 

5. Enter whd in the Login name: field. 

6. Click SQL Server authentication. 

7. Enter a password in the Password: field, and then enter the same password 
in the Confirm password: field.  

8. Ensure that Enforce password policy, Enforce password expiration, and 
User must change password at next login check boxes are all not 
selected.  

9. Click OK. 

10. Right-click the Database folder and select New database…..  

11. Enter whd in the Database name: field and then assign the whd user as the 

Owner.   

12. Click OK. 
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Configuring MySQL for Web Help Desk 

1. Connect to the MySQL database server using the SQL Development pane of 
the MySQL Workbench application.  

 



Administrator Guide  SolarWinds Web Help Desk 
 

 
12  Installing SolarWinds Web Help Desk 

2. Select Actions > Add Schema. 

 

3. Enter whd in the Name field, select utf8 - utf8_general_ci as the collation 
type, and then click Apply.  

4. Click the Home tab and click on your MySQL server.  

 

5. Select Configuration > Options File > General. 

6. Select the port check box and enter 3306 in the port field. 
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7. Select the default-storage-engine check box, enter InnoDB in the default-
storage-engine field, and then click Apply. 

 

8.  Select Configuration > Options File > Misc. 

9.  Select the init_connect check box, enter SET NAMES utf8, and then click 
Apply. 
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10. Click on Startup/Shutdown and click Stop Server. 

11. Click Startup/Shutdown and click Start Server. 

12. Click Security > Users and Privileges then click Add Account.  

13. Enter whd in the Login name: field. 

14. Enter and confirm a password. 

15. Enter the host name for the WHD server in the Limit Connectivity to Hosts 

matching: field. If MySQL is on the same server as WHD enter localhost. 

16. Click Apply. 
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17. Click the Schema Privileges tab, select the whd user from the left column, 
and then click OK. 

18. Click Add Entry...  

19. Select your host in the Host box, click Selected Schema and whd in the 
Schema box, and then click OK.  

20. Click Select All and then click Save Changes. 
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Using the Windows Web Help Desk Installation Wizard 

 
1. Using an account with local administrative privileges, log on to the server 

where you want to install SolarWinds WHD. 

Notes:  

 To avoid permissions issues, this account should not be a domain 
account, and it should not be subject to any local or group policy 
restrictions. 

 If you are installing WHD on a Windows 2008 server you must use the 
Run as administrator option when launching the installer. 

 It is recommended that you quit all other programs before running the 
installer. 

2. If you downloaded the product from the SolarWinds or the Web Help 

Desk website, navigate to your downloaded .zip file, extract the evaluation 

package to an appropriate location, and then launch the WebHelpDesk 
executable. For a Windows 2008 server, right-click the installer, and then 
choose Run as administrator.  

3. If you received physical media, browse to the WebHelpDesk executable, 
and then launch it. 

4. Review the Introduction text, and then click Next. 

5. Accept the terms of the license agreement, and then click Next. 

6. Confirm the installation location or click Choose to provide another location 
on the Choose Destination Location window, and then click Next. 

7. Choose a location for the WHD program icons. The default location is 
recommended. 

Note: Icons are only created at the location you select. If you select a 
location other than in a new Program Group, the icons will not be available in 
Start > All Programs. 

8. Review the Pre-Installation Summary information, then click Install. 

9. If you will be using the embedded FrontBase database, and then click 
Continue. 

10. If you will be using SQL or MySQL as your WHD database, follow these 
steps to connect WHD to SQL. 
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a. Clear the Use Embedded Database check box. 

b. Click the down arrow on the right of the Vendor list, and then select 
Microsoft SQL Server 2005+, or My SQL. 

c. Enter the IP Address of the SQL server in the left Host field and 1433 in 

the Port field.  

d. Enter whd in the Database and Username fields. 

e. Enter the SQL whd user’s password, and click Save. 

g. Close the WHD web console. 

h. Click Done. 

i. Click Start >All Programs > Web Help Desk >Stop Web Help Desk. 

j. Click Start > All Programs > Web Help Desk >Start Web Help Desk. 

k. Click Continue… to initialize the SQL database and start WHD. 

11. Enter admin for the user email address and admin for the password, and 

then click Log In.  

Using the Mac Web Help Desk Installation Wizard 

Note: It is recommended that you quit all other programs before running 

the installer. 
1. Using an account with local administrative privileges, log on to the server 

where you want to install SolarWinds WHD. 

2. If you downloaded the product from the SolarWinds or the Web Help 

Desk website, navigate to your downloaded .dmg file, and double click to 

mount this file.  

3. If you received physical media, browse to the .dmg executable, and then 

double click to mount it.  

4. Double click WebHelpDesk.pkg  in the initial splash screen. 

5. Review the Introduction text, and then click Continue. 

6. Review the terms of the license agreement, and then click Continue. 

7. Click Agree to accept the license terms. 

8. Review the installation information, and then click Continue. 

9. When the installation completes, click Close. 

10. Launch your browser and navigate to 127.0.0.1:8081. 

11. If you will be using the embedded FrontBase© database, click Continue. 
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12. If you will be using SQL as your WHD database, click Cancel and follow 
these steps to connect WHD to SQL. 

a. Clear the Use Embedded Database check box. 

b. Click the down arrow on the right of the Vendor list, and then select 
Microsoft SQL Server 2005+. 

c. Enter the IP Address of the SQL server in the left Host field and 1433 in 
the Port field.  

d. Enter whd in the Database and Username fields. 

e. Enter the SQL whd user’s password, and click Save. 

g. Close the WHD web console. 

i. In the Applications folder double click Stop Web Help Desk. 

j. In the Applications folder double click Start Web Help Desk. 

k. Click Continue… to initialize the SQL database and start WHD. 

13. In the WHD web console, enter admin for the user email address and admin 

for the password, and then click Log In.  

Using the Linux Web Help Desk Installation 

Note: It is recommended that you quit all other programs before running the 
installer. 

1. Using an account with local administrative privileges, log on to the server 
where you want to install SolarWinds WHD. 

2. If you downloaded the product from the SolarWinds or the Web Help 

Desk website, navigate to your downloaded rpm.gz file, and double click to 

mount this file.  

3. If you received physical media, browse to the .dmg executable, and then 

run gunzip webhelpdesk-10.x.x-1.noarch.rpm.gz, where x.x is the 

downloaded WHD version. 

4. Run the installer using the command sudo rpm -ivh webhelpdesk-
10.x.x-1.noarch.rpm 

5. Review the Introduction text, and then click Next. 

6. Review the terms of the license agreement, and then click Agree. 

7. Review the installation information, and then click Next. 

8. When the installation completes, click Close. 
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9. Launch your browser and navigate to 127.0.0.1:8081. 

10. If you will be using the embedded FrontBase database, click Continue. 

11. If you will be using SQL as your WHD database, click Cancel and follow 
these steps to connect WHD to SQL. 

a. Clear the Use Embedded Database check box. 

b. Click the down arrow on the right of the Vendor list, and then select 
Microsoft SQL Server 2005+. 

c. Enter the IP Address of the SQL server in the left Host field and 1433 in 

the Port field.  

d. Enter whd in the Database and Username fields. 

e. Enter the SQL whd user’s password, and click Save. 

g. Close the WHD web console. 

i. In the Applications folder double click Stop Web Help Desk. 

j. In the Applications folder double click Start Web Help Desk. 

k. Click Continue… to initialize the SQL database and start WHD. 

12. In the WHD web console, enter admin for the user email address and admin 
for the password, and then click Log In.  

Apache Integration 

By default, the Web Help Desk runs on port 8081. 

If you don’t need Apache, and would prefer to run the application on port 

80,  

1. Stop Apache. 

2. Set the DEFAULT_PORT variable in webhelpdesk/conf/whd.conf to 80. 

3. Restart Web Help Desk using  /usr/local/webhelpdesk/whd start. 

If you want to have Apache running on port 80, you can allow it to proxy 
requests to the Web Help Desk on port 8081. This will make it appear as if the 
application is running on port 80.  

To proxy port 8081 requests:  

1. Open webhelpdesk/conf/whd.conf. 

2. Set URL_DEFAULT_PORT=80 

3. Save the webhelpdesk/conf/whd.conf file. 
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4. Enable mod_proxy as described in this following reference: 

5. Add the following lines at the end of your Apache configuration file 
(httpd.conf): 

 ProxyPass /helpdesk http://localhost:8081/helpdesk 

 ProxyPassReverse /helpdesk http://localhost:8081/helpdesk 

6. Save the file, and then restart Apache 

WHD and IIS Installations 

Web Help Desk does not integrate with IIS. WHD runs on port 8081 by default.  

To run WHD on port 80 and shut off IIS on Server 2008: 

1. Stop Web Help Desk. 

2. Go to Startup > Administrative Services > Server Manager.  

3. Click Roles.  

4. Select to IIS, click Remove Roles. 

5. Click Confirm. 

6. Open \Program Files\WebHelpDesk\conf\whd.conf. 

7. Set DEFAULT_PORT= 80. 

8. Save \Program Files\WebHelpDesk\conf\whd.conf. 

9. Start Web Help Desk. 

To run WHD on port 80 and shut off IIS on Server 2003: 

1. Stop Web Help Desk. 

2. From Control Panel, click Add or Remove Programs. 

3. Click Add/Remove Windows Components. 

4. Select Application Server. 

5. Clear the Internet Information service check box. 

6. Click Yes to confirm. 

7. Click OK. 

8. Click Next. 

9. When Windows Component Wizard completes, click Finish. 

10. Open \Program Files\WebHelpDesk\conf\whd.conf. 

11. Set DEFAULT_PORT= 80. 

http://httpd.apache.org/docs/2.0/mod/mod_proxy.html
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12. Save \Program Files\WebHelpDesk\conf\whd.conf. 

13. Start Web Help Desk. 

Notes:  

If there are multiple IP addresses on the machine and one of them uses IIS, 
bind IIS and Web Help Desk to separate IP addresses  

To specify the IP address for Web Help Desk, edit the \Program 
Files\WebHelpDesk\conf\whd.conf file and set the IP_ADDRESS option. 

To bind IIS to an interface on Windows 2003 with multiple NICs: 

1. At a command prompt, navigate to the \Program Files\Support Tools folder.  

2. At the \Program Files\Support Tools prompt ,enter httpcfg set iplisten 

-i xxx.xxx.xxx.xxx, where xxx.xxx.xxx.xxx is the IP address on which you 

want to run IIS.  

3. To check your settings, enter httpcfg query iplisten. 

4. Restart your server after making this change.  

 

To bind IIS to an interface on Windows 2008: 

1. Log on with the local Administrator account.  

2. Open a command prompt window, and then enter netsh http add 

iplisten ipaddress= xxx.xxx.xxx.xxx. 

3. To check your settings, enter netsh show iplisten. 

4. Restart IIS.  

 

Upgrades 

To upgrade to the latest version of Web Help Desk: 

1. Backup the Web Help Desk server and any database server involved with 
Web Help Desk. 

2. Double click Stop Web Help Desk  . 

3. Launch the new Web Help Desk installer. 

4. Accept the terms. 
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5. When the upgrade completes, close any browsers and double click Start 

Web Help Desk  . 

Note: For Windows 2008 server and above right click Start Web Help Desk 
and select Run as administrator.  
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Chapter 3 

Getting Started with SolarWinds WHD 

This section assists you in configuring the initial settings. These setting enable 
you to send and receive email about trouble tickets, create tickets, and create 
assignments for service locations and service technicians. With these setting in 
place, WHD automatically matches an available technician with customers and 
customer locations, and creates a ticket as appropriate.  

Note: Web Help Desk has an extensive library of popup tooltips. To activate a 
tooltip hover over the area in question.  

Configuring the Web Help Desk Server  

Settings are made in WHD using setup   which initializes the left setting 
navigation bar. The left navigation bar is comprised of setting topics and 
individual settings pages within each topic. Detailed tooltip help is available for 
most items on each settings page.  

 

Initial Security Settings 

Changing the admin password is the first task in the setup configuration. 
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WHD installs one account active, the admin account. Because this account uses 
a default password, you should change the admin password to add security to 
your WHD server:  

1. To change the admin account password, click setup    in the top 
navigation bar, and then click Techs > My Account on the left navigation 
bar.  

2. If you want to use an administrator name other than the default (admin), 
enter the new admin name in the User Name field. 

3. Enter a new password in both the Password and Confirm Password fields. 

4. Enter the administrator’s email address in the E-Mail field. 

5. The remaining fields are not required at this point and can be filled in at your 
discretion. 

6. Click Save.  

Each of the following Setup sections begins with the left Setup navigation bar. 

To access the left setup bar click the Setup button on the top menu bar.   

Setup – General 

 

License 

Web Help Desk installs with a fully functional, 30-day trial license. 

To apply a purchased perpetual license key: 

1. Click lock  in the License screen. 

2. Copy the license key text and paste it over the existing License Key text. 

3. Click Save. 
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Options 

No changes are required in the Options settings page for a basic configuration. 
You may set any of the options to fit your environment. For most environments, 
use the defaults. If you make changes on this page, click Save to save the 
changes.  

Authentication 

You may change the login message to one more suitable for your use case. Most 
of the other settings on this page are related to login security. Change these to fit 
your security requirements. Do not use the API Key area at this time. If you do 
make changes on this page, click Save to save the changes. 

Time & Place 

The Time & Place page is used to indicate time zone and local work hours for 
locations your help desk manages.  

To add a new location and set the business hours: 

1. Click New. 

2. Enter a name for the location. 

3. Select the Time Zone for the location. 

4. Select the Country for the location. 

5. Use a Currency Precision to for the countries monetary system. The default 
setting will often work.  

6. Select the proper time and date formats for the location.  

7. Select the Business Hours and Work Days for the location, and then click 
Save.  

Look & Feel 

The Look & Feel page allows you to place your company logo on the web 
console. Follow the instructions and guidelines on the page to make this change.  
If you make changes on this page, click Save to save the changes.  

Database 

The Database page displays information about your database. This is a read only 
page. 

Logs 

The Logs page allows you to set a criticality level for logging. This is not 
necessary for your initial configuration and is typically used for troubleshooting. If 
you make changes on this page, click Save to save the changes.  
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System Information 

The System Information page contains information for troubleshooting and 
understanding your server’s configuration. This is a read only page and is 
typically used for troubleshooting.  

Setup – E-Mail 

 

E-Mail is used extensively to automate communications and actions in WHD. 
Each item in the E-mail pages has a popup tooltip to explain how to set the 
option and the effect the settings will have on your installation.  

Options 

The Options page contains advanced settings for restricting email formats, 
senders, and contents. Most of the options can accepted at the default settings. 

Simplify the incoming mail process by configuring WHD to accept email from 
unknown persons in your client’s domains. Otherwise you will have to define and 
maintain lists of each email sender for each client.  

To simplify managing emails, complete the followings steps: 

1. Click Only if e-mail matches an Accepted Domain in the Create Accounts 
for Unrecognized Senders section. 

2. Enter the domain names for your clients separated by a comma and then a 
space. For example, solarwinds.com, example.com. 

3. Click Save. 

The Ignored Senders box allows you to deny email from senders who may be 
sending SPAM or other unwanted email.  

The Regular Expression Filters allow you to filter out email, based on specific 
criteria for the Subject, Body, Content, or Attachments. The tooltip provides 
detailed information on using each of these filters.  

Review the remaining options settings and make any changes required for your 
email environment.  

If you make any other changes on the page, click Save to submit the changes.  
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Outgoing Mail Accounts 

You define your SMTP server(s) and help desk email address in the Outgoing 
Mail Options page.  

To configure your outgoing WHD mail: 

1. Click New.  

2. In the SMTP Server field, enter the IP address of your SMTP server. Use 
port 25 unless your server uses something other than the default port.   

3. If your SMTP server requires SSL authentication, click the SSL check 
box. 

4. Enter the SMTP Username and SMTP Password. 

5. Enter the administrator’s email address in the E-Mail field. 

6. The Accepted Domains field defines the domains to which your SMTP 
server sends email. Enter the domain names for each of your help desk 
customer domains. Separate each name with a comma and then a space.  

7. Enter the administrator’s email address in the E-Mail field. 

Note: If you have specific mail.smtp or mail.from requirements for your 
SMTP server, enter those requirements in the Advanced E-Mail Properties 
field. Hover your mouse over the field title to see details on these properties. 

8. When you have completed entering information on this page, click Save. 

A green dot  to the right indicates a connection has been made to your SMTP 
server. A red dot  indicates a failure to connect to the SMTP server. The error 
message at the top of the page indicates the nature of the failure.  

Note: Be certain to delete the sample outgoing server that was installed by 
default. The sample server may interfere with your actual SMTP server.  

Incoming Mail Accounts 

The Incoming E-mail Accounts page defines the requirements for accepting e-
mail and initiating some of the automated e-mail processes.  

To setup Incoming E-Mail: 

1. Click New on the Incoming Mail Accounts page. 

2. If you want to be able to open tickets automatically from incoming e-
mail, select the Enable E-mail Tickets check box.  

3. If this server is your default incoming mail server, click Make Default.  

4. Enter the E-Mail Address for the Web Help Desk incoming e-mail. 
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Note: This should be a new email inbox for WHD. Do not use a personal 
inbox. E-mail in this inbox is processed and deleted. 

5. Select the Account Type (IMAP, POP3 or Exchange2007/2010). 

6. Leave Compatibility Mode cleared. 

7. Enter the Incoming Mail server IP Address, port, and then select SSL if your 
server requires SSL.  

8. Enter the User Name and Password for the email account  

9. Leave Inbox Folder as INBOX. 

10. For the Outgoing Mail Account, select the server defined on the Outgoing 
Mail Accounts page. 

11. Click the Allow Auto-Submitted E-Mail check box.  

12 Special settings may be required for your e-mail server to properly process 
incoming mail. Leave the Advanced E-Mail Properties blank at this point. If 
your server fails incoming email tests, you may have to troubleshoot this 
area. Hover your mouse over Advanced E-Mail Properties for more 
information. 

13 Click Save.  

Templates 

E-Mail Templates allow for incoming and outgoing e-mail to be auto-populated 
with various information. WHD comes with several ready to use E-mail 
Templates. 

To modify an existing E-mail message: 

1. Choose Outgoing Mail or Incoming Mail using the tabs at the top of the page.  

 

2. Click the message to be modified. 

3. Modify the text as required using plain text and the tags shown on the 
screen. 

4. If you want the message sent in multiple languages, click the Add button 
under Other Languages. You must enter the text in the language you 
choose. WHD does not translate languages.  

5. When you are done editing the message, click Save. 
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Setup – Locations 

 

The Locations Setup tab provides the ability to store information about customer 
locations, and map those locations to technicians in the same geographical area. 
Populating the location pages is another step towards automated ticket 
processing and technician dispatch.  

Note: When you first use the Locations tab, only the four Location pages 
(Options, Locations & Rooms, Location Groups, and Location Custom Fields) are 
listed, as seen above. Depending on the features you choose, the tab name and 
pages will change. 

Options 

The options page implements the Company option. This makes Managed 
Service Provider (MSP) installations possible. 

1. If you want to separate data and tickets by Companies, click the Use 
Companies check box.  

Note: The Locations tab changes to Companies & Locations, and a 
Companies page is added to the tab selections as seen below.  

 

2. If you want to be able to breakdown ticket assignments and billing by 
department, click the Use Departments check box, then click Save. 

Note: Department setting pages are now added to the tab selections as seen 
below.  
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Companies 

To add a new company from the Companies& Locations > Companies 
page: 

1. Click New. 

2. In the Company Info page, enter the pertinent information, and then click 
Save.  

Notes: 

 The Assigned Locations and Assigned Techs page now displays as 
shown below. These fields are populated after defining Locations and 
Techs.  

 You cannot assign a Manager other that the default account or default 
location at this point as those are yet to be created. 

 

 

3. To add another Company, click back  in the Company Info page, and then 
repeat steps 1 and 2 above.  

Locations & Rooms 

Locations are street addresses or similar information that is used to locate a 
client facility. Rooms are specific to individual Locations and are used to further 
specify the location. 

To add a new Location from the Settings > Companies& Locations > 
Locations and Rooms page: 

1. Click New. 

2. In the Location Info page, enter the pertinent address information. 



SolarWinds Web Help Desk  Administrator Guide 
 

 
Getting Started with SolarWinds Web Help Desk  31 

3. If the location is going to be used to store spare parts, select Yes in the 
Store Parts option. This allows you to track inventory levels and create 
inventory alerts as described in Chapter 9, Parts & Billing.  

Note: If you set a Default Priority for the location, this will override all tickets’ 
status for this location. It is recommended you leave this set to None.  

4. If you have defined individual Companies, select the company associated 
with this location from the Company list. 

5. Select a Business Zone from the Business Zone list. 

All other fields may be left at default.  

6. Click Save. 

The Room Editor page tab displays as shown below.  

 

To add a new Room from the Settings > Companies& Locations > 
Locations and Rooms > Room editor page: 

1. Click New. 

2. Enter the Room Name. 

3. Click Save. 

Note:  The TSV  and Excel  buttons allow you access to 
downloadable spreadsheet templates for bulk Company importing. This 
eliminates the need to manually fill in each Location Info page and Room 
Editor page. For additional information on importing see the Chapter 12 
Importing Data. 

Location Groups 

Location Groups are used to specify locations that are in the same general area. 
This makes it possible to assign a group of technicians to a location group, so a 
technician from the proper area can be located.  

To add a new Location Group and assign Locations to Location Groups, 
from the Settings > Companies& Locations > Locations Groups page, 

1. Click New. 

2. Enter the Group Name description for the general location. For example “Los 
Angeles”, or “Metro NYC” or “South Florida.”. 

3. Click Save. 
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Note: The Assigned Locations and Assigned Tech page tabs are now 
available as shown below.  

 

4. Click Back  . 

5. Select the name of the new Location Group.  

6. Click the Assigned Locations page tab. 

7. Click Edit. 

8. Click the check box next to the locations you want to assign to this group, 
and then click Save.  

9. Click back  . 

Repeat steps 1 through 9 above to define all of your location groups. The 
Assigned Techs will be addressed after Techs have been added.  

Note: A Location can be assigned to only one Location Group.  

Location Custom Fields 

You add information about locations using Location Custom Fields. These fields 
allow you to add information about the location such as entrance instructions or 
point of contact information.  

Departments 

Departments are useful when a client divides their business units by department.  

To add a new Department from the Settings > Companies& Locations > 
Departments page: 

1. Click New. 

2. Add the department group name. 

Note:  The Client Admins have not yet been defined. You may change the 
settings for Client Admins and those will be granted to the Client Admins as 
Admins are created.  

3. Click Save. 

Note: The Assigned Departments and Assigned Techs page tabs displays as 
shown below.  
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Department Groups 

To add a departments to a department group, 

1. Click New. 

2. Enter the Group Name. 

3. Click Save. 

4. Click the Assigned Departments tab. 

5. Click Edit. 

6. Select the boxes for the departments to be added. 

7. Click Save. 

Note:  Techs and Admin roles have yet to be created. You can assign Tech 
and Admins once those have been added.  

Department Custom Fields 

You add information about departments using Department Custom Fields. These 
fields allow you to add information about the location such as entrance 
instructions or a point of contact.  

Setup – Tickets 

 

The Tickets tab defines several ticketing functions, such as how tickets are 
generated, routed, updated, and closed.  

Options 

The Ticket Options page is used to set ticket contents, generation, and ticket 
access options. Options are categorized into three categories; General Options, 
Client Options, and Tech Options.  
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Ticket options include: 

 Default setting for e-mail recipients for tickets with no Tech Group 

 Enable clients to set priority on initial help request 

 Lock the ticket to the client’s assigned location so that service locations 
remain private 

 Field style for rooms (text or popup menu) 

 Requiring the use of an assigned asset 

 E-Mail auto-reply settings 

 Tech note sorting 

 Simultaneous ticket edit warning options 

1. Review each field and make changes as needed. Tooltips are available for 
each item by hovering the mouse over the item name.  

Note: The Enter Work Time As option allows you to enter time in minute 
intervals or as tenths (6 minutes) of an hour.  

2. Click Save when finished reviewing and making changes.  

Request Types 

Define the types of tickets your help desk services in the Request Types page. 
Request types define what type of issue the customer is experiencing and what 
action needs to be taken. When a user opens a ticket, they choose a request 
type.  

Request types can be defined as a parent and child types. An example is a 
request to have a password reset. The parent type may be “IT Software 
Assistance” and the child type may be “password reset”.  

Build all of your parent types first, and then add child types. If you build a child 
type but have not built the parent type, you will not be able to set the child type 
as a child.  

To add a new Request Type, from the Settings > Tickets > Request Types 
page: 

1. Click New. 

2. Enter the Request Type name. 

3. If this is a child request type, select the parent type from the Parent Type 
list. 

4. Tech groups have not been defined at this point, so leave Tech Group blank.  
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5. Place the text you want the requestor to see in the Detailed Instructions 
text box.  

6. Approval Processes, Lead Technicians, and Surveys have not been defined, 
so leave these as they are.  

7. Review the other options and set them appropriately for your help desk and 
for your clients. Refer to the tooltip help on each item for details.  

8. Click Save. 

Repeat steps 1 through 8 above to define each of your request types.  

Status Types 

Each ticket is assigned a status from the available Status Types. The following 
status types are predefined: 

 Open 

 Pending 

 Closed 

 Cancelled 

 Resolved 

To enable Change Access Board (CAB) features, you add Pending Approval, 
Approved and Denied status types. 

Note: Adding these status types is not necessary if you do not implement CAB 
Process. It is recommended that you add these status types in case you need to 
enable the CAB feature in the future.  

To add Approved, Approval Pending, and Denied status types: 

1. Navigate to Setup > Tickets > Status Types and click New. 

2. In the Name field enter Denied. 

3. In the Description field enter CAB Status Type. 

4. Click Alerts Enabled. 

5. Click Client Reminders, and then click Save. 

Repeat steps 1 through 5 above to add the Approved and Approval Pending 
Status types. 

After adding the above status types, you set the Status Types Options to allow 
the CAB features. 

To set the Status Type Options for the CAB feature: 
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1. Navigate to Setup > Tickets > Status Types > Options. 

2. Set the Needs Approval Status Type to Pending approval. 

3. Set the Approved status type to Approved. 

4. Set the Approval Denied status type to Denied, and then click Save. 

Priority Types and Alerts 

This section defines flow of automated e-mail alerts. The following Priority Types 
are predefined: 

 Urgent 

 High 

 Medium 

 Low 

Notes:  

 Each Priority Type has adjustable Alert Levels for automatic e-mail 
escalation.  

 Alert levels are set at three levels with an Alert Level 3 being the highest 
severity. 

 “Not Completed” condition is considered more important than the “Not 
Updated”, which is more important than “Not Assigned”.  

 If alert levels have matching criteria, the highest severity level will be 
used.  

To set the Alert Triggers for a Priority Type:  

1. Click the Priority Type name. 

2. Leave the Name and Display Order as is.  

3. Choose a Color (optional). 

4. Set the Due Time to the proper time to close a ticket with this priority. 

5. Set the proper Conditions (time interval, criteria and E-mail To:) for each 
Alert Level starting at Alert Level 1 and working downward.  

6. After you have completed the Conditions for each Alert Level, set the Alert 
Repeat Interval time (optional). 

7. Click Save.  

Repeat steps 1 through 7 above for each Priority Type.  
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Ticket Custom Fields 

This section allows you to insert custom fields into tickets.  

Tasks 

Tasks are used to create scheduled events and are made up of elements. Each 
element generates a ticket and can be set to trigger on creation of the element, 
or when the element’s ticket status equals a set value. 

To create a new task:  

1. From Setup > Tickets > Tasks click New. 

2. Enter the Task name.  

3. Click Scheduled to create a recurring task. 

4. Complete the scheduling intervals and start date. 

Setup – Clients 

 

The Clients tab pages define how WHD client users enter WHD and how they 
are defined. When a new client accesses WHD and are accepted by the system, 
they are automatically given the access and interaction you have defined for that 
client.  

Data import and LDAP synchronization options allow for client information import. 
This helps avoid adding clients manually.  

Options 

Most of the Options page settings can be accepted at default. If you want clients 
to be able create accounts, Only if client’s e-mail matches Accepted Domains is 
recommended. Use the tooltip help to assist on other settings.  

Click Save when you have completed any changes on this page. 
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Client Admin Roles 

A Client can be assigned limited administrative roles. Typically, this is used for 
simple tasks such as resetting a user’s password.  

To Create a Client Admin Role: 

1. Click New on the Client Admin Roles setup page. 

2. Enter a Role Name. 

3. Select the proper Request Types Supported check boxes. 

Note: The Request Types Supported are populated from the Request Types you 
defined in the Tickets -> Request Types section above.  

4. Click Save. 

Client Custom Fields 

This defines custom fields clients see on the web console or in e-mail.  

LDAP Connections 

LDAP Connections allows bulk importing or updating information on clients from 
a client’s LDAP server.  

Notes:   

 The person configuring and using this LDAP import should be experienced 
with LDAP or Active Directory administration.  

 You will need to work with a customer representative who is also familiar with 
LDAP and has administrative access to the customer’s LDAP server. This 
person will also need to be familiar with the LDAP structure in place.  

 If your LDAP directory contains mostly users who will not be using WHD, we 
recommend you do not perform a bulk LDAP import.  

To connect to a client LDAP server and synchronize users: 

1. From the LDAP Connections > Connection Basics page, enter a 
Connection Name that describes the connection. 

2. Fill in the User Base DN, Group DN, and Search filter with information from 
the customer’s LDAP representative. 

3. Leave Clear Unmapped Values cleared. 

4. Leave Ignore Blank LDAP Values selected. 

5. If this is a new sync, not an update, leave Sync With Existing WHD 
Clients Only not selected.  
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6. Set When LDAP Records are Removed to reflect how to handle WHD 
client accounts for persons who are no longer with the customer.  

7. Set the Authentication settings according to information from the customer. 

8. Do not select Enabled box for Bulk Synchronization. (See note above) 

9. Set the Cache Time Period to the length of time required for an LDAP 
resynchronization.  

10. Click Save. 

11. Click the Attribute Mappings page tab. 

12. Click Pencil  to edit the page. 

13. Enter Attribute Mappings as specified by the customer’s LDAP 
representative.  

14. Click Done. 

To manually add clients:  

1. Click Clients   on the top menu bar.  

2. If you are taken to an existing client form, click the back  button to go 
to the Clients page. 

3. Click New  

4. Fill in the pertinent information for this client.  

5. In the Help Desk Location section, assign a company, and a primary 
location. 

6. Click Save. 
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Setup – Techs 

 

The Techs tab pages define the WHD technicians, the Tech Groups they belong 
to, and what Permissions the techs have. Once Tech Groups are created they 
are assigned to Location Groups, Customers, and Business Zones. This is the 
last portion of the WHD configuration that makes automatic ticketing possible.  

My Account 

The My Account page allows you to enter additional information for the account 
used to log in.  

To change your account information: 

1. Click  to enter edit mode. 

2. Update your information. 

3. Click Save. 

Techs 

Create Techs and define their work schedules, Location Groups, and Business 
Zones on the Techs pages.  

Note: When you add techs, add non-supervisorory techs first. This will allow you 
to assign tech to supervisors as you create the supervisors. 

To add Techs,  

1. Click New. 

2. Fill in the pertinent information for the user’s name, email and contacts. 

3. Assign a password for the user. 

4. Assign an Account Type from the Account Type list. 

5. If this user will be a supervisor, select the techs assigned to this 
supervisor in the Supervisor list. 
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6. Select the proper Notifications for this tech.  

7. Assign a Business Zone for this user. 

8. If this user works a schedule other than the one defined in the assigned 
Business Zone, select the Specify Work Schedule check box, and then fill in 
the tech’s schedule.  

9. Click Save.  

To create additional Techs, repeat steps 1 through 9 above. 

Tech Groups 

This option allows you to group techs together with similar skills, technical 
expertise, and by the type of requests they can service. Typical Tech Groups 
would be “Phone Techs”, “Systems Techs” or “Software Techs.” 

To create Tech Groups:  

1. Click Tech Groups in the settings bar at the left of the screen. 

2. Click New. 

3. Enter a Group Name, such as “Phone Techs”. 

Note: The Tech Group Levels and Request Types Supported page tabs display 
as shown below.  

 

4. Click Save. 

5. Click back . 

Repeat steps 1 through 5 above to add all of your Tech Groups. 

Technical groups are assigned Tech Group Levels to indicate the members’ level 
of expertise. These are typically Level 1, Level 2, and Level 3.  

To assign Tech Group Levels:  

1. From the Tech Groups home display, click the name of a Tech Group. 



Administrator Guide  SolarWinds Web Help Desk 
 

 
42 Getting Started with SolarWinds Web Help Desk 

 

2. Click the Tech Group Levels tab. 

3. Click Level 1  . 

4. To allow automatic ticket assignment to this level of tech, select the type of 
tech you want to receive the ticket. (A Level Tech, Group Manager, or Lead 
Tech.) 

5. Choose an Assignment Algorithm to indicate how to distribute the tickets.  

6. Do not select the Ignore Location and Department check box.  

7. Choose your preferences for email notifications and recipients. 

8. Select one or more Level Tech using the Level Techs check boxes.  

9. Click Add Level to add another level.  

Repeat steps 4 through 8 above to add additional levels. 

To assign Request Types Supported: 

1. Click the Request Typed Supported page tab. 

2. Click Edit. 

3. Select one or more Request Types for this group to receive. 

4.  Click Done. 

Note: You must repeat the above two procedures to assign Tech Group 
Levels and Support Types to each Tech Group. 

To assign Tech Group Levels to the rest of the groups, return to Step 1 in the 
Tech Group Levels section above.  

To assign Request Types Supported to the rest of the groups, return to Step 1 in 
the Tech Group Levels section above. 
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Tech Permissions 

The Tech Permissions pages allow you to control what features techs can 
access. There is a default set of permissions that can be edited and any number 
of additional permission sets can be defined and assigned to techs.  

Permissions are divided into five main sections:  

 Location Permissions  

 Ticket Permissions  

 Client Permissions  

 Asset Permissions  

 Other Permissions 

Once permissions are defined, use the Assigned Tech tab to link techs to the 
permission. The tooltips provide more information about each permission. A tech 
can only be linked to one permission at a time. 

Setup – Assets 

 

Assets are typically customer-owned software and hardware. Because 
customers usually have large numbers of assets, and assets have a large 
number of properties associated with each one, assets are not typically entered 
manually. WHD has an extensive selection of asset import and discovery 
options. These include interface to: 

 LANrev© Absolute Manager  

 Apple© Remote Desktop 

 JAMF© Casper 

 LANSweeper© 
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 Microsoft© SMS/SCCM 

 Spreadsheet import 

 CSV or TSV imports 

Asset importing is detailed in Chapter 12. 

Options 

This page sets options for asset import and assigns asset permissions for techs. 
Fill in the pertinent information on this page. Popup tooltips are available in the 
application to describe each item and its function. Hover the mouse cursor over 
an item to see the tooltip.  

 

Note: If you select to enable an import tool, you will also need to enable that tool 
in Setup > Techs > My Account or Setup > Techs > Techs > {Tech} > 
Account Info  

When you are finished making any changes on this page, click Save. 

Types 

If you will be using an asset importing tool, asset types are included within the 
data import, so you do not need to specify them manually at this point. If you find 
after import that there are undefined asset types, you will need to return to this 
page and define them.  
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To manually add asset types: 

1. Navigate to Setup > Assets > Types.  

2. Click New.  

3. Enter The Name for the new type, and then click Save. 

Status Types define the current status of an asset. WHD comes with the 
Deployed status type defined.  

To manually add asset status types: 

1. Navigate to Setup > Assets > Types.  

2. Click the Asset Status Types tab. 

3. Click New. 

4. Enter The Name for the new type, and then click Save. 

Asset Custom Fields 

Custom Fields can be used to extend the types properties associated with 
assets.  

Manufactures & Models 

This information is also populated from the asset import. You can manually add 
manufacturers and models from this section if you need to add one or two 
devices.  

Vendors 

The Vendors field defines the contacts for ordering customer parts or software. 
Fill in the pertinent information for each vendor contact and click Save when 
finished.  

Discovery Connections 

Discovery Connections sets up the basic information for the asset import tool 
chosen. It also defines the mappings of the imported data fields to WHD 
database fields. This can also be managed using the Asset Data Import below.  

PO Custom Fields 

PO Custom Fields define custom fields and specify view/editing permissions for 
techs. No client permissions are available for these fields because clients never 
view purchase orders. Details on Purchase Orders are in Chapter 6, Managing 
Assets. 
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Asset Data Import 

Using the data import function from Settings > Data Import>Import Asset is the 
preferred method of populating asset data.  

 

To Import assets using the Import Assets page: 

1. Select a Sync Bases On type. This field synchronizes the data import with 
any existing asset data.  

2. Choose a Client Key. This specifies the key field for database column 
reference.  

3. If you expect that some of the table fields will not be populated, ensure 
that Ignore Blank Fields check box is selected. 

4. If you need to add fields that are not defined on the downloaded 
template, Select Add New Entries.  

5. If you get poor results after importing your data, select Abort Import on 
First Error.   

6. Select the proper File Type and File Encoding. Use MS Excel Unicode for 
.xls imports.  

7. Populate the downloaded template and click Save. 

8. Use the Browse button and specify the saved template. 

9. Click Import. 
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Setup – Processes 

 

Note: Versions prior to 11.0.8 referred to this feature as Change Management. 
The two are functionally equivalent.  

Action Rules 

Action rules create custom actions that are triggered by events you define. To 
create an action rule, you will: 

 Define the action properties. 

 Assign a criterion. 

 Define an action.  

Action rules can be used to escalate specific events or to reroute the assignment 
of an event based on the criteria. These are often used to route a ticket to the 
Change Advisory Board (CAB) when necessary.  

To add a new action rule:  

1. Click Setup > Processes > Action Rules. 

2. Enter a Rule Name and Description.  

3. Select Cascade if you want all a triggering ticket to trigger all defined actions. 
Do not select Cascade if you want to only have the highest priority action 
triggered.  

4. Click the Criteria tab. 

5. Enter your criteria options using the menu lists provided. 

 Notes:  

 The upper section of criteria are evaluated using an AND condition. All of the 
upper section criteria must be true to trigger this section.  

 The lower section is evaluated as an OR. At least one of the lower section 
criteria needs to be true to trigger.  

6. Click the Actions tab.  
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7. Enter your actions options using the menu lists provided. 

8. Click Save. 

Additional CAB options are detailed in Chapter 7, Change Management 
Processes.  

For Surveys setup, see Chapter 11, Surveys and Messages. 

For Parts & Billing setup, see Chapter 9, Parts & Billing. 
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Chapter 4 

Managing Clients 

This chapter provides specific information for managing WHD clients, including  

What is a Client? 

A client is an individual using WHD in the role of a customer. Only customer 
personnel who will be directly interacting with WHD need be defined as clients. 
Clients typically interact with WHD using the web interface, but they can be set to 
also use e-mail or to only interface with WHD in e-mail.  

Manual Web Entry 

To manually add a new client: 

1. Click Clients   in the tool bar. 

2. Click New Client  in the lower left. 

3. Complete the client information, and then click Save.   

Note: An email will be sent to the client if this option was set in Setup > Clients 
> Client Options > E-Mail Client When Account is Created. 

Importing Clients 

Chapter 12 details your options importing data for clients.   

Assigning Assets 

To assign an existing asset to a client:  

1. Click Assets  in the top menu bar. 

2. Select the Assets Basic tab. 

3. Search for the asset using the search parameter options available. The 
dialog bog lists found assets. 

4. Click the asset number to open the edit asset page. 

5. Search for the client using the Client Lookup widget. 
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6. Click the client name link, and then click Save. 

To manually add a new asset, click New Asset in the Assets > Basic Search 
page.  

 

Viewing Client Information 

To view information about a client: 

1. Click Clients  . 

2. Click a Client Name. 

3. To edit any information about the client, click Pencil  , add the pertinent 
information, and the click Save. 

View all ticket history using the Ticket History tab. View all assigned assets for 
this client using the Assigned Assets tab.  

 

Client Initiated Account Setup 

To allow clients to create their accounts upon first login:  

Click Setup > Clients > Client Options and select Client Can Create Account. 

Notes: 

 All new clients are now permitted to create an account. 

 New clients see the below screen for creating their account.  
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Notes:  

 Clients must be qualified using the email restriction set in Setup > Clients > 
Options. 

 It is highly recommended to require domain matching for new clients. See the 
figure below: 
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Chapter 5 

Managing Tickets 

Web Help Desk provides several options for handling tickets in your environment. 
In addition to e-mail initiated ticketing, The Web Help Desk console allow your 
clients to open and managed tickets in a web browser. Web Help Desk provides 
the following ticket functionalities.  

 Quick Tickets 

 Manual Ticket Creation 

 Working with the Ticket Details Page 

 About Tech Notes 

 Using FAQs in Notes 

 Tech Permissions and Tickets 

 Ticket E-Mail Recipients 

 

Ticket flow is detailed in the following diagram. 
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Quick Tickets 

,The Quick Ticket dialog opens tickets for repetitive issues, such as a forgotten 
password. Ticket templates define Quick Tickets.  

To define a quick ticket: 

1. Click Tickets  . 

2. Click New Ticket   in the lower left. 

3. Click  + to create a new Quick Ticket.  

. 

4. In the Quick Tickets Details page, complete the requirements for this ticket 
type. 

Note: Subject and Request details are required fields. 

5. Enter a name for this quick ticket type in the Save Quick Ticket as: field. 

6. Click Shared to allow others to use this quick ticket template.  

7. Click Save, and then click Apply. 

 

To launch a previously saved quick ticket: 

1. Select the saved quick ticket from the pull down list. 

2. Click OK to launch the ticket. 

To edit a quick ticket before launching:  

1. Select the saved quick ticket from the pull down list. 

2. Click pencil  . 

3. Make the required edits. 

4. Click Save, and then click Apply. 

Typically the technician or admin edits the client information to assign to the 
ticket, then runs the Quick Ticket action. 

Manual Ticket Creation 

To manually create a new ticked: 

1. Click Tickets  in the tool bar. 
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2. Click New Ticket   in the lower left. 

3. Assign the ticket to a client using the client search dialog box. 

4. If the ticket will require an asset, click the Asset tab, and add the proper 
asset. 

5. Click the Ticket Details tab to assign a location, room, department, tech, 
schedule and any text instructions. 

6. If parts or specific labor charges will apply, click the Parts & Billing tab. 

Note: Parts and Billing are detailed in Chapter 9. 

7. Select the applicable parts & billing options, and then click Save or Save and 
Send E-Mail. 

Save will only save the ticket, Save and E-Mail will trigger the ticket E-Mail 
process. The ticket will now be sent to the individuals you have specified in the 
ticket and in the Tech, Clients, Locations, and Tickets set up options.  

Working with the Ticket Details Page 

The Ticket Detail page was initially configured in Chapter 3. Here we will explore 
some the options available now that assets, locations and tech have been 
defined.  

Note: You only see tickets under My Tickets and Group Tickets if you belong to a 
group that has assign tickets, or you have tickets directly assigned to you.  

To view the ticket detail page: 

1. Click Tickets .  

2.  Open a ticket detail page by: 

 a. Click My Tickets, and then click a ticket number. 

 b. Click Group Tickets, and then click a ticket number. 

 c. Use the search options to locate the ticket of interest.  

To assign a technician to the ticket use the Assigned Tech list, or click Add 

Tech . 

To escalate the ticket, click the up triangle on the 

Tech Group  . 

All fields in the ticket Details page are editable. This includes: 

 Location 
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 Department 

 Ticket Type 

 Request Type 

 Action Rules 

 File Attachments 

 Status 

 Schedules 

 E-Mail Recipients 

 

About Tech Notes  

Technicians add information to a ticket using a tech note.  

A ticket can have any number of notes, and notes can be added by any 
technician.  

Ticket notes can contain basic HTML tags or BBCode (Bulletin Board Code) tags 
for formatting.  

If Setup > Parts & Billing > Options > Parts & Billing Enabled is selected, a 
billing rate for the work can be specified. 

A tech note can also be used to create a new FAQ – the request detail is used as 
the question and the tech note is used as the answer. New FAQs created from 
tech notes are set to Unapproved status by default and use the ticket’s request 
type as the FAQ category. FAQs are detailed in Chapter 8.  

Using FAQs in Notes 

To add a FAQ to a tech note, 

1. Open the ticket details page for the ticket of interest. 

2. Click New in the Notes section. 

3. Click Link FAQ. The FAQ Search dialog will open. 

4. Search for the proper FAQ, and then click the FAQ Number to insert it into 
the ticket notes.  

5. Click the Save & E-Mail button. 
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Tech Permissions and Tickets 

Administrators can re-assign technicians, change ticket status and delete tickets. 
Technicians have various levels of access depending on the permission set they 
are granted. Permissions are set at Setup > Techs > Tech Permissions. The 
access limits are: 

 Limit to Assigned Tech Groups: create, view and edit tickets belonging 
only to Tech Groups to which the tech is assigned. 

 New Ticket Assignment Override: override the normal Ticket assignment 
logic and self-assign the Ticket instead. 

 Other’s Ticket Status Edit: allows the tech to change the status of tickets 
not assigned to them. 

 Change Ticket Dates: Change the ticket’s Open Date, Close Date, Note 
Date, and Due Date. 

 Request Detail Edit: allows the tech to update the text of the reported issue. 

 Client Note Edit: allows the tech to edit a client created note. 

 Allow Re-Assignment: enables the tech to re-assign the ticket to any other 
tech. Disabling this option allows the tech to only re-assign jobs to 
themselves. 

 Change Priority: allows the tech to change the priority of tickets assigned to 
themselves or, if Edit Other’s Tickets is enabled, the priority of any ticket. 

 Close Tickets: enables the tech to set tickets to the “Closed” status type. 

 Delete Tickets: allows tech to delete tickets. 

 Import Tickets: allows the tech to access Tickets > Import Tickets. 

 Task Edit: allows the tech to create and edit tasks at Setup > Tickets > 
Tasks. 

 Limit by Location Group: allows the tech access only to those tickets, 
clients, and assets that are in “assigned” status 

 Limit by Department Group: allows the tech access to only those tickets, 
clients and assets that are in assigned Department Groups. This option is 
only visible if Departments are enabled. 

All of the above are Rights are assigned in a grouping called a Permission.  

To create a new permission:  

1. Navigate to Setup > Techs > Tech Permissions. 

2. Click New. 
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3. Enter a name for the new permission in the Permission Name field. 

4. Select the permissions you want this type of user to have. 

Note: Hover the mouse over an option's text to see detailed information 
about that option.  

5. Click Save. 

Ticket E-Mail Recipients 

When the ticket is saved, you can e-mail it to the client, assigned technician, 
level techs, group manager, or other addresses in the cc: and bcc: fields. Select 
the recipient check boxes and add cc: or bcc: addresses if necessary, then click 
Save & E-Mail.  

Clicking Save does not cause an e-mail to be sent, unless the ticket has been re-
assigned. In that case, the newly assigned Tech receives an e-mail. Clicking the 
padlock toggles the ticket privacy setting – when tickets are private, non-tech 
users can’t see them. 

 

 

Problem Tickets 

The problem tickets feature links multiple reports of a single incident type. A 
problem ticket is considered a “parent” and each linked incident is considered a 
“child”. 

To create linked problem tickets: 

1. Open the Ticket Details page, for a ticket with a cause in common with other 
tickets.  

2. Click Problem in the Ticket Type section. The Problems tab will appear on 
the upper right. 

 

3. Click the Problems tab to expand it. 
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4. Enter terms in the search boxes that are common to all the suspected child 
tickets.  

For example, if the issue is that the connection to building 17 is down, many 
users in building 17 may open tickets. By searching on “building 17” and perhaps 
Bldg 17 the possible child tickets will be listed.  

5. Click View to preview a possible child ticket. 

6. Click Link to assign the ticket as a child ticket.  

A ticket with a linked parent problem ticket adds a row in the Linked Problem tab 
to display the parent ticket number. The link can be broken by clicking on the 
trash can icon.  

 

Clicking on the ticket number opens the parent problem ticket. The parent ticket 
also has a Linked Incidents tab that can be used to switch to any linked child 
ticket. 

Managing Ticket Tasks 

A Task is a series of one or more separate steps, called Elements. A task can 
be scheduled to repeat at daily, weekly or monthly intervals.  
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1. To create a new task, go to Setup > Tickets > Tasks. Click the New button 
at the bottom of the Task list. The Task Info page will open. 

 

2. Enter a Task Name. 

3. Use the Client Lookup widget to look up and assign the client. 

4. If you want to schedule the task to run automatically, click Scheduled. 

 a. Select a Schedule Interval. 

 b. Click the applicable run times (calendar days, week days or time) you 
want the task to run. 

5. Click Shared if you want other to be able to launch this task. 

6. Click Save. 

7. Click the Task Elements tab. 

8. Click New. 

9. Select a Location, Room, and Department. 

10. Add a Subject and Request Detail. 

11. Select a Tech and Priority.  

12. Add an Asset Number, if applicable.  

13. If you want to generate all task element tickets when the task is 
triggered, select On Creation in the Generate Next Element section. 

14. If you want to issues the next task element ticket based on the status of 
this element, select When Status Equals in the Generate Next Element 
section, and then select a Status. 

15. Click Save. 

16. To create the next element click New, and then repeat steps 1 through 15 
above.   

Tasks run automatically on their scheduled date or they can be triggered 
manually using the green Play triangle next to the task name.  

Ticket Views 

Several options are available for viewing by clicking the Tickets button in the 
upper tool bar.  
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The My Tickets and Group Tickets views are pre-filtered tickets lists. Techs only 
see tickets that have been assigned directly to them in My Tickets. Techs only 
see tickets that have been assigned directly to a tech group they belong to in 
Group Tickets. 

Note: The two restrictions above apply to all accounts, including all admin 
accounts.  

Searching Tickets  

Locate tickets quickly using the Search Tickets tab.  

To initiate a basic search:  

1. Click the Basic Search tab. 

2. Use the text boxes and lists to narrow the search for the desired ticket. 

3. Click Search. 

4. To view or edit a ticket, click the Ticket Number (No.) as shown below.  

 

Advanced Search qualifies ticket using Boolean qualifiers.  

To create an Advanced Search:  

1. Click the Advanced Search tab. 
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2. Select qualifying conditions starting from the left most list and continuing to 
the right. 

3. If you want to add a new qualifying condition to Tickets matching ALL 
of these conditions, click the  + button to the right of the top condition. 

 

4. Select qualifying conditions as in step 2.  

Note: The conditions specified in the ALL grouping must all be true to result 
in a found ticket. These conditions are qualified using the Boolean AND.  

5. If you want to add qualifying condition to Tickets matching ANY of these 
conditions:, click the  + button in the right of the … and ANY of these 
conditions: section. 

 

Notes:  

 The conditions specified in the ALL grouping must have all condition 
true to result in a found ticket. These conditions are qualified using the 
Boolean AND.  

 The conditions specified in the ANY grouping must have at least one 
condition true to result in a found ticket. These conditions are qualified 
using the Boolean OR.  

 The ANY condition group begins with …and. Therefore the ANY group is 
evaluated along with the conditions in the ALL condition group, if the 
ALL group is used. 

 If no condition exists in the ALL group, the ANY is evaluated using only 
the Boolean OR. 

6. When you have completed entering search conditions, click Search. 
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For the above screenshot, the following illustrates a query that returns tickets that 
meet these criteria: 

 Priority = Urgent 

 Status = Open 

-- And either – 

 Escalation is 2 or above 

-- OR – 

 Company = ABC Co 

If you want to save the search enter a query name and then click Save. The 
Shared check box allows other techs to access the query.  

Refining Search Results 

The search results list may display a large amount of ticket data. Filter the results 
and available using the Column Set widget. The widget is located at the upper 
right corner of the search results list.  

 

1. If you want to modify the column headers, click + to add a new set, or 

Pencil to edit the selected set.  

2. Drag and drop column headers between The Available Columns and 
Selected Columns areas.  

3. Click Save. 
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Note: Saved column sets are not shared across techs. Each column set can 
specify a different PDF download option (Invoice or Ticket format) and full 
text option. 

Ticket Bulk Actions 

Ticket bulk actions apply pre-defined actions to multiple tickets.  

To create an action: 

1. Click +  in the Bulk Actions widget. 

 

2. Select the actions you want to apply to this bulk action. 

3. When you have finished specifying actions, enter a name for the action in 
Save Bulk Action as:, and then click Save. 
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Print Views 

To display the ticket information in a printer-friendly view, use the printer   at 
the top of the ticket. Clicking the button opens the ticket in a window suitable for 
printing. 

E-Mail Ticket Management 

Clients and Techs create tickets by sending an e-mail message to the dedicated 
help desk e-mail address. A ticket is created for each new message sent to the 
address. For details on setting up E-Mail Tickets, see Setup – E-Mail. 
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Chapter 6 

Managing Assets 

WHD provides a number of options to work with assets. This chapter details the 
following: 

 Adding Assets 

 Asset Properties 

 Searching Assets 

 Adding Purchase Orders 

 Reserving Assets 

Assets are client-owned software and hardware that Techs work with. The WHD 
asset features keep tracks several properties of each asset such as: 

 Location 

 Type 

 Status 

 Owner 

 Serial Number 

 Model and Make 

 Warrantee Dates 

 Lease Types 

 Relationship to Other Assets 

 Ticket History 

 Purchase Orders 

Adding Assets 

To manually add an asset: 

1. Navigate to Assets > Search Assets and click New Asset at the top of the 
search results list. 

Note: Asset numbers increment automatically beginning at the highest asset 
number in use. You can accept the number shown or enter a different 
number. 
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2.  Click the Asset Basics tab.  

3. Enter the information for the asset, and then click Save. 

4.  Click the Asset Details tab. 

5. Enter the asset details, and then click Save. 

Note: Chapter 12, Asset Discovery Tools, details asset import options and asset 
discovery tools.  

Asset Properties 

Web Help Desk imports several asset properties when you perform an asset 
discovery or an asset import operation. The WHD web interface provides a 
method of adding and editing asset properties.  

Basics Properties 

Asset basics are the “what, where, and who” of the asset.  

To Edit an asset’s basic properties: 

1. Click Assets . 

2. Fill in any search criteria and click Search. 

3. Click the asset number for the asset you want to edit.  

 

4. Click the Asset Basics tab to edit basic information such as the location, 
client, or status. 

5. Click the Asset Details tab to edit asset details such as network information, 
PO, or ownership. 

6. Click Save. 

Asset Details 

The asset details tab stores information following information about assets: 

 Serial Number 

 IP Address 

 MAC Address 

 Network name 
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 Purchase Order 

 Lease Information 

 Audit date 

 Attachments 

 Notes 

None of these fields are mandatory, but all of the fields are helpful in locating and 
managing assets.  

Creating Parent and Child Assets Associations 

Using this feature, you link assets as a parent or as a child of another asset. 
Keep the following in mind when assigning parent/child associations: 

 A parent asset can have any number of child assets. 

 A child asset cannot be a parent to another asset. 

 Removing the parent status orphans all the child assets for that parent. 

 Child assets can be removed from individually from a parent.  

 A child asset can have any number of parent assets.  

 Child assets inherit priorities from the parent objects including location, status 
and other properties.  

 Parent/child status is set by adding child assets to a parent asset. You 
cannot add a parent to a child.  

To add assets as children of a parent asset: 

1. Locate the parent asset by clicking Assets . 

2. Click the Asset Basics tab. 

3. In the Child Assets box, click Edit. 

 

4. Fill in the search criteria to locate the asset you want to make a child.  

5. Click Link to select one of the listed assets as a child asset.  

6. Click Done, and then click Save.  
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To remove a child asset from a parent asset: 

1. Locate the parent asset using Assets . 

2. Click the Asset Basics tab. 

3. Locate the child asset in the Child Assets box.  

4. Click the trash can next to the child you want to remove. 

 

5. Click Save. 

Asset History 

Asset History displays a read-only history of the asset including:  

Creation date 

Location/room change 

Client change 

Status change 

Sync date.  

Tech that made the change.  

Ticket History -  

Ticket history provides a list of all tickets created for the asset as well as a link to 
a ticket detail view for editing.  

Searching Assets 

You search for assets in either the either Basic or Advanced tabs. Basic 
searching provides a simplified sub-set of the search criteria available in the 
advanced search mode.  

If you want to sort search results, click on a column header.  

If you want to download the search results in PDF format, click the button for 
the format type you want.  
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Refining Search Results 

The search results list can display a large amount of asset data. To control what 
information is displayed, use the Column Set widget on the upper right of the 
search results list to enable or disable specific columns. Click + to add a new 

column set, or edit the selected column set by clicking  pencil.  

Saved Queries 

You save searches for future use in the Advanced Search Tab.  

To save a query:  

1. Define your search criteria using the same method explained in Searching 
Tickets 

2. Provide a name in the Save Query as: field.  

3. Select the Shared box if you want others to be able to use this search. 

Note: Depending on your access level, you may not have access to the 
share box.  

To run a query, select the query name from the Query menu at the top of the 
search results display. The query will be run automatically upon selection.  

Adding Purchase Orders 

The purchase orders feature of the Web Help Desk simplifies tracking your 
assets purchases and leases. This feature is not meant to replace your 
company’s current accounting or ordering systems. Web Help Desk does not 
create purchase orders but rather stores information about purchase orders. 

Define Vendors 

Before adding a new PO, one or more vendors must be entered into the 
database.  
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To add a new Vendor: 

1. Go to Setup > Assets > Vendors.  

2. Click New. 

3. Fill in the vendor information, and then click Save.  

Adding a Purchase Order 

Fields in a purchase order include: 

 PO Number (must be unique in the database) 

 Request Date – the date the purchase order was entered 

 Invoice Date – the date the vendor shipped the product (used to help 
calculate warranty / lease expiration date) 

 Vendor 

 Originator Name – lookup, by last name, the client who made the PO 
request. 

 Deliver To – lookup, by last name, the client the purchased items should be 
delivered to 

 Attachments - link any supporting documentation 

 Notes 

To add Purchase Order information: 

1. Click Assets > Purchase Orders.  

2. Click New at the bottom of the search display list.  

 

3. Fill in the Purchase Order information, and then click Save. 
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Add Purchase Order Line Items 

After saving a purchase order, you add line items to the purchase order using the 
line item editor. You add individual parts and their costs to purchase orders in 
Line Items.  

You associate specific assets by providing a valid asset number. If you attempt to 
link a line item to an asset number that doesn’t exist, or is already linked to 
another PO, you will receive an error message. 

To access the line item editor: 

1. Select a purchase order by navigation to Assets > Purchase Orders, 
search for a PO and click the PO Number link.  

2. Click Pencil  to edit the PO. 

3. Complete the Line Item box to the right. 

4. If you want to add more line items, click New Line Item. 

5. When you have completed the line items, click Save.  

Line items must define a model and may contain part number and price 
information. TIP An asset can also be associated to a PO from within the asset 
detail view.  

You must have a “free” line item defined in the PO in order to link the asset. If 
you were to add a new iMac G5 asset, you could associate it with the PO in the 
example above, because the iMac G5 line item is free (not linked) to any asset 
number. 

Purchase Order Import 

See Chapter 12, Importing Data, for details on importing purchase orders.  

Reserving Assets 

You ensure that an asset is available when you need it using the asset 
reservation feature. Before reserving an asset, the asset must first be set to 
reservable in the Asset Basics editor. 

Making an Asset Reservable 

To set an asset as reservable: 

1. Navigate to Assets > Search Assets  

2. Search for and select the asset you want to make reservable. 
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3. Select the Reservable check box.  

4. Click Save. 

Reserve An Asset As A Tech 

To set up an asset reservation as a tech: 

1. Navigate to Assets > Reservations and click New Reservation.  

2. Use the Client Lookup to select the client who will be checking the asset out, 
and set the Scheduled Out and Scheduled In dates and times. 

3. Find the asset to be reserved using the Asset Lookup box  

4. Click the asset to be reserved, and then click Save. 

Reserve An Asset As A Client 

An administrator must give clients permission to reserve assets before clients 
can use the reserve asset feature. 

To allow clients to reserve assets: 

1. Navigate to Setup > Assets > Options. 

2. Click Clients can Search Assets. 

3. Click Limit to Assigned and Reservable, and then click Save. 
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To reserve an asset as a client:  

1. Click Assets at the top of the client interface.  

2. Click Search. 

3.  Once the desired asset has been located, select the Reserve check box and 
then click Reserve Checked.  

 

Upon clicking Reserve Checked a calendar window will appear and allow for the 
selection of a reservation date or range of dates.  

To select a reservation date range click on the first date of the reservation, drag 
the cursor to the last day of the reservation and then click Save.  

To remove a reservation, click the trash can on the reservations page.  

 

Asset Check Out and Check In 

Only Techs can check reserved assets in or out. 

Navigate to Assets > Reservations and click Search to find reserved assets  

To check assets in or out, click Check Out or Check In.  
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Chapter 7 

Change Management Processes  

The change management feature provides a controlled environment for 
managing time sensitive or costly changes You add client personnel that are 
responsible for approving or denying changes. You define the process work flow 
and requirements. The Change Management Processes feature enforces these 
settings and implements the change management processes. This chapter 
details the following: 

 Adding CAB Status Types 

 Adding Approver Roles 

 Assigning Clients To Location Approval Roles 

 1. Select Setup > Process Location Approvers. 

2. Click Add Role. 

3. Select the Approver Role from the list. 

4. Click Search in the Client Lookup Box. 

5. Click the Name of the person you want to assign as a Location Approver. 

Note: Repeat steps 4 and 5 above to add more approvers. 

6. When you have finished assigning approvers, click Save.  

Assigning Clients To Department Approval Roles 

1. Select Setup > Process Department Approvers. 

2. Click Add Role. 

3. Select the Approver Role from the list. 

4. Click Search in the Client Lookup Box. 

5. Click the Name of the person you want to assign as a Department Approver. 

Note: Repeat steps 4 and 5 above to add more approvers. 

6. When you have finished assigning approvers, click Save.  

 Creating a Change Advisory Board (CAB) 

 Defining the Approval Processes 

 Using Approvals 
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Adding CAB Status Types 

The ticket creator assigns a status type when each ticket is created. Before 
making settings to the Processes section, check the Ticket Status Types to 
ensure that Change Advisory Board (CAB) status types are configured. 

To enable Change Access Board (CAB) features, you add Pending Approval, 
Approved and Denied status types. 

To add Approved, Approval Pending, and Denied status types: 

1. Navigate to Setup > Tickets > Status Types and click New. 

2. In the Name field enter Denied. 

3. In the Description field enter CAB Status Type. 

4. Click Alerts Enabled. 

5. Click Client Reminders, and then click Save. 

Repeat steps 1 through 5 above to add the Approved and Approval Pending 
Status types. 

After adding the above status types, you set the Status Types Options to allow 
the CAB features. 

To set the Status Type Options for the CAB feature: 

1. Navigate to Setup > Tickets > Status Types > Options. 

2. Set the Needs Approval Status Type to Pending approval. 

3. Set the Approved status type to Approved. 

4. Set the Approval Denied status type to Denied, and then click Save. 
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Adding Approver Roles 

Approver roles specify the level of authority for a given approver. These roles 
are: 

 Location Approver - Allows for the assignment of approve for specific 
locations. 

 Department Approver - for the assignment of approve for specific 
departments. 

 Change Advisory Board Member participates in a Change Advisory Board 
(CAB)  

Location Approver Roles 

To add a position that will be responsible for approvals for one or more 
locations:  

1. Click Setup > Change Management > Approver Roles > Location 
Approver Roles.  

2. Click New to bring up a panel that will allow for a new location approver to be 
added inside the Approver Role Name cell. 

3. Enter a Location Approver Role Name that describes the role, such as NYC 

Approver, and then click Save. 

Department Approver Roles 

To add a position that will be responsible for approvals for one or more 
departments:  

1. Click Setup > Change Management > Approver Roles > Department 
Approver Roles. 

2. Click New and add an Approver Role Name that describes the role, such as 
Legal Dept Approver, and then click Save. 

Assigning Clients To Location Approval Roles 

1. Select Setup > Process Location Approvers. 

2. Click Add Role. 

3. Select the Approver Role from the list. 

4. Click Search in the Client Lookup Box. 

5. Click the Name of the person you want to assign as a Location Approver. 

Note: Repeat steps 4 and 5 above to add more approvers. 

6. When you have finished assigning approvers, click Save.  
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Assigning Clients To Department Approval Roles 

1. Select Setup > Process Department Approvers. 

2. Click Add Role. 

3. Select the Approver Role from the list. 

4. Click Search in the Client Lookup Box. 

5. Click the Name of the person you want to assign as a Department Approver. 

Note: Repeat steps 4 and 5 above to add more approvers. 

6. When you have finished assigning approvers, click Save.  

Creating a Change Advisory Board (CAB) 

Note: In WHD versions prior to 11.0.8 the Processes tab was called Change 
Management. 

To create a new CAB: 

1. Navigate to Setup > Processes > Change Advisory Boards and click New. 

2. Enter a CAB Name.  

3. Use the Client search box to locate CAB members. 

4. Add members to the board by clicking on their names. 

5. After you have added all the CAB members, select the minimum number of 
members required to approve a change ticket. The minimum can be any 
number between one and the number of CAB members. 

6. Click Save.  

Defining the Approval Processes 

Now that you have created approver roles, you will now define the approval 
process. 

To define the approval process:  

1. Navigate to Setup > Change Management > Approval Processes. 

2. Click an existing Approver Process or click New.  

3. Enter a Process Name and Description in the appropriate fields. 

4. Select the desired E-Mail Reminder Interval for approvers.  

5. Select the e-mail recipients for any approvals and denials, and then click 
Save.  
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Adding Approval Steps 

To add approval steps: 

1. Select the Approval Steps tab and click New.  

2. Use the Step No. list menu to select the step number of this approval step.  

3. In the Step Name field add a descriptive name.  

4. In the Approver Type field, use the radio buttons to select which type of 
approver will handle the step.  

Note: Selecting CAB, Location or Department approver type results in a popup 
menu for the selection of the specific approver role or CAB to link to the step.  
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Selecting “Client” as the approver type requires the lookup of a specific Client to 
assign to the step. 

5. Click the Request Types Supported tab.  

6. Click Edit, click the request type , and then click Save. 

 

Note: To add additional approval steps, repeat steps 1 through 6 above.  

Using Approvals 

Ticket Approvals 

When a client logs in and creates a new ticket and selects a request type that 
has been assigned to an approval process, a notification in a large blue field 
denotes This Request Type requires approval.  

The following describes the approval process: 

1. WHD sends an e-mail to the approver assigned to the first step of the 
approval process. 

2. When the first approver approves the change, an email is sent to the next 
approver.  

3. This continues until the ticket is approved or declined as specified in the 
approval process criteria.  

 Approver Action  

An approver views or responds to the approval request in e-mail or the web 
interface.  
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E-Mail Approvals 

 

The following describes the e-mail approval process: 

1. Approvers receive e-mail when a ticket has been created that has an 
approval process assigned to it. The approver responds by clicking Yes or 
No. 

2. WHD opens a web page asking the approver to confirm their decision.  

a. If the required number of required approvers choose Yes, the ticket status is 
changed to Approved.  

b. If the required number of required approvers do not choose Yes, the ticket 
status is changed to Denied. 

3. If an approver clicks No, the approver is given an Explanation text box 
where they provide reasons for declining the request. The approver also has 
the option of using a Visible to Requestor check box below that allows the 
explanation to be viewable by the requestor. 

Client Web Approvals 

To view and approve through the web interface: 
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1. Click Approvals  to view New Approvals and vote on each new request 
and to view Old Approvals.  

2. Add an explanation if desired. 

3. Select Visible to Requester to share the denial explanation as a note in the 
ticket. 

4. Click Save. 

Action Rules 

Action rules provide the ability to create a customized process for unique use 
cases.  

To add a new Action Rule: 

1. Navigate to Setup > Processes > Action Rules, and click New. 

2. Select a Priority for this rule. Priorities determine which action rule will be 
triggered if multiple rules meet the same criteria. 

3. Assign a unique Rule Name  

4. Add a Description for the rule. 

5. Select the Rule Triggering criteria options to fit your criteria. 

6. Click the Criteria tab. 

7. Select the Tickets Matching ALL of these conditions and the Tickets 
Matching ANY of these conditions to fit your criteria. 

Notes:  

 The conditions specified in the ALL grouping must have all condition true to 
trigger an action. These conditions are qualified using the Boolean AND.  

 The conditions specified in the ANY grouping must have at least one 
condition true to meet the triggering condition. These conditions are 
qualified using the Boolean OR.  

 The ANY condition group begins with …and. Therefore the ANY group is 
evaluated along with the conditions in the ALL condition group, if the ALL 
group is used. 

 If no conditions exist in the ALL group, the ANY is evaluated using only the 
Boolean OR. 

8. Click the Actions tab. 

9. Specify the action to be taken when the criteria is met, and then click Save.  
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Chapter 8 

Managing FAQs 

Using the FAQ feature you create a database of information on common issues. 
Clients access the FAQs from the  

Creating New FAQs 

To Create a new FAQ: 

1. Click FAQs, and then click New.  

2. Select a category from the Category list.  

Note: The category list is populated from the ticket request types. To add 
additional Ticket request types go to Setup > Tickets > Request Types. 

3. Enter an answer. Answers can include HTML hyperlinks and formatting, or 
use Bulletin Board Code (BBC) tags.  

4. If you want to link this FAQ to a related FAQ, click Link FAQ, click 
Search, and then click Link on the FAQ you want to link. 

5. Select the following viewing options: 

 Audience 

 Models 

 Companies 

 Locations 

 Departments  

6. Select Approved to publish the FAQ.  

Note: Only Administrators can approve FAQs.  

7. If you want the FAQ to expire, add an Expiration Date and Time.  

8. Click Save. 

FAQ Search 

Click  FAQs in the menu bar.  

Filter FAQs by FAQ number, category, location, model, approval, expiration, and 
question/answer text.  
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To edit a FAQ, click the FAQ hyperlink number.  

To sort the results list, click a column header.  

Accessing FAQs 

Web Access 

FAQs that are available to “Everyone” and are approved can be accessed by 
anonymous users by connecting to the following URL: 

http://{myserver.com}/helpdesk/WebObjects/Helpdesk.woa/wa/FaqActions/viewA
ll 

FAQs that are linked to specific Locations or Departments are not accessible 
using the public URL.  

RSS Feed  

An RSS feed of public (Everyone) FAQs is also available at the following URL: 

http://{myserver.com}/helpdesk/WebObjects/Helpdesk.woa/wa/FaqActions/rss?ty
pe=atom 

Clicking on the subject of the RSS entry opens the corresponding FAQ in its own 
window. 
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Chapter 9 

Parts & Billing 

This chapter covers the following: 

 Parts & Billing Options 

 Rates & Terms 

 Managing Parts 

 Invoicing 

Parts & Billing Options 

Disabling Parts & Billing 

The Web Help Desk Parts & Billing feature tracks parts, inventory and billing on 
tickets. This functionality is enabled by default. 

To disable this feature navigate to Setup > Parts & Billing > Parts & Billing 
Options and clear the Parts & Billing Enabled check box.  

Disabling parts & billing hides the main Parts icon, the ticket detail Parts & Billing 
tab, billing preferences and the billing reporting options. 

Manual Part Entry 

To manually add parts: 

1. Click Parts  > New Part.  

2. Enter a Part Number. 

3. Select a Manufacturer and Model. 

Note: Manufacturers and models are added at Setup > Assets 
>Manufacturers & Models. 

4. Add a description of the part. 

5. To mark a part as Tax free, select the Tax Free check box.  

6. If you want to track inventory thresholds, select the Inventory Alerts 
Enabled check box.  

7. Enter the desired Inventory Alert Threshold. 

Note: Do not leave this number at zero. The alert is triggered when the 
inventory level is one less than the number you select.  
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8. Set the Inventory Alerts Interval in Setup > Parts & Billing > Inventory 
Alerts. 

9. Enter Default Inventory Alert Recipient (Optional) 

Notes:  

 This address will only be used to alert for inventory levels where there is no 
location inventory recipient set. 

 Location recipients are set at Setup > Location & Departments > 
Locations & Rooms > Edit Location > Location Info. Select the check box 
to Enable Location to store Parts and then enter an e-mail recipient.  

Importing Parts Lists 

For detailed information on importing parts lists, see Chapter 12, Importing Data.  

Rates & Terms 

Billing Rates, Terms and Taxes 

This feature allows you to define billing rates to use in your tickets. You configure 
specific billing rates to be consistent with the level of service delivered (Level 
tech) and the applicable local tax codes.  

To define billing rates: 

1. Navigate to Setup > Parts & Billing > Rates & Terms >Billing Rates  

2. Click New. 

3. Enter a Rate Name. 

4. Enter an Hourly Rate. 

5. Select Subtracts From Time Blocks if you use time block billing.  

6. Select Travel Rate if this rate is for travel time only.  

7. Click the Billing Terms tab. 

8. Enter a Term Name that reflects the negotiated term, such as Net 30. 

9. Click the Tax Rates tab, and then click New. 

10. Enter the applicable tax rate. 

11. If you want this rate to apply to parts only, Select Do not Apply in the Apply 
to Labor section.  

12. Select Apply to Parts and Apply to Shipping as appropriate, and then click 
Save.  
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Managing Parts 

Inventory 

WHD tracks part inventory levels for locations that are set to store parts. To 
designate locations for parts storage see Setup – Locations. 

To add parts to a location: 

1. Click Parts  , and then click the Inventory tab. 

2. Locate the part you want to add to a location using the search box. To list all 
parts leave the search fields empty and click Search  

3. Select a Storage Location. 

4. Add the number of part available at the storage location in the Add Count 
Field.  

Note: To reduce the number of parts available, use a negative number. For 
example, to change the number of available parts from 6 to 4, enter -2.  

5. Click Save. 

 

Note: When a part inventory reaches zero the inventory status will change from 
Available to Back Ordered.  
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To use parts in a ticket, 

1. Click Tickets  , and then click the ticket number. 

2. Click the Parts and Billing tab.  

3. Locate the part using the Part Search box. The Search Results box now 
displays the location and number of parts available. 

4. Click the inventory name or the number available to add the part.  

 

The part now appears in the Assigned Parts box. 

 

If you want to have defective parts removed from inventory, enter the 
number of parts in the DOA field. 

WHD removes the cost of the DOA parts from the ticket, and lists DOA parts in a 
separate area in your billing reports.  

To remove an entire parts line item and return the parts back to inventory, click 
the trash can on the right.  

When you have finished making changes, click Save.  

Additional fields available include Billing Terms, PO Number, Shipping, Discount 
and a Tax Free option.  

You configure tax rates in Setup > Parts & Billing > Rates & Terms > Tax 
Rates. If you update your rates, tickets created prior to the update retain their 
original rate.  

To update an old ticket with the new rates, click Refresh Tax Rate.  

Invoicing  

To specify a company contact for invoices: 

1. Navigate to Setup > Invoicing Options. 

2. Add the contact information in the Invoicing tab fields.  
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3. Optionally, add your company logo in the Logo tab 

4. Click Save. 

 

To generate a PDF invoice or quote directly from a ticket: 

1. Click Tickets  . 

2. Search for your ticket. 

3. Click the ticket number in the search results. 

4. Click the Parts and Billing tab.  

5. Select the type of PDF you want to generate using the list on the top left of 
the Parts and Billing tab.  

 

6. Click the PDF icon.  

Service Time Blocks 

This option allows you to offer support to your client locations based on 
predefined service time blocks. 

To enable Time Block Billing: 

1. Navigate to Setup > Parts & Billing > Options  

2. Select Enable Location Service Time Blocks, and then click Save. 

3. Navigate to Setup > Locations And Rooms. 

4. Click the location for which you want to enable time blocks. 

5. Click Pencil  to edit the location  

6. Select the Service Time Blocks Enabled check box.  

7. Click Save. 

8. Click the Service Time Blocks tab.  

9. Click New. 

10. Enter the amount of time in the Time Block field 

11. Optionally, click Expiring to define an expiration time and date.  
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12. Click Save.  

Notes:  

 For an expired block, the usable value may be lower than the block value 
depending on how much time was used before the block expired.  

 The amount of service time available for a location is displayed within the 
Ticket Details of a ticket under the location popup. If the value is negative, it 
will display in red.  
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Chapter 10 

Reports 

Web Help Desk provides a robust reporting feature that helps clients and 
administrators to track service quality and billing information. This chapter covers 
the following: 

 Using Sample Reports 

 Creating Reports 

 Report Groups 

 Creating Report Schedules 

Using Sample Reports 

The Web Help Desk includes a set of sample reports you can use immediately.  

To run a sample report click Reports  and then click the Play Triangle 
 on the right side of the screen.  

To generate a printable web view in a new window, click the Print View  icon 
in the report row.  

To create a PDF for downloading or printing, click the PDF icon  in the report 
row.  

Creating Reports 

The reports feature creates custom reports for billing information, ticket 
information, or a mixture of reports linked together.  

Billing Reports 

Billing Reports generate a table showing the total work time, parts cost, and labor 
cost accrued for a set of tickets. 

To create a new billing report: 

1. Click Reports   and then click New. 

2. In the Report Basics tab, enter the Report Name. 

3. Optionally, select a Report Group. 

4. Select Billing Report in the Report Type list.   
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5. Click the Report Details tab.  

6. Select a Category to indicate the type of information this report will contain. 

7. Select a Time Range for the report.  

 Note: The default range is not shown, but it is from today, back one month.  

8. Select a Date Attribute for Time Range from the list.   

9. Optionally, click the Report Filters tab to add a report filter. 

10. Select a Filter Attribute. WHD populates the filer values available by this 
choice. 

11. Select a Filter Type and the Filter Values, and then click Save.  

Ticket Reports 

Four sets of options define ticket reports; categories, metrics, time range, and 
filters. Categories determine which values various dimensions of the report will 
represent. Metrics determine which ticket attribute will be used to calculate the 
length of bars or size of pie slices, and determines which attribute will be 
included in the table. 

To create a new Bar Chart ticket report: 

1. Click Reports   and then click New. 

2. In the Report Basics tab, enter the Report Name. 

3. Optionally, select a Report Group. 

4. Select Ticket Report in the Report Type list.  

 

5. Click the Report Details tab.  
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6. Select Bar Chart as the Chart Type.  

7. Select a Bar Category to indicate what data the bar will represent.  

8. Optionally, choose a Bar Stack Category to indicate data to be stacked on 
the bar.  

For example, the chart below was created using Day of Week Opened as the 
Bar Category and Hour of the Day Opened as the Bar Stack Category.  

 

 

9. Optionally, choose a Repetition Category to create multiple charts, 
separated by this field. 
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For example, the chart below was created using Day of Week Opened as the 
Bar Category, Hour of the Day Opened as the Bar Stack Category, and 
Assigned Tech as the Repetition Category. This creates multiple reports, one 
for each tech.  
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10. Select a Chart Metric to indicate the type of measurement. The above 
examples were created using the Tickets metric.  

11. If you want to show a data table with the chart, select Show Table.  

12. Select a Time Range and a Date Attribute.  

13. Click Save.  

14. Optionally, click the Report Filters tab to add a report filter. 

15. Select a Filter Attribute. WHD populates the filer values available by this 
choice. 

16. Select a Filter Type and the Filter Values, and then click Save. 

 

To create a new Pie Chart ticket report: 

1. Click Reports   and then click New. 

2. In the Report Basics tab, enter the Report Name. 

3. Optionally, select a Report Group. 

4. Select Ticket Report in the Report Type list.  

 

5. Click the Report Details tab.  

6. Select Pie Chart as the Chart Type.  

7. Select a Pie Slice Category to indicate what data the slices will represent.  

8. Optionally, choose a Repetition Category to create multiple charts, 
separated by this field. 

For example, the chart below was created using Day of Week Opened as the 
Pie Slice Category and Location as the as the Repetition Category.  



Administrator Guide  SolarWinds Web Help Desk 
 

Reports 98  

 

 

 

Date Worked On is a unique date attribute as it looks specifically at tech notes 
created during the specified date range and not ticket dates. Ticket reports using 
this date attribute include data based on all tech notes in the date range 
regardless of who created them, however all work time is attributed to the 
assigned tech on the ticket.  

To group request sub-types together within a single entry for their parent type, 
create a filter that includes the parent request type.  

For example, if there are request types for Hardware and Software, and each 
have subtypes that you do not wish to appear as separate lines in the report, 
create an inclusive Request Type filter that includes the Hardware and Software 
request types. The report shows a single line for Hardware that includes all 
tickets with subtypes of Hardware, and a single line for Software that includes all 
tickets with subtypes of Software. 
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Report Groups 

Creating Report Groups 

The Report Groups function facilitates organization and helps control access to 
report data.  

Report Groups control access to created reports sorted by Tech and Location 
Group. This ensures that each Tech is only presented with the reports 
concerning their scope of work. 

To create a new Report Group: 

1. Navigate to Reports > Report Groups, and then click New. 

2. Enter a Report Group Name. 

3. Select the Tech Groups, Location Groups, and Department Groups that 
will have access to the reports. 

4. Click the Included Reports tab. 

5. Select the applicable Reports, and then click Save.  

Creating Report Schedules 

To further facilitate the distribution of reports, WHD includes the Report 
Schedules function. This function schedules and automates to report creation 
and distribution.  

To create New Report Schedule: 

1. Navigate to Reports > Report Schedules, and then click New.  

2. Enter a Schedule Name. 

3. Specify the Interval values.  

4. Use the Client Lookup widget to search for clients. 

5. Click a client Name to add a client.  

6. Optionally, add non-client and non-tech recipients in the Other Recipients’ 
E-Mails field.  

7. Click the Tech Recipients tab, and the click Edit.   

8. Select the applicable tech check boxes.  

9. Click the Included Reports tab, and then click Edit. 

10. Select the reports you want to include. 

11. Click Save.  
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Chapter 11 

Surveys and Messages 

Surveys provide feedback from your client users. You have the option to link 
surveys to a specific ticket for a single client, or to send surveys as general 
questionnaires to a number of clients. 

You specify which survey to use for a specific ticket request types at Setup > 
Tickets > Request Types.  

 

 Creating Surveys 

 Sending Surveys 

 Viewing Survey Results 

 Creating Messages 

Surveys provide feedback from your client users. You have the option to link 
surveys to a specific ticket for a single client, or to send surveys as general 
questionnaires to a number of clients. 

You specify which survey to use for a specific ticket request types at Setup > 
Tickets > Request Types.  

 

Creating Surveys 

To create a new survey: 

1. Navigate to Setup > Surveys > Surveys, and click New.  

2. Enter a Survey Name and a Description. 

3. Enter the Greeting and the Thank You Message.  

4. Enter an E-Mail Invitation Message. 

Note: See the tooltip help in WHD for a description of the available tags. 
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5. Select the Frequency for this survey.  

Note: Frequency defines the rate at which the survey is sent. A frequency of 
1 sends the survey for each ticket. A frequency of 2 sends the ticket on every 
second ticket.  

6. Select the Max E-Mail Invitations to specify how many times you want the 
survey to be sent if the client has not responded.  

7. Select an E-Mail Reminder Frequency. 

8. Enter an Email-Reminder Subject, and an Email-Reminder Message.  

9. Optionally, enter an e-mail address for Competition Notification Address.  

10. Click New Question  in the lower left corner.  

11. Select a Display Order to indicate the position of this question. 

12. Enter the Question text. 

13. Select the Answer Type. 

14. Enter the Answer Options using semicolons to denote each option. 

15. Optionally, select Allow Explanation to allow the client to provide feedback 
on why they chose a specific answer.  

16. Click Save in the lower right corner of the Question Editor widget.  

To add more questions, repeat steps 10 through 16.  

17. When you have entered all of the question for this survey, click Save. 

To set the Survey Options: 

1. Navigate to Setup > Surveys > Options. 

2. Optionally, select a Default Survey to specify a survey for ticket request 
types that are marked for Default Survey.  

Note: If the Default Survey is set to None, no survey will be offered for 
tickets with a request type using the Default Survey selection.  

3. Select the Default Max Survey Invitations and the Default Max Survey 
Reminder Interval.  

4. Enter an Email-Reminder Subject, and an Email-Reminder Message. 

5. Click Save.  
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Sending Surveys 

WHD sends e-mail ticket surveys for each closed ticket that has a survey 
specified in Setup > Tickets > Request Types. Clients access surveys either by 

replying to the e-mail or by selecting History  from the top menu.  

To send a General Survey to one or more clients: 

1. Click Clients  , and then click Search. 

2. Select the check boxes for the clients you want to send surveys.  

 

3. Select the Survey to be sent, and then click Save & Email. 

Viewing Survey Results 

WHD offers two ways to examine survey results, the Ticket Detail View and 
Survey Results. Ticket Detail Views shows the result for a single ticket where as 
the Ticket Reports provides the ability to combine and sort results.   

Ticket Detail View 

To see the results of an individual ticket: 

1. Click Tickets  , and then click the number of the ticket you want to view. 

2. Tickets with survey results display a Survey View Button. Click the survey 
results button.  
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Survey Reports 

To view summary data regarding both ticket and general surveys 

1. Navigate to Reports > Survey Results. 

2. Select the Survey you want to view.  

3. Optionally, select any of the other fields to narrow the scope of the results.  

4. When you have completed your selections, click Run Report.  

Note: Survey Reports are the only way to view the results of a general (non-
ticket) survey. 

Creating Messages 

To create a new message: 

1. Navigate to Messages > Create Message. 

 

2. Click New Message. 

3. Enter the Message text. 

Note: Messages can contain plain text, HTML tags, and inserted FAQ links.  

4. Select an Audience for the message. 

5. If you want to include a link to a FAQ, click Link FAQ. 

a. Click Search and then click Link. 

b. To add additional FAQ links repeat steps 5 and 5 a. 

6. Optionally, If your message includes Techs, select Specify Tech Groups, 
and then select the groups to receive the message.  

7. If you want to lock the message so that recipients cannot delete the 
message, select Locked. 

8. Optionally, select a Start Date and an Expiration Date. 

9. Click Save to save and send the message. 
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Chapter 12 

Importing Data 

The data import options let you import data in bulk, rather than having to add 
individual items manually. You import data using either predefined templates, or 
by using an asset discovery tool. WHD provides templates in three formats; 
Excel spread sheets, Tab Separated Variable (TSV) files, and Comma Separated 
Variable (CSV) files.  

This chapter covers template data imports for: 

Locations 

Companies 

Clients 

Assets 

Purchase Orders 

Tickets 

FAQs 

Parts 

Inventory 

 

This chapter also covers the following asset import tools: 

 Absolute Manage 

 Apple Remote Desktop 

 Casper 

 LANSweeper 

 Microsoft SMS/SCCM 

Importing Data Using Templates 

To import data for TSV, CSV and Excel files: 

1. Navigate to Setup > Data Import.  



Administrator Guide  SolarWinds Web Help Desk 
 

 
106  Importing Data 

2. Select an import type. 

 

3. Select a data format for the template. 

4. Download the template. 

5. Populate the template. 

6. Upload the populated template.  

The table below specifies.  

Type of Import Required Fields 

Locations Location Name 

Companies Company Name, Manager Tech Username 

Clients Last Name, User Name, E-Mail 

Assets Asset Type, Manufacturer, Model 

Purchase Orders PO Number, Vendor 

Tickets Open Date, Request Type 

FAQs Category, Question, Answer 

Parts Part Number, Manufacturer, Our Cost, Customer Cost 

Inventory Part Number, Location, Count 

 

Notes: 

 Do not alter the order of the columns or delete any column in any import. 
Altering the import file in this way results in failed imports.  

 All parts within an inventory imports must be defined in WHD before 
importing inventory.  

 If your tickets to import use request sub-types, enter the type and sub-type in 
the Type column and separate the type and sub-type with a semicolon. 

 For parts imports, costs cannot contain commas or currency symbols. 
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Asset Discovery Tools 

Web Help Desk supports several methods of automated asset discovery. Using 
one of these tools, you synchronize WHD with the tool and import the assets into 
the WHD database.  

Web Help desk support the following import tools: 

 Apple Remote Desktop version 3 or later. 

 Casper Suite 6 and Casper Recon.  

 LANrev 4.6.4 or later. 

 Microsoft SMS/SCCM. 

 Database Table or View. 

Asset Discovery Basics 

WHD imports assets using the following process. 

First WHD compares the discovered asset against all assets currently associated 
with any existing Asset Discovery Connection. 

Anytime an asset discovery is run, the asset discovery tool provide unique 
identifiers for each asset. For example, Casper assigns each asset a JSS ID. 
WHD records this JSS ID as the asset’s synchronization identifier. 

During subsequent synchronizations, WHD finds each discovered asset’s 
corresponding WHD record by matching the JSS IDs provided by the discovery 
database against the synchronization identifiers stored in the WHD database. 

If a discovered asset is found having a synchronization identifier that matches 
that of the discovered asset, WHD verifies the asset using the following: 

 Asset Number 

 Serial Number 

 MAC Address 

If any of the above fail to match the discovered asset, WHD assume this is new 
asset and assigns a new synchronization identifier. 

Configuring Discovery Tools 

This section details the steps required to configure WHD to use the following 
third party asset discovery tools: 

Apple Remote Desktop 3.2 
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Apple Remote Desktop 3.3 

Casper 

LANrev 

Microsoft SMS/SCCM 

Database Table or View Settings 

Lansweeper 

Apple Remote Desktop 3.2 

In order to use Apple Remote Desktop 3.2, you enable and configure the ARD 

PostgreSQL database to allow network connections. WHD provides a setup 

script to make the configurations for you. Next, you will scan all the assets that 

must be included in WHD and then run a System Overview report in ARD (The 

System Overview Report option exports the asset data to the ARD PostgreSQL 

database.  

For more information about the Apple database see: 

http://developer.apple.com/appleapplications/ardsql.html. The Apple document 

explains in detail what the WHD script does, and gives instructions on how to 

manually access the database from the Apple terminal. 

To configure an ARD 3.2 connection: 

1. Download WHDRemoteDesktopBridge.dmg from 
http://downloads.solarwinds.com/solarwinds/Release/WebHelpDesk/WHDAp
pleScriptBridge.dmg 

2. Run the bridge installer on the WHD server. 

3. Install Apple Remote Desktop on the discovery database server. 

4. Start Apple Remote Desktop and ensure it is scanning for computers. 

http://developer.apple.com/appleapplications/ardsql.html
http://downloads.solarwinds.com/solarwinds/Release/WebHelpDesk/WHDAppleScriptBridge.dmg
http://downloads.solarwinds.com/solarwinds/Release/WebHelpDesk/WHDAppleScriptBridge.dmg
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5. Follow the steps in http://developer.apple.com/appleapplications/ardsql.html 
to configure ARD for TCP/IP access. 

Notes:  

Remote Desktop must be started at before continuing on to configure the 
database for TCP/IP access. 

The Apple script configures the ARD database to enable TCP/IP access, and 
then displays your database connection information. Take note of these 
connection settings. You will need to enter them into Web Help Desk. 

6. Open Remote Desktop and select the computers to imported. 

7. Navigate to Report > System Overview, and then click Run to run a System 
Overview Report.  

Note: ARD does not remove computers from the database when they are no 
longer included in a System Overview report. Remove any retired assets 
from ARD before synchronizing with WHD.  

8. In Web Help Desk, go to Setup > Assets > Discovery Connections and 
click New. 

9. Select Apple Remote Desktop as the discovery type, click 3.2 or earlier for 
the version and enter the database connection parameters provided by the 
database setup script in step 5. 

10. Enter the Remote Desktop PostgreSQL Database Host IP address and 
port.  

11. Enter the Database Name, Username and Password for the database. 

12. Optionally, select an Auto-sync Schedule. 

http://developer.apple.com/appleapplications/ardsql.html
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13. Set the Advanced Options on the lower section of this screen. See the tooltip 
help for detailed explanations of each options. 

 

 

 14. Click Save.  

To view the imported assets, navigate to Assets > Search Assets. 

Apple Remote Desktop 3.3 

As of version 3.3, Apple Remote Desktop uses a local SQLite database to store 

report data. This means that ARD must be installed on the same machine as 

your Web Help Desk to sync inventory data.  

When using ARD 3.3 requires no additional configuration on the SQLite database 

to make the connection.  

To configure an ARD 3.3 connection: 

1. Install Apple Remote Desktop on the WHD server. 

2. Start Apple Remote Desktop and ensure it is scanning for computers. 

3. Open Remote Desktop and select the computers to imported. 

4. Navigate to Report > System Overview, and then click Run to run a System 
Overview Report.  

Note: ARD does not remove computers from the database when they are no 
longer included in a System Overview report. Remove any retired assets 
from ARD before synchronizing with WHD.  

5. In Web Help Desk, go to Setup > Assets > Discovery Connections and 
click New. 

6. Select Apple Remote Desktop as the discovery type, click 3.3 or later for 
the version. 

7. Enter the Remote Desktop SQLite Database Filename.  

8. Set the Advanced Options on the lower section of this screen. See the tooltip 
help for detailed explanations of each options. 
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 9. Click Save.  

To view the imported assets, navigate to Assets > Search Assets. 

Casper 

To configure Casper Asset Discovery: 

1. In Web Help Desk, go to Setup > Assets > Discovery Connections and 
click New. 

2. Select Casper as the discovery type. 

3. Enter the Casper MySQL Database Host IP address and Port.  

4. Enter the Database Name, Username and Password for the database. 

5. Optionally, select an Auto-sync Schedule. 

6. Set the Advanced Options on the lower section of this screen. See the tooltip 
help for detailed explanations of each options. 

 

7. Click Save.  

To view the imported assets, navigate to Assets > Search Assets. 

LANrev 

Web Help Desk features an asset discover integration with LANrev 4.6.4. This 
integration consists of two components:  

 A LANrev MySQL ODBC connection to WHD.  
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 Remote control of LANrev system using a link in WHD.  

To implement this integration: 

1. Configure the LANrev MySQL ODBC export. 

2. Configure the LANrev admin console to respond to HTML requests from Web 
Help Desk.  

3. Configure Web Help Desk to import client inventory data from the LANrev 
MySQL database and enable the LANrev inventory and remote control links. 

Configuring LANrev MySQL ODBC Export 

The following link provides a complete walk through of configuring a LANrev My 
SQL ODBC export. Complete this procedure then return to this document to 
continue.  

http://forums.absolute.com/viewtopic.php?f=10&t=223&p=1855&hilit=ODBC+exp
ort#p1855 

Configuring the LANrev Admin Console 

To prepare the LANrev Admin Console for Mac OS WHD integration: 

1. Close the LANrev admin console.  

2. Using the Property List Editor, add the following setting to the LANrev admin 
console preferences in the following location. 

 ~/Library/Preferences/com.poleposition-sw.lanrev_ admin.plist  

Note: Alternately, you may choose to make the change using the Mac 
terminal by entering these two commands: 

defaults write com.poleposition-sw.lanrev_admin 

HTTPServerEnabled -bool true 

To prepare the LANrev Admin Console for Windows WHD integration: 

1. In Regedit, enter the following two lines. 

Edit “HKEY_CURRENT_USER\Software\Pole Position Software\LANrev 

Admin” registry key 

Set HTTPServerEnabled - Boolean/DWORD - Yes/1  

Configuring Web Help Desk for LANrev Manager 

1. In the Web Help Desk Admin interface navigate to Setup > Assets > 
Discovery Connections, and click New.  

2. Enter a descriptive Name for this connection. 

http://forums.absolute.com/viewtopic.php?f=10&t=223&p=1855&hilit=ODBC+export#p1855
http://forums.absolute.com/viewtopic.php?f=10&t=223&p=1855&hilit=ODBC+export#p1855
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3. Enter the Absolute Manage Mysql Database Host IP address and Port.  

4. Enter the Database Name, Username and Password.  

5. If you want virtual machine assets included, select Included Virtual 
Machines.  

6. Optionally, select an Auto-Sync Schedule.  

7. Use the Attribute Mapping tab of the asset discovery connection to map any 
custom asset fields to LANrev attributes. 

8. Navigate to Setup > Assets > Options and select Absolute Manage Links 
Enabled. 

Note: With this enabled, wherever assets are selected in Web Help Desk, 
icons will appear allowing you to open the asset in the LANrev admin 
console. 

Microsoft SMS/SCCM 

To create a discovery connection for Microsoft SMS/SCCM: 

1. In the Web Help Desk Admin interface navigate to Setup > Assets > 
Discovery Connections, and click New. 

2. Select Microsoft SMS/SCCM as the discovery type. 

3. Enter the SCCM SQL Database Host IP address and Port.  

4. Enter the Database Name, Username and Password for the database. 

5. Optionally, select an Auto-sync Schedule. 

6. Set the Advanced Options on the lower section of this screen. See the tooltip 
help for detailed explanations of each options. 

 

7. Click Save.  
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Database Table or View Settings 

To create a discovery connection for a Database Table or View: 

1. In the Web Help Desk Admin interface navigate to Setup > Assets > 
Discovery Connections, and click New. 

2. Select Database Table or View as the discovery type. 

3. Select the Database Type. 

4. Enter the database Host IP address and Port.  

5. If you are adding a connection to Microsoft SQL, My SQL, OpenBase, 
PostgreSQL, or Sybase, enter the Database Name.  

6. If you are adding an Oracle connection, enter the database SID.  

7. Enter the Database Name, Username and Password for the database. 

8. Select a Table or View to be imported.  

9. Select s Sync Column 

10. Optionally, select an Auto-sync Schedule. 

11. Set the Advanced Options on the lower section of this screen. See the tooltip 
help for detailed explanations of each options. 

 

12. Click Save.  

Lansweeper 

To configure Casper Asset Discovery: 

1. In Web Help Desk, go to Setup > Assets > Discovery Connections and 
click New. 

2. Select Lansweeper as the discovery type. 

3. Enter the Lansweeper SQL Database Host IP address and Port.  
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4. Enter the Database Name, Username and Password for the database. 

5. Optionally, select an Auto-sync Schedule. 

6. Set the Advanced Options on the lower section of this screen. See the 
tooltip help for detailed explanations of each options. 

 

7. Click Save.  

Attribute Mapping 

 

Use the Attribute Mapping tab to map asset custom fields to the discovery tool’s 
attributes. The asset attributes available to be mapped to depend on the 
particular discovery tool. These values are taken directly from the values 
provided by the discovery tool’s database.  

The ARD popup menu is hard coded in the WHD ARD plug-in, based on the 
values Apple provides in the database. There is no way to customize the 
attributes that appear in this popup. 
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Appendix A 

Deployment Considerations 

Memory Sizing and JVM Options 

The main deployment factor to consider is the number of concurrent users you 
expect your application to support. Tech sessions use much more memory than 
Client sessions, so use the estimated number of concurrent Tech sessions to 
determine which type of deployment will work for your needs. 

Supporting less than 20 Techs 

On a 32 bit OS, the WHD uses a 32 bit Java Virtual Machine (JVM). The 
maximum memory a 32 bit JVM can address varies slightly by operating system, 
but 1600 MB is a common maximum value. This maximum supports 10-20 
concurrent Techs without a problem. 

Ensure you have enough physical memory in your machine to support both the 
1600 MB for the JVM as well as the server OS and any other services you run on 
the machine. 

If you want to adjust the maximum memory setting, edit the WebHelpDesk/ 
conf/whd.conf file’s MAXIMUM_MEMORY option. The default value is 512 MB. 

Supporting more than 20 Techs 

If you need to support more that 20 simultaneous Tech sessions, we 
suggest installing WHD a 64 bit OS and a 64 bit JVM. On a 64 bit JVM you are 
free to increase the max heap memory to multiple gigabytes in size by editing the 
WebHelpDesk/conf/whd.conf file’s MAXIMUM_MEMORY option.  

A 64 bit JVM is available by default on Mac OS X 10.5 for Intel.  

To enable the 64 bit JVM, add the following argument to the 
/Library/WebHelpDesk/conf/whd.conf file’s JAVA_ OPTS option: 

 JAVA_OPTS=“-d64”  

For other operating systems, install your own 64 bit JVM (Java 5 or Java 6), then 
update the JAVA_HOME option in the WebHelpDesk/conf/whd.conf file to point 
to your Java installation. 
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WebObjects on Mac OS X Server 

WebObjects deployment is supported on Mac OS X 10.4 and 10.5 Server only. 
WebObjects deployment is not supported on 10.6 Server.  

To configure the WHD to run under WebObjects using the Monitor tool:  

1. Install the Web Help Desk, and then run the following deployment script in 
the terminal (as root or sudo):  

/Library/WebHelpDesk/bin/UpdateWebObjectsConfiguration  

2. In Mac Server Admin, start the Web and the WebObjects services. Enable 
the Monitor by selecting Turn Monitor On. You can leave the default ports.  

3. With a web browser, connect to the Monitor tool at 
http://yourserver.com:56789.  

4. Click the Site tab. Provide a valid URL to Adaptor.  

5. Select Round Robin as your load balance scheme and set the Receive 
Timeout value to 300. 

6.  Click Update Adaptor Settings to save. 

7. Click the Host tab. Provide the DNS name or IP address of the server and 
then select Mac OSX as the of type option. Click Add Host button. If this is 
the only host that will be running the application, enter 127.0.0.1 as the Host 
Address. 

8. Click the Application” tab. Add an application called Helpdesk. Click Add 
Application. 

 

To configure the new application: 

1. Click Path Wizard for the Mac OSX path field to lookup the following path to 
the application startup file: 

/Library/WebHelpDesk/bin/webapps/helpdesk/ WEB-INF/Helpdesk.woa/Helpdesk 

2. If you want to capture log files, provide an Output Path. 

Note: The directory you designate must be writable by the appserver user. 

3. Provide Additional Arguments to specify the max JVM heap size for the 
application instances. Each instance can handle up to 1600m, but values of 
256m to 384m are sufficient. The format is: -Xmx256m 

4. Click Push All to save all settings, and then click on the Applications tab 
again. You should see your application listed. 
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5. Click Detail View and add the optimal number of instances for your server 
based on the max JVM memory setting you specified in the application 
configuration.  

Note: Remember to leave enough free memory for your System and any 
other services you are running on the machine and leave an additional 64 
MB free for the Daemon application which we will add.  

6. Click Add to create the instances.  

7. The instances should startup on their own.  

Notes:  

 Optionally, you can speed up the process by clicking the green Start button 
in the ALL INSTANCE row for the Start/Stop column.  

 To refresh click the blue hyperlink Refresh Now text below the application 
name. 

At this point you should be able to connect to your application by going to the 
following URL: http://myserver.com/cgi-bin/WebObjects/Helpdesk.woa If you 
didn’t name your application “Helpdesk”, make sure to substitute the appropriate 
application name in the URL. 

 8. Click Applications tab and add a new application called Daemon. This 
application will have a similar configuration to Helpdesk, but the path to the 
application startup file is:  

 /Library/WebHelpDesk/bin/webapps/WHDReminder- Daemon/WEB-
INF/WHDReminderDaemon.woa/WHDReminderDaemon 

9. Provide an Output Path if you are capturing log files. You can use an 
additional argument of -Xmx64m for the memory setting. 

10. Click Push All to save. 

11. Go to the Detail View for the Daemon application and add one instance of 
the Daemon.  

Note: It is important that you have only a single instance, as multiple 
instances will cause problems with e-mail ticketing and alert email 
generation. 

The Web Help Desk is now configured to run under WebObjects using the 
Monitor tool. 

Clearing JVM Heap Memory 

WHD deployments may eventually fill up the JVM Heap Memory which may 
result in degraded performance. To solve this problem, periodically restart WHD 
to clear the heap memory. The procedure for doing this varies based on the OS 
where WHD is hosted. 
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Mac OS X 

Note: This procedure requires WHD version 8.4.6.8 or later. 

1. Login to your OS as root or admin. 

2. Copy the /Library/WebHelpDesk/bin/ 

com.macsdesign.RestartWebHelpDesk.plist file into your 

/Library/LaunchDaemons folder. 

3. Execute this command: 

launchctl load com.macsdesign.RestartWebHelpDesk.plist 

4. You can verify that the plist was loaded successfully with this command: 

launchctl list 

5. To unload the LaunchDaemon, use this command: 

launchctl unload com.macsdesign.RestartWebHelpDesk.plist  

The plist file provided is configured to restart Web Help Desk each night at 1AM. 
You can change the schedule by editing the StartCalendarInterval property in the 
plist. See the Mac OS X documentation for details.  

Notes:  

This launch daemon works only with the standard Tomcat deployment of 
Web Help Desk. WebObjects Monitor deployments use the Monitor tool to 
configure automatic restarts.  

When scheduling with the Monitor, make sure to clear Is Graceful to force 
the instances to restart. 

Windows 

To schedule the WHD application for a nightly restart: 

 1. Navigate to Start > Control Panel > Scheduled Tasks > Add Scheduled 
Task to start the Scheduled Task Wizard.  

2. Select any application to run. 

3. Select a Daily time to run the task.  

Select open advanced option. Change the Run command to be net stop 
webhelpdesk. 

To create a second Scheduled Task to restart the WHD application: 

Follow the same steps above, but use the Run command net start 

webhelpdesk as the final step.  
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Note: Schedule the start at least one minute later than the stop command to 
ensure that the service has completely stopped before attempting to restart. 

Linux/Solaris 

For Linux and Solaris installations, create a nightly cron job that calls the 
stop/start scripts as root or using sudo. The following commands would need to 
be called: 

/usr/local/webhelpdesk/whd stop /usr/local/webhelpdesk/whd start  
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Appendix B 

Multiple Instance WHD Installation 

Prior to version 10.0.16, the Web Help Desk consisted of two separate 
applications: "Helpdesk" and "WHDReminderDaemon." WHDReminderDaemon 
ran as a background service providing services for tasks such as checking for 
new e-mail tickets, syncing with LDAP on an automatic schedule, and checking 
for expired warranties. As of version 10.0.16, the services provided by 
WHDReminderDaemon are now bundled into a single Helpdesk application. 

For standard deployments of Web Help Desk, the installer automatically 
configures the Helpdesk deployment descriptor (web.xml) to run daemon 
services in the background. 

For multiple instance configurations, however, one instance must be configured 
to provide daemon services as either dedicated or background. Having more 
than one instance provide daemon services can result in the creation of duplicate 
tickets and the unnecessary use of system resources. Consequently, all but one 
application instance should run without daemon services 
(WHDDaemonMode=none). The single daemon instance can be set to either 
dedicated or background. 

The other instance must have be set to none. The below describes the function 
of the daemon settings. 

Dedicated  

The application instance functions only as a daemon, and the login page is 
disabled. 

Background 

The application instance functions as a daemon but users can also log in to 
it. 

None (default)  

The application instance does not execute daemon tasks.  

To configure a multiple instance installation, set the memory, the tomcat 
deployment descriptor, and the WebObjects daemon mode. 
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Memory 

Daemon processes should be allocated at least 256MB of memory. If the 
WHDDaemonMode is set to background, it should be given an additional 256MB 
of memory beyond the amount given to other instances, since it will provide 
daemon services in addition to serving the application user interface.  

To set the daemon memory:  

1. Stop Web Help Desk. 

2. Open the \WebHelpDesk\cong\whd.conf file. 

3. Change the MAXIMUM_MEMORY setting to MAXIMUM_MEMORY=1024. 

4. Save the whd.conf file. 

5. Restart Web Help Desk.  

Tomcat daemon 

To set the Tomcat deployment descriptor daemon mode: 

1. Stop Web Help Desk 

2. Open \WebHelpDesk\conf\tomcat_web_tempate.xml. 

3. Set the WHDDaemonMode (near the end of the xml file) for the instance type 
as described above.   

4. Save the file. 

5. Restart web Help Desk 

WebObjects Daemon 

To set the daemon mode for WebObjects Monitor deployments: 

1. Stop Web Help Desk. 

2. Open \WebHelpDesk\bin\wrapper\conf\wrapper_template.conf 

3. Add the following parameter to the end of the # Java Additional Wrappers 
section.  

wrapper.java.additional.14=-DWHDDaemonMode=background 

4. Save the file 

5. Restart Web Help Desk. 

Note: We recommend creating a separate WebObjects Monitor application for 
the daemon instance, naming it HelpdeskDaemon. This will ensure that the 
WebObjects adaptor will not attempt to direct login requests intended for the 
Helpdesk instance to the daemon instance. 
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Like the other application instances, the daemon instance should have its 
application path set to /Library/WebHelpDesk/bin/webapps/helpdesk/WEB-
INF/Helpdesk.woa/Helpdesk. 

Since the default daemon mode is none, it is not necessary to set the 
WHDDaemonMode argument for non-daemon instances. 
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Appendix C 

High Availability Deployments 

You create a high availability WHD deployment using one of these three 
methods: 

 Use WebObjects Monitor on Mac OS X.  

 Configure a multi-instance Tomcat deployment on Linux.  

 Separate instances into virtual machines. 

Monitor Deployment on Mac OS X 

Mac OS X Server 10.6 and earlier included WebObjects. For later versions, use 
the instructions provided at  

http://wiki.wocommunity.org/display/documentation/Deploying+on+Mac+OS+X+S
erver. 

After installing WebObjects: 

1. Run the Web Help Desk installer to extract the application. 

2. Install the application to /Library/WebHelpDesk. 

3. Run the following script to configure the Web Help Desk to work with 
WebObjects: 

sudo /Library/WebHelpDesk/bin/UpdateWebObjectsConfiguration 

Note: You must run this script again whenever you apply Web Help Desk 
update. 

4. In WebObjects Monitor, add a new application named Helpdesk with the 
following path: 

/Library/WebHelpDesk/bin/webapps/helpdesk/WEB-

INF/Helpdesk.woa/Helpdesk 

5. Also in Monitor, add a new application named HelpdeskDaemon with the 
same path as above: 

/Library/WebHelpDesk/bin/webapps/helpdesk/WEB-

INF/Helpdesk.woa/Helpdesk 

6. In the instance configuration page for HelpdeskDaemon, add the following to 
the "Additional Arguments" setting: 

-DWHDDaemonMode=dedicated 

http://wiki.wocommunity.org/display/documentation/Deploying+on+Mac+OS+X+Server
http://wiki.wocommunity.org/display/documentation/Deploying+on+Mac+OS+X+Server
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Note: Only one instance of Web Help Desk should ever be running as a daemon. 

After starting the applications in Monitor, you should be able to connect to the 
Web Help Desk with the following URL: 

http://localhost/cgi-bin/WebObjects/Helpdesk.woa 

Multi-instance Tomcat Deployment on Linux 

Follow the instructions for configuring a multi-instance Tomcat deployment 
provided 
http://knowledgebase.solarwinds.com/kb/questions/4281/Creating+multiple+insta
nces+of+WHD+on+one+server. 

Virtual Machines  

Multi-instance Windows deployments are problematic because the service name 
used for the Web Help Desk and the embedded database are hard coded, so 
you can't simply install a second instance to a different location. However, you 
can install another instance on another machine and connect it to the same 
database. If multiple instances are needed on the same physical machine, 
multiple instances could be installed on separate virtual machines. 

Note: 

Web Help Desk can run daemon processes in three different modes: dedicated, 
background, or none. In a multi-instance deployment, it is important that only one 
instance be configured to run as the daemon, either in dedicated or background 
mode. We recommend running it in background mode so that it can be restarted 
at will, on a more frequent basis than the front-end instances, without interfering 
with the front-end application. For information on configuring the daemon, see 
http://knowledgebase.solarwinds.com/kb/questions/4228/How+to+configure+the+
Web+Help+Desk+daemon. 

http://knowledgebase.solarwinds.com/kb/questions/4281/Creating+multiple+instances+of+WHD+on+one+server
http://knowledgebase.solarwinds.com/kb/questions/4281/Creating+multiple+instances+of+WHD+on+one+server
http://knowledgebase.solarwinds.com/kb/questions/4228/How+to+configure+the+Web+Help+Desk+daemon
http://knowledgebase.solarwinds.com/kb/questions/4228/How+to+configure+the+Web+Help+Desk+daemon

